Jump to content

Coffee Lake Intel UHD Graphics 630 on macOS Mojave 7MB Vram


5 posts in this topic

Recommended Posts

Hello,

I am now stuck on my Hackintosh on trying to fix the VRAM. Next to that, it is hard to really fix this problem alone by my self because my boot gets blocked sometimes having the next error WHILE i am trying to fix the VRAM problem: Graphics driver failed kextd stall[0] 60s IGPU, it freezes on that but lines before there are more noticable lines like : Graphics driver failed to load could not register with framebuffer, Failed to load kext com.Apple.driver.appleIntelKBLgraphicsFramebuffer, AppleIntelKBLGraphicsFramebuffer failed to load.

I have tried alot of .plist files, and i adjusted my plist file to other plist files but nothing worked. The combination of the above doesn't work to fix the problem. I tried to adjust my kext files inside clover - other, but that gives the error stall[0] 60s IGPU (having more names after this), like IGPU, 86Framebuffer, something else. And i tried changing drivers64UEFI to files someone had. I tried this for 1 week now. Youtube video's, different forums, you name it.

And i am losing hope. I hope someone can give me some hope that it can be fixable. Because i saw alot of people having this fixed but it doesn't work with me, don't know why.

First thing that needs to be understand for me is: How do i fix the stall[0] 60s IGPU problem. Then after that we can hopefully look at the 7MB Vram to be fixed.

Let me know what you guy's think. Tips are also helpfull, everything can be helpfull. Please check out my plist and tell me what is wrong.(also added my drivers64UEFI folder and my Kext folder from Clover location map.

 

I read a post on how you can use Hackintool. On how to use Whatevergreen + Lilu. And that i can remove every intelGFX etc. , but if i remove my intelGFX: 0x12345678 . I get the kextd stall[0] 60s IGPU Freeze. Someone know why?

About An Idiots guide to Lilu and Its plugins: Section

WEG Pre-requisites
First you must remove all IGPU injections, settings, fake id's .. etc from Clovers config.plist, failure to do so can cause conflicts with WhatEverGreen resulting in unexpected results.

UPDATE*

Busy with Hackintool, but Current Framebuffer Info shows ? and 0x0 (See printscreen hackintool.png)

UPDATE2*

IGPU Patch Generation

Next click on the General sub-page and select Devices / Properties and check Graphic Device, deselect everything else for the time being. Now click on the Generate Patch button.

^
This doesn't work with me see Hackintool2.png

drivers64eUEFI and kexts.zip

config-upload.plist.zip

Hackintool 2.png

Hackintool.png

@AkimoA Sorry sir.

 

ASUS N580GD-E4045T

 

NVIDIA GeForce GTX 1050 & Intel UHD 630

Intel Core i7-8750H

 

 

We have to fix the (Kextd stall[0] 60s IGPU boot error) first because i have a new plist file that worked WITHIN the FIRST boot. But after the first boot i got this Kextd stall[0] 60s IGPU boot error. New plist file is attached.

 

I already patched with MacIasl to remove dual graphics, now only the Intel GPU driver show's.

 

 

config-upload.plist

Edited by Poemko
  • 1 month later...
×
×
  • Create New...