Jump to content
gengik84

[Pre-Release] macOS Catalina 10.15.4

252 posts in this topic

Recommended Posts

On 2/6/2020 at 3:18 AM, BALDY_MAN said:

Im unlucky with this update at the moment. the is power to the monitor. but my screen stays black.

 

I feel your pain. :( I have exactly the same issue. I'm backing now in preparation for a fresh install.

Share this post


Link to post
Share on other sites
Advertisement

So I'm going to leave this one up for posterity. I fixed the issue (and others with my display) by generating a kext using Hackintool I didn't add any resolutions, nor did I check fix monitor ranges (all other settings enabled). Either inject the kext using Clover or OC, or place it in Overrides. I no longer have the option (I suspect macOS thought my display was a TV before) and notice I no longer have issues with windows being rescaled after display sleep or randomly when memory got kicked.

Share this post


Link to post
Share on other sites

Hi all, i have missing "Refresh Rate" option in Display control panel. How's it look at you guys? On 10.15.3 it was ok.

Edit: Connection via HDMI.

Edited by darthsian

Share this post


Link to post
Share on other sites
7 minutes ago, darthsian said:

Hi all, i have missing "Refresh Rate" option in Display control panel. How's it look at you guys? On 10.15.3 it was ok.

Edit: Connection via HDMI.

looks like BETA bugs i have the same prob.

Share this post


Link to post
Share on other sites
On 2/9/2020 at 6:25 PM, bkdwt said:

Good news for AMD users

 

 

 

What are those codenames? GPU models or is Apple finally killing it's exclusivity contract with Intel?

 

Edit: nvm, just looked them up.. those seem to be desktop/mobile APUs. Seems like my next cpu will be an AMD after all...

Edited by Nightf4ll

Share this post


Link to post
Share on other sites
3 hours ago, Moviemakergr said:

Something goes wrong ..

Two times restart but not "install data boot choice.."

 

2 hours ago, MorenoAv said:

Yep this time the update failed... reboot 2 times and nothing...

 

Try WEG from master.

Share this post


Link to post
Share on other sites

Hi @Andrey1970

Thanks for the tip, I tried to build WEG from master but it gave 2 errors...  

Captura de ecrã 2020-02-19, às 23.37.57.png

Edited by MorenoAv

Share this post


Link to post
Share on other sites
3 hours ago, Andrey1970 said:

Try WEG from master.

 

Yeah, that worked.  It was not easy to compile it.  I had to make a "Lilu.kext" folder with everything in Contents/Resources and there are two aliases where I had to move a folder and a file into Contents/Resources/Headers but then it compiled and made a Debug version of the kext.  I'll be looking forward to a release version of 1.3.8 soon.

 

Oh, here, if anyone else needs it:

 

WhateverGreen-1.3.7-DEBUG.zip

Edited by mnfesq

Share this post


Link to post
Share on other sites

By the way for us Xcode devs who had issues archiving builds with 10.15.4 b1, I can happily report that /usr/bin/xar is back on 10.15.4 b2

 

xar-10_15_4b2.thumb.png.7e78d6d3f09cd387e090f58aea5b2f9b.png

Edited by WizeMan

Share this post


Link to post
Share on other sites
22 hours ago, MorenoAv said:

Yep this time the update failed... reboot 2 times and nothing...

any luck on this? im having the same issue, no installer at reboot. weg has been compiled, lilu, clover & kexts are the latest

Share this post


Link to post
Share on other sites

I don't use WEG at all and updated without issues, though I also only have macOS installed and no other OS.

Share this post


Link to post
Share on other sites
1 hour ago, MorenoAv said:

Hi @ricktm,

 

No luck yet, I have used the WEG from @mnfesq but it didn't work... I have the latest kexts also.

 

Your issue is different from mine.  I was able to get to the first stage of update installation but, upon reboot to get to the second stage, I had repeating errors regarding IGPU.  You don't seem to be able to create the preboot installer.  I ran into that issue before learning about the WEG problem when I attempted to reinstall the update from my recovery partition.  I suggest that you use one of the update scripts available here to download the update and you may possibly need to put it onto a flash drive or other location to be sure it shows up in Clover.  Once you get the update to begin, you may still run into the WEG problem I encountered but take it one problem at a time.

Share this post


Link to post
Share on other sites

Getting kernel panics from AMDRadeonX4000 kext after update. Tried using the WhateverGreen posted here but no luck.

 

Using RX570 for driving hackintosh, iGPU enabled, but with platform-id disabling driving displays. Everything was fine till last update :(

 

Any help appreciated :)

20200220_222340.jpg

Edited by Rymek

Share this post


Link to post
Share on other sites
1 hour ago, MorenoAv said:

Hi @ricktm,

 

No luck yet, I have used the WEG from @mnfesq but it didn't work... I have the latest kexts also.

Interesting. If I was to guess, our issue may be that the installer isn't able to create the drive necessary for installation. When I try to run the update it does seem to end early before the shutdown & bootup. Does the progress bar complete when you start the upgrade from system preferences?

 

 

Share this post


Link to post
Share on other sites

Thanks @mnfesq, I'll try that or re install the macOS... 

No @ricktm the update ends before the shutdown. After the reboot it boots directly to the OS...

Edited by MorenoAv

Share this post


Link to post
Share on other sites

I'm back after re install macOS Catalina, but now my script for changing the apple catalog stopped working. Anyone has one script that works?

Thanks in Advance

 

PS. Solved found an apple developer profile, after that I re download macOS Catalina and this time I have installer but returned the text at boot and the update didn't work... see pictures at bottom... 

2020-02-21 00.05.43.jpg

2020-02-20 23.56.07.jpg

2020-02-21 00.01.28.jpg

2020-02-21 00.03.21.jpg

2020-02-21 00.04.58.jpg

2020-02-21 00.05.43.jpg

Edited by MorenoAv

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×