Jump to content
Sign in to follow this  
Followers 0
KNNSpeed

Combo Jack Solution

2 posts in this topic

Recommended Posts

NOTICE: The official AppleALC now contains layout-id 72. There's no more need to download the AppleALC.kext.zip file from this post.

 

NEW!

 

After several weeks of toiling (it's July already?!), here's a new audio solution for perfect working audio. I basically ported the linux driver and created a GUI popup menu to configure the combo jack (see screenshot).

 

Features:

  • Fully working Combo Jack! (Heaphones, headset, AND line-in!)
  • New verb sending kext (no more need for CodecCommander on systems without EAPD troubles; VerbStub is simply a direct port of hda-verb for Linux)
  • Launchdaemon with Windows-like pop-up menu monitors the jack for insertion
  • Automatic OMTP (Nokia)/CTIA (iPhone) detection for headsets!
  • Fully commented sources

Notes:

  • Line-in mode disables audio output. I haven't been able to re-enable the speakers when the jack is purely an input, but that's the only "issue"
  • Zero "no audio after sleep" issues so far
  • Make sure to turn off "Use ambient noise reduction" when using an input that isn't the internal Mic (unless you find that it helps)

How does it work?

 

Simple! Due to the way the Realtek codec is set up on this machine, the ComboJack program watches the jack and switches the codec selector (node 0x22) to the correct input after applying all the requisite processing coefficients and pin widgets. This means that Mac OS only sees a built-in mic, but behind the scenes it actually is connecting to the headset and line-in ports. This works because all input paths lead through selector node  0x22 and into capture node 0x09, and the OS only acknowledges the capture node.

 

How to install (uses modded AppleALC):

  1. Disable SIP (I use 0x67 for CSRActiveConfig and 0xEE for booterconfig)
  2. Remove ALCPlugFix from /usr/bin (may need to kill with Activity Monitor first)
  3. Remove good.win.ALCPlugFix.plist from /Library/LaunchAgents (may need to launchctl unload first)
  4. Remove CodecCommander from Clover/kexts/Other (unless you need it, but it looks like the 9560 doesn't)
  5. Copy VerbStub.kext to EFI/Clover/kexts/Other
  6. Copy AppleALC** to EFI/Clover/kexts/Other
  7. Change layout-id to 72 (in SSDT-Config -- 0x48 is hex)
  8. Run install.sh and read what it says
  9. Reboot (and enable SIP if you want)!

Download "ComboJack Installer.zip" and "AppleALC.kext.zip" for everything. The other zips are sources.

(Also included in "ComboJack Installer" is a folder containing the platform, layout, and pinconfigs used.)

 

**AppleALC now includes this layout (layout-id 72) in the official release.

ComboJack Installer.zip

post-1024628-0-65208600-1499361809_thumb.png

VerbStub Source.zip

Combo Jack Source.zip

AppleALC.kext.zip

Share this post


Link to post
Share on other sites
Advertisement

NEW!

 

After several weeks of toiling (it's July already?!), here's a new audio solution for perfect working audio. I basically ported the linux driver and created a GUI popup menu to configure the combo jack (see screenshot).

 

~~~

 

Reporting in, just tested using my iPhone headset all good and working here. Can't test the line thing as I don't have the equipment for such.

Your solution is brilliant. Thanks for your efforts on your hack and all of ours.

Can anyone confirm if they've managed to successfully complete KNNSpeed's tutorial with a Lite-On CX2 SSD? 

 

I'm finding conflicting information on whether this drive supports 4k sector sizes or not. According to some sources, it does not. Yet there is a thread on InsanelyMac where it seems people have gotten this Lite-On drive to work.  http://www.insanelymac.com/forum/topic/312803-patch-for-using-nvme-under-macos-sierra-is-ready/page-43

 

Also, over on Tonymacx86 someone successfully hacked a Dell XPS 13 with a Lite-On CX2. https://www.tonymacx86.com/threads/guide-dell-xps-13-9360-on-macos-sierra-10-12-x-lts-long-term-support-guide.213141/page-16

 

Can someone clarify? Thanks!

 

Where's the source that says it does not? Rehabman confirms in the first link you posted, it's the 3rd post. He's pretty damn knowledgable. Your second post the guy with the CX2 says "I'm not using HackrNVMeFamily.kext nor SSDT-NVMe-Pcc.aml." Those files are only necessary for 512 nvme drives. I think it should be crystal clear now that you do in fact have a 4K sector drive.

 

 

At any rate you could even if it's not 4K, I'm using a Samsung which is 512 and it works fine as long as you go and find a guide for that. Also I believe in high sierra or maybe even the next version of sierra we'll have native support for 512 nvme drives as well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By jamesxxx1997
      Hi everyone !
      I have a laptop thinkpad x1 yoga 2018 , the sound device is realtek alc285.
      My friend and I spend numerous time on patching its layout-id , however either the headphone jack or laptop audio recording have noises.
      Any help is appreciated , thank you !!!
       
      HdaCodec#0 (Realtek ALC285).bin
      HdaCodec#0 (Realtek ALC285).txt
      HdaCodec#1 (Realtek ALC285).bin
      HdaCodec#1 (Realtek ALC285).bin.cpgz
      HdaCodec#1 (Realtek ALC285).txt
      HdaCodec#2 (Intel Kaby Lake HDMI).bin
      HdaCodec#2 (Intel Kaby Lake HDMI).txt
    • By jcrcarmo
      Hello guys,

      I’m running macOS Catalina 10.15.2 on my Lenovo Ideapad 300-15isk laptop. Everything works, except HDMI audio. I can’t get it right no matter what I try, and I’ve tried every guide I’ve found. I was able to patch AppleHDA.kext and sound is working great, but still no HDMI audio in the sound properties window, only 'internal speaker out'. Here are my specs:

      Lenovo Ideapad 300-15isk 80RS
      Intel core i5 6200U @ 2.40 GHz
      Intel HD 520 Graphics
      16GB of DDR3L RAM @ 1600Mhz
      480GB SSD as primary boot and system drive
      1TB SATAIII HD as secondary. Backup drive
      Dual boot (macOS Catalina 10.15.2 and Windows 10 Pro)

      Please refer to attached .docx file containing a picture of DPCIManager window and picture of Kexts installed in EFI-EFI-CLOVER-Kexts-Other. Also, in case you wish to look at it, I am posting the link to my RunMe files. Thanks a lot for your time and help!
       
      https://drive.google.com/file/d/1a7ooQ7unNid5up12P1ygagZa1kjzzHSD/view?usp=sharing
       
       
       
       
      Screen_Shots.docx
    • By lestercamp234
      Ho da poco installato High Sierra sul mio computer, ma da subito ho notato che non si sente niente. Ho Realtek ALC887.
      Come faccio a sistemare?
    • By Denny
      Salve a tutti, ho un problema con l'audio. Ovvero non riconosce le giuste porte audio e manca anche l'audio tramite DP tramite GPU. Allego la cartella EFI nel caso vorreste dare uno sguardo.
      Config:
      GigaByte Z370P D3
      I5 8400
      Ram corsair vengeance LPX 16gb 3000MHz
      Nvidia 1050ti 

      Grazie in anticipo!
      P.S. Se serve ioreg posto
       
      https://www.mediafire.com/file/0hmpnp6x1f6u26p/EFI.zip/file
       
    • By andyapple
      Hi, I need help to fix my HDMI output on my Acer Aspire F5 573G with Intel HD 520.
       
      This is the situation, and it is unstable:
       
      When I connect my HDMI cable the internal monitor of the notebook gets black but the secondary monitor works.

      To get also the internal notebook monitor working I have to close the notebook for like 5-6 seconds and then open it up, and also the secondary monitor works.
       
      So I would like to fix this and get both monitor always working when HDMI cable is connected.
       
      I noticed that if I keep the notebook closed, the secondary monitor works in 4K resolution (while if the notebook is open, even with 4k resolution selected the secondary monitor is 1080p), so the secondary monitor works in 4k only if the notebook is closed.
       
      And I would like to fix this too.
       
      Audio over HDMI is not working and I would like to fix this too.
       
      I'm attaching useful report files as EFI and others.
       
      Thanks,
       
      Andyapple
      Problem Files Report.zip
×