Jump to content

iMessage Facetime error

5 posts in this topic

Recommended Posts


I used OpenCore with this configuration:

-b450i Aorus pro wifi

- ryzen2700

- rx5700

- dw1560



I followed the instruction and Catalina 10.5.2 works flawlessly. Usb power, bluetooth patched, iCloud,  airplay. audio, gpu.


The only thinks that aren't working are iMessage, FaceTime and handoff.


iMessage Error: a.cicala@logicsolution.com

FaceTime Error: This account has not reachable addresses. Please signing to appleid.apple.com in order to add one.

I think it could be related to ROM configuration in PlatformInfo-> Generic -> Rom 


But even if I tries to change the value it doesn't seems to work.


Steps I've done:


- Change Rom Value

- Change entirely the Generic settings

- Used CloverConfigurator to create a new rom value

- checked that en0 is stetted in Wifi

- removed  [~/Library/Caches/com.apple, ... , networkPreferences.plist] files


Is anything wrong I'm doing in the rom code creation? I attach my config.plist (without  smUUID) maybe in OpenCore I should use not data but string type?







Share this post

Link to post
Share on other sites

Shall be so.



You shall use valid MLB, ROM and S/N.

You shall use the unique SmUUID.

Don't use Clover/OpenCore Configurator.

Edited by Andrey1970

Share this post

Link to post
Share on other sites
8 hours ago, Slice said:

WiFi should be en1. LAN must be en0 if present.


Ok, so maybe that's the problem: my configuration has an Ethernet card (Intel211AT) the works with "SmallTree-Intel-211-AT-PCIe-GBE.kext" but if I install the kext

a) is not recognised as built-in=true and I can't find any parameter equivalent to clover fixlan (and I have NO IDEA how to fix lan)

b) is always listed as en1 (even removing networkPreferences.plist)


So I removed the kext (since I don't need LAN connection)...but maybe it's not the smartest thing to do:whistle:. Do you think this could generate the problem?


So my actual network config is:

Screenshot 2019-12-21 at 15.21.23.png

Share this post

Link to post
Share on other sites

I found the solution,

- injected the kext again

- removed networkPreferences.plist

- added built-in 01 in my pcie card ethernet as mentioned here




If you have troubles find the correct pcie for the card use hackintool-> PCI Tab> export data> find your LAN CARD


Now I Have ethernet en0

Thanks for the help!


Screenshot 2019-12-21 at 15.46.21.png

Screenshot 2019-12-21 at 15.47.10.png

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By Ericine
      Hi there i wanted to share my experience with the fenvi fv-t919
      order it from ali exprees 
      got it after 2 weeks 
      installed it in 10 minutes and turn on the mac and everything works 
      connected my magic mouse, matias wireless keyboard and airpods togheter and everything works perfect.
      and the most amazing part is now i have airdrop and calls from my mac in and out (airdrop needs wifi and bluetooth, calls needs only bluetooth)
      worth any dollar or in my case NIS.

      catalina 10.15.5
      opencore 0.5.9

    • By fusion71au
      Clover r5101 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
      1. Download and unzip "EFI_Clover_r5101 for VMware.zip". Mount Clover-v2.5k-5101-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By Shogun212
      I'm currently running MacOS Catalina 10.15.2
      Here's what i need help with: 
      1. Wifi (which previously worked on Mojave)  
      2. iMessage 
      3. FaceTime 
      4. AirDrop 
      Note: I can't do DSDT patching, tried it many times, and i failed. That's just beyond my capabilities. 
      I really hope someone can help me, i've been busting my head for days.  
      If possible, i would like to avoid bricking my os, because i need it for my job on the day after tomorrow. 
      My RunMe app file: https://mega.nz/#!yxlgiIwR!-XZsreXxNjxjQemXiQia2vcSfITWwr_AVciV2Kdb-ps  
      My specs: https://drive.google.com/file/d/1d47b7YXOAitKSYvA9Z6Ojv57ThqXzZxJ/view
    • By Hectorsky
      Hello InsanelyMac users,
      I'm constantly getting into troubles with iMessage & FaceTime on my Hackintosh.
      When I'm trying to activate iMessage on my hackintosh I'm getting message to contact apple with a customer code.
      Registration failed for <private> (Error: 31) My build is based on Lenovo ThinkCentre M83 MT which specifications is:
      CPU: Intel Core i7-4770
      MB: Lenovo SHARKBAY (Intel Q85)
      AD: Realtek 662v2
      LAN: Intel I217-LM
      BL: Clover 5070
      Native NVRAM
      My SMBIOS seems be properly generated for iMac14,2
      I've used macserial to generate serial numbers and MLB.
      For RTVariables I've use MacAddr0 of my LAN Card.
      Maybe someone else haves idea which thing can cause these errors?