Jump to content
tonyx86

Catalina on Dell Latitude E6410 (Nvidia Graphics) With Working Sleep

242 posts in this topic

Recommended Posts

After updating to 10.15.3, along with updating the EFI, I'm still unable to use my modular bay drive. As stated before,

  1. macOS reports disk I/O errors during verbose boot
  2. Finder claims it's unable to recognize the disk and asks to initialize it
  3. Disk Utility fails to erase the disk (see attached screenshot)
  4. After a while with the drive plugged in, the screen goes white. Sometimes the laptop will automatically reboot from here; other times I'll need to manually force it to power off and on again

I've generated several debug reports of this issue, and linked to them in this post.

What I find bizarre about this issue is that it doesn't occur in literally any other circumstance:

  • Connecting the bay drive to my desktop (through a frankly horrifying configuration), which is also a hackintosh, works fine
  • Accessing the bay drive within another OS works fine (e.g. Linux)
  • Even Clover properly recognizes the partitions on the disk in the drive
  • The stock DVD bay drive works fine in macOS

I've tried multiple HDDs in the drive; the problem is the same amongst all of them.

@tonyx86 - you say you have a modular bay drive that works with macOS? I wonder if there's an internal difference between our drives. If you wouldn't mind, could you take photos of the internals of your drive? I've attached some of my own to this post.

Screen Shot 2020-02-23 at 12.46.01 PM.png

IMG_20200124_073638.jpg

IMG_20200124_073648.jpg

Share this post


Link to post
Share on other sites
Advertisement

@unilock I originally thought SATA 3 vs SATA 2 might be an issue, but my adapter also indicates SATA 3 like yours.  Pix are attached.

 

Also, there's a switch on the side that I've never played with.  I see your board has one, too.  Does the switch position matter?  I don't know what it does.

thumbnail_IMG_0941.jpg

thumbnail_IMG_0942.jpg

thumbnail_IMG_0943.jpg

Edited by tonyx86

Share this post


Link to post
Share on other sites

@tonyx86

From the casing, it looks like we have the same model of modular bay drive. Though, based off what it says on the circuit board, you seem to have a slightly newer revision than I do. But I can't see any visual differences, other than that yours has a disk activity indicator LED soldered on while mine does not. If you want to disassemble the drive further, there are screws under the stickers on the side where you would insert the HDD (one on the white/black transition line under the cylinder in the top-left corner, one on the text under the book with the "i" in it in the bottom-left corner, and one on the left side of the cylinder in the bottom-right corner).

The switch enables/disables the diags pin, whatever that means. The ON state is towards the laptop-size SATA connector; the OFF state is towards the full-size SATA connector. The state of the switch doesn't seem to have any effect my problem.

I don't think a difference in SATA speed (SATA2 vs. SATA3) is part of the issue, as I believe the bay drive acts only as a passthrough between SATA port standards.

Share this post


Link to post
Share on other sites

@unilock I'm not sure that further disassembly of my aux bay adapter is going to reveal anything helpful.  I was comparing my IORegistry  to the one you last posted and quickly realized that your last debug files do not reflect your current installation.  Could you please post a new set of debug files (generated with black.dragon74's gen_debug tool) for your 10.15.3 installation with the aux bay populated with your data drive (one set of debug files)?  Please make sure that you're running the same file versions as those posted in Post #1 (including the same FakeSMC) as file differences generate different IORegistry attributes that complicate the comparison for me.

 

This will make the comparison easier for me.  Also, I imagine you have at least one BIOS config that is different from the config I specified in Post #1 (e.g. enabling your cellular modem).  Can you provide a list of the differences between your BIOS config and the BIOS config that I have recommended in Post #1?

 

Short of the detailed comparisons of the configs which I'm willing to do after seeing your updated post, I'm not sure what else to consider except for a new aux bay adapter.

 

EDIT: One other thing... When I was examining your last-posted IORegistry dump (I still need an updated set of debug files as explained earlier in this post), I noticed that your IORegistry (as viewed with IORegistryExplorer) has at least one device that I don't (e.g. RP04@1C,3).  It's possible that the presence of other hardware in your laptop (like the cellular modem) requires additional ports to be active, so your BIOS config is different and thus you need a slightly different DSDT.  You may need to try:

 

  1. My DSDT attached to Post #1 in this thread emulates Linux for running macOS.  Attached is a DSDT that emulates Win7 instead of Linux (see more details about this in the Mojave thread).  Try this DSDT to see if this helps.
  2. *** Deleted - no longer believe that you need to extract / patch your own DSDT.

DSDT.zip

Edited by tonyx86
deleted DSDT extract / patch suggestion

Share this post


Link to post
Share on other sites

@unilock I just did a quick compare of your unpatched ACPI to mine and don't see any relevant differences, so I don't think you need to create your own patched DSDT.  I hope I posted this before sending you on a wild goose chase.  I'm stumped.  While it's strange that your aux drive caddy works with other OSes and not macOS, the only thing I can think is to get another caddy.

Share this post


Link to post
Share on other sites

@unilock After I posted my comment below, I realized that the additional SATA ports may be a port expander / docking station or that you have enabled eSATA ports in BIOS.  Are you performing your testing with your laptop in a docking station or with eSATA enabled?  If so, this would be a big difference between your configuration and mine.  I never examined the DSDT (let alone tested) with a docking station or with eSATA enabled.  If that's the case, try testing "undocked" and/or with eSATA disabled in BIOS to see if that affects operation of your aux bay drive.

 

-------------------------------------------------------------------------

 

 

@unilock I finished reviewing your posted files to see if there's anything I can learn from your previously posted configurations.  I'm not sure if those configurations accurately represent your current state, but if they do, this might offer a clue about your SATA problem.  There's one IORegistry difference that leads me to believe we have different BIOS settings, so I'd encourage you to review the BIOS settings I listed in Post #1 and compare to yours.

 

If you look at the two IORegistry screenshots attached to this post, the screenshot of my IOReg lists only two SATA PRT "ports": PRT0 (my primary SSD) and PRT1 (my aux bay SSD).  Your IOReg lists two additional SATA "ports" that I don't have listed on my laptop: PRT4 and PRT5.

 

It's possible that if you can determine the difference between your SATA configuration and mine, this might provide a clue for you.

 

Screen Shot 2020-02-27 at 8.20.02 AM.png

Screen Shot 2020-02-27 at 8.20.42 AM.png

Edited by tonyx86
Added comment about docking station

Share this post


Link to post
Share on other sites

@tonyx86

Apologies for the late response.

I tested your DSDT that emulates Win7 instead of Linux, but no change in bay drive behavior.

I've been testing the laptop undocked. While I believe my BIOS settings are identical to yours, this may not be the case. I'll disable eSATA in BIOS if it is indeed enabled, then upload a new debug report.

 

EDIT:

Looks like disabling the eSATA ports in BIOS did get rid of the extra SATA entries. Unfortunately, it didn't solve the bay drive issue. Attached is the output of black.dragon74's tool.

If you need me to list the changes I've made from the "baseline" specified in post #1, I'd be glad to do so later, but I have a killer headache right now.
Thanks for taking the time to look at this.

debug_2020-02-27.zip

Edited by unilock
add debug files

Share this post


Link to post
Share on other sites

@unilock I see the obvious differences between our configs (listed below) of which you are already aware.  I'm not sure how these would affect the aux drive bay (probably they don't), but I have no other guesses.  If you have already tried the baseline that I've posted and it produces the same result, I have no other guesses.

  • Different version of FakeSMC
  • Different version of Lilu.kext
  • Kexts in E/C/k/O instead of /L/E

Just to clarify the way I'm using the aux drive,

  • I do NOT have an EFI installed on the aux bay drive
  • Aux bay drive is MBR formatted
  • Windows 10 is installed on aux bay drive in Legacy mode
  • I installed Windows 10 on the aux bay drive WITHOUT any other drives installed in the laptop (to be sure that the Windows 10 installer did not modify my macOS drive in any way)
  • I installed Windows 10 on a 100GB partition of the aux bay drive, initially leaving the remainder of the 256GB aux bay drive unformatted
  • On the remaining unformatted portion of the aux bay drive, I created an HFS+ partition on the aux bay drive using "Paragon HardDisk Manager Basic" running IN WINDOWS 10
  • I added the aux bay partitions to Spotlight Privacy tab in macOS so that macOS does not try to index the aux bay drive
  • To boot Windows 10 from the aux bay drive, I press F12 at boot and select the aux bay drive
Edited by tonyx86

Share this post


Link to post
Share on other sites

Attached is a new DSDT for the Latitude E6410.  Details are below.  This DSDT is not yet included in the baseline in Post #1.

 

I don't know much about Clover hot patching, so I was reading to learn and I just learned that I have been incorrectly applying Rehabman's "Instant Wake" DSDT patch.  Rehabman explains that in order to prevent instant wake, any Method (_PRW) that returns Package() { 0x0D, 0xXX } should be changed to return Package() { 0x0D, 0x00 }.  What is a bit harder to find (at least it was for me) is Rehabman's explanation of the proper handling of Method (_PRW) that returns GPRW(0x0D, 0xXX).  In this case, I had incorrectly changed GPRW(0x0D, 0xXX) to GPRW(0x0D, 0x00).  The correct application of Rehabman's instant wake fix is to change GPRW(0x0D, 0xXX) to Package() {0x0D, 0x00} so that GPRW is not called and _PRW simply returns the Package.  You'll find this explanation if you Google "Rehabman Using Clover hot patch ACPI". Rehabman actually changes Method (GPRW), which achieves the same as my correction below.

 

The result of this correction is that my originally patched Method(_PRW):

 

 

                Method (_PRW, 0, NotSerialized)  // _PRW: Power Resources for Wake
                {
                    Return ( GPRW (0x0D, 0x00) )
                }

 

 

should be changed to

 


                Method (_PRW, 0, NotSerialized)  // _PRW: Power Resources for Wake
                {
                    Return ( Package() { 0x0D, 0x00 } )
                }
 

 

I have made this change in the attached DSDT.  This DSDT also includes other minor fixes to resolve DSDT compile warnings (fixes that I found in Slice's E6430 DSDT (thank you, @Slice)).

 

By the way - with this instant wake patch, you will not be able to wake your laptop with USB.  This patch completely disables wake by USB (even if it is enabled in BIOS).

 

 

DSDT.zip

Edited by tonyx86

Share this post


Link to post
Share on other sites

@tonyx86

The way I'm using the aux drive is almost identical:

  • It's formatted as MBR
  • Windows 7 is installed on it
  • Windows 7 was installed without any other drives in the laptop (it wouldn't install correctly otherwise)
  • The Windows 7 partition takes up the entirety of the drive
  • I enabled "legacy" scanning in Clover so I could boot Windows 7 from there

Pardon if the following seems a bit rushed:

I realized the other day that perhaps there truly is a difference between aux drives, as mine was originally purchased for a Thinkpad W500 (which no longer functions for unrelated reasons). I've read online that there could be technical differences between aux drives advertised for different brands concerning how they interface with the laptop. Maybe that's the issue? If it is, fully disassembling your drive might provide some insight, as we could search for any differences in wiring or whatnot that I might be able to solve with a soldering iron.

See here

Share this post


Link to post
Share on other sites

CORRECTION: I thought the circled resistor in the attached pic was missing from my circuit board, but upon closer inspection, I can't be certain.  I would recommend purchasing a new caddy specifically for the E6410.  Sorry I can't be of more help with this.

 

@unilock That sounds logical. I don't want to disassemble my aux bay caddy any more than I have, so I'd suggest purchasing one specifically for the E6410.  I think I found mine for $8 on Ebay.  I splurged and purchased one with the release latch, since reviews I read suggested that other "universal" caddies did not fit well.  My caddy fits perfectly and has the same release mechanism as the original DVD.

IMG_20200124_073638.jpg.2028863b36a274f5cb90dd950a5a9f4b.jpg

Edited by tonyx86
Added picture with suspected extra pull-up resistor

Share this post


Link to post
Share on other sites

@tonyx86

I think I can spy the same resistor on your board from the image you supplied -- it looks like it has something to do with the activity indicator LED.

I'm going to end up spending money on *something* here, anyway, since I accidentally broke the aforementioned release latch off of my aux bay drive. Unfortunately, that was the same one that was on my stock DVD drive...

Thanks for all the help trying to get this working, though. At least we figured out what the white switch on the side of the modular bay drive does, after all this.

Share this post


Link to post
Share on other sites
Posted (edited)

For those who would like to figure out why AppleALC.kext "interferes" with Wi-Fi, causing a delay in the Wi-Fi connection, I might have a clue.  I'm content with VoodooHDA and won't be pursuing an alternative to VoodooHDA, but others may find this of interest.  When using AppleALC.kext for sound instead of VoodooHDA.kext, I have noticed that Wi-Fi won't connect until there is an AppleHDA "event" in Device (HDAU) (observed using IORegistryExplorer).  If you open IORegistryExplorer and watch Device (HDAU) when AppleALC is installed, you'll noticed a change in the status of HDAU, immediately followed by the Wi-Fi connection.  Wi-Fi won't connect until this HDAU status change occurs.

 

I have also noticed that, with AppleALC installed, the layout-id of Device (HDAU) always changes to 0x07, regardless of the injected value in the DSDT.  From what I have read, HDAU should have the same layout-id as HDEF.  With AppleALC installed, I had tried to inject layout-id 0x0b (to match that of HDEF) by including layout-id in HDAU._DSM, but the layout-id doesn't seem to matter when using AppleALC. The layout-id of HDAU is always changed to 0x07 when AppleALC is installed.

Edited by tonyx86

Share this post


Link to post
Share on other sites
Posted (edited)

EDIT: I did a little more research on USB Power and found that Rehabman discussed this issue for Sierra and later ( Google "Rehabman USB power property injection for Sierra (and later)" ). He suggests that the IORegistry keys for USB Power should be injected via the custom SSDT-UIAC for USBInjectAll.kext.  Since we're using USBInjectAll.kext for this HackBookPro6,2, I have modified SSDT-UIAC (attached) to include Rehabman's suggestion (still using the MacBookPro6,2 power values from High Sierra 10.13.6 IOUSBHostFamily.kext).  You can choose your method of injecting these values (the attached SSDT-USBX or the replace SSDT-UIAC in EFI/CLOVER/ACPI/patched with the attached SSDT-UIAC).  Note that if you employ the revised SSDT-UIAC, the USB power keys are properly injected (search for AppleBusPowerController in IORegistryExplorer), but the USBMap utility mentioned below will still report that you haven't created Device (USBX).  I don't think that USBMap's reported status matters as long as the values are injected, but I can't be sure, since I still haven't determined whether these USB Power keys make any difference in operational behavior.

 

-----------------------------------------------------------------------------------------

 

As I continue to try to figure out the Bluetooth Issue mentioned in Known Issues in Post #1, I found this tool that reports USB status:   USBMap.  When I ran the tool and selected option 'U' to Validate USB Power Settings, the tool reported that MacBookPro6,2 is not defined in IOUSBHostFamily.kext/Contents/Info.plist.  The tool proposes installation of a custom SSDT-USBX.aml that injects power values from the MacBookPro12,2 definition.  

 

Instead of using the USBMap tool's proposed power settings, I went back to High Sierra 10.13.6 (MacBookPro6,2 wasn't defined in Mojave's  IOUSBHostFamily.kex either) to find the USB power settings, created the attached custom SSDT-USBX.aml and installed this custom SSDT in EFI/CLOVER/ACPI/patched.  After rebooting Catalina, I don't notice any difference in behavior, other than that the USBMap Tool now says that USB Power is configured correctly.

 

I'm not sure what this custom SSDT is supposed to resolve/address, but I just want to report that it does NOT appear to fix the Bluetooth issue (in Known Issues in Post #1) and Catalina sleep still takes 32 seconds while High Sierra and Mojave sleep in 5 seconds.

 

 

SSDT-USBX.zip

SSDT-UIAC.zip

Edited by tonyx86
Added updated SSDT-UIAC

Share this post


Link to post
Share on other sites
Posted (edited)

A new E6410-Catalina-3v6.zip archive is attached to Post #1 of this thread with the changes listed below.  My Latitude E6410 (Nvidia Graphics) is running perfectly with this configuration.  You may need to execute Step #9 in Post #1 before applying these changes.  Note that I am no longer pursuing a solution for the Display brightness slider, so these changes have no attempts to fix the Display brightness slider (use the Dell brightness keys).  Also, I'm continuing to use CLOVER r5103 since I didn't see any required changes in r5104.  Also, I am using the same EFI for triple-booting High Sierra 10.13.6, Mojave 10.14.6 and Catalina 10.15.3 (with kexts unique to each macOS in /Library/Extensions) and all three OSes run great.

 

Changes in E6410-Catalina-3v6.zip attached to Post #1

  • Addition of SSDT-USBX.aml (install in EFI/CLOVER/ACPI/patched) - injects MacBookPro6,2 USB wake/sleep power properties which have been removed from IOUSBHostFamily.kext after High Sierra 10.13.6
  • DSDT changes
    • Resolve a few ACPI compile warnings (fixes borrowed from Slice's E6430 DSDT)
    • Rename EHCx to EH0x in DSDT (the only instance of these renames is in the DSDT, so no need for Clover to do this)
    • Other minor revisions 
  • Disabled EHCx -> EH0x renames in CLOVER config.plist (no longer necessary after performing renames in DSDT)
  • Upgraded Lili.kext from 1.4.1 to 1.4.2
Edited by tonyx86
Removed note about EH01:HP14 since it is a real external USB2 port

Share this post


Link to post
Share on other sites
Posted (edited)

EDIT: I prefer a revision to this kext injection strategy here.  Leaving this post for historical purposes.

 

--------------------------------------------------------------

 

Setting Clover's "Inject Kexts" to YES (not DETECT) and placing the Brcm kexts in E/C/k/O may be a solution to the Bluetooth issue reported in Known Issues in Post #1 of this thread.  See more here.

 

EDIT: I am now running with the following configuration for triple-booting High Sierra 10.13.6, Mojave 10.14.6 and Catalina 10.15.3.  I will continue to test and am not yet recommending this as a baseline, but it looks promising.

 

Clover: Inject Kexts -> YES (not Detect)

 

The following kexts in E/C/k/O (not in /L/E)

  • Lilu.kext v1.4.2
  • BrcmFirmwareData.kext v2.5.1
  • BrcmPatchRAM3.kext v2.5.1
  • BrcmBluetoothInjector.kext v2.5.1
  • AirportBrcmFixup.kext v2.0.6
  • FakeSMC.kext v6.26
  • IntelMausiEthernet.kext v2.5.0
  • USBInjectAll.kext v0.7.1
  • VoodooPS2Controller.kext (Bronxteck) v6.0.0
  • ACPIBatteryManager.kext v1.90.1
  • FakeSMC_CPUSensor.kext v6.26
  • FakeSMC_GPUSensor.kext v6.26

 

The following kexts in /L/E for High Sierra and Mojave (not Catalina)

  • VoodooSDHC.kext 1.1.2

 

EDIT2: It appears that in Mojave (not Catalina), AppleHDADisabler.kext and VoodooHDA.kext need to be installed in /System/Library/Extensions.  In Mojave, I tried moving these kexts to /Library/Extensions and my laptop took forever to boot.  I do not observe this in Catalina 10.15.3 (where I can move AppleHDADisabler.kext and VoodooHDA.kext to /Library/Extensions without any issues).

 

EDIT3: It appears that FakeSMC_CPUSensors.kext and FakeSMC_GPUSensors.kext dependencies are such that they don't load unless they are co-located with FakeSMC.kext.  I haven't needed to set Clover's "Inject Kexts" to "Yes" before (I have always used "Detect"), so I'm not sure if there are problems with including kexts in both E/C/k/O and /L/E when set to "Yes."  It may be necessary to place the FakeSMC Sensor kexts in E/C/k/O as well if running HWMonitor.

 

EDIT4: I have moved all kexts to E/C/k/O as indicated above.  This kext configuration (combined with Clover "Inject Kexts" set to "YES" and not "DETECT") apprears to be working for High Sierra 10.13.6, Mojave 10.14.6 and Catalina 10.15.3.  I have VoodooHDA.kext and AppleHDADisabler.kext installed in /System/Library/Extensions where the VoodooHDA installer package placed them.

Edited by tonyx86
corrected typos

Share this post


Link to post
Share on other sites
Posted (edited)

EDIT: I prefer a revision to this kext injection strategy here.  Leaving this post for historical purposes.

 

--------------------------------------------------------------

 

I'm now convinced that the correct way to install the Brcm kexts for Catalina requires placing them in E/C/k/O with CLOVER "Inject Kexts" = YES.  On this Latitude E6410, the BrcmRepo kext does not inject reliably from /L/E.   Placing Brcm kexts in /L/E was reliable in High Sierra and Mojave.

 

I will be updating the baseline with this new (for me) kext installation strategy.  You can all tell me you told me so :)

 

EDIT: My candidate updates are attached.  Note that the LE folder is no longer included, as no 3rd party kexts are installed in /L/E for Catalina.

 

EDIT2: I haven't timed it, but it seems the boot times are slower.  I think that's to be expected now that Clover is injecting all 3rd-party kexts.

 

E6410-Catalina-3v7.zip

Edited by tonyx86
Added E6410-Catalina-3v7.zip attachment

Share this post


Link to post
Share on other sites

hi. need link how to create a bootable flash drive . and where to download the catalina . I have latitude e6410 but can't find , how  zip to make a download from the format

Share this post


Link to post
Share on other sites
1 hour ago, ferfwe said:

hi. need link how to create a bootable flash drive . and where to download the catalina . I have latitude e6410 but can't find , how  zip to make a download from the format

 

Sounds like you're new to hackintosh.  You have a lot to learn - just be patient with yourself.  You will need to know quite a bit in order to maintain your hackintosh, so the learning is essential.  Follow the installation instructions in Post #1 of this thread.  At each step, use Google to search when there are instructions that you don't understand.  There is plenty of available documentation that explains each step in more detail.  Good luck!

Share this post


Link to post
Share on other sites

should I change the wi-fi module?

BCM943225HM
BCM943225HMB
BCM94322HM8L
BCM943224HMS
BCM94352HMB will be alright?

21 час назад tonyx86 сказал:

 

Похоже, вы новичок в хакинтош. Тебе есть чему поучиться - просто будь терпелив с самим собой. Вам нужно будет знать немало, чтобы поддерживать свой хакинтош, поэтому обучение необходимо . Следуйте инструкциям по установке в Посте № 1 этой темы. На каждом этапе используйте Google для поиска, когда есть инструкции, которые вы не понимаете. Существует множество доступных документов, которые объясняют каждый шаг более подробно. Удачи!

Благодарю. Мне нужно изображение. остальное немного понятно

Share this post


Link to post
Share on other sites
4 hours ago, ferfwe said:

should I change the wi-fi module?

 

I personally have only tested the Broadcom BCM 94352HMB as noted in Post #1 of this thread.  Others who have posted in this thread have other cards working with the use of antenna adapter cables.  My instructions in Post #1 have been designed and tested to work with BCM 94352HMB.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By miliuco
      Install macOS 10.15 Catalina on Gigabyte P55-USB3 with Radeon RX 580 graphics card using a USB device created with the createinstallmedia command and Clover as bootloader. Instructions to install macOS 10.14 Mojave on this computer are almost identical, replacing Catalina app with Mojave, so this article is suitable for both versions of macOS. The Gigabyte P55-USB3 motherboard (and some others from the same brand with the P55 / H55 chipset) have made it easy to build a hackintosh and install macOS since 10 years ago. Although it is an old motherboard, the behavior with Mojave or Catalina is very good after changing the classic hard drive (HDD) for a solid state drive (SSD).

      Components of the hackintosh
      Gigabyte GA-P55-USB3 motherboard: P55 chipset, 1156 socket, ALC892 audio, Gigabit RTL8111D network, DDR3 RAM Intel Core i5-750 processor for socket 1156: 4 cores, 8MB cache, clock rate 2.66 GHz Fenvi FV-T919 wireless + Bluetooth card: PCI-Express, wifi is ac type, detected by macOS as Airport and Apple Bluetooth Radeon RX 580 8 GB graphics card: works OOB but with a few details to be considered, it has its own article.  
      Previous requirements
      Install macOS Catalina app in /Applications folder USB flash drive with at least 16GB prepared from Disk Utility with MBR partition scheme and formatted as Mac Os Plus (on older Gigabyte boards like mine, USB sticks partitioned with GUID scheme instead of MBR usually hang the system when booting) Recent version of Clover (I have used r5117) Recent versions of Lilu (at least 1.4.4) and WhateverGreen (at least 1.3.9) to fine-tune the behavior of the graphics card Recent version of RealtekRTL8111 (I have used 2.2.2) FaceSMC version 6.26-322 (newer versions disable automatic mounting of USB devices on my system).  
      Create install USB
      Run this command from Terminal (assuming the target device is called USB):
      Bash: sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/USB /Applications/Install\ macOS\ Catalina.app
      Clover must be installed on the USB memory, I choose the following options:
      Bootloader > Install boot0af on the MBR CloverEFi > CloverEFI 64-bit SATA BIOS Drivers, 64 bit > Recommended drivers > FSInject + SMCHelper + XhciDxe BIOS Drivers, 64 bit > File System drivers > ApfsDriverLoader Install RC scripts on selected volume Optional RC scripts > Disable sleep proxy client.  
      You have to copy 4 kexts to the EFI/CLOVER/kexts/Other folder of the USB device: FaceSMC 6.26-322, Lilu 1.4.4, WhateverGreen 1.3.9 and RealtekRTL8111 2.2.2. Regarding the config.plist file, the most significant is:
      Boot > kext-dev-mode = 1 in Boot arguments GUI > Theme embedded, EmbeddedThemeType Dark, Screen Resolution 1920x1080, Preboot in Hide Volume Graphics > blank, nothing is checked except if foxbox solution is used to have more than 2 connectors enabled RT Variables > 0x28 in BooterConfig and 0x67 in CsrActiveConfig SMBios > iMac14,2 Sytem Parameters> Yes in Inject Kexts and check Inject System ID.  
      Install macOS Catalina

      Boot from the USB device and choose Install macOS from Install macOS Catalina. The installation program runs until the PC restarts. Here choose Install macOS from HDD (the name of the volume you are installing macOS on). With RX 580 graphics card, the screen goes black in this second phase of the installation, it is a phase in which the user has nothing to do until the PC is restarted so you can let it work until the Clover menu again. You have to choose Boot macOS from HDDto boot the installed system from the hard disk, the screen is recovered and you can configure the account and the initial options. From this moment the screen works fine.

      In summary:
      Boot from USB > Clover menu > Install macOS from Install macOS Catalina > screen works fine Boot from USB > Clover menu > Install macOS from HDD > black screen Boot from USB > Clover menu > Boot macOS from HDD > screen works fine.  
      Install Clover and kexts on the hard drive

      Clover needs to be installed on the disk where we just installed macOS. Options are the same as when installing it on the USB memory. You also have to copy the 4 kexts (FaceSMC 6.26-322, Lilu 1.4.4, WhateverGreen 1.3.9 and RealtekRTL8111 2.2.2) into the EFI/CLOVER/kexts/Other folder on the EFI partition of the disk. And review the config.plist file remembering the comments for the USB.

      If everything goes well, the computer starts from the hard disk with a running copy of macOS Catalina.
       
       

    • By miliuco
      Radeon RX 580 8 GB graphics card on macOS High Sierra (as of 10.13.6), Mojave and Catalina on the P55-USB3 board: excellent performance with acceleration (Metal) OOB, no need for drivers (kexts), with 3 drawbacks, one has to do with the boot of the operating system (a solution is proposed), another with the number of rear connectors enabled (a solution is proposed) and another that only affects to one phase of the Mojave or Catalina installation (without clear solution for now).

      I have placed the XFX AMD Radeon RX-580 P8DFD6 8GB Triple X Edition GDDR5, 256BIT, DVI + HDMI + 3DP graphics card on a 10 year old motherboard (Gigabyte P55-USB3) in order to update the hackintosh to 10.14 Mojave and 10.15 Catalina because the card that I have used in past years, Nvidia Geforce GTX 750 1GB, has stopped working after 10.13.6 High Sierra since this was the last version for which Nvidia published the alternate web drivers that were necessary for the card to work well with graphic acceleration.

      The new RX 580 card needs considerably more space than the old one although it fits perfectly in an ATX case, and requires an additional power connector. It has 2 big fans that most of the time are stopped, at least in my case. In macOS it works perfectly, even with Metal acceleration, without additional drivers and without extra settings in Clover. But it has drawbacks that I comment below.

      Alterations during startup

      During the boot of the operating system, when the screen goes from the basic driver to the AMD driver, 2 artifacts appear randomly, they are very short in duration (from one to a few seconds):
      Very short flashing white screen that may or may not be accompanied by purple lines The fans runs for a few seconds (the noise is clearly audible). This behavior is solved with the installation of 2 kexts, Lilu and WhateverGreen. Lilu is an extension created by acidantheraand vit9696 among others whose function is to help to patch kexts, processes and libraries during macOS boot. It is accompanied by specific plugins for the task required, for example WhateverGreen that injects necessary patches for certain AMD, Intel and Nvidia graphics cards. It is mandatory to have both extensions together, one of them separately does not correct the problem.
      I have installed Lilu 1.4.4 and WhateverGreen 1.3.9 in the EFI/CLOVER/kexts/Other folder of the EFI partition and artifacts have disappeared. Remember that these 2 extensions are not necessary for the card to work properly, if you tolerate those very brief distortions of the screen or the noise of the fans running for a few seconds, you can live without Lilu and WhateverGreen.

      Note: authors recommend that when using Lilu and WhateverGreen with Radeon cards, NO graphic settings have to be added to Clover (Inject ATI, etc.).

      Note: these alterations, especially the brief white screen and less frequently purple lines and fan noise, are also seen in Windows and some real Macs with the same card.

      Alteration during macOS installation

      Boot from USB > Clover menu > Install macOS from Install macOS Catalina > screen works fine
      Boot from USB > Clover menu > Install macOS from MacintoshHD > black screen
      Booting from USB > Clover menu > Boot macOS from MacintoshHD > screen works fine.

      In the first and third stages, screen works fine. In the second stage the screen goes black although the installation continues. The user has nothing to do at this moment so you can leave the PC working until the Clover menu is shown again, the screen is recovered, the initial account options can be configured and you can enter into the newly installed system with correct resolution and acceleration.
      This behavior is not corrected even by placing Lilu and WhateverGreen into the USB device. At least in my case I have not found a solution for it. Yo can install macOS perfectly with that drawback of not seeing how it progresses during the second phase of the installation.

      Only 2 connectors of the 5 available work

      This card has 3 Display Port (DP) ports, 1 HDMI port and 1 DVI port. In my case, only 2 DP work, those that are further from the HDMI connector. It is enough if you use a single monitor or 2 monitors that can be connected by DP. But if you want to have 3 or more connected devices or some of them only have HDMI, it is necessary to enable the 5 connectors or at least 4 of them since the DVI is obsolete and does not allow resolutions as high as DP and HDMI.
      User foxbox has proposed a solution in a thread titled [Solved] Sapphire RX 580 Nitro + SE | black screen on HDMI and DVI. Must inject from Clover a modification to the Orinoco framebuffer (which is used in the RX 580 card) so that the 5 connectors lack a fixedly assigned address and, instead, receive it dynamically. This change is made from the KextsToPatch section of Clover. Read the post from foxbox.
      This has to be accompanied by 3 changes in the Graphics section of Clover: Orinoco in FB Name / Inject ATI / 5 in Video Ports. I have tested this solution in macOS Catalina and it effectively enables the 5 ports of the card but, since I only use 1 monitor, I have removed it and I am with Lilu and WhateverGreen.
       

    • By vinnytwice
      How to finish the Catalina installation.
      1. Use EasyMBR-Installer1015 to make USB Catalina Installer.
      2. Boot to USB Catalina Installer, open Utilities -> Disk Utility, format as MBR HFS+.         <==  won't boot..there is no boot loader in the created usb drive..also format "target drive"
          Install Catalina to blank MBR HFS+ "Target" partition.
      3. Boot to USB Catalina Installer, open Utilities -> Terminal, run the script command:         <== no Volumes gets listed to select
          copytempdata
      4. Boot to "Target" MBR HFS+ partition on single user mode (-s), run the script command:install.log
          hfsupdatecache
      5. Reboot to "Target" MBR HFS+ partition, setup user name and login, finish the installation.
       
       
       
      After trying many times of following the procedure for EasyMBR-Installer1015 creation I'm stuck at step 3.
      Basically what I've done is:
      1. I made the usb with EasyMBR-Installer1015.
      1b. Installed clover on it.
           Added Lilu,WhateverGreen, AppleAHCIPort AppleALC  kexts needed for my motherboard in other folder.
           Set RtVariables to BooterConfig 0x28 CsrActiveConfig 0x67.
           Set SystemParameters InjectKext to yes.
      2. Boot into the Usb installer fine, formatted the target drive and installed Catalina on it.
          Installation went smooth and system rebooted. At Clover screen dough I see a new Catalina recovery disk. ( not sure it's normal )
      3. Reboot into the Usb installer again and from terminal run the script copytempdata.
          The script asks to select a drive from the available ones to perform three things..
          but in script  "Available target volumes:" there's none to select and there I'm stuck.. 

      I checked the volume I installed Catalina on and it has this folder structure:
      private/var/log/install.log()114 kb
      vm (empty)  
      GetInfo shows 8,56 GB used.
      I attached the log so it might help understanding what's happening .
      What else can I check to see what's happening?
      Thank you very much
    • By tonyx86
      This guide is a work in progress and will be updated as I refine the installation.
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
       
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec SMBIOS MacModel MacMini 8,1 Unsupported M.2 PCIe x1 2230 Intel Wi-Fi (currently disabled in BIOS).  I may replace this with Brcm, but am using only Ethernet (IntelMausi) for now.  
      Installation Steps: To be provided
      See attached EFI and /L/E kexts in EliteDesk.zip archive See installation methodology here See references here  
      What is not working
      Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card).  
      What is not tested
      USB c 3.1 port Microphone port  
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions
      (Solved and included in the attached EliteDesk.zip archive) Unable to upgrade from 10.15.4 to 10.15.5 when using IntelMausiEthernet.kext.  Solution is to switch to IntelMausi.kext (Rev 1.0.2 here). (Solved and included in the attached EliteDesk.zip archive) Some USB devices were not recognized. My SSDT-UIAC.aml was incomplete and did not specify all required USB port types (missing SSxx ports). The attached EliteDesk.zip archive includes this fix. (Reported this as a possible Clover issue - no solution yet) Clover boot loader may default to Recovery volume after a normal shutdown.  Work-around is to select your normal macOS volume.  This may only happen when Clover is configured to boot LastBootedVolume and may be "fixable" by explicitly setting a boot volume (haven't tested this). (No longer observed) At least one display blanks (sleeps) when plugging / unplugging USB device (observed in front USB 3.1 ports).  Display wakes immediately on keyboard and mouse activity, so this is a minor issue but may be indicative of another issue. (Solved - this is a BIOS setting and requires no macOS changes) Safari has problems loading insanelymac web pages after sleep / wake.  I suspect that the problem is with the embedded video on the pages.  Also observed video problem in AppStore after sleep/wake.  Console: VideoDecodersUnavailable.  Solution is to enable Intel ME in BIOS. (Solved and included in the attached EliteDesk.zip archive) Display does not fully wake after resuming from sleep (needs an extra mouse or keyboard stimulus to fully wake).  Solution is to change boot arg darkwake=0 to darkwake=2.  Other values of darkwake may work as well, but this is the first I tried and it worked. (Solved and included in the attached EliteDesk.zip archive) -disablegfxfirmware boot arg is not required with WEG.  I inadvertently left this boot arg after I encountered an endless gfx firmware update boot loop while working on my FB patching.  This boot arg is no longer necessary after completing FB patching with WEG. (Solved and included in the attached EliteDesk.zip archive): Sometimes, CMOS time is lost on shutdown or restart.  Solution is to enable Clover's Apple RTC fix in config.plist. (Solved and included in the attached EliteDesk.zip archive) headphone jack doesn't work.  Solution is to change HDEF layout-id to 28. (Solved and included in the attached EliteDesk.zip archive) System freezes on wake from sleep because of a kernel panic related to hda-gfx (my system does not have HDMI and my DP->DVI adapters do not drive monitor speakers).  Solution is to add No-hda-gfx property to HDEF as described here.  This property is recognized as a Lilu flag and prevents loading hda-gfx. (Solved and included in the attached EliteDesk.zip archive) Device (PMCR) is not defined.  Solution is a SSDT that "injects" the missing device. (Solved and included in the attached archive) eficheck is loaded (not sure why this is bad, but may be a privacy issue - see here). Solution is to add updated EFICheckDisabler kext that include Q370 chipset.  See here.  
      BIOS Version / Configuration: To be provided
      Version: 02.11.01 Rev.A Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration: To be provided
       
      UHD 630 Framebuffer Patching: To be provided
       
      Current Versions
      Catalina 10.15.4.02 Clover (UEFI) r5118 Lilu.kext 1.4.4 WhateverGreen.kext 1.3.9 AppleALC.kext 1.4.9 IntelMausi 1.0.2 (Not IntelMausiEthernet)  
      Credits To be provided
       
       




      EliteDesk800 G4 Mini - Rev 0.7.zip



    • By ludufre
      Installing macOS Catalina 10.15.5 on Gigabyte Z370N WIFI + i7 8700K + UHD 630



      Changelog:
       
      05/27/2020 20:02h GMT-0
      - Update instructions 10.15.5.
       
      03/24/2020 20:23h GMT-0
      - Update instructions 10.15.4.
       
      01/30/2020 23:54h GMT-0
      - Update instructions 10.15.3.
       
      12/11/2019 03:58h GMT-0
      - Update instructions 10.15.2.
      - Updated EFI folder attached.
       
      11/30/2019 18:03h GMT-0
      - Changed Device -> Graphics platform to fix dual HDMI monitor.
      - Updated EFI folder and config.plist
       
      11/29/2019 21:28h GMT-0
      - Added full EFI folder as requested.
       
      11/27/2019 02:33h GMT-0
      - Added BIOS profiles for ease.
       
      11/25/2019 22:45h GMT-0
      - Fixed wrong ethernet link (IntelMausi.kext).
      - Thanks to @MiMoHo
       
      11/24/2019 04:56h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i7-8700K ->  Work. All SpeedStep stages.
      - Video Card: Intel UHD 630 ->  Work. QE/CI and Metal.
      - Chipset: Intel Z370 ->  Work.
      - HDMI 2.0 (1st) ->  Work.
      - HDMI (2nd) ->  Work.
      - DP ->  Work.
      - Audio: ALC1220 ->  Work.
      - HDMI Audio ->  Work.
      - WiFi/Bluetooth ->  Not work. Replaced with BCM94360CS2.
      - Ethernet (1st) ->  Work.
      - Ethernet (2nd) ->  Work.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Todo
       
      - Empty
       
      What you need to install
       
      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Catalina install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction  This will take about 30 minutes.
       


      Install bootloader
       
      Download the CloverEFI from official repository (used 5099) and install only with these options on "Install macOS Catalina":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended Drivers - FSInject (I still don't know if it's really necessary)
      - UEFI Drivers - File System drivers - ApfsDriverLoader (Support to APFS partitions)
      - UEFI Drivers - File System drivers - VBoxHfs (Support HFS/HFS+ partitions)
      - UEFI Drivers - Memory fix drivers - AptioMemoryFix (Fix the memory management of de UEFI/BIOS)
      - UEFI Drivers - Additional drivers - NvmExpressDxe (If you are going to use NVMe)
       
      FileVault 2
       
      If you plan to use FileVault 2, you need to download additional drivers, since what comes with Clover is not up to date and use VirtualSMC instead of FakeSMC.
      Follow instructions bellow:
       
      From current Clover installation, check these options to USB keyboard/mouse work on password screen:
      - UEFI Drivers - Human Interface Devices - UsbKbDxe
      - UEFI Drivers - Human Interface Devices - UsbMouseDxe
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      Download the versions 2.1.0 and 2.0.9 of AppleSupportPkg from: https://github.com/acidanthera/AppleSupportPkg/releases
      We need the last version of AppleGenericInput.efi that is inside 2.1.0 and last version of AppleUiSupport.efi that is inside 2.0.9.
      OR download attached bellow.
       
      Put in /Volumes/EFI/EFI/CLOVER/drivers/UEFI/
       
      That's it! FileVault 2 will work without problems.
       

       
       
       
      Make things works
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      - Replace the /Volumes/EFI/EFI/CLOVER/config.plist with mine attached below according to your processor version.
      - Put all SSDT-*.aml attached below in /Volumes/EFI/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.8.0.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Copy the Clover Configurator to flash drive because you will need later.
       
      Download those Kexts and put in /Volumes/EFI/EFI/CLOVER/kexts/Other/
       
      - Download the VirtualSMC.kext, SMCProcessor.kext, SMCSuperIO.kext and UEFI driver (put VirutalSmc.efi inside /Volumes/EFI/EFI/drivers/UEFI/). I used the version 1.0.9.
      - Download the Lilu.kext from here. I used the version 1.3.9.
      - Download the WhateverGreen.kext from here. I used the version 1.3.4.
      - Download the AppleALC.kext from here. I used the version 1.4.3.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
      - Download the IntelMausi.kext from here. I used the version 1.0.2.
      - Download the SmallTree-Intel-211-AT-PCIe-GBE.kext attached bellow to enable second ethernet.
       
      Important! If you are coming from my previous Mojave guide, please note that I am using some kexts from other repositories / authors.
       
      Wifi and Bluetooth (BCM94360CS)
       
      Works out of box (plug 'n' play).
       
       
      Now you can start the installation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is F10 (I use an 8th generation processor, so I don't need to upgrade)
       
      You can configure manually or load my BIOS profile.
       
      Manually:
      - Shutdown and insert the flash.
      - Power on with DEL pressed to enter BIOS setup.
      - Change value: BIOS - CSM Support to Disabled
      - Change value: BIOS - Secure Boot to Disabled
      - Change value: Peripherals - Initial Display to IGP
      - Change value: Chipset - VT-d to DISABLE
      - Change value: Chipset - Internal Graphics to ENABLE
      - Save & Exit Setup
       
      or, BIOS profile
      You can use one of my BIOS profiles attached bellow.
      It's two versions. One stock (Geekbench 4: 5840/27384) and another with overclock [5.0 GHz] (Geekbench 4: 6360/30348)
      - Put the profile in the root of the flash drive at EFI partition.
      - Restart with DEL pressed to enter BIOS setup.
      - Go to Save & Exit.
      - Select Load Profiles.
      - Select last option and then the flasdrive in the list.
      - And finally choose MACOS_STOCK or MACOS_5GHZ.
      - Save & Exit Setup
       
      Then:
      - Now, hold the F12
      - In the list, select your flash drive.
      - Choose the flash drive (white icon).
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot. Maybe you have to press ESC again and select the flash drive.
       
      Choose the internal disk (gray hdd icon) if not already selected.

      The second part of the installation will begin. This will take 16 minutes.

       
      Post installation
       
      Bootloader

      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to make the system disk bootable.

      Open the Clover Configurator from flash drive that you copied before.

      Mount and open the flash drive EFI partition. (Inside Clover Configurator, Mount EFI -> Select flash drive in Efi Partitions list -> Mount Partition -> Open Partition)
       
      Copy the EFI folder to desktop.
       
      Go back to Clover Configurator, unmount the EFI partition of the flash drive and mount and open the EFI partition of internal disk.
       
      Move the EFI folder from Desktop to EFI partition of the internal disk.
       
      Eject the flash drive.
       
      Move all Kexts from EFI partition of internal disk to /Library/Extensions and make kext cache, with those commands in Terminal:
      sudo mv -R /Volumes/EFI/EFI/CLOVER/kexts/10.15/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
      Last thing
       
      Run this command in Terminal to disable hibernation (doesn't work in macOS):
      sudo pmset -a hibernatemode 0  
       
      It's done!
       
       
      System Updates
       
      10.15.2
       
      Before install, update the following kexts:
      - Lilu.kext. I used version 1.4.0.
      - WhateverGreen.kext. I used version 1.3.5.
      - AppleALC.kext. I used version 1.4.4.
      (all download links above)
       
      Download the latest CLOVERX64.efi.zip build. I used version 5100.
      Mount EFI partition and unzip to:
      - /Volumes/EFI/EFI/CLOVER/CLOVERX64.efi
      - /Volumes/EFI/EFI/BOOT/BOOTX64.efi (rename the copy of CLOVERX64.efi to BOOTX64.efi
       
      Install update. Will reboot at least four time.
       
       
      10.15.3
       
      Updated with success without changing anything.
       
       
      10.15.4
       
      Before install, update the following kexts:
      - Lilu.kext. I used version 1.4.2.
      - WhateverGreen.kext. I used version 1.3.7.
      - AppleALC.kext. I used version 1.4.7.
      - VirtualSMC.kext. I used version 1.3.7.
      (all download links above)
       
      Download the latest CLOVER installer. I used version 5107.
      - Install respecting the configuration mentioned above in "Install bootloader" section.
       
      Install update. Will reboot at least four time.
       
       
      10.15.5
       
      - Same as usual, update all Kexts and Clover.
      - Install Update, reboot.
       
      If you like me, I had a problem with two monitors. I needed to roll back two Kexts of video from 10.15.4: FixGraphics10.15.5.zip
      After replace, fix permissions and cache.
       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas and all others members involved directly or indirectly.
       
      Attachments
       
      config.plist v2.zip
      EFI v4.zip
      Filevault 2 additional drivers.zip
      SmallTree-Intel-211-AT-PCIe-GBE.kext.zip
      SSDTs.zip
      MACOS_5GHZ
      MACOS_STOCK
       
       
       
×