Jump to content
vector sigma

Clover.app testing

353 posts in this topic

Recommended Posts

First time posting on this thread. Updated Clover with the latest build, 5102 . I was able to update fine using the pkg file, but the Clover app corresponding to it seems broken, macOS says is damaged and needs to be trashed. Deleted it, re-downloaded it, the same thing, deleted again and replaced it with the previous version, it seems to be working. Is this a know issue? I barely use the app, just installed it to get familiar with it, I still use the old Clover ways. If any input from me, like sending files, system data is useful, I can try to post it.

Edited by Vyzantion

Share this post


Link to post
Share on other sites
Advertisement
7 minutes ago, Vyzantion said:

First time posting on this thread. Updated Clover with the latest build, 5102 . I was able to update fine using the pkg file, but the Clover app corresponding to it seems broken, macOS says is damaged and needs to be trashed. Deleted it, re-downloaded it, the same thing, deleted again and replaced it with the previous version, it seems to be working. Is this a know issue? I barely use the app, just installed it to get familiar with it, I still use the old Clover ways. If any input from me, like sending files, system data is useful, I can try to post it.

Yep, you're right, the app under last release is damaged. But you can use the one from release 5101 which is the same: https://github.com/CloverHackyColor/CloverBootloader/releases/download/5101/Clover.app-v1.12-5101.zip

Share this post


Link to post
Share on other sites
1 hour ago, vector sigma said:

Yep, you're right, the app under last release is damaged. But you can use the one from release 5101 which is the same: https://github.com/CloverHackyColor/CloverBootloader/releases/download/5101/Clover.app-v1.12-5101.zip

I do not know what the app writes in the libraries and caches, but I assume that, if the app was broken and returned to the previous version, nothing bad shall happened, until the next version of the app. No need to manually delete caches and stuff when the next version of the app will come, to make it work,I mean.

Edited by Vyzantion

Share this post


Link to post
Share on other sites
1 hour ago, Vyzantion said:

I do not know what the app writes in the libraries and caches, but I assume that, if the app was broken and returned to the previous version, nothing bad shall happened, until the next version of the app. No need to manually delete caches and stuff when the next version of the app will come, to make it work,I mean.

Bro' not sure what you mean, but the app is the same version, i.e v1.12

Share this post


Link to post
Share on other sites
On 12/28/2019 at 4:06 AM, vector sigma said:

For the moment run this in Terminal:


sudo nvram TestEmuVariableUefiPresent=true

Then I'll change how to recognize a legacy boot

Morning,

 

Sorry not sure if you need me to run the above command or run the IOReg as per Slice's post?

 

Thank you

Share this post


Link to post
Share on other sites
8 hours ago, vector sigma said:

Yep, you're right, the app under last release is damaged. But you can use the one from release 5101 which is the same: https://github.com/CloverHackyColor/CloverBootloader/releases/download/5101/Clover.app-v1.12-5101.zip

 

Your app under last release is damaged because of zip compression/uncompression? or something else. Can I compile it instead?

 

Thanks

Share this post


Link to post
Share on other sites
9 hours ago, vector sigma said:

Yep, you're right, the app under last release is damaged. But you can use the one from release 5101 which is the same: https://github.com/CloverHackyColor/CloverBootloader/releases/download/5101/Clover.app-v1.12-5101.zip

What is happen? I compiled it as usual under the same condition. 10.14.6 + Xcode 11.2.1

Share this post


Link to post
Share on other sites
8 hours ago, vector sigma said:

Bro' not sure what you mean, but the app is the same version, i.e v1.12

Sometimes in the past, when running a faulty version of an app, I could not run a good one after that, due to the fact that the faulty app placed some damaged files into the Library folder and in caches, I needed to find the folders and delete them manually alongside any version of the app, then I needed to re-download it in order to run. I was thinking about the future version of the app, v1,13 . I meant that this is probably not the case, I assume. 

Edited by Vyzantion

Share this post


Link to post
Share on other sites

Clover.app v1.13 with Clover r5102:

 

  • Fixed detection of legacy firmware for CloverDaemonNew.
  • Detection of System Serial and OEM manufacturer informations.
  • Startup sound settings in the interface.
  • Installer inform with a sound and an alert window the installation result.
  • Installer now produce the installation log.
  • Installer is now thread safe.
  • The UI is modified to make room for all the new functionalities

 

that is how the UI looks like now:

 

theme.png.715dc5fac10dfce23d937c3f40b57597.pngsound.png.89ca6a217577e5531f4998c5aa04cb26.pngmount.png.fd326369d58a0c2d556e0956de020e97.png  

the installer button is moved down, under "Update":

installer.png.0f5c673a810ec5236e735fa5543c7c9e.png

...as it fit better.. 

Let me know.

Share this post


Link to post
Share on other sites

very simple script to save nvram.plist

maybe it will be useful for something

#!/bin/bash

if [[ $1 == "install" ]]
then
sudo defaults write com.apple.loginwindow LogoutHook "$0"
else
UUID=$(ioreg -lw0 -p IODeviceTree | grep boot-log | sed 's/.*<\(.*\)>.*/\1/' | xxd -r -p | grep SelfDevicePath | sed 's/.*GPT,\([^,]*\),.*/\1/')
diskutil mount "${UUID}"  && nvram -xp > "$(diskutil info "${UUID}" | sed -n 's/.*Mount Point: *//p')"/nvram.plist
fi

 

Share this post


Link to post
Share on other sites
29 minutes ago, vector sigma said:

Clover.app v1.13 with Clover r5102:

 

  • Fixed detection of legacy firmware for CloverDaemonNew.
  • Detection of System Serial and OEM manufacturer informations.
  • Startup sound settings in the interface.
  • Installer inform with a sound and an alert window the installation result.
  • Installer now produce the installation log.
  • Installer is now thread safe.
  • The UI is modified to make room for all the new functionalities

 

that is how the UI looks like now:

 

theme.png.715dc5fac10dfce23d937c3f40b57597.pngsound.png.89ca6a217577e5531f4998c5aa04cb26.pngmount.png.fd326369d58a0c2d556e0956de020e97.png  

the installer button is moved down, under "Update":

installer.png.0f5c673a810ec5236e735fa5543c7c9e.png

...as it fit better.. 

Let me know.

 

Thanks and Happy New Year :yes:

Share this post


Link to post
Share on other sites
Posted (edited)

Hi @vector sigma

 

Is it possible to have the same region date for CloverBackup and System: for example, 18:00 (System - Local Hours France - Paris) instead of 06.00 PM (CloverBackup)?

 

V1.13 is Great :thumbsup_anim:

 

Thanks

Edited by Matgen84

Share this post


Link to post
Share on other sites
1 minute ago, Matgen84 said:

V1.13 is Great :thumbsup_anim:

Thanks

2 minutes ago, Matgen84 said:

Is it possible to have the same region date for CloverBackup and System: for example, 18:00 (System - Local Hours France - Paris) instead of 06.00 PM (CloverBackup)?

Not sure. It is en_US locale and I was thinking to make it GMT+0 to be more universal. The idea is to make developers understad what is going on when looking at  any log(s).

... also someone could be unpleasant to be located lol

Share this post


Link to post
Share on other sites
4 hours ago, vector sigma said:

Clover.app v1.13 with Clover r5102:

 

  • Fixed detection of legacy firmware for CloverDaemonNew.
  • Detection of System Serial and OEM manufacturer informations.
  • Startup sound settings in the interface.
  • Installer inform with a sound and an alert window the installation result.
  • Installer now produce the installation log.
  • Installer is now thread safe.
  • The UI is modified to make room for all the new functionalities

 

that is how the UI looks like now:

 

theme.png.715dc5fac10dfce23d937c3f40b57597.pngsound.png.89ca6a217577e5531f4998c5aa04cb26.pngmount.png.fd326369d58a0c2d556e0956de020e97.png  

the installer button is moved down, under "Update":

installer.png.0f5c673a810ec5236e735fa5543c7c9e.png

...as it fit better.. 

Let me know.

Do I need to delete some files, like caches, because I ran the broken version of just place it in Applications and run it?

Share this post


Link to post
Share on other sites
On 12/28/2019 at 4:06 AM, vector sigma said:

For the moment run this in Terminal:


sudo nvram TestEmuVariableUefiPresent=true

Then I'll change how to recognize a legacy boot

Hi @vector sigma,

 

Happy New Year and thank you for the updated app. I have run this and have attached an updated log. From my limited knowledge I presume the last fix you have applied has fixed the issues on my machine and waking from sleep will be resolved.

 

Will keep an eye and report back.

 

Thank you again for all your time and help.

clover.daemon.log

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, Sherlocks said:

@vector sigma

thank you so much for new version :)

here is ko.lang for 1.13 beta

ko.strings

Thanks!

EDIT

committed

5 hours ago, d620osx said:

Hi @vector sigma,

 

Happy New Year and thank you for the updated app. I have run this and have attached an updated log. From my limited knowledge I presume the last fix you have applied has fixed the issues on my machine and waking from sleep will be resolved.

 

Will keep an eye and report back.

 

Thank you again for all your time and help.

clover.daemon.log

Yes, now it is really good:

--------------------------------------------
- CloverDaemonNew v1.0.9
- macOS Version 10.15.1 (Build 19B88)
- System start at 2020-01-02 05:37:01
------
root mount point is '/Volumes/SSD_CATALINA'
Started with Clover r5097.
Firmware vendor is 'CLOVER'.
making '/' writable as Clover.RootRW=true.
Clover.DisableSleepProxyClient=true.
Sleep Proxy Client is already disabled.
Installing the LogoutHook..
LogoutHook is already set.
Logout hook is: /Library/Application Support/Clover/CloverLogOut

SIGTERM received at 2020-01-02 05:37:17
Clover.DisableSleepProxyClient=true.
Sleep Proxy Client is already disabled.

 

On 1/1/2020 at 10:22 PM, Vyzantion said:

Do I need to delete some files, like caches, because I ran the broken version of just place it in Applications and run it?

It is an Application and not a kernel extension, so I don't understand what cache you want delete. There is no cache.

Edited by vector sigma
committed ko language by Sherlocks

Share this post


Link to post
Share on other sites
10 hours ago, vector sigma said:

Thanks!

EDIT

committed

Yes, now it is really good:


--------------------------------------------
- CloverDaemonNew v1.0.9
- macOS Version 10.15.1 (Build 19B88)
- System start at 2020-01-02 05:37:01
------
root mount point is '/Volumes/SSD_CATALINA'
Started with Clover r5097.
Firmware vendor is 'CLOVER'.
making '/' writable as Clover.RootRW=true.
Clover.DisableSleepProxyClient=true.
Sleep Proxy Client is already disabled.
Installing the LogoutHook..
LogoutHook is already set.
Logout hook is: /Library/Application Support/Clover/CloverLogOut

SIGTERM received at 2020-01-02 05:37:17
Clover.DisableSleepProxyClient=true.
Sleep Proxy Client is already disabled.

 

It is an Application and not a kernel extension, so I don't understand what cache you want delete. There is no cache.

Most applications create files in other places on the os, preferences, caches etc , not just in the Applications folder, where the main app resides. I meant that, sometimes, to replace an app, those need to be deleted first, not just the main app. I was thinking that, due to the fact that there was a broken version, there may be broken preferences files somewhere else on the else, for example.

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, Vyzantion said:

Most applications create files in other places on the os, preferences, caches etc , not just in the Applications folder, where the main app resides. I meant that, sometimes, to replace an app, those need to be deleted first, not just the main app. I was thinking that, due to the fact that there was a broken version, there may be broken preferences files somewhere else on the else, for example.

A damaged application is not even executed by the OS, so there is nothing to think about, period.

Edited by vector sigma

Share this post


Link to post
Share on other sites
10 hours ago, Vyzantion said:

Most applications create files in other places on the os, preferences, caches etc , not just in the Applications folder, where the main app resides. I meant that, sometimes, to replace an app, those need to be deleted first, not just the main app. I was thinking that, due to the fact that there was a broken version, there may be broken preferences files somewhere else on the else, for example.

 

Just try it, if it works winner!

Share this post


Link to post
Share on other sites

Morning @vector sigma

 

Just checked my machine this morning and am still getting the wake over night:

 

2020-01-04 04:37:56.356024+0000  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: RTC (Alarm)

2020-01-04 04:37:56.356025+0000  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: RTC (Alarm)

2020-01-04 04:42:41.799795+0000  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: RTC (Alarm)

2020-01-04 04:42:41.799796+0000  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: RTC (Alarm)

2020-01-04 04:44:57.896561+0000  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: RTC (Alarm)

2020-01-04 04:44:57.896562+0000  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: RTC (Alarm)

2020-01-04 04:47:20.380496+0000  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: RTC (Alarm)

2020-01-04 04:47:20.380498+0000  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: RTC (Alarm)

2020-01-04 04:49:05.327023+0000  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: RTC (Alarm)

2020-01-04 04:49:05.327025+0000  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: RTC (Alarm)

2020-01-04 04:55:21.378664+0000  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: RTC (Alarm)

2020-01-04 04:55:21.378666+0000  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: RTC (Alarm)

2020-01-04 05:02:03.984132+0000  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: RTC (Alarm)

 

Log log fine so could it be something else on my machine:

 

--------------------------------------------
- CloverDaemonNew v1.0.9
- macOS Version 10.15.1 (Build 19B88)
- System start at 2020-01-02 05:37:01
------
root mount point is '/Volumes/SSD_CATALINA'
Started with Clover r5097.
Firmware vendor is 'CLOVER'.
making '/' writable as Clover.RootRW=true.
Clover.DisableSleepProxyClient=true.
Sleep Proxy Client is already disabled.
Installing the LogoutHook..
LogoutHook is already set.
Logout hook is: /Library/Application Support/Clover/CloverLogOut

SIGTERM received at 2020-01-02 05:37:17
Clover.DisableSleepProxyClient=true.
Sleep Proxy Client is already disabled.

 

Thank you

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×