Jump to content

AudioGod's Aorus Z390 Master Patched DSDT EFI for Catalina Mini Guide and Discussion


AudioGod
1,810 posts in this topic

Recommended Posts

On 6/7/2021 at 9:07 PM, AudioGod said:

OpenCore 0.7.0 EFI Update (Big Sur 11.6 Ready), 7th June 2021

(Use With Bios Revision F11L or Newer) 

 

The EFIs and DSDTs have now been updated to the my latest versions.

Changes made include,

  • Lilu 1.5.3,
  • AppleALC 1.6.1,
  • IntelMausi 1.0.6,
  • VirtualSMC 1.2,4,
  • WhateverGreen 1.5.0
  • OpenCore Updated to Revision 0.7.0 (Big Sur 11.5 Ready),
  • SIP can now be toggled from within OpenCanopy 
  • New OpenCanopy Icons
  • HFSPlus Updated
  • Plus other minor tweaks and changes to all of the configs.

 

OpenCore EFI Update v0.7.0 - 07/06/2021

OC 070 1,1 Z390 Master EFI.zip - OpenCore v0.7.0, SMBios iMacPro1,1 (IGPU Disabled)

 

OC 070 19,1 Z390 Master EFI.zip -  OpenCore v0.7.0, SMBios iMac19,1

 

Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.

 

Note 2 - Do not try to carry across your old OpenCore Config.plist to the new EFI as to many changes have occurred in 0.6.7. Use the new Config.plist instead.

 

For OpenCore Using PlistEdit Pro add your details by modifying the following 

1126595787_Screenshot2020-01-16at19_25_01.png.890a13d93c1ce4f42ee7dedb6d156e1e.thumb.png.b3ab8c747f2ed0d4697eaae541fcd843.png
 

Sadly this will be my last EFI update for this thread as my focus is no longer on the Intel side of life and it’s hard for me to keep up with little quirks and problems on the EFI side of life. 
Im still here to annoy you all though and the thread will stay alive.

Enjoy and BigUps

AG

Has anyone updated to 11.5 with OC 71 yet? What can you report back, can we use the same config without changes?

  • Like 3
Link to comment
Share on other sites

Ok, I took the plunge...  🛁  Here's what I did:

 

1) I updated the Opencore files. In these folders

a) /BOOT

b) /OC

c) /OC/Drivers 

and d) /OC/Tools

NOTE: ONLY the files that were present. I did not add any new ones.

 

2) I updated all the present kexts.

 

3) I added to

    <key>ACPI</key>
    <dict>

        <key>Quirks</key>
        <dict>
            <key>SyncTableIds</key>
            <false/>

 

and to

    <key>Kernel</key>
    <dict>

        <key>Scheme</key>
        <dict>
            <key>CustomKernel</key>
            <false/>

 

It's been running stable for a small week now. I haven't noticed anything weird.

  • Like 4
Link to comment
Share on other sites

On 8/3/2021 at 1:31 AM, Benjamin Franklin said:

Ok, I took the plunge...  🛁  Here's what I did:

 

1) I updated the Opencore files. In these folders

a) /BOOT

b) /OC

c) /OC/Drivers 

and d) /OC/Tools

NOTE: ONLY the files that were present. I did not add any new ones.

 

2) I updated all the present kexts.

 

3) I added to

    <key>ACPI</key>
    <dict>

        <key>Quirks</key>
        <dict>
            <key>SyncTableIds</key>
            <false/>

 

and to

    <key>Kernel</key>
    <dict>

        <key>Scheme</key>
        <dict>
            <key>CustomKernel</key>
            <false/>

 

It's been running stable for a small week now. I haven't noticed anything weird.

 

Hi, 
Can you please share your EFI file? 

Link to comment
Share on other sites

  • 1 month later...

For anyone upgrading to 0.7.3: Make sure to check your config.plist file against the "ocvalidate" utility... The validation errors might be not that clear but the most important thing is that your UEFI>Drivers should follow the "Dictionary" format instead of "String". Check the sample configuration there and update your files accordantly. Don't be like me, always read the changelog messages :)
 

  • Like 6
Link to comment
Share on other sites

On 9/8/2021 at 5:51 PM, davimachado said:

For anyone upgrading to 0.7.3: Make sure to check your config.plist file against the "ocvalidate" utility... The validation errors might be not that clear but the most important thing is that your UEFI>Drivers should follow the "Dictionary" format instead of "String". Check the sample configuration there and update your files accordantly. Don't be like me, always read the changelog messages :)
 

Can you post your EFI?

  • Like 1
Link to comment
Share on other sites

12 hours ago, Benjamin Franklin said:

Can you post your EFI?

 

Hi @Benjamin Franklin

This is the new way for 0.73+:

 

	   <key>Drivers</key>
		<array>
			<dict>
			<key>Path</key>
			<string>OpenHfsPlus.efi</string>
			<key>Enabled</key>
			<true/>
			<key>Arguments</key>
			<string></string>
			</dict>
			<dict>
			<key>Path</key>
			<string>OpenRuntime.efi</string>
			<key>Enabled</key>
			<true/>
			<key>Arguments</key>
			<string></string>
			</dict>
			<dict>
			<key>Path</key>
			<string>OpenCanopy.efi</string>
			<key>Enabled</key>
			<true/>
			<key>Arguments</key>
			<string></string>
			</dict>
			<dict>
			<key>Path</key>
			<string>CrScreenshotDxe.efi</string>
			<key>Enabled</key>
			<true/>
			<key>Arguments</key>
			<string></string>
			</dict>
		</array>

 

  • Like 4
Link to comment
Share on other sites

×
×
  • Create New...