Jump to content
AudioGod

AudioGod's Aorus Z390 Master Patched DSDT EFI for Catalina Mini Guide and Discussion

1,176 posts in this topic

Recommended Posts

Posted (edited)
1 hour ago, AudioGod said:

If you need more space just get a normal ssd and save some money and gain some space...lol

nvme are great little things and have serious transfer speeds in bursts but in the real world it really doesn’t matter for now.

gen 4 pcie helps a lot but that’s not for intel is it? Maybe in a few years lol

 

I've kind of gotten used to not having any Sata cables routed in my rig but you're right.  I might just get two large regular SSD's and call it a day.

 

edit:  Actually 2TB M2 drives are only about $20 bucks more than regular SSDs here.  :surprised:

Edited by hungrywallet

Share this post


Link to post
Share on other sites
Advertisement

Thank you for this guide. I have similar spec but use thunderbolt display via alpine ridge and don't have sound and brightest. Can you help what I miss? 

Share this post


Link to post
Share on other sites

@AudioGod

 

May I suggest PollAppleHotKeys: be set to Yes in your next OC release.  It gives us the ability to use Apple's hotkeys during boot.  I've found enabling verbose mode on the fly from time to time pretty useful.

 

Cmd+V: Enables verbose

Cmd+Opt+P+R: Cleans NVRAM

Cmd+R: Boots Recovery partition

Cmd+S: Boot in Single-user mode

Option/Alt: Shows boot picker when ShowPicker set to NO, an alternative is ESC key

 

 

Just a suggestion.

Share this post


Link to post
Share on other sites
4 minutes ago, hungrywallet said:

@AudioGod

 

May I suggest PollAppleHotKeys: be set to Yes in your next OC release.  It gives us the ability to use Apple's hotkeys during boot.  I've found enabling verbose mode on the fly from time to time pretty useful.

 

Cmd+V: Enables verbose

Cmd+Opt+P+R: Cleans NVRAM

Cmd+R: Boots Recovery partition

Cmd+S: Boot in Single-user mode

Option/Alt: Shows boot picker when ShowPicker set to NO, an alternative is ESC key

 

 

Just a suggestion.


Sure no problem, :) 

Share this post


Link to post
Share on other sites
Posted (edited)

@AudioGod

 

First of all, thank you for sharing your knowledge and expertise with the community.

 

I've been using your EFI for a while and it's superb. Very stable and reliable. I'm running the latest Catalina with an Imac19,1 profile on my Gigabyte Aorus Master Z390, Intel i9900K, Vega 64, Titan Ridge TB3 and 64GB Ram.

 

Got a few question though, which I'd really appreciate your input on.

 

* Is it safe to delete all of USB port limit patches from the config file and use a USBPorts.kext of my flavor instead to make it even more stable?

 

* If I opt for an ImacPro1,1 profile for my system, would I need to edit /replace some of parameters other than the usual in SMBIOS as well as any of the files included in your EFI?

 

* Would it conflict with the DSDT files including in the EFI folder if I add a Titan Ridge hot plug patch (Such as SSDT-Z390-TB3HP.aml)?
 

Thanks for any help you can provide on those topics.

 

Cheers..

 

Edited by alpha2008

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, alpha2008 said:

@AudioGod

 

First of all, thank you for sharing your knowledge and expertise with the community.

 

I've been using your EFI for a while and it's superb. Very stable and reliable. I'm running the latest Catalina with an Imac19,1 profile on my Gigabyte Aorus Master Z390, Intel i9900K, Vega 64, Titan Ridge TB3 and 64GB Ram.

 

Got a few question though, which I'd really appreciate your input on.

 

* Is it safe to delete all of USB port limit patches from the config file and use a USBPorts.kext of my flavor instead to make it even more stable?

 

* If I opt for an ImacPro1,1 profile for my system, would I need to edit /replace some of parameters other than the usual in SMBIOS as well as any of the files included in your EFI?

 

* Would it conflict with the DSDT files including in the EFI folder if I add a Titan Ridge hot plug patch (Such as SSDT-Z390-TB3HP.aml)?
 

Thanks for any help you can provide on those topics.

 

Cheers..

 

Usb is done via the ssdt and dsdt, this is how I’m able to give you no port limits while keeping the usb native. If you want to convert to your own usb.kext that’s not needed at all then you need to drop the ssdt and the patches but I would advise against it as you will gain nothing and lose native usb.

 

imacpro1,1 is perfectly fine to use with no major changes needed other then disabling the igpu in the bios and adding the smbios details but if your using a Navi GPU and push it in anyway via macos then again I would advise against it as the drivers are so bad that the system will become unstable if the gpu is pushed hard.

 

it won’t conflict with the dsdt if you use a ssdt for your tb card no that’s fine.

 

Edited by AudioGod

Share this post


Link to post
Share on other sites
On 3/28/2020 at 10:20 PM, AudioGod said:

 

It’s because the z390 master has a missing option to disable its onboard serial port and it conflicts with the Apple Watch unlock of all things.

the good news is it will be fixed in the next official bios update when it’s released.

what il do for you though is send you the latest beta bios now and unlocked MSR profile to go with it and your Apple Watch will work and unlock your Mac. (Your need to sign out and back into your iCloud account on your hack to reactivate it and make the watch unlock)


Check your inbox for the fix from me :thumbsup_anim:

 

Hi @AudioGod, could you send me the beta bios + MSR profile too? The Apple Watch bug is super annoying. 

 

Thanks! 

Share this post


Link to post
Share on other sites
Posted (edited)
22 minutes ago, Spybreak said:

 

Hi @AudioGod, could you send me the beta bios + MSR profile too? The Apple Watch bug is super annoying. 

 

Thanks! 


Your wish is my command, 

Check your inbox in a minute from now. :thumbsup_anim:
 

@Spybreak Sent!

Edited by AudioGod

Share this post


Link to post
Share on other sites
7 hours ago, AudioGod said:

Usb is done via the ssdt and dsdt, this is how I’m able to give you no port limits while keeping the usb native. If you want to convert to your own usb.kext that’s not needed at all then you need to drop the ssdt and the patches but I would advise against it as you will gain nothing and lose native usb.

 

imacpro1,1 is perfectly fine to use with no major changes needed other then disabling the igpu in the bios and adding the smbios details but if your using a Navi GPU and push it in anyway via macos then again I would advise against it as the drivers are so bad that the system will become unstable if the gpu is pushed hard.

 

it won’t conflict with the dsdt if you use a ssdt for your tb card no that’s fine.

 

 

I've got it.. Thanks a bunch buddy...

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/3/2020 at 10:36 PM, AudioGod said:

Alternative EFI - OpenCore, No DSDT and Done the way OpenCore intended it 3rd March 2020

We have now created a OpenCore EFI done the way the OpenCore Devs intended it to be made, There is no DSDT in use so you can use this EFI on any supported GPU and the SSDTs have been made so they will not be used in any other Operating System apart from MacOS.

AG OpenCore 056 Z390 Master EFI 040320.zip - OC Version 0.5.6, SMBios19,1 (04/03/20)

 

Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.

 

hi
Thank you for the great work and spruce guide.
Next to Windows 10 I put Hactkintosh on OpenCore 0.5.6 on my PC (Catalina 10.15.4) with files from AudioGod's "AG OpenCore 056 Z390 Master EFI 040320.zip" on another disk and I encountered a problem that requires your help because I don't know what to do next .

 

The computer started up immediately, most of the things I was able to check worked (except FileVault), however, after a few hours of work, I restarted and after selecting "MacOs Catalina" from the Boot menu, an apple appeared for a few seconds and then the message "OCB: StartImage failed - Aborted. Halting on critical error "and black screen. In addition to Windows, I could only run the Boot menu option - Recovery.
I did the installation again - the computer worked 1.5 days (with several reboots and running Windows 10) and the situation repeated,

 

In AudioGod's config.plist, I only entered serial numbers in the platforminfo and I introduced 3840x2160 resolution in UEFI-Output-Resolution. The rest unchanged.

 

My computer - specification:
- Gigabyte Aorus Master Z390

- Intel i9-9900K
- Sapphire Radeon XR 5700 XT
- Samsung 970 EVO Plus 1 Tb SSD (only for MacOs)
- 32 Gb Ram HyperX Fury 3600 Mhz
- WiFi with OSX WIFI Apple Broadcom BCM943602CDP
- Noctua NH-D15 cooling

- Eizo EV3237 4K monitor

 

In addition, the "F11c MSR Unlocked Profile" works on the motherboard, however, I did not complete point 6 of MSR placement because it was about Clover and I do not know if the motherboard is unlocked (probably not).

 

What could be the problem - I would like to ask for feedback and thank you in advance for your help.

IMG_0211.jpeg

IMG_0217.jpeg

Edited by Filip71

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Filip71 said:

 

hi
Thank you for the great work and spruce guide.
Next to Windows 10 I put Hactkintosh on OpenCore 0.5.6 on my PC (Catalina 10.15.4) with files from AudioGod's "AG OpenCore 056 Z390 Master EFI 040320.zip" on another disk and I encountered a problem that requires your help because I don't know what to do next .

 

The computer started up immediately, most of the things I was able to check worked (except FileVault), however, after a few hours of work, I restarted and after selecting "MacOs Catalina" from the Boot menu, an apple appeared for a few seconds and then the message "OCB: StartImage failed - Aborted. Halting on critical error "and black screen. In addition to Windows, I could only run the Boot menu option - Recovery.
I did the installation again - the computer worked 1.5 days (with several reboots and running Windows 10) and the situation repeated,

 

In AudioGod's config.plist, I only entered serial numbers in the platforminfo and I introduced 3840x2160 resolution in UEFI-Output-Resolution. The rest unchanged.

 

My computer - specification:
- Gigabyte Aorus Master Z390

- Intel i9-9900K
- Sapphire Radeon XR 5700 XT
- Samsung 970 EVO Plus 1 Tb SSD (only for MacOs)
- 32 Gb Ram HyperX Fury 3600 Mhz
- WiFi with OSX WIFI Apple Broadcom BCM943602CDP
- Noctua NH-D15 cooling

- Eizo EV3237 4K monitor

 

In addition, the "F11c MSR Unlocked Profile" works on the motherboard, however, I did not complete point 6 of MSR placement because it was about Clover and I do not know if the motherboard is unlocked (probably not).

 

What could be the problem - I would like to ask for feedback and thank you in advance for your help.

You need to enter your serial number, uuid and mlb into the plist bud.

 

it may also be a case of needing to clear you cmos by removing all power from the hack and then removing the battery from the board for 2 mins, put it all back together and load back your settings and away you go.

there are fixes in clover to make it play better with the igpu enabled that are not in Oc 056 as of yet but will be in the next release 0.5.7 when it goes public soon.

 

Edited by AudioGod

Share this post


Link to post
Share on other sites
10 minutes ago, AudioGod said:

You need to enter your serial number, uuid and mlb into the plist bud.

 

it may also be a case of needing to clear you cmos by removing all power and then removing the battery for the board for 2 mins, put it all back together and load back your settings and away you go.

there are fixes in clover to make it play better with the igpu enabled that are not in Oc 056 as of yet but will be in the next release 0.5.7 when it goes public soon.

 

Thanks for the information and advice :-).

 

I entered all serial numbers (serial, MLB and UUID).

 

It is night in Poland now so tomorrow I will take the battery out of the motherboard and let me know about the effects.

 

And what do you advise you to do to fully unlock MSR?
After resetting the motherboard I will load the F11c MSR Unlocked Profile, however AudioGod's guide in point 6 refers to Clover and not to OpenCore.

 

Share this post


Link to post
Share on other sites
Just now, Filip71 said:

Thanks for the information and advice :-).

 

I entered all serial numbers (serial, MLB and UUID).

 

It is night in Poland now so tomorrow I will take the battery out of the motherboard and let me know about the effects.

 

And what do you advise you to do to fully unlock MSR?
After resetting the motherboard I will load the F11c MSR Unlocked Profile, however AudioGod's guide in point 6 refers to Clover and not to OpenCore.

 

its fine for any boot loader, that was written pre OC :)

Share this post


Link to post
Share on other sites

Since the new EFI was installed my mouse only works for 50% in Clover. I can move the pointer but can't click on Win or MacOS to continue booting.  Anyn idea what this could be?

Share this post


Link to post
Share on other sites
Posted (edited)
6 minutes ago, decat said:

Since the new EFI was installed my mouse only works for 50% in Clover. I can move the pointer but can't click on Win or MacOS to continue booting.  Anyn idea what this could be?


that’s very strange.

nothing has changed concerning usb on the EFI for a long time now.

infact the last upgrade was a very minor one mainly for the latest version of clover so 15.4 would install and also the latest Oc quirks drivers.

Otherwise it’s the same EFI as before.


is this only happing at the clover bootsplash and not in macOS itself?

 

could be clover I guess, check if there’s a new version and if there is update it and see.

Edited by AudioGod

Share this post


Link to post
Share on other sites

Idd, just in Clover, in MacOS & Windows it works fine. Still in same usb port, same mouse as before. Will try another mouse after work tonight and see what it gives.

It's not a big issue but since the it popped up after placing the new EFI it presumed it could have been related.

Share this post


Link to post
Share on other sites
Posted (edited)
31 minutes ago, decat said:

Idd, just in Clover, in MacOS & Windows it works fine. Still in same usb port, same mouse as before. Will try another mouse after work tonight and see what it gives.

It's not a big issue but since the it popped up after placing the new EFI it presumed it could have been related.


It could b a bug in the clover build so it’s worth checking to see if there’s an update for it.

Edited by AudioGod

Share this post


Link to post
Share on other sites

Just checked the Clover topic and it's indeed mentioned. The CloverX64.efi file needs to be changed.

Thx for pointing out where to look!

Share this post


Link to post
Share on other sites

The iGPU still makes my system little unstable. What for is iGPU used ? Do I actually have to have it enabled?

Share this post


Link to post
Share on other sites
28 minutes ago, photom said:

The iGPU still makes my system little unstable. What for is iGPU used ? Do I actually have to have it enabled?

Unstable in what way?

if you mean runtime errors at start up it’s nothing like it used to be and when it happens you just power off and on again. (I might also be able to tighten it up before release)

 

the other way Togo would be to use  smbios iMacpro1,1 with the igpu disabled but because the 5700xt drivers are so bad under Mac OS at the moment it could become unstable. 
 

I intend to release a 1,1 variant of OpenCore along with 19,1 upon release but at this moment in time I’m a little tied up helping out debugging some issues with OpenCore.

 

 

 

Share this post


Link to post
Share on other sites

No, I am not getting any errors - but after a reboot I get really really slow performance in apps like chrome.  Choppy scrolling.  Delays in tabs opening.  I can work without iGPU and it is very smooth - but will that affect my system in any way?

Share this post


Link to post
Share on other sites
27 minutes ago, photom said:

No, I am not getting any errors - but after a reboot I get really really slow performance in apps like chrome.  Choppy scrolling.  Delays in tabs opening.  I can work without iGPU and it is very smooth - but will that affect my system in any way?

only if you use quick sync otherwise no.

Share this post


Link to post
Share on other sites

No quick sync so all good then :}. Thanks AudioGod.

Share this post


Link to post
Share on other sites

Just will say THANKS to everybody who make it possible run MacOs on this motherboard so easy. Easy for me as a user without any knowledges in this case. Im a copy paster. Thanks for different fixes and updates, at all of You keep it fresh all the time.

Share this post


Link to post
Share on other sites

@AudioGod

 

On OC I don't think my USB-C is charging as fast as it used to on Clover.  My iPad loses charge while connected with SideCar.  I don't think this was ever the case on your Clover EFI.  Have you noticed this at all?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
        ***The topic is for Notebooks and Desktops***   Install MacOS with Olarila Image, Step by Step, Install and Post Install
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      Mobos serie 400 with 10th processors, use MacBookAir9,1 smbios for now
        First... ***Update bios to last available version!***   If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app     Look at my Clover folders and understand what we really need, this is the best way to learn     1-Installation     --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder    https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install Sierra/High Sierra and boot into system! 2-Post Installation     --Install Clover in HDD/SSD and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Reboot and activate video!   3-Video     -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/   -Nvidia WebDriver High Sierra   http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/   -Cuda   http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   -Check it, easy way   nvidia-update.command.zip by Benjamin-Dobell   4-DSDT       Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC* -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS* -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -IMEI -EC -PNLF(Nvidia/AMD) -HDMI ---To avoid problems use some patches in config.plist, don't forget!--- GLAN to GIGE 474c 414e 4749 4745 GFX0 to IGPU 47465830 49475055 HDAS to HDEF 48444153 48444546 HECI to IMEI 48454349 494d4549 SAT0 to SATA 53415430 53415441 5-SSDT   Generate your SSDT for PM, use ssdtPRGen by Piker-Alpha https://github.com/Piker-Alpha ssdtPRGen.command.zip   or just use "plugin-type"=0x01 in DSDT, SSDT or Clover config.plist   for check Power, Frequency, Temperature and Utilization, use it Install Intel Power Gadget.pkg.zip   6-Brightness  
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
        -Clover   https://sourceforge.net/projects/cloverefiboot/files/Installer/   -Lan driver by Mieze     -Atheros http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   -Links     -FakeSmc https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   if u like, Rate Topic     It's time to Rock -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, badruzeus and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By tonyx86
      This guide is a work in progress and will be updated as I refine the installation.
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks (Laptop: Thinkpad T61 / Nvidia NVS 140m, Laptop: Dell Latitude E6410 / Nvidia G3100m, Desktop: Gigabyte G31 / GeForce 9600, Desktop: Biostar TH55HD / Sapphire Pulse RX580) are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec SMBIOS MacModel MacMini 8,1 Unsupported M.2 PCIe x1 2230 Intel Wi-Fi (currently disabled in BIOS).  I may replace this with Brcm, but am using only Ethernet (IntelMausi) for now.  
      Installation Steps: To be provided
      See attached EFI and /L/E kexts in EliteDesk.zip archive See installation methodology here See references here  
      What is not working
      Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card).  
      What is not tested
      USB c 3.1 port Microphone port  
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions
      (Reported this as a possible Clover issue - no solution yet) Clover boot loader may default to Recovery volume after a normal shutdown.  Work-around is to select your normal macOS volume.  This may only happen when Clover is configured to boot LastBootedVolume and may be "fixable" by explicitly setting a boot volume (haven't tested this). (Watching this - not sure it's a problem) At least one display blanks (sleeps) when plugging / unplugging USB device (observed in front USB 3.1 ports).  Display wakes immediately on keyboard and mouse activity, so this is a minor issue but may be indicative of another issue. (No solution yet - work-around is to use Firefox) Safari has problems loading insanelymac web pages after sleep / wake.  Work-around: use Firefox or reboot.  I have seen reports in forums where Safari issues are experienced after sleep / wake on a real Mac.  Not sure if the problems are related.  I suspect that it might be related to streaming video on InsanelyMac pages (since I haven't observed the issue on "static" pages).
      Also observed video problem in AppStore after sleep/wake.  Console: VideoDecodersUnavailable  (Solved and included in the attached EliteDesk.zip archive) Display does not fully wake after resuming from sleep (needs an extra mouse or keyboard stimulus to fully wake).  Solution is to change boot arg darkwake=0 to darkwake=2.  Other values of darkwake may work as well, but this is the first I tried and it worked. (Solved and included in the attached EliteDesk.zip archive) -disablegfxfirmware boot arg is not required with WEG.  I inadvertently left this boot arg after I encountered an endless gfx firmware update boot loop while working on my FB patching.  This boot arg is no longer necessary after completing FB patching with WEG. (Solved and included in the attached EliteDesk.zip archive): Sometimes, CMOS time is lost on shutdown or restart.  Solution is to enable Clover's Apple RTC fix in config.plist. (Solved and included in the attached EliteDesk.zip archive) headphone jack doesn't work.  Solution is to change HDEF layout-id to 28. (Solved and included in the attached EliteDesk.zip archive) System freezes on wake from sleep because of a kernel panic related to hda-gfx (my system does not have HDMI and my DP->DVI adapters do not drive monitor speakers).  Solution is to add No-hda-gfx property to HDEF as described here.  This property is recognized as a Lilu flag and prevents loading hda-gfx. (Solved and included in the attached EliteDesk.zip archive) Device (PMCR) is not defined.  Solution is a SSDT that "injects" the missing device. (Solved and included in the attached archive) eficheck is loaded (not sure why this is bad, but may be a privacy issue - see here). Solution is to add updated EFICheckDisabler kext that include Q370 chipset.  See here.  
      BIOS Version / Configuration: To be provided
      Version: 02.11.01 Rev.A  
      Clover Configuration: To be provided
       
      UHD 630 Framebuffer Patching: To be provided
       
      Current Versions
      Catalina 10.15.4.02 Clover (UEFI) r5118 Lilu.kext 1.4.4 WhateverGreen.kext 1.3.9 AppleALC.kext 1.4.9 IntelMausiEthernet 2.5.0  
      Credits To be provided
       
       




      EliteDesk800 G4 Mini - Rev 0.5.zip

    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
       
      ---TUTORIAL---
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Original Post--
      https://www.olarila.com/topic/6531-olarila-hackbeast-z390-designare-thunderbolt-full-dsdt-patches-clover-opencore/
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://www.olarila.com/topic/6364-mojave-catalina-on-mobos-series-100200300-with-opencore-bootloader/
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
        Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell   https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Skylake, Kabylake and Coffeelake is here https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By shawnski
      i have managed to install catalina to my hackintosh, everything else seems to work be very smooth but geek bench score is very low. 490 single core, 3879 multi score
      my build is
      3930k intel,
      rx570 gpu,
      huananzhi x79,
      32gb kingston 1600,
      kingspec 512 nvme,
      Broadcom BCM94360CS2 wifi & bluetooth pci
      clover smbios i choose iMac13,2
      i installed Intel Power Gadget, screenshot here: https://prnt.sc/slit8z
      any help would be greatly appreciated.
×