Jump to content
AudioGod

AudioGod's Aorus Z390 Master Patched DSDT EFI for Catalina Mini Guide and Discussion

479 posts in this topic

Recommended Posts

I repeat once again. Download your EFi and did nothing else, then add your data (sn uuid mlb) and that’s it. After that, only 15 USB ports work for me. And I wanted it to work - ALL ports.

Share this post


Link to post
Share on other sites
Advertisement

The OpenCore bootloader only has 15 USB ports. On the bootloader "Clover" - all USB ports are wound up. Can you make all of the USB ports factory installed in the OpenCore bootloader?

Share this post


Link to post
Share on other sites
08.02.2020 в 18:18 Matgen84 сказал:

1

 

08.02.2020 в 18:18 Matgen84 сказал:

2

 

Edited by kapelan6

Share this post


Link to post
Share on other sites

Hi

i'm using opencore Efi (i9 9900k , radeon vii with both smbios 19.1 & 1.1)

everything is fine except the mouse sometimes become laggy (jump )

What's the problem ?

Share this post


Link to post
Share on other sites
2 minutes ago, Matgen84 said:

Hi @AudioGod

 

Update to OcQuriks Rev_14: all works fine :)


I noticed you have been fiddling with Oc over on there thread.

have you got it improved any by them lot?

im fed up with OC at the moment so I’ve gone back to clover...lol

Share this post


Link to post
Share on other sites
43 minutes ago, AudioGod said:


I noticed you have been fiddling with Oc over on there thread.

have you got it improved any by them lot?

im fed up with OC at the moment so I’ve gone back to clover...lol

 

I will reply in MP :)

Share this post


Link to post
Share on other sites

Thank you

I'm getting some probs when using the smbios 19.1 oc, on cold boot the system shows black screen with debug code 99.. but on sb 1.1 everything's going well

Share this post


Link to post
Share on other sites
1 hour ago, channa13 said:

Thank you

I'm getting some probs when using the smbios 19.1 oc, on cold boot the system shows black screen with debug code 99.. but on sb 1.1 everything's going well


You might want to try doing a battery bios reset to fully clear out the NVram and that will kick 19.1 into gear.

check the update notes

Share this post


Link to post
Share on other sites
23 minutes ago, AudioGod said:


You might want to try doing a battery bios reset to fully clear out the NVram and that will kick 19.1 into gear.

check the update notes

I did it but something , the OC update for 14/01 is working , but the last one when I shutdown my pc I cannot boot. I only can when I hit the reset button

Share this post


Link to post
Share on other sites
3 minutes ago, channa13 said:

I did it but something , the OC update for 14/01 is working , but the last one when I shutdown my pc I cannot boot. I only can when I hit the reset button

Again read the update notes as it explains everything.

Share this post


Link to post
Share on other sites
8 minutes ago, AudioGod said:

Again read the update notes as it explains everything.

why u keep saying read the update as It seems the first time I use the Efi ? all the previous update are working , not the last 

Share this post


Link to post
Share on other sites
5 minutes ago, channa13 said:

why u keep saying read the update as It seems the first time I use the Efi ? all the previous update are working , not the last 

It explains why in my update post buddy and I’m in the middle of a massive job so you can save me the time of going though it all again and just read the post.

sorry I can’t be more helpful at the second but it really is all explained in my post. 


@channa13

NEW Clover Major EFI, 4th February 2020 

(Use With Bios Revision F11c)

 

VERY IMPORTANT NOTICE

PLEASE NOTE IT HAS BEEN DISCOVERED THAT THE DRIVER MemoryAllocation.EFI IS MADE FROM THE SAME CODE AS THE FREE2000.EFI DRIVER AND IS POTENTIALLY HARMFUL TO YOUR SYSTEM SO I HAVE DECIDED TO DROP THE DRIVER FROM MY EFIs.

 

You will need to preform a full bios reset by removing all power to the system and then removing the motherboards internal battery for a few minutes then put it all back and load back in your bios profile and continue as normal.

 

If you find your unable to boot up with the new EFI and the IGPU enabled then you can try dropping the IGPU memory from 64mb to 32mb or if that doesn't work you can disable the IGPU and change the boot argument from shikigva=80 to shikigva=144

 

im not sure that could be any clearer tbh lol

Edited by AudioGod

Share this post


Link to post
Share on other sites

@AudioGod I really appreciated you buddy, I was trying other method to install Catalina on my Aorus Master with no luck for many hours but I got it successful with your method within 20mins for fully working Hackintosh since January , Not yet test your last update EFI yet, I will try it tonight, anyway I tried to monitor my temperature and fan rpm through iStat Menu by copy SMCSuperIO.kext and SMCProcessor.kext to EFI/Clover/Kext/Other but it is not working. Is there anyway to get temperature monitor working ?

Thanks you

Share this post


Link to post
Share on other sites
17 minutes ago, pl4n__b said:

@AudioGod I really appreciated you buddy, I was trying other method to install Catalina on my Aorus Master with no luck for many hours but I got it successful with your method within 20mins for fully working Hackintosh since January , Not yet test your last update EFI yet, I will try it tonight, anyway I tried to monitor my temperature and fan rpm through iStat Menu by copy SMCSuperIO.kext and SMCProcessor.kext to EFI/Clover/Kext/Other but it is not working. Is there anyway to get temperature monitor working ?

Thanks you

Should be working fine bud,

redownload the latest version of VirtualSMC and instal again replacing virtualSMC for the latest version too.

Share this post


Link to post
Share on other sites
2 hours ago, AudioGod said:

Should be working fine bud,

redownload the latest version of VirtualSMC and instal again replacing virtualSMC for the latest version too.

Thanks buddy, just download the latest version and replace it, CPU sensor worked great but there is GPU temperature. 

Is there anything I could do to ???

Edited by pl4n__b

Share this post


Link to post
Share on other sites
37 minutes ago, pl4n__b said:

Thanks buddy, just download the latest version and replace it, CPU sensor worked great but there is GPU temperature. 

Is there anything I could do to ???

Il check on mine when I’m next in front of it.

Share this post


Link to post
Share on other sites
15 hours ago, AudioGod said:

Il check on mine when I’m next in front of it.

one more question buddy, in my clover boot menu there is no windows partition, I have them dual boot on a separate 500gb ssd, windows on the 1st slot and Catalina on the second slot ( I installed windows first ), I have tried to find the uuid of the Windows EFI to add to clover custom entries but couldn't find it, there is no efi partiton on windows drive please see the photo...

Screen Shot 2020-02-14 at 1.47.15 PM.png

Edited by pl4n__b

Share this post


Link to post
Share on other sites
2 hours ago, pl4n__b said:

one more question buddy, in my clover boot menu there is no windows partition, I have them dual boot on a separate 500gb ssd, windows on the 1st slot and Catalina on the second slot ( I installed windows first ), I have tried to find the uuid of the Windows EFI to add to clover custom entries but couldn't find it, there is no efi partiton on windows drive please see the photo...

Screen Shot 2020-02-14 at 1.47.15 PM.png

You must have windows booted up as a non UEFI boot.

to find out if that’s the case you need to go into the bios and enable CSM and if you windows drive reappears after that then there’s your answer.

 

Share this post


Link to post
Share on other sites

Hey @audiogod

I just purchased exact same setup as you, to replicate this build. I have a macbook pro 2016 at catalina 15.3 which i used to built the bootable USB and then replaced the efi with your provided efi (after inserting the correct uuid and serial number from clover configurator). The system doesnt seem to boot and restarts halfway in the apple logo screen. Is there a way to get your current bios profile and efi backup that I can upload in mine? i am also on 11c bios.

 

Shall I install MacOS with GPU (5700 XT) or without GPU? (in your settings for BIOS it says to use PCIE slot). I was trying to install macos without GPU though by changing that setting to IGFX)

 

Thank you so much for all you have done here.

Edited by texasdude11

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Pro and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Pro, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware using Catalina 10.15.3
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install.
       
       
      HARDWARE USED
      • Intel I9 9900k 
      • Gigabyte AORUS Z390 PRO
      • Sapphire Nitro+ SE Vega56 (connected to monitor with DisplayPort)
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit. 
      • CoolerMaster MASTERLIQUID ML360R RGB CPU Cooler
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       

       
       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar
       
       
      CLOVER  FOLDER
      Use this folder with fully patched DSDT
      Current EFI 
      Updated 14/02/2020
      Z390 Pro Navi Vega Clover EFI 140220.zip - Use with Bios revision F12d Only (14/02/2020 Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI)
      Z390 Pro Polaris Clover EFI 140220.zip - Use with Bios revision F12d Only (14/02/2020 RX5XX Polaris DSDT EFI)
      HD630 Z390 Pro F12d EFI 140220.zip  Use with Bios revision F12d Only (14/02/2020 IGPU Only EFI) SMBIOS MacMini 8,1 
       
      PLEASE NOTE - Please flash your motherboard bios to revision F11 to use my current EFI. It’s a major rework of the bios and vital changes have been made to the layout and power tables. New DSDTs have been created and installed into the new EFI’s but will not work correctly with any other bios revision.
       
      Latest Gigabyte Z390 PRO BIOS (F12d)
      mb_bios_z390-aorus-pro_f12d.zip
       
       
      CFG Unlock (MSR) F12d BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - N-D-K Fork of OpenCore (16/01/2019)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Clover
      Clover Configurator
      Kext Updater
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      FakeSMC    (Can be used instead of VirtualSMC)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F12d)
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup 
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

       

       

       

       
       
       
    • By ricardos7
      Boa tarde a todos, estou fazendo um hack em um notebook Dell 5557, as configurações estão abaixo.
      Preciso de ajuda para terminar alguns detalhes que nÃo consegui, alguém poderia ajudar?
       
      bem com a minha pasta EFI que pode ser baixada nesse post vc poderá fazer o seu hack mais facilmente nesse modelo,
      pois quase tudo ja esta configurado e pronto pra uso.
       
      ESPECIFICAÇÕES TÉCNICAS
      Processador Intel Core i7 - 6ª Geração Intel Core i7-6500U
      Velocidade: 2.5 GHz até 3.1 GHz com Max Turbo Cache: 4Mb
      Memória RAM Quantidade: 16GB DDR3L 1600MHz (2X8).
      Armazenamento Capacidade: 240 GB SSD
      Tela Tamanho:15.6” Resolução: FULL HD 1920x1080p Touch
      Webcam integrada de alta definição (720p) com microfone digital
      Gráfico Integrado Intel HD 520
      NVIDIA® GeForce 930M com 4GB DDR3 Dedicada
      Áudio Realteck ALC255

      Dell Wireless 1707 WiFi, chip ar9565
      1x  HDMI 1.4ª
      2x USB 3.0
      1x USB 2.0
      1x Ethernet 10/100 RJ-45
      1x Entrada de Cartão 5 em 1 (SD, SD 3.0, SDHC, MS e MS PRO)
      Leitor de Cartão
      Tipo: SD, SDHC, SD3.0, MS, MS Pro
      Alimentação Bivolt 3 células 43Wh
       
       
      O QUE NÃO FUNCIONA?
      BRILHO DA TELA
      BLUETOOTH
      SONO (Hibernação)
      HDMI (audio) video funciona mais a tela do note fica preta ao conectar o cabo HDMI
      GRAFICOS DEDICADOS NVIDEA 930M (DESATIVADO)
       
      O QUE FUNCIONA?
       
      GRAFICOS INTEL
      WI-FI - a intel original foi substituída pela DELL dw1707 ar9565
      AUDIO
      TECLADO
      TRACKPAD (com gestos)
      TOUCHSCREEN (com alguns gestos)
      TECLAS  DE ATALHO
      PLACA DE REDE RJ45
      GERENCIAMENTO DE ENERGIA
       
      OBS. PARA DESATIVAR OS GRÁFICOS FOI USANDO UMA SSDT EM CONJUNTO COM A DSDT-5 E 7, DEPOIS DE APLICADO ALGUNS PACHES.
       
      A DSDT E AS SSDT
      PACHS BASICOS APLICADOS.
      Aparentemente o gerenciamento de energia está funcionando bem, pelo menos o processador parece esta bem estável.
       

       
      PASTA OTHER CLOVER (DEPOIS DESSA IMAGEM FOI ADICIONADO MAIS DUAS KEXT QUE NAO ESTAO PRESENTES NA IMAGEM, PARA FUNCIONAR
      O TOUCH E PARA O WIFI CONSEGUIR ENCONTRAR AS REDES.
       

       
      EFI 
       

       
       
       
       
      ESTAREI DEIXANDO UM LINK PARA DOWNLOAD DA MINHA PASTA EFI, CASO ALGUEM ESTEJA FAZENDO ESSE MESMO HACK ESSA PASTA PODERÁ AJUDAR.
       
      ATENÇÃO
       
      LEMBRANDO QUE OS ARQUIVOS DSDT E SSDT, SSDT DE 5 A 8 SÃO DO MEU NOTEBOOK, QUEM FOR USAR DEVER EXTRAIR E CONSTRUIR SEUS PRÓPRIOS DSDT E SSDT.
      O SSDT-EC E O SSDT-PNLF PODEM SER USADOS POIS SÃO GENERICOS.
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F PARA COLOCAR NO PENDRIVER DE INSTALAÇÃO.
      https://drive.google.com/open?id=1nPM2CNgpr7cwOkjwj7UReziqrh9xjtf1
      SE NAO SUBIR COM A Config.plist INICIAL SELECIONE A Config2.plist
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F (EM USO) 14/02/2020
      https://drive.google.com/open?id=1US7j-YlufrFTasLihmUZwElyV4jBfHDg
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F (ANTIGA)
      https://drive.google.com/open?id=1Q2tnoqQZ9K44Bv6k2k1yauaHCAop_ZyW
       
      QUEM PUDER AJUDAR A CORRIGIR OS PROBLEMAS RESTANTE EU AGRADEÇO, OBRIGADO.
       
       

    • By Krani93
      Hi guys,
       
      I'm trying to install Catalina on a Lenovo m720q (i5-8600T with B360).
      After some other issues I'm know stuck at attached screen.
      Im using latest opencore version and have my EFI folder attached.
       
      Can someone help me I've got no clue what to try next :/ 
       
       
      Cheers!

      EFI.7z
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://www.olarila.com/topic/5165-olarila-app-images-and-folders/   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell   https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Skylake, Kabylake and Coffeelake is here https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
×