Jump to content
AudioGod

AudioGod's Aorus Z390 Master Patched DSDT EFI for Catalina Mini Guide and Discussion

1,176 posts in this topic

Recommended Posts

16 minutes ago, AudioGod said:

@Matgen84 @WizeMan @texem

New Kexts all release no betas. Update Update Update!!!!!!!!!!!

 

WhateverGreen-136.zip

Lilu 141.zip

AppleALC-145.zip

VirtualSMC 110.zip

 

:thumbsup_anim:

 

Im going to have to make a new Updated EFI ain't I? 

@Matgen84 Should I use F11c or F10 as the DSDT for it?

I very much prefer F11c TBH

 

 

@AudioGod I think you can make two EFI versions: one with DSDT for F10, one with DSDT for F11c. I don't know if the new DSDT works on F10 and vice versa. As I don't know the difference between these two DSDT.

I also prefer F11c, for the moment.

Share this post


Link to post
Share on other sites
Advertisement
6 minutes ago, Matgen84 said:

 

@AudioGod I think you can make two EFI versions: one with DSDT for F10, one with DSDT for F11c. I don't know if the new DSDT works on F10 and vice versa. As I don't know the difference between these two DSDT.

I also prefer F11c, for the moment.

The F10 DSDT is no good for F11c and vice versa. The DSDTs are very much Bios Revision Specific.

 

I would prefer not to post to many variations of the EFI as it will only add confusion especially for the noobs so its F10 or F11c but not both.

Personally I Vote F11c, 

you?

 

Anybody else wanna chuck there voice in here before I go ahead and do it?

Edited by AudioGod

Share this post


Link to post
Share on other sites
20 minutes ago, AudioGod said:

The F10 DSDT is no good for F11c and vice versa. The DSDTs are very much Bios Revision Specific.

 

I would prefer not to post to many variations of the EFI as it will only add confusion especially for the noobs so its F10 or F11c but not both.

Personally I Vote F11c, 

you?

 

@AudioGod I vote also F11c. It's time to open Github repo: Users can download EFI folder with BIOS F10, or with BIOS F11c. You keep only the latest EFI folder in this topic. What do you think of that? Just my opinion. 

Share this post


Link to post
Share on other sites
28 minutes ago, Matgen84 said:

 

@AudioGod I vote also F11c. It's time to open Github repo: Users can download EFI folder with BIOS F10, or with BIOS F11c. You keep only the latest EFI folder in this topic. What do you think of that? Just my opinion. 

I keep all EFI under a archive section on my thread and what il do is il put a update warning for F11c and post the f10 dsdt separately with an option to swap over the dsdt.

Share this post


Link to post
Share on other sites
43 minutes ago, AudioGod said:

I keep all EFI under a archive section on my thread and what il do is il put a update warning for F11c and post the f10 dsdt separately with an option to swap over the dsdt.

 

@AudioGod More simple and more efficiency. I vote for it, my bro. :thumbsup_anim:

Share this post


Link to post
Share on other sites
27 minutes ago, Matgen84 said:

 

@AudioGod More simple and more efficiency. I vote for it, my bro. :thumbsup_anim:

 

Im going to post it up tonight I think, im just playing with F11c Opencore now that @texem kindly put together and that's working well too. :)  

Share this post


Link to post
Share on other sites
On 1/11/2020 at 8:54 PM, AudioGod said:


1. if Catalina was installed on it’s own drive then go ahead and rebuild the whole drive. If it was built on the same drive via a second partition then check using clover config to see if there’s a EFI partition connected to the Catalina Partition.

 

2. With a RX580 MSR unlocked isn’t so necessary but saying that a real Mac has MSR Unlocked as standard and it’s a plus to system stability no matter what so with all that in mind I do recommend it.

 

3. There’s no one specific tool to use that’s better then your eyes and brain, if it all looks good and feels good and there’s no errors showing in the logs then your golden buddy.

 

4. I’m about to update the thread with a new EFI and or DSDTs for bios F11c for the master and I’m going to post a MSR Unlocked Profile for it while I’m at it. If you tell me what colour you mean by macOS colours then I can program the profile to make the board light up that way for everybody as standard. I was going to set it to RGB colour changing for fun but you tell me and il make it so?

 

i hope that help, :thumbsup_anim:

 

Thanks for the info, Catalina and later on Mojave were installed on the same drive, not partitioned but 'splitted' by using volumes.

I deleted the Catalina volumes and Mojave kept on booting with no problems though there where still two boot options for the same drive in the board's boot manager.  To keep it 'clean' I wiped whole the drive and installed Mojave from scratch.

 

MSR profile will be installed soon, pitty the graphic card always needs to be removed to access the board's battery. :|

Programming a RGB color in the board is not necessary for me, but thanks for the proposal. You'll never be able to content everybody by chosing one color.  Thanks again for the work you all are putting in to this, unbelievable. :w00t:

Share this post


Link to post
Share on other sites

That's awesome for new updates - thanks for quick work ;)

 

I have GTX 780 running on primary slot and looks like no problems, but i got confused from all over place is it better to enable or disable IGPU?

 

Thanks ;)

Share this post


Link to post
Share on other sites
Just now, LVNona said:

That's awesome for new updates - thanks for quick work ;)

 

I have GTX 780 running on primary slot and looks like no problems, but i got confused from all over place is it better to enable or disable IGPU?

 

Thanks ;)

 

SMBIOS 19,1 = IGPU Enabled so yes indeed you want it enabled plus it will aid your GTX 780 nicely :) 

Share this post


Link to post
Share on other sites
4 minutes ago, AudioGod said:

 

SMBIOS 19,1 = IGPU Enabled so yes indeed you want it enabled plus it will aid your GTX 780 nicely :) 

OK great, ill try tonight and I have to use?

 

• Settings -> IO Ports -> DVMT Pre-Allocated -> 64M to 512M

• Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M to MAX

Share this post


Link to post
Share on other sites
3 minutes ago, LVNona said:

OK great, ill try tonight and I have to use?

 

• Settings -> IO Ports -> DVMT Pre-Allocated -> 64M to 512M

• Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M to MAX


you can use either but start with 

Settings -> IO Ports -> DVMT Pre-Allocated -> 64M 

Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M

Test and then try the raising it and test again and go with whatever works best with your gpu.

let me know how it goes :thumbsup_anim:

 

Share this post


Link to post
Share on other sites

NEW Clover Major EFI and DSDT UPDATE, 14th January 2020 (Use With Bios Revision F11c Only or read below)

 

Important Notice

This New EFI Contains a brand new DSDT made for for the Z390 Master Bios Revision F11c ONLY, If you dont want to update your bios and I personally recommend you do then replace the new DSDT with your old F10 DSDT and then you can continue using the F10 bios with the new EFIs.


The EFI and DSDT has now been updated to the my latest version.

Changes made include,

New DSDT's For bios revision F11c ONLY

OcQuirks Revision 12

Whatevergreen 1.3.6

Lilu 1.4.1

AppleALC-145

VirtualSMC 1.10

Clover Updated too Revision 5103

Plus other minor tweaks to the clover config

 

EFI Update - 14/01/2020 - Use with Bios revision F11c Only or Replace with the older F10 DSDT if you don't want to update the bios

Aorus Z390 Master F11c Navi Vega VII EFI.zip - Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI

Aorus Z390 Master F11c RX Polaris EFI.zip - RX5XX Polaris DSDT EFI

 

If you prefer using SMBios 1,1 then by all means switch to it but all the old problems of using 19,1 are corrected now with this EFI plus DRM is fully working unless you have a Polaris gpu. Just to add, SMBios 19,1 is the correct one to be using for our chipset and cpu, if you check the spec of a real macpro it is not a using a CoffeeLake CPU or Z3xx chipset. It does work perfectly but correct is correct so 19,1 it is.

 

 Please Note, If you use a 5700 or 5700XT then SMBios 1,1 in unstable using the Navi GPUs so please stick to 19,1 with igpu enabled.

 

 

 

Alternative EFI - N-D-K Fork of OpenCore 14th January 2020 Use with Bios revision F11c Only or Replace with the older F10 DSDT if you don't want to update the bios (DSDT F10 is already in the ACPI Folder you just need to rename it)

 

Big Thanks to @texem for hes countless hours of hard work and help to bring a fully working version of OpenCore using SMBios 19,1 for you all to try.

We have chosen to use N-D-K's Fork of OpenCore as it works happily alongside windows and has a lot of features and changes that I wish were in the original version of OpenCore,

 

Support on this thread for these EFIs won't be great but @texem and myself will help out where we can. 

 

PLEASE NOTE - All bios settings and guide notes are the same for these EFI's and the SMBios is now set to 19,1

OC Aorus Z390 Master Navi Vega VII EFI.zip - Vega 56/64 Navi (5700/5700XT) & Radeon VII DSDT Bios F11c

OC Aorus Z390 Master RX Polaris EFI.zip - RX Polaris Series DSDT Bios F11c

 

 

Using PlistEdit Pro add your details by modifying the following 

 

453128831_Screenshot2020-01-16at19_25_01.thumb.png.7a9beac3ccc0096941fc4a0ec07b8248.png

 

PLEASE NOTE - These EFIs are setup to be used with your msr Unlocked so make sure you use the F11c Unlocked Profile but if for any reason you can not unlock MSR then just modify following in the OpenCore config.plist :



249434888_Screenshot2020-01-16at19_26_02.thumb.png.948834bc41d84df577e126ae92c9d773.png

 

 

Additional Downloads

 

mb_bios_z390-aorus-master_f11c.zip - Aorus Z390 Master Bios F11c 

PlistEdit Pro.zip - PlistEdit Pro (use to edit OpenCore)

 

CFG Unlock (MSR) F11c BIOS Profile - The Easy Way (Bios F11c ONLY)

Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU

 

F11c MSR Unlocked Profile.zip

 

1 - Download the profile and save it to a USB Key

2 - Go into the bios,

3 - Load the profile, 

4 - Save and exit

5 - Go straight back into the bios and save your bios to a new profile and name it Default CFG Unlocked or something like that.

6 - Boot back into Catalina go into your clover config and under Kernal and Kext Patches Uncheck KernalPM 

7 - Save the changes and then restart and your done, your motherboard will now be CFG (MSR) Unlocked

 

    PLEASE NOTE - If you reset the bios or load bios defaults it will clear the Unlock making CFG Locked again. 

Edited by AudioGod

Share this post


Link to post
Share on other sites
6 hours ago, AudioGod said:


you can use either but start with 

Settings -> IO Ports -> DVMT Pre-Allocated -> 64M 

Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M

Test and then try the raising it and test again and go with whatever works best with your gpu.

let me know how it goes :thumbsup_anim:

 

 

Ok,great and what is the best way to test? And I Enabled my IGPU but from MAC system info it shows only Dedicated GPU which is GTX 780. Is that normal?

Share this post


Link to post
Share on other sites
6 minutes ago, LVNona said:

 

Ok,great and what is the best way to test? And I Enabled my IGPU but from MAC system info it shows only Dedicated GPU which is GTX 780. Is that normal?

That’s perfect and exactly what you should see when the igpu is running in headless mode.

if you look in geekbench your see both Gpus listed.

test using luxmark and just general use really. Your know instinctively what setting feel, look and work better. You can use geekbench too but it score is all over the place every time you test so it’s not a tool to gauge what’s going on really.

Edited by AudioGod

Share this post


Link to post
Share on other sites
20 minutes ago, AudioGod said:

That’s perfect and exactly what you should see when the igpu is running in headless mode.

if you look in geekbench your see both Gpus listed.

test using luxmark and just general use really. Your know instinctively what setting feel, look and work better. You can use geekbench too but it score is all over the place every time you test so it’s not a tool to gauge what’s going on really.

So I overclocked up to 5.1 and IPGU set to 512 & MAX ... scores on benchmark looks low, but I have feeling because of GTX780.

But Catalina feels better and it flyes. 

Only last thing is left I need to figure out how to get 60+ mhz on monitor.

Now best I get is 50 hertz on 3440x1440 with HDMI.

It might be limitation of HDMI - I'll play.

DisplayPort not able to use because monitor already ocupated DisplayPort from Win10 2080ti

 

Any suggestions are welcome ;)

Share this post


Link to post
Share on other sites
18 minutes ago, LVNona said:

So I overclocked up to 5.1 and IPGU set to 512 & MAX ... scores on benchmark looks low, but I have feeling because of GTX780.

But Catalina feels better and it flyes. 

Only last thing is left I need to figure out how to get 60+ mhz on monitor.

Now best I get is 50 hertz on 3440x1440 with HDMI.

It might be limitation of HDMI - I'll play.

DisplayPort not able to use because monitor already ocupated DisplayPort from Win10 2080ti

 

Any suggestions are welcome ;)

 Use cinibench r20 to test your cpu and luxmark for the gpu

dont try comparing against my scores as your never beat them, :hysterical: (jokes)  I’m at 5.2 with no avx offset , 4.7 cache, 3600mhz @ 16 16 16 36 and I’m under water and I overclock for a living,

my hack is tight!  :startreck:
 

for your monitor add the boot argument  -cdfon  and then reboot and see if that fixes it (this will enable HDMI 2.0 properly and should give you all your refresh rates and resolutions)

Edited by AudioGod

Share this post


Link to post
Share on other sites
31 minutes ago, AudioGod said:

 Use cinibench r20 to test your cpu and luxmark for the gpu

dont try comparing against my scores as your never beat them, :hysterical: (jokes)  I’m at 5.2 with no avx offset , 4.7 cache, 3600mhz @ 16 16 16 36 and I’m under water and I overclock for a living,

my hack is tight!  :startreck:
 

for your monitor add the boot argument  -cdfon  and then reboot and see if that fixes it (this will enable HDMI 2.0 properly and should give you all your refresh rates and resolutions)

I haver moster water cool build as well. Dual rad, dual d5 pump + cpu+gpu1+gpu2 blocks;)

can you share your 5.2 Bios setting profile? 

 

-cdfon - haven't done any changes - Hertz selection is still locked and when I try to use ALT button - different resolution I can select but Herz still locked

Edited by LVNona

Share this post


Link to post
Share on other sites
1 minute ago, LVNona said:

I haver moster water cool build as well. Dual rad, dual d5 pump + cpu+gpu1+gpu2 blocks;)

can you share your 5.2 Bios setting profile? 


That would be cheating, LoL

i don’t mind sending them to you sure , I won’t post them for anybody to try though il pm them to you.

i have a very golden 9900k so don’t expect to be able to hit or maintain 5.2 with no avx offset but I’m very interested to see what happens when you try it,,,lololol

 

give me a few mins and il do it now for you ;) 

Share this post


Link to post
Share on other sites
1 minute ago, AudioGod said:


That would be cheating, LoL

i don’t mind sending them to you sure , I won’t post them for anybody to try though il pm them to you.

i have a very golden 9900k so don’t expect to be able to hit or maintain 5.2 with no avx offset but I’m very interested to see what happens when you try it,,,lololol

 

give me a few mins and il do it now for you ;) 

thanks buddy ;) 

Any idea what else might help besides -cdfon

Share this post


Link to post
Share on other sites
17 minutes ago, LVNona said:

thanks buddy ;) 

Any idea what else might help besides -cdfon


did -cdfon not work?

hold on is the 780 Evan HDMI 2.0?

Share this post


Link to post
Share on other sites
1 hour ago, AudioGod said:


did -cdfon not work?

hold on is the 780 Evan HDMI 2.0?

No effect after adding - cdfon

Looks like hdmi 1.4

Edited by LVNona

Share this post


Link to post
Share on other sites

Updated to the latest bios, CFG profile and EFI.

All seems to be working fine for now.

The only minor culprit I have is that menumeters (app to show cpu usage & temp, ram & network usage) doesn't show the temperature anymore.

Share this post


Link to post
Share on other sites
10 minutes ago, decat said:

Updated to the latest bios, CFG profile and EFI.

All seems to be working fine for now.

The only minor culprit I have is that menumeters (app to show cpu usage & temp, ram & network usage) doesn't show the temperature anymore.

Il send you the extra VirtualSMC kexts to make it work again for you when I’m back home in a few hours bud. :thumbsup_anim:

in-fact I think they might be in here.
VirtualSMC 110.zip
 

if it’s not in there let me know.

there should be two extra kexts, if they are there add them to your kext folder and reboot. 

Edited by AudioGod

Share this post


Link to post
Share on other sites
19 minutes ago, AudioGod said:

Il send you the extra VirtualSMC kexts to make it work again for you when I’m back home in a few hours bud. :thumbsup_anim:

in-fact I think they might be in here.
VirtualSMC 110.zip
 

if it’s not in there let me know.

there should be two extra kexts, if they are there add them to your kext folder and reboot. 

 

zip contains the  two extra kexts and they are necessary now.  

SuperIO kext is updated f.i. and fan's are all visible with HWMonitorSMC2

Have a look with ioregexplorer for SMCSuperIO

 

Share this post


Link to post
Share on other sites
1 hour ago, texem said:

 

zip contains the  two extra kexts and they are necessary now.  

SuperIO kext is updated f.i. and fan's are all visible with HWMonitorSMC2

Have a look with ioregexplorer for SMCSuperIO

 

I thought I left them in there. I removed all the other rubbish though lol

Edited by AudioGod

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
        ***The topic is for Notebooks and Desktops***   Install MacOS with Olarila Image, Step by Step, Install and Post Install
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      Mobos serie 400 with 10th processors, use MacBookAir9,1 smbios for now
        First... ***Update bios to last available version!***   If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app     Look at my Clover folders and understand what we really need, this is the best way to learn     1-Installation     --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder    https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install Sierra/High Sierra and boot into system! 2-Post Installation     --Install Clover in HDD/SSD and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Reboot and activate video!   3-Video     -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/   -Nvidia WebDriver High Sierra   http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/   -Cuda   http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   -Check it, easy way   nvidia-update.command.zip by Benjamin-Dobell   4-DSDT       Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC* -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS* -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -IMEI -EC -PNLF(Nvidia/AMD) -HDMI ---To avoid problems use some patches in config.plist, don't forget!--- GLAN to GIGE 474c 414e 4749 4745 GFX0 to IGPU 47465830 49475055 HDAS to HDEF 48444153 48444546 HECI to IMEI 48454349 494d4549 SAT0 to SATA 53415430 53415441 5-SSDT   Generate your SSDT for PM, use ssdtPRGen by Piker-Alpha https://github.com/Piker-Alpha ssdtPRGen.command.zip   or just use "plugin-type"=0x01 in DSDT, SSDT or Clover config.plist   for check Power, Frequency, Temperature and Utilization, use it Install Intel Power Gadget.pkg.zip   6-Brightness  
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
        -Clover   https://sourceforge.net/projects/cloverefiboot/files/Installer/   -Lan driver by Mieze     -Atheros http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   -Links     -FakeSmc https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   if u like, Rate Topic     It's time to Rock -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, badruzeus and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By tonyx86
      This guide is a work in progress and will be updated as I refine the installation.
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks (Laptop: Thinkpad T61 / Nvidia NVS 140m, Laptop: Dell Latitude E6410 / Nvidia G3100m, Desktop: Gigabyte G31 / GeForce 9600, Desktop: Biostar TH55HD / Sapphire Pulse RX580) are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec SMBIOS MacModel MacMini 8,1 Unsupported M.2 PCIe x1 2230 Intel Wi-Fi (currently disabled in BIOS).  I may replace this with Brcm, but am using only Ethernet (IntelMausi) for now.  
      Installation Steps: To be provided
      See attached EFI and /L/E kexts in EliteDesk.zip archive See installation methodology here See references here  
      What is not working
      Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card).  
      What is not tested
      USB c 3.1 port Microphone port  
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions
      (Reported this as a possible Clover issue - no solution yet) Clover boot loader may default to Recovery volume after a normal shutdown.  Work-around is to select your normal macOS volume.  This may only happen when Clover is configured to boot LastBootedVolume and may be "fixable" by explicitly setting a boot volume (haven't tested this). (Watching this - not sure it's a problem) At least one display blanks (sleeps) when plugging / unplugging USB device (observed in front USB 3.1 ports).  Display wakes immediately on keyboard and mouse activity, so this is a minor issue but may be indicative of another issue. (No solution yet - work-around is to use Firefox) Safari has problems loading insanelymac web pages after sleep / wake.  Work-around: use Firefox or reboot.  I have seen reports in forums where Safari issues are experienced after sleep / wake on a real Mac.  Not sure if the problems are related.  I suspect that it might be related to streaming video on InsanelyMac pages (since I haven't observed the issue on "static" pages).
      Also observed video problem in AppStore after sleep/wake.  Console: VideoDecodersUnavailable  (Solved and included in the attached EliteDesk.zip archive) Display does not fully wake after resuming from sleep (needs an extra mouse or keyboard stimulus to fully wake).  Solution is to change boot arg darkwake=0 to darkwake=2.  Other values of darkwake may work as well, but this is the first I tried and it worked. (Solved and included in the attached EliteDesk.zip archive) -disablegfxfirmware boot arg is not required with WEG.  I inadvertently left this boot arg after I encountered an endless gfx firmware update boot loop while working on my FB patching.  This boot arg is no longer necessary after completing FB patching with WEG. (Solved and included in the attached EliteDesk.zip archive): Sometimes, CMOS time is lost on shutdown or restart.  Solution is to enable Clover's Apple RTC fix in config.plist. (Solved and included in the attached EliteDesk.zip archive) headphone jack doesn't work.  Solution is to change HDEF layout-id to 28. (Solved and included in the attached EliteDesk.zip archive) System freezes on wake from sleep because of a kernel panic related to hda-gfx (my system does not have HDMI and my DP->DVI adapters do not drive monitor speakers).  Solution is to add No-hda-gfx property to HDEF as described here.  This property is recognized as a Lilu flag and prevents loading hda-gfx. (Solved and included in the attached EliteDesk.zip archive) Device (PMCR) is not defined.  Solution is a SSDT that "injects" the missing device. (Solved and included in the attached archive) eficheck is loaded (not sure why this is bad, but may be a privacy issue - see here). Solution is to add updated EFICheckDisabler kext that include Q370 chipset.  See here.  
      BIOS Version / Configuration: To be provided
      Version: 02.11.01 Rev.A  
      Clover Configuration: To be provided
       
      UHD 630 Framebuffer Patching: To be provided
       
      Current Versions
      Catalina 10.15.4.02 Clover (UEFI) r5118 Lilu.kext 1.4.4 WhateverGreen.kext 1.3.9 AppleALC.kext 1.4.9 IntelMausiEthernet 2.5.0  
      Credits To be provided
       
       




      EliteDesk800 G4 Mini - Rev 0.5.zip

    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
       
      ---TUTORIAL---
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Original Post--
      https://www.olarila.com/topic/6531-olarila-hackbeast-z390-designare-thunderbolt-full-dsdt-patches-clover-opencore/
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://www.olarila.com/topic/6364-mojave-catalina-on-mobos-series-100200300-with-opencore-bootloader/
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
        Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell   https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Skylake, Kabylake and Coffeelake is here https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By shawnski
      i have managed to install catalina to my hackintosh, everything else seems to work be very smooth but geek bench score is very low. 490 single core, 3879 multi score
      my build is
      3930k intel,
      rx570 gpu,
      huananzhi x79,
      32gb kingston 1600,
      kingspec 512 nvme,
      Broadcom BCM94360CS2 wifi & bluetooth pci
      clover smbios i choose iMac13,2
      i installed Intel Power Gadget, screenshot here: https://prnt.sc/slit8z
      any help would be greatly appreciated.
×