Jump to content
  1. SV0911

    SV0911

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kushwavez
      MOBO: GIGABYTE Z77P-D3
      CPU: Intel Core i7-3770 Quad (Ivy Bridge) 3,4 GHz
      RAM: 8 GB (4+4) KINGSTON 1333MHz
      Audio: HD Audio (ALC888)
      Ethernet: Realtek8111
      Graphics: HD 4000 and(or) RX 5700 8 GB
      SSD: KINGSTON 240GB SSDNow mSata
      HDD: 1: 500 GB SAMSUNG 2: 1 TB Western Digital
       
      Running: macOS Catalina 10.15.1 - Windows 10
       
      Bios settings:
      UEFI - ON CSM: Disabled AHCI Integrated Graphics: AUTO Primary Graphics: iGFX Memory: 1024M DVMT: MAX Working
      Everything (App Store, Messenger, FaceTime, etc.)  
      Not working
      For AirDrop and Handoff you need a compatible Broadcom Wifi+Bluetooth card. I bought a BCM94360 card with a PCI-E adapter, it's OOB. Currently waiting for arrive, will report back.  
      Issues
      Sometimes I hear crackling sound (just on Catalina 10.15.1, didn't happen on 10.15 or before) If you don't have this issue please let me know.  
      Before updating to newer versions, update your kexts! (and Clover if necessary)
      Generate a new serial with Clover Configurator
      Download the Clover folder: Z77P-D3-catalina.zip
       
      - SMBIOS: iMac13,2: iMac (27-inch, Late 2012)
      - ig-platform-id: 0x0166000b
       
      - There is no need for Whatevergreen.kext 
      - The HD 4000 is working with- or without a graphics card (headless with IntelQuickSync)
      - RX 5700 (ASUS RX 5700 GAMING OC 8 G) working OOB, just delete WhateverGreen.kext (causes black screen)
       
      Triple-Boot Win 10 and Linux (in my case it's Manjaro) (on one drive)
      Make sure your drive is in GPT and you're using UEFI If you have Win 10 installed then: Open diskmgmt (Disk Management), then Shrink your existing Win 10 partition to create two new for Mac and (if you want) for Linux If you have Mac installed: Create a new partition for Linux and (or) Windows in FAT Simply format that partition in Linux, Windows, or Mac installer, then install the OS Copy your working Clover folder to the system's EFI drive If it's automatically booting to Win, open cmd in administrator and write: bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi That's it, automatically booting to Clover and you can select your OS If your Linux doesn't show up in Clover make sure you have GUI/Scan/Linux=Yes in config.plist  
      Mount your EFI on Windows:
      Open CMD in administrator and write: mountvol b: /s Use Explorer++ or TotalCommander in administrator to manage the folder Pictures:

       



    • By Slice
      As I see many novices in the forum ask "How to make my Radeon working? I have bad resolution, no QE/CI...." and so on. They come to the section and have no find an answer here because all Radeons are different and they don't know where else they read about this.
      I want to explain all steps needed for launching the Radeon family of videocards.
       
      Bootloader.
      I will speak about Clover because I maintain this bootloader to know recent hardware and modern OSX. Not sure if you will have the same result with other bootloaders. I am carefully checking the injecting of ATI card and correcting it times to times. I am also accessible for bug reports.
       
      OSX version.
      Older card require older system, newer cards require new system.
      ATIRadeon9000 is possible to launch under Tiger.
      ATIRadeonMobilityX1400 requires 10.5-10.6. See RadeonHD topic.
      As I see RadeonHD3xxx was successful only in 10.5
      For new AMDRadeonHD7xxx there must be 10.8.3+ system.
       
      DeviceID.
      This must be the first question before asking about the card.
      You may know the device-id from Windows->DeviceManger->VideoCard.properties->compatibleIDs
      You may boot into system in safe mode (key -x) and see system profiler
       
      And you may boot into Clover GUI, press F2 and get preboot.log. Find here something like
      2:709 0:000 PCI (00|01:00.00) : 1002 6758 class=030000 2:709 0:000 Found Radeon model=AMD Radeon HD 6670 Series It means my DeviceID=6758 (these are hex numbers)
      Then you must check that Apple's drivers support your DeviceID. If not then add it!
      For example HD7850 has DeviceID=6819. If we look into ATI7000Controller (AMD7000... in new systems) we find 6818 here but no 6819!
       
       
      I show you how to do this with terminal commands. Launch /Application/Utilities/Terminal.app. Type in opened window:
       
      cp /System/Library/Extensions/ATI7000Controller.kext/Contents/Info.plist ~/Desktop So you get a copy of the Info.plist on Desktop. Edit it with TextEdit. Change 68181002 -> 68191002.
      Don't edit this file directly in the system folder! 
      Then copy back by terminal. Don't use finder to copy kexts! They will have wrong permissions in this case.
      sudo cp ~/Desktop/Info.plist /System/Library/Extensions/ATI7000Controller.kext/Contents/ sudo rm -r -v /System/Library/Caches/com.apple.kext.caches/* Second command make sure next reboot the kext will use your edited info.plist.
      The same operation you must do with a kext AMDRadeonAccelerator or ATIRadeonX2000 or other one. Check all candidates if they contain such list of possible IDs and choose closest to you.
       
      FakeID
      Since Clover revision 1971+ you may just inject new DeviceID into DSDT instead of correcting kexts. See instruction here.
       
      GraphicsEnabler or Injector
      OSX needs to know some properties (Model name, Family, etc...) that must be somehow injected at boot time. Yes, also real Macs got DeviceProperties string from firmware.
      Alternatives:
      1. Set InjectATI=Yes in Clover (same as GE=y in Chameleon).
      2. Use custom string made with gfxutil. For whom who knows.
      3. Write _DSM into DSDT. You should know what to write.
      4. Use some kext like ATY_init.kext or Natit.kext. If you are sure that the kext is for your card namely.
      I want to say that all this methods make the same thing. Differencies in their tuning.
      The Clover do this automatically for most known cards at this moment.
       
      Connectors.
      As you may see to start HD5000-7000 some strange names used: Pithecia, Orangutan, Elodea... What are they?
      They are configs for framebuffer. Predefined configs how connectors are solded for cards used in real Macs. Strange but these configs rear coincide with PC card. Usually gurus make advice "choose a framebuffer that most appropriate for your card". The chances 1:10. In most cases you may find a FB name that gives you main monitor working. Or nothing at all.
      Great respect to bcc9 who gives us a method to correct one of config to be exactly for you. See here.
      My retelling for Clover is here
      Success example in the thread in posts 44-52
       
      Radeon Mobility
      I tested Clover's methods with two users having Mobility Radeon HD5470 and HD5650M. We found that full memory and QE/CI will be achieved if we set in Clover's config
      LoadVBios=Yes
      even thou no file with bios is provided. This is the key to make Radeon Mobility working!
      Other problem is bad gradients or artifacts. For this case Clover accept the key
      InjectEDID=Yes
      and sometimes you also need to inject CustomEDID.
      See Clover instructions for details.
       
      And my results.
      Gigabyte Radeon HD6670
      <key>Graphics</key> <dict> <key>GraphicsInjector</key> <true/> <key>InjectEDID</key> <true/> <key>FBName</key> <string>Ipomoea</string> <key>LoadVBios</key> <false/> <key>VideoPorts</key> <integer>3</integer> <key>PatchVBios</key> <true/> </dict> <key>KernelAndKextPatches</key> <dict> <key>KernelCpu</key> <false/> <key>ATIConnectorsController</key> <string>6000</string> <key>ATIConnectorsData</key> <string>000400000403000000010000120401050008000004020000000100001102040310000000100000000001000000000002</string> <key>ATIConnectorsPatch</key> <string>040000000403000000010000100001061000000010000000000100000000000100080000040200000001000012040403</string> VTX Radeon HD5570
      <key>Graphics</key> <dict> <key>PatchVBios</key> <false/> <key>FBName</key> <string>Baboon</string> <key>VideoPorts</key> <string>3</string> <key>GraphicsInjector</key> <string>Yes</string> <key>LoadVBios</key> <string>No</string> </dict> <key>KernelAndKextPatches</key> <dict> <key>Debug</key> <false/> <key>KernelCpu</key> <false/> <key>ATIConnectorsController</key> <string>5000</string> <key>ATIConnectorsData</key> <string>040000001400000000010000010201030008000000020000007100002205020110000000100000000001000000100002</string> <key>AppleRTC</key> <true/> <key>ATIConnectorsPatch</key> <string>040000001400000000010000010001040008000000020000007100002200020510000000100000000001000000000002</string> <key>AsusAICPUPM</key> <false/> <key>KextsToPatch</key> <array> <dict> <key>Name</key> <string>AppleAHCIPort</string> <key>Find</key> <data>RXh0ZXJuYWw=</data> <key>Replace</key> <data>SW50ZXJuYWw=</data> </dict> </array> </dict> See PatchVBios=No
      for this card "yes" leads to black screen. Use with precautions.
       
      A sample for Radeon R7 240
       
      UPDATE for ElCapitan.
      It seems has more problems. My HD6670 is not working in ElCapitan OOB unlike Mavericks.
      I had to set FakeID=0x67401002 as correspond to real iMac12,2 and set this model in SMBIOS section.
      It related to GraphicsPM or GraphicsControl.
      Look these kexts to decide what you can do for your configuration.
       
      HighSierra requires change these kexts by version from Sierra 10.12.6
      for Radeon HD6xxx
      AMDRadeonX3000.kext AMDRadeonX3000GLDriver.bundle IOAccelerator2D.plugin IOAcceleratorFamily2.kext .  for Radeon HD7xxx and up AMDRadeonX4000.kext AMDRadeonX4000GLDriver.bundle IOAccelerator2D.plugin IOAcceleratorFamily2.kext .    Black screen after wake problem resolved by follow method radeon_bios_decode.0.2.zip
      ati-personality.pl.0.15.zip
      ati-personality.pl.0.15a.zip
    • By Shaneee
      Here we have the AMD Vanilla guide. Compatible from Windows. 
       
      Click here for the guide.
       
      For installation help make a post here. And for post installation help make a post here.
       
      Thanks,
      Shaneee

    • By Arman Hossain
      HI 
      I want install High Sierra  on my pc . my CPU is : AMD Ryzen 3 2200g and my MotherBoard is : ASUS EX A320m. and 8gb ram DDR4 ram . i dont have any external gripch card. i have seen some video on youtube how to install High Sierra but they use extranal gripch card to make it good  but i don't have any extranal gripch card . on my windows sysem the shared gpu is 2GB which is using my ram to crate the vega gripch  . i want know is it possible to install High Sierra on my pc with out any extarnal gripsh card  ?


    • By MatthewBayard
      Current Build ( just purchased the RX 580 )
       
      CPU Intel Core i7-3770K 3.5GHz Quad-Core Processor       CPU Cooler Corsair H100i 77.0 CFM Liquid CPU Cooler     Motherboard Gigabyte GA-Z87X-UD7 TH       Memory 4x 8gb     (Corsair CML16GX3M2A1600C10 Vengeance Low Profile   16GB (2x8GB) DDR3 1600 Mhz CL10 XMP Performance Desktop Memory Kit Black)       Case Fractal Design   Define R4 (Black Pearl)       Power Supply Corsair HX750       HDD SATA 6Gb / s 256GB SSD         Wifi TP-LINK TL-WDN4800 N900 Wireless PCI Express Adapter       Graphics Card MSI RADEON RX 580 ARMOR MK2 8G OC Graphic Card      
       
      The installation has failed a dozen times after creating a bootable USB via the instructions outlined at serval different places:
      https://www.tonymacx86.com/threads/[url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]-install-macos-mojave-on-any-supported-intel-based-pc.259381/   
      https://hackintosher.com/forums/thread/mojave-flummoxed-with-ga-z97x-ud7.1338/
      https://hackintosher.com/guides/guide-to-fresh-installing-macos-mojave-on-a-hackintosh-10-14/
       
       
      I have used UniBest to create my builds in the past and they have mostly been successful. I tried the other methods as a last resort. I have not gotten past the Apple boot screen with any method attempting to install Mojave. 
       
       

       
       
       
      I have followed all the guides I can in order to get a successful install. However, it has been hard to get a definitive guide to solve my issues.
       
       
      Could somebody please help me with the correct [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] settings. Ie UEFI Boot Mode or Legacy Boot Mode? 
      Recommended BIOS Settings for my system. 
       
       
      It might also just be the required Clover boot screen setup / flags 
       
       
       
      I also have no clue which [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] configurations are required for me to build.
       
       
       
      Any help at all will be most appreciated.
       
       
      I can post any more information regarding errors and crashes if required.       
       
       
       
       
       
×