Jump to content
Rammjet

[How To] Solutions for Wireless Problems

173 posts in this topic

Recommended Posts

Wireless

 

This is a compilation of many of the different wireless solutions available. It is nearly exhaustive. If you don't find what you want, search for it.

 

Please do not post questions in this thread looking for a solution that is not listed. Use other threads for that.

 

Please do post other good known wireless solutions in this thread. I will try to incorporate any posted solutions into the list. Otherwise, users can read the thread for any other solutions.

 

Driver Info
Atheros chipset
- Use this
or else use the Broadcom
and edit this file:
sudo nano /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros5424.kext/Contents/Info.plist

Atmel
- No solution available, purchase a compatible card.

 

Broadcom chipset
- Use this
except edit this file:
sudo nano /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AppleAirPortBrcm4311.kext/Contents/Info.plist

Intel 2200BG/2915ABG/2945ABG
- Working driver now available. Download the latest
and read the
and the forum
about the driver.

 

Intel 3945ABG
- No solution available (yet), purchase a compatible card.

 

Marvell
- No solution available, purchase a compatible card.

 

PrismGT chipset
- Get driver
(link is often down) and a different driver
.

 

Prism USB devices
- Get driver and instructions
(Deutsch/English) and another unknown driver
.

 

Ralink chipset
- Get driver

Ralink RT2500-USB Driver (a la Airport Driver) - Development effort
- Go

 

Ralink RT2500-USB Replug Fix
- If you have to unplug and then replug your device after boot, go

Zydas USB chipset

Zydas was acquired by Atheros and the links for these drivers were taken down. However, the company ZyXel sells a device with the Zydas chipset and has posted OSX drivers.

 

ZD1211
and
ZD1211 rev B
- are installed by the same installer. It installs ZD1211.kext for ZD1211 and ZD1215.kext for ZD1211 rev B. Here are the links for the installer
or
and for the
.

Misc Info

Replacing mini-PCI(e) Cards
- Some laptops won't allow you to replace the internal mini-PCI(e) card with a different model.
may help.

 

By
:

For Hp users that have tried to replace the intel wifi cards and been greeted with the 104 error, it is because of a bios whitelist which have been removed from the bios below. Instructions; Download the matching bios update from hp for your laptop, run the update, do not flash, just cancel at that point, go to the path that it installed to, usually c:\swsetup\sp.... open up the folder then open swinflash folder, open the phlash config settings, and change hideall=1 to =0 then run the swinflash utility and use the hacked bios instead of the hp one. for more info or troubleshooting look here

 

bios for older hp models: f27

 

bios for newer hp models: f53

 

Share this post


Link to post
Share on other sites
Advertisement

For those on incompatible Intel 2200 cards I can just say that an excellent working MiniPCI replacement wireless card working *NATIVE* in osx is:

 

- Dell's truemobile 1450 a/b/g card. It's available on ebay for less than $20.

 

Cheers,

:compress:

osxG

Share this post


Link to post
Share on other sites

I've got a different (simpler?) method for Atheros-based cards here. I dunno if it's worthy of being added to the genius bar tutorials but....

Share this post


Link to post
Share on other sites

Here is my report of success using a Lenovo T60 Type 1952 A97 which has Intel Core Duo, ICH7, GMA950

 

Running JaS 10.4.7 SSE3 Intel ISO

 

First, you have to replace the integrated miniPCI Express Intel Wireless a/b/g card with the optional Atheros based miniPCI Express wireless a/b/g - $49.99 from Best Buy Business

 

Easy to install, only 5 screws - remove wrist rest, and keyboard, actually just move them aside

and you get clear access to the wireless card, remove 2 small screws and the antenna leads and replace the card with the new one... of course follow good electronics safety, remove from power source, remove battery before starting and wear a ESD strap.

 

You do not have to replace the IO80211Family.kext.. simply kextload the AirportAtheros5424.kext, repair permissions and reboot and you will see the Airport icon on the tool bar.. go into Network utility and there you have it.

Edited by nyjets12

Share this post


Link to post
Share on other sites

This might sound like a stupid question but... what's stopping me from sticking an official Apple Airport Extreme Card (mini-PCI) into my IBM T40?

 

If not the Apple card, which one should I get between a Dell 1350 and a 1450?

Thanks!

 

EDIT: I'm a moron. I should have used the search earlier. I wish there was a way to delete this post...

Edited by hardboiledwonderland

Share this post


Link to post
Share on other sites

what about Intel 3945ABG???

 

 

about Intel 2200BG/2945ABG.

our driver(jalavoui and xkazu ) begin to work ( only open network and no-encryption ).

 

 

plz add http://code.google.com/p/iwidarwin/ ( project web )

 

 

http://code.google.com/p/iwidarwin/downloads/list ( download list)

http://forum.insanelymac.com/index.php?showtopic=36976 (forums's link)

Edited by george.d

Share this post


Link to post
Share on other sites

I tried but nothing is working (using the google code wiki)

I've a HP dv1675ea (dv1000 series) and using mac osx 10.4.7

 

edit: i'm not using ipw3945 but abg3945!! oups :)

Edited by blesso

Share this post


Link to post
Share on other sites

My Truemobile 1370 card ran natively in 10.4.7, but now it's not even recognized in 10.4.8 with Semthex's 8.8.1 kernel. Anybody have any ideas?

 

Is there maybe a kext I can move from the 10.4.7 DVD to make this work?

 

Thanks in advance. :unsure:

Share this post


Link to post
Share on other sites
My Truemobile 1370 card ran natively in 10.4.7, but now it's not even recognized in 10.4.8 with Semthex's 8.8.1 kernel. Anybody have any ideas?

 

Is there maybe a kext I can move from the 10.4.7 DVD to make this work?

 

Thanks in advance. :(

 

I'm pretty sure that that card is a Broadcom card, there is an edit that you can do to the IO80211Family.kext under 10.4.8.

 

If you edit the file "/system/library/extensions/io80211family.kext/contents/plugins/appleairportbrcm4311.kext/contents/info.plist" and then find the strings and edit it with your card's device ID. In my case I had to add the string <string>pci14e4,4318</string> to the file. Yours should be the same.

 

Add that string to your file and use Disk Utility to repair disk permissions. Should fix your problem. Worked for me.

Share this post


Link to post
Share on other sites
I want to set up my intel 2100 card and i don't know which tutorial to choose..Any solution. I'm on a dell d600 with mac osx 10.4.6

 

This card worked fine once I installed this file: http://iwidarwin.googlecode.com/files/iwi2...est2-xkazu2.dmg

 

Theres a driver for the Intel 3945 here http://code.google.com/p/iwidarwin/downloads/list

Share this post


Link to post
Share on other sites

I have a prism2 card, but when I try to textload the prism (non-gt) drivers it tells me "executable file doesn 't contain kernel extension code " How to fix it ?

 

"Prism USB devices - Get driver and instructions here (Deutsch/English) and another unknown driver here." I tried those drivers, (on an Intel machine) and they don't seem to be "universal binaries" is this why I can't use it?

 

KisMAC works fine with the adapter (Linksys WUSB11 v3.0) (Prism2 chipset)

 

Can someone edit the first post to say that prism drivers are for PPC only? Thanks

Share this post


Link to post
Share on other sites

Just a little note........

 

I got my Belkin 7001 card working however it would not connect to my Wireless Access Point with WEP enabled with the "Error connecting to Airport network" message.

 

Turns out that I had to turn the WEP system from Automatic to Open System.

 

Started working perfectly.

 

Hope this helps.

Share this post


Link to post
Share on other sites

FYI to anyone using AppleAzalia Audio fix ==> The 802.11n enabler for the Airport Extreme Cards works but will DISABLE audio if installed!

 

See my post HERE

 

I have yet to find a solution.

Share this post


Link to post
Share on other sites
Hi guys!

 

Any progress on the "Intel 3945ABG " issue?

 

Guys can someone please please send me the link to the Intel 3945ABG driver please? thanks thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×