Jump to content
d5aqoep

macOS Catalina 10.15 is out !!!

121 posts in this topic

Recommended Posts

Posted (edited)

Final Build released. Will Nvidia release drivers in the wild?

 

Possible to download full release from macadmins script from this link -> github

 

Open terminal, type sudo and drag drop installinstallmacos.py on it and press Enter. (Noob friendly instructions)

Edited by d5aqoep

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)

I installed it from AppStore but it just 19MB.

 

Edit: I think this is an installer.

Edited by telepati

Share this post


Link to post
Share on other sites
8 minutes ago, justin said:

im on 10.15 Beta (19A582a), not able to get updates.

 

Go to the App Store and download it from there.  It doesn't show up in Software Updates.

Share this post


Link to post
Share on other sites
3 minutes ago, mnfesq said:

 

Go to the App Store and download it from there.  It doesn't show up in Software Updates.

The requested version of macOS is not available.

Share this post


Link to post
Share on other sites
12 minutes ago, justin said:

The requested version of macOS is not available.

Yeah, strangely you need to do a Safari update first. At least it was like that in my case.

Share this post


Link to post
Share on other sites
3 minutes ago, xtraa said:

Yeah, strangely you need to do a Safari update first. At least it was like that in my case.

 

Safari is already Version 13.0.2 (15608.2.30.1.1)

21 minutes ago, justin said:

The requested version of macOS is not available.

 

sudo rm -rf ~/Library/Caches/*
sudo rm -rf /Library/Caches/*
sudo rm -rf /System/Library/Caches/*
 

now i'm able to download from app store. 

Share this post


Link to post
Share on other sites

Installed without issues on my Precision. 
196618934_Schermafbeelding2019-10-07om21_23_40.png.b546fb5ae6393fa15d67376aeb4fea92.png
 

Share this post


Link to post
Share on other sites
44 minutes ago, mnfesq said:

 

Go to the App Store and download it from there.  It doesn't show up in Software Updates.

 

No, it shows;

537514458_ScreenShot2019-10-07at22_37_28.png.9643ecede5f33cb6c232b404f990bb1e.png

Share this post


Link to post
Share on other sites
Posted (edited)

@justin, I'm pretty sure one has to exit out of Beta seeds enrollment program to see the final/general release version in the AppStore.

 

Edited by Hervé

Share this post


Link to post
Share on other sites
8 minutes ago, Konami® said:

Can anyone with a real MacPro 2010 machine test the installation? 

Just done it with dosdude's Catalina patcher and working fine. Make sure to download latest patcher.

Share this post


Link to post
Share on other sites
21 minutes ago, Hervé said:

@justin, I'm pretty sure one has to exit out of Beta seeds enrollment program to see the final/general release version in the AppStore.

 

 

No,  at least I had no problems and didn't need to exit the beta program.

 

1386257650_Screenshot2019-10-07at21_23_59.png.d7c3a4f07c7bf2d2260043276bf4480a.png

 

696555432_Screenshot2019-10-07at21_27_26.png.52ae7681eea772b4d6ee020f0451d38d.png

 

Share this post


Link to post
Share on other sites

Updated without issues from the latest beta on a Thinkpad X260. The download was quite slow though, Apple servers must be taking a pounding...

Share this post


Link to post
Share on other sites

hi..

@iCanaro ..

could you post the script you used to update..

and appears on your pics..

thanks..

c.frio

Share this post


Link to post
Share on other sites

@C.Frio 

the catalina update was performed with the app store installer. The webdrivers have been patched to adapt them to catalina, they are used only for possible uses of decoding with the 970M

nvweb_patcher by  @gengik84 here by login 

 

you get the same result with the benjamin dobell scripts

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ltooz_audis
      OK, it's been a while since I posted something here. The new Catalina was out last month, the current version is 10.15.1. I decided to install on my HP Envy 13" Kaby Lake. This one should work for all Kaby Lake laptops out there and also with MOJAVE OS too. So read carefully and watch the videos.
      1. You can't install Catalina on MBR unless you patch it, but it too complicated for me and I like to try the APFS system now instead of HFS. So, if you create the external USB drive using Boot Disk Utility, it won't install.
      2. Replace original WIFI-Bluetooth COMBO with DW1560 or better.
      3. Thanks to Lilu and people on Hackintosh world, things are much easier to install than before: Clover boot loader 5070, Lilu 1.3.9, Whatevergreen 1.3.4, AppleAlc 1.4.3, AirportBrcmFixup.kext, Bluetooth Patchram3 (I found BrcmPatchRAM3.kext + BrcmFirmwareData.kext + BrcmBluetoothInjector.kext), Hackintool is a must, VoodooPS2Controller.kext for trackpad, USBinjectAll , ACPIBatteryManager from rehabman, FakeSMC.kext.
      4. Use a 1GB USB flash drive, use Boot Disk Utility to create an EFI folder, then copy it to the EFI folder of the External USB SSD hard drive.
      I'll post more in details, but with these, you can boot Catalina without any problems.
       
      Cheers,
      Louis
       
    • By digivish
      Hi All - quick thing - I have a NUC 8i7BEH with 32GB RAM and 2 x 1TB SSD drives. Each drive has its own OS - Windows 10 and Catalina 10.15.
       
      Clover works well - Catalina Boots, so does Windows.
      Catalina - has sound over HDMI (to my monitor's speakers)
      Windows - no audio device found - It does show Realtek and Intel Display Drivers - but the speaker has a red"x" and in Devices, there is no entry for Microphone Array under Audio Input/Output. It does, however, show Intel display over the HDMI - but actually no sound.
       
      I have tried reinstalling Realtek drivers - now here's the thing...when it installs, it first uninstalls existing Realtek drivers - at this stage (and it's important) the sound starts working - as if uninstalling did the trick. As part of the installing, I have to reboot and upon reboot, it actually reinstalls the Realtek drivers. After that, I'm back to square 1. Unsure if it's the config.plist or boot args in clover. But something with Clover for sure.
       
      I have tested this by removing the Mac Drive with clover and just booting directly to Windows 10 bootloader and everything works as it should, I have sound over HDMI and the audio device shows. Just not when I boot with Clover.
       
      has anyone experienced this and have thoughts or pointers.
       
      Thanks a ton!
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/viewtopic.php?f=28&t=10578
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
×