Jump to content
d5aqoep

macOS Catalina 10.15 is out !!!

85 posts in this topic

Recommended Posts

Advertisement
4 hours ago, arsradu said:

For anyone interested, looks like dosdude1 does have a Catalina patcher. :)

http://dosdude1.com/catalina/

And for a video tour, you can also watch his video here:
 

 

 

if you have a real Mac computer hardware that does not support catalina, that patch will work but if you don't have a real Mac computer... that patch is useless.

Share this post


Link to post
Share on other sites

How to add a picture to System\Library\Desktop Pictures in MacBook Air 2018 Catalina?

 

I am attaching the image but it will not allow adding the image to the folder 

 

Please help

 

 

Screen Shot 2019-10-09 at 15.26.15.png

Share this post


Link to post
Share on other sites
On 10/8/2019 at 3:01 PM, Hervé said:

I updated 2 x systems directly through the downloaded app rather than go through the fresh/new installation route.

 

1/ Ivy Bridge/HD4000 Latitude E6230 laptop:

initial OS: Catalina beta11

initial Clover: r5058

Cancelled enrolment to beta versions seeding.

Downloaded Catalina off the AppStore and simply ran it.

All Ok on update completion.

Updated Clover to r5093 aftewards.

 

2/Kaby Lake R/UHD620 Latitude 7490 laptop:

initial OS: Mojave 10.14.6

initial Clover: r4919

Catalina offered through the macOS Software Update panel.

Updated Clover to r5093 before updating macOS.

All Ok on upgrade completion.

 

Can you upload efi folder of ivybridge hd 4000 laptop.

Can you upload efi folder of ivybridge hd 4000

Share this post


Link to post
Share on other sites
Posted (edited)

There is an E6230 guide at OSXL, I suggest you consult it if you have an interest in that specific model.

 

This being said, apart from eventual dropped hardware (eg: some Broadcom wireless cards) and the known & documented EC-related ACPI device renaming that was identified with beta #5, there's absolutely nothing that differs from High Sierra and/or Mojave to run Catalina on IvyBridge/HD4000 laptops.

Edited by Hervé

Share this post


Link to post
Share on other sites

If anyone else is having issues updating Xcode from App Store, just delete the old version, empty Trash Can and then redownload the new version from App Store works.

Share this post


Link to post
Share on other sites
8 hours ago, headkaze said:

Thanks for the suggestion but I get the same error.

 

Drag Xcode.app to Trash, and Empty Trash, cd $TMPDIR../C/com.apple.appstore/  && sudo rm -rf * to clear the app store cache, then download from app store again. 

Share this post


Link to post
Share on other sites
20 hours ago, headkaze said:

Catalina Beta 11 (19A582a) won't let me update to Xcode 11.1. "Xcode could not be installed please try again later". Tried several times today with the same error.

 

I deleted my Xcode from my apps folder and then ran the installation from the App Store.  That worked after multiple failures before that.

Share this post


Link to post
Share on other sites

Hey guys, can anyone with the Catalina installed check if the CPU core limit is still there? Is there a support for Intels new WiFi 6 support?

Share this post


Link to post
Share on other sites
12 hours ago, Balamut said:

Hey guys, can anyone with the Catalina installed check if the CPU core limit is still there? Is there a support for Intels new WiFi 6 support?

Balamut

it is the same...

think also new Mac Pro will have "only" 28 cores (56 threads) so Apple does no need to modify deeply this

:-(

1077960288_ScreenShot2019-10-10at14_24_39.png.74bc0138c154c2074b4693bf678707dc.png

Edited by fabiosun

Share this post


Link to post
Share on other sites
On 10/8/2019 at 6:46 PM, headkaze said:

Catalina Beta 11 (19A582a) won't let me update to Xcode 11.1. "Xcode could not be installed please try again later". Tried several times today with the same error.

 

I had same issue with all App store downloads.

 

Finally solved by logging into Music app. Then I could re-log into App store to properly download. (Some report needing to log out of Music app before logging back into App store.)

Edited by iGPU

Share this post


Link to post
Share on other sites
15 hours ago, fabiosun said:

Balamut

it is the same...

think also new Mac Pro will have "only" 28 cores (56 threads) so Apple does no need to modify deeply this

:-(

 

 

Was a long shot and hopes of a dual LGA system. :)

Hopping the new 10.15.1 to bring a new BT5 and WiFI6 chips.

 

 

 

Share this post


Link to post
Share on other sites

Hi, Anyone else found the Energy Saver preference pane won't load in 10.15.1?

 

It fails on both my hacks, i5-8600K and i7-4790K.

 

2058345699_Screenshot2019-10-12at13_11_24.png.81d9e485b22aa073be27ece611f7afa7.png

 

Share this post


Link to post
Share on other sites
43 minutes ago, Montblanc said:

Hi, Anyone else found the Energy Saver preference pane won't load in 10.15.1?

 

It fails on both my hacks, i5-8600K and i7-4790K.

 

2058345699_Screenshot2019-10-12at13_11_24.png.81d9e485b22aa073be27ece611f7afa7.png

 

 

That...is a bug. :) 

 

They fixed the wallpaper issue from the final build though. But apparently they also introduced new ones.

Edited by arsradu

Share this post


Link to post
Share on other sites

Bug?

 

No issue opening the Energy Saver PrefPane and adjusting settings on my 3xHacks running Catalina:

  1. C2D Dell Vostro200 desktop (E8600, Intel G33 chipset)
  2. Ivy Bridge Dell Latitude E6230 laptop (i7-3540M, Intel QM77 (Series 7/C210) chipset)
  3. Kaby Lake R Dell Latitude 7490 (i7-8650U, Intel Sunrise Point-LP chipset)

 

Edited by Hervé

Share this post


Link to post
Share on other sites

I have no update available, but at this moment I'm in Catalina 19B68f and this is an supplemental update for Catalina 10.15, right?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

  • Similar Content

    • By Barry_dhb52
      After a quite smooth running /w Mojave (both Clover, OC build), a few days ago I upgraded to Catalina soon after public release, and I found out DP output to black screen, then I switch to HDMI, it works. When DP goes black screen, unplug then plug the cable, screen comes back then gone.
      After a lot of searches, I found out some simalar cases, but none of them have a solution,
      today I was quite happy to find out this post is https://www.tonymacx86.com/threads/majove-to-catalina-displayport-not-working.284983/.
      which solving by swithing to iMac19,1, which I think WEG quite needs an enhancement
      But I tried with no luck.
       
      And I don't know is it relevant to this issue, sometimes wakeup, I got panic, somehow like this:
      Kernel Extensions in backtrace: com.apple.driver.AppleACPIPlatform(6.1)[927FAB0F-5B29-3E31-A1A4-DA7E904986C4]@0xffffff7f96b8c000->0xffffff7f96c26fff dependency: com.apple.iokit.IOACPIFamily(1.4)[9BA2613C-A129-3EDD-8DC1-2CFF6B62B832]@0xffffff7f9528f000 dependency: com.apple.iokit.IOPCIFamily(2.9)[E6E855AD-A5B2-3518-A997-1384B4360708]@0xffffff7f952a1000 dependency: com.apple.driver.AppleSMC(3.1.9)[EB9D605D-85B1-3506-8B2E-ABD195817A4F]@0xffffff7f952de000 whole panic log in attachment 

      My build:
      Asrock z370 gaming itx/ac
      i3 8100
      Only Intel UHD630 with LG UL550 4k monitor
       
       
      Or is there any guide how to do some logging for this issue?
      thanks
      panic-log.txt
      EFI.clover.zip
    • By ajoykarmakar
      I have working Mojave version of Hackintosh and it's working perfectly but when I have upgraded to Catalina it's stuck after reaching 90% of the progress bar. When I verbose the boot I got the IGPU problem and if I pass -disablegfxfirmware then I don't get any error log but the progress bar still stuck on the same position and screen became purple. Am I need anything more patch to get a working Catalina machine with Intel HD 630? If I need then how can I do it?
      My EFI link -
      Download
        
      My computer specification is -
      Motherboard: Gigabyte h110m-h-cf
      CPU: Intel Core i5-7400 CPU@3.00GHZ
      Graphics: 4gb GeForce GT730 DDR3 (I have disabled it)
      Ram - 16gb ddr4
      Monitor - Dell connects through the HDMI port.
    • By Ethan Jarvis
      Hello,
       
      Here I am looking for the answer of new Mac OS Catalina features and what type of Mac will support this new Os??
    • By kushwavez
      Acer Aspire V15 V5-591G - Catalina 10.15
      Original link:
      https://osxlatitude.com/forums/topic/11355-acer-aspire-v-15-v5-591g-catalina-windows-10/
      (Note: mine is 55TU version, but the bootpack will work fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)
      Specifications:
      - Motherboard: USOPP_SLS (Skylake-H PCH)
      - BIOS: Insyde Corp. v 1.15
      - CPU: Intel Core i5-6300HQ 2.3 GHz (Skylake)
      - GPU: NVIDIA GeForce GTX 950M 2 GB (Optimus) & Intel HD Graphics 530
      - RAM: SK hynix 4 GB DDR4 (Later I bought + KINGSTON 4 GB) 2133 MHz
      - WiFi + Bluetooth: Qualcomm Atheros QCNFA344A 5 GHz (Later -> Broadcom BRCM94352Z M.2 5 GHz WiFi + 4.0 Bluetooth)
      - Audio: Realtek HD Audio: ALC 255 
      - Ethernet: Realtek RTL8168/8111
      - Card Reader: Realtek USB 2.0 Card Reader (USB2.0-CRW)
      - Webcam: HD Webcam
      - HDD: TOSHIBA MQ01ACF032 320 GB HDD
      - SSD: SPCC M.2 230 GB SSD
      - Display: 1366x768 (15.6", Matte)
      - Battery: 6 cell 56Wh / 5040mAh
      - Connectors: 
      1x SD Card Reader 2x USB 3.0 (1x USB Charging), 1x USB 2.0 1x VGA 1x HDMI 1x 3.5mm microphone/audio combined jack connector 1x Ethernet (Rj-45) - Keyboard & Touchpad: Multi-Touch & Multi-gestures ELAN 501 Touchpad, Backlight Keyboard.
      Working:  
      - Wi-Fi (with BCM94352Z)
      - Bluetooth hand-off (With BCM94352Z)
      - Full Graphics enabled on HD 530: ig-platform-id: 0x191b0000 (HD 530 Mobile)
      - Display: if default colour profile is corrupted (blue is not actual blue but purplish) Use "Rec. ITU-R BT. 709-5" Color Profile (System Pref. -> Displays -> Color)
      - HDMI & VGA Outputs: AppleGraphicsDevicePolicy.kext Clover patch
      - Audio (ALC 255): (Internal Speakers, Internal Microphone, Headphone jack with AppleALC, ALCPlugFix -> layout-id=17)
      - Ethernet Realtek 8168/8111: RealtekRTL8111.kext
      - App Store, Messages, FaceTime, Siri, iCloud (native)
      - Integrated webcam (native)
      - 3.0 USB (native)
      - Touchpad and Keyboard (ELAN501): Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn-> To fix this try Karabiner (VoodoPS2Controller.kext), - for gestures try SmartTouchpad drivers
      - Battery info: Install ACPIBatteryManager.kext with Kext Utility or other installer.
      - Sleep Mode
      - SSD with TRIM enabled (to enable trim, open Terminal and write "sudo trimforce enable")
      Not working:
      - Original Wi-Fi (Qualcomm Atheros QCNFA344A):  unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle.
      - NVIDIA GeForce GTX 950M: Optimus not supported.
      - Card Reader: Unsupported -> Can't really fix because I don't have any SD Card at the moment, maybe can be fixed by adding Prod & Ven IDs to AppleStorageDevices.kext, I never used it anyway. name: "USB2.0-CRW" Prod ID: "0x0129" Ven ID: "0x0bda  (Realtek Semiconductor Corp.)"
      For Wi-Fi:
      - 1st method: You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it
      - 2nd and I think the best method: Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, they're all in my attached zip). You could buy this card from ebay, aliexpress, or amazon
       
      Issues:
      - None
      BIOS Settings:
      - BIOS version 1.15 (irrelevant)
      - Secure Boot: Disabled
      - Touchpad: Advanced
      - Boot mode: UEFI
      Getting ready for Installation:
      - Download the Catalina install zip (bootpack & postinstall): acer_aspire_V591G-55TU_cata.zip
      Installation:
      - Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager)
      - Copy my Clover folder to the USB's EFI folder
      - Boot with the Installer USB
      - If you stuck in boot, reboot and in the Clover bootloader select "config_debug.cfg" -> you'll have more informations about the freeze
       
      Please open the README.rtf in my install zip for more informations about the USB Installer & Post installation!
      For any system kext installation\modification you need to boot with config_debug.plist (or disable SIP manually)
      Also on Catalina the System folder is read-only, so you need to remount in rw. 
      If you have a single RAM and getting panic at boot, then you need to edit the "config.plist" with these (SMBIOS->after "Version 1.0"):
      ->Edit "Frequency" and "Size" to match your RAM values
      <key>Version</key> <string>1.0</string> <key>Memory</key> <dict> <key>Channels</key> <integer>1</integer> <key>SlotCount</key> <integer>1</integer> <key>Modules</key> <array> <dict> <key>Slot</key> <integer>0</integer> <key>Size</key> <integer>8192</integer> <key>Frequency</key> <integer>2133</integer> <key>Type</key> <string>DDR4</string> </dict> </array> </dict> </dict>  
      PowerManagement  fix:
      Set HWPEnable=YES in Clover (already set), CPUFloor to "700", Frequency to "2300" and "3200"(Normal and Turbo, if you have i7-6700HQ version then it should be "2600", "3500") and "FrequencyVectors" from "0x0d000000" to "0x07000000" in "S/L/E/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-A5C67F76ED83108C.plist", MSR _xcpm_idle Patch to KernelToPatch in Clover (If you have High Sierra, change "MatchOS" to 10.13):

      <key>KernelToPatch</key> <array> <dict> <key>Comment</key> <string>MSR 0xE2 _xcpm_idle instant reboot(c) Pike R. Alpha</string> <key>Disabled</key> <false/> <key>Find</key> <data> ILniAAAADzA= </data> <key>MatchOS</key> <string>10.14</string> <key>Replace</key> <data> ILniAAAAkJA= </data> </dict> </array> Reboot, and it's 800MHz in idle state, same on Windows.
       

      Elan SmartTouchpad
      I only use scrolling, one-, double- & tripletap
      If you want to try other gestures go to this link for more informations, options (v4.6.5) ->  DETAILS ABOUT THE SMART TOUCHPAD DRIVER FEATURES
      Fn Brightness keys not working with this, tried several things without success. With VoodoPS2Controller it's working, but you'll have no gestures (neither scrolling).
       
       
      Before updating to a new version of Catalina please update kexts (and clover if necessary) to newer versions to avoid kernel panics.
      Generate a serial number with Clover Configurator.app (open up your config.plist with CC then -> SMBIOS -> Serial Number -> Generate New)
       
      Catalina & Windows 10 Dual-Boot:
      Dual-boot clean install (on one drive), UEFI Only:
       
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac),   Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart,  Boot into your Win installer, Format the partition you created for Win, install.   Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       5.  You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      Dual-boot with Windows installed first (on one drive), UEFI Only:
      If you already have Windows and you don't want to lose all your data there is a hope:
      I created a video from this restore method: [Hackintosh] Dual-Boot High Sierra & Windows - when Windows already installed - no data waste - UEFI
      You need bootable Mac Installer and a full system restore image (link is in my video's description).
      (You may see errors if your EFI partition is not 200 MB)
       Boot into your Windows, resize your partition or create one for Mac.  Boot into your Mac installer and in Disk Utility format the partition you created.  Restore from image: select your full system restore image.  When it's finished restoring you just need to restart, then boot to the system with your usb.  When you successfully booted to Mac desktop, mount your EFI partition (use terminal or an EFI mounter app), open EFI, you will see there is a Microsoft folder already (don't touch that!). Copy my CLOVER folder to the EFI folder then Restart.  Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       7.  You're done! You can select your old Windows and your new macOS!
      (Only tried with Windows 8/8.1/10. I don't know Windows 7,etc.)
       
      IF YOU GETTING ERRORS DURING MAC RESTORE:
      - Make sure you have partitions in GPT
      - Windows using 100 MB EFI and will annoy the Mac restore. Don't worry, just ignore the errors.
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      - Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)
       
      IF YOU USED RESTORE METHOD THEN CAN'T MOUNT YOUR EFI PARTITION (No EFI partition found):
      - It's because your EFI is not 200 MB or not an "Apple" original EFI,  but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem)
      - You also could "mount" the EFI from Windows:
      1st method: open cmd in administrator mode and type:
      diskpart list vol (Now select the "System" volume,(FAT 32) For example I select 4) sel vol 4 list part (Select System type partition, for example 2) sel part 2 assign letter=b (This will "mount" your EFI partition) Open Explorer++ or TotalCommander in administrator mode to manage EFI remove letter=b (This will "unmount" your EFI) 2nd method: open cmd in administrator mode and type:
      mountvol b: /s (This will mount your EFI) Open Explorer++ or TotalCommander in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI) Thanks to all OSXLatitude members for helping me out! (Jake Lo, Hervé, Bronxteck, black.dragon74)!
      Notes:
      2019.10.09: Installed macOS Catalina 10.15 -> Updated Clover, kexts & config.plist -> no problem so far
      2019.08.18: Updated to 10.14.6 -> no problem when/after installing
      2019.06.01: Updated to 10.14.5 -> no problem when/after installing
      2019.04.25: Optimized touchpad scrolling -> updated install files
      2019.03.30: Fixed USB 3.0 ports, fixed Bluetooth crashes after sleep -> updated bootpack
      2019.03.28: Updated to 10.14.4. Unexpected crashes while updating to 10.14.4 -> fixed by updating Clover to the latest (v4910) version. Bluetooth crashes appeared -> fixed by downgraded Brcm*.kexts. Updated bootpack.
      2019.02.24: Bluetooth crashes after sleep -> fixed, updated bootpack. 
      2019.02.22: Updated to 10.14.3. Fixed HDMI Audio by installing "FakePCIID_Intel_HDMI_Audio.kext" -> fixed freezing during boot. Fixed brightness levels by installing "AppleBacklightFixup.kext". Also updated bootpack & postinstall zip down in attachments.
      2019.01.21: Removed FakeSMC.kext, SMCHelper-64.efi, replaced by VirtualSMC.kext, VirtualSMC.efi because I got random freezes when booting system (kextd stall[0], (120s): 'AppleACPICPU' -> CPU is at 100%, fans are spinning fast), also updated bootpack in the attachments "acer_aspire_v591g-55tu_clover.zip" -> Freeze continued, brought back FakeSMC, deleted VirtualSMC (caused BT crashes).
      2019.01.18: HDMI Audio is fixed, I didn't do anything HDMI Audio is not fixed, sometimes it worked but most likely not. (no idea why)
      2018.12.09: Updated to 10.14.2 -> did without any complication
      2018.11.28: Fixed combo-jack garbage sound output by installing ALCPlugFix and CodecCommander.kext
      2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14.
      2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working
×