Jump to content
About Just Joined group Read more... ×
Sign in to follow this  
Followers 0
mattprince

X299 Asus Rampage VI Extreme - Issues!

29 posts in this topic

Recommended Posts

Hi,

 

Really struggling to get Mojave on this.

 

The issues im having are..

Ive got the clover efi folder from kgp imac x299 thread and also created the boot installer for mojave on a usb pen. Im having to do this on a High Sierra VM (couldnt get a mojave one to work) as know nobody with a mac. I cant download xcode for some reason as it says i need to verify my apple id , which i have done many times but still refuses to let me download it. Therefore 2 of the steps i cant do as i need xcode to do them. Im getting it to boot to efi now and its getting past the "end randomseed" now but after a few seconds, the verbose text goes fuzzy and a white circle with a dash appears" From what ive read its usb related but this efi folder from kgps post already has injectusb?

Could somebody create me the tscadjustrest based on a 7920x (12 core 24 threads) and make a kext for me please? Also just searching now how to make a kext in clover as struggling to find out how to do this part..

"Valid USB port limit patches for 10.14.4 provided by @PMHeart (hardwired but yet disabled in my respective EFI-Folder distribution) by following initial USB port limit patch approach for 10.14.3 by @ydeng :

Code:
kext : com.apple.iokit.IOUSBHostFamily
Find : 83FB0F0F 87
Replace : 83FB3F0F 87
Name : USB Port Limit Patch 1 ©PMHeart
Code:
kext : com.apple.driver.usb.AppleUSBXHCI
Find : 4183FF0F 0F83
Replace : 4183FF0F 0F83
Name : USB Port Limit Patch 2 ©PMHeart
Code:
kext : com.apple.iokit.IOUSBHostFamily
Find : 83E30FD3 E34109DF
Replace : 83E33FD3 E34109DF
Name : USB Port Limit Patch 3 ©PMHeart

Finally save the modified config.plist. "

Share this post


Link to post
Share on other sites
Advertisement

Ah thanks for that. How do i do the other things in my post? Think they are to do with the usb and maybe why im getting the white circle ?

 

These..

 

"Valid USB port limit patches for 10.14.4 provided by @PMHeart (hardwired but yet disabled in my respective EFI-Folder distribution) by following initial USB port limit patch approach for 10.14.3 by @ydeng :

Code:
kext : com.apple.iokit.IOUSBHostFamily
Find : 83FB0F0F 87
Replace : 83FB3F0F 87
Name : USB Port Limit Patch 1 ©PMHeart
Code:
kext : com.apple.driver.usb.AppleUSBXHCI
Find : 4183FF0F 0F83
Replace : 4183FF0F 0F83
Name : USB Port Limit Patch 2 ©PMHeart
Code:
kext : com.apple.iokit.IOUSBHostFamily
Find : 83E30FD3 E34109DF
Replace : 83E33FD3 E34109DF
Name : USB Port Limit Patch 3 ©PMHeart

Finally save the modified config.plist. "

 

Edited by mattprince

Share this post


Link to post
Share on other sites

Ah thanks for that. How do i do the other things in my post? Think they are to do with the usb and maybe why im getting the white circle ?

 

Just tried to install it and its getting past the point of the white circle now but its getting so far and then it resets. Happens so fast that i cant see what it stops at to try and nail it down as to the problem.

 

Share this post


Link to post
Share on other sites

Hi,

 

Thats the one im using. Only thing ive added is that kext you have done for me. But part of the guide it says i have to add them things above. Dont know how and where to?

Actually im using h is 10.14.4 efi folder as the 10.14.5 says beta so thought it best to avoid that.

Share this post


Link to post
Share on other sites

You also need to adjust your bios settings : read carefully the posts about the installation on the X299 platform.

 

Share this post


Link to post
Share on other sites

I have followed the guide to the letter. Adjusted the bios, done the mojave bootable usb , with his efi , with everything apart from the kext you sent me and also the part above which i cant see how i do it?

Share this post


Link to post
Share on other sites

So when you did boot the installer in verbose mode : what message can you read on your screen ?

 

Did you put the essentials kexts in Other folder ?

 

 1760429021_Capturedcran2019-09-1920_34_26.png.7322eabdab2b1223c83c6e39cdb09558.png

 

Share this post


Link to post
Share on other sites

Hi,

 

The kexts i have in other are..

 

Annotation 2019-09-19 184702.png

Yours has loads more than mine. Would that work on my motherboard? If so would you mind sharing your efi folder and ill go in and change the serial number etc 

Share this post


Link to post
Share on other sites

The sensors kexts are not needed for the install.

You must add :

- Whatevergreen

- Lillu

- XHCi 200 series 

- USBinjectall 

- AppleALC

 

I suppose you have a compatible AMD GPU ? 

 

Other.zip

Edited by Loloflat6

Share this post


Link to post
Share on other sites

What about the white circle :

 

Normally to boot the installer your must press the F8 key and after select the EFI USB installer , at the log screen in Clover select Install MacOS Mojave and after you will see the boot screen with messages : Example of a bad messages

 

 

 

image2.jpeg

Edited by Loloflat6

Share this post


Link to post
Share on other sites

I deleted the usbinject kext and it worked. Booted, went into disk utility and formatted my nvme hard drive in apfs (the only one I have in the pc) and it freezes on 2 mins left on the install. I hope I haven't got to put windows back on, install the vm and start all over again :(

Edited by mattprince

Share this post


Link to post
Share on other sites

When you say : freezes on 2 min left on the install : did your system reboot ?

 

If the system reboot you must try to select your usb installer and see at the Clover boot screen if there is another new boot disk EG : Install MacOs Mojave in the volume with the name you selected with the disk utility ? 

Edited by Loloflat6

Share this post


Link to post
Share on other sites

Yeah it just freezes. Only options on clover now are bootmacos install from install macos mojave, options, about clover, exit clover . So looks like I have issues installing it.  Problem is I wiped my windows off this ssd to install this and now have to reinstall windows and the vm and then try again as dont have another hard drive to install macos on whilst keeping windows incase I hit issues like this

Appreciate all the help btw :thumbsup_anim:

Share this post


Link to post
Share on other sites

OK it would  bee more easier if you could buy another disk : a SSD with 120 GB ins't expensive and is sufficient to manage a success installation.

Keep me informed with yours attempt and be patient , read other guides here and  elsewhere your system is compatible...

Edited by Loloflat6

Share this post


Link to post
Share on other sites

Ok  I'm going to buy an ssd tomorrow and reinstall windows. Are you around tomorrow if I still need help? Really appreciate the help

Just tried again and it's now freezing on the disk utility part when I format the disk

Share this post


Link to post
Share on other sites

Yes of couse ,  tomorrow about at 7:00 PM ( in France)  when i'll come back from my job 

Edited by Loloflat6

Share this post


Link to post
Share on other sites

Brill. Speak then. Should have windows installed then. I'm going to buy another 500gb disk as the other can be a storage device for macos when its running perfect. Are ssds better for this than m.2 nvme?

Share this post


Link to post
Share on other sites

The SSDs are not better: m.2 nvme are just more expensive, but I always start my installation with SSD and, after a successful installation, I restart the installation on m.2 nvme and keep the SSD for Time Machine, by example.

 

Could you complete your signature with yours components: MOBO, CPU, GPU, Memory and so on ... ;-)

 

Share this post


Link to post
Share on other sites

Well i dont have a clue whats going on but i cant even get the VM to load now. DOne a new format and installed it exactly the same way as before and just keeps throwing error after error up. Going to buy a used mac tomorrow and make the usb boot with that and will update the thread. Cheers for the help and would appreciate you checking in on this in a few days :)

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

×