Jump to content
Natty

Audio High Sierra Hackintosh

174 posts in this topic

Recommended Posts

2 minutes ago, iCanaro said:

@Natty dimenticavo.. se sei in legacy è ovvio che Audiodxe va copiato anche nella cartella BIOS

 

 

ti starai mica confondendo tra GUI di Clover e Clover Configurator eh??! dalla risposta sono sicuro di si.. e hai un bel da pigiare F8 :hysterical::whistle:

Eh figurati, ero totalmente impallato a rileggere quella nota 3, quindi al bootloader con davanti il disco di High Sierra selezionato ? 

Share this post


Link to post
Share on other sites
Advertisement

e che occorre ribadire l'ovvio... avvii l'hack, fermi il countdown se presente spostandoti con le frecce della tastiera ( e ora non mi saltare fuori con il dire che le frecce te le hanno rubate gli indiani.. quelli d'america :hysterical: ) pigi F8 aspetti 40 secondi e poi che famo??? 

 

un giorno o l'altro dovrai ritornare sul desktop di high sierra :whistle:

Share this post


Link to post
Share on other sites
8 minutes ago, iCanaro said:

e che occorre ribadire l'ovvio... avvii l'hack, fermi il countdown se presente spostandoti con le frecce della tastiera ( e ora non mi saltare fuori con il dire che le frecce te le hanno rubate gli indiani.. quelli d'america :hysterical: ) pigi F8 aspetti 40 secondi e poi che famo??? 

 

un giorno o l'altro dovrai ritornare sul desktop di high sierra :whistle:

Ecchela EFI.zip

 

:lol: Il livello si sta alzando, ormai faccio tutto da solo, quasi

Edited by Natty

Share this post


Link to post
Share on other sites

ora siamo sicuri al 100%che tu hai ALC662 --> layout 5, 7, 11, 12, 13, 15, 16, 17

 

per me il candidato più probabile è quello che tu hai già, cioè il 7 

vi sono diverse strade e modi per attivare l'audio, ma non te li voglio elencare tutti... proviamo una cosa alla volta..

ti allego il pacchetto io da mettere assieme agli altri kext, 2 sono da sostituire, uno che ora non hai

 

mi serve sempre hack_info eh per vedere se AppleHDA è OK

inserisci i kext, riavvia, al desktop apri terminale:

 

sudo kextcache -i /

 

terminato riavvii e vedi.. nel caso non avessi l'audio, provi uno ad uno i layout 5, 11, 12, 13, 15, 16, 17

 

Schermata 2019-09-17 alle 01.23.11.png

audio.zip

Share this post


Link to post
Share on other sites
7 hours ago, iCanaro said:

ora siamo sicuri al 100%che tu hai ALC662 --> layout 5, 7, 11, 12, 13, 15, 16, 17

 

per me il candidato più probabile è quello che tu hai già, cioè il 7 

vi sono diverse strade e modi per attivare l'audio, ma non te li voglio elencare tutti... proviamo una cosa alla volta..

ti allego il pacchetto io da mettere assieme agli altri kext, 2 sono da sostituire, uno che ora non hai

 

mi serve sempre hack_info eh per vedere se AppleHDA è OK

inserisci i kext, riavvia, al desktop apri terminale:

 

sudo kextcache -i /

 

terminato riavvii e vedi.. nel caso non avessi l'audio, provi uno ad uno i layout 5, 11, 12, 13, 15, 16, 17

 

Schermata 2019-09-17 alle 01.23.11.png

audio.zip

 

Questo è il Report

 

Ho fatto ma ancora nulla, come ho un pò di tempo faccio la prova dei layout

 

Edited by Natty

Share this post


Link to post
Share on other sites
1 minute ago, MARZILLO said:

applehda è al suo posto....dovresti avere audio funzionante

 

Eh ma non si sente nulla, questo è suono :

 

50224138_Senzatitolo.png.e88566655f665a54c7ac0b1aa3c27e2a.png

Share this post


Link to post
Share on other sites
12 minutes ago, MARZILLO said:

prova i diversi layout:dev:

 

7 hours ago, iCanaro said:

ora siamo sicuri al 100%che tu hai ALC662 --> layout 5, 7, 11, 12, 13, 15, 16, 17

 

per me il candidato più probabile è quello che tu hai già, cioè il 7 

vi sono diverse strade e modi per attivare l'audio, ma non te li voglio elencare tutti... proviamo una cosa alla volta..

ti allego il pacchetto io da mettere assieme agli altri kext, 2 sono da sostituire, uno che ora non hai

 

mi serve sempre hack_info eh per vedere se AppleHDA è OK

inserisci i kext, riavvia, al desktop apri terminale:

 

sudo kextcache -i /

 

terminato riavvii e vedi.. nel caso non avessi l'audio, provi uno ad uno i layout 5, 11, 12, 13, 15, 16, 17

 

Schermata 2019-09-17 alle 01.23.11.png

audio.zip

E' andata con layout 5 :D ALLELUIA. Solo che non funziona la parte davanti, cioè ho l'ingresso cuffie/microfono anche dalla parte davanti del pc, solitamente funziona, anche con Voodoo funzionava, mentre qui no, devo mettere per forza da dietro, perché ?

 

Comunque avendo risolto pure il freeze, mi rimane solo quel fastidioso doppione di Windows 10 al boot, e ho risolto tutto, idee ?:D 

Edited by Natty

Share this post


Link to post
Share on other sites

@Natty da hack_info NON vedo codeccommander caricato seppur visibile in EFI

 

questo è segno di qualcosa di anomalo, quando avvii vedi di NON avere pendrive USB inserite,controlla di NON avere una EFI nella root di high sierra

 

dici che con il 5 qualcosa si è mosso, provali tutti i layout e riesegui hack_info

Schermata 2019-09-17 alle 09.27.01.png

Share this post


Link to post
Share on other sites
1 hour ago, MARZILLO said:

provane altri magari sei fortunato....non sei il primo a cui le prese frontali non vanno

 

1 hour ago, iCanaro said:

@Natty da hack_info NON vedo codeccommander caricato seppur visibile in EFI

 

questo è segno di qualcosa di anomalo, quando avvii vedi di NON avere pendrive USB inserite,controlla di NON avere una EFI nella root di high sierra

 

dici che con il 5 qualcosa si è mosso, provali tutti i layout e riesegui hack_info

Schermata 2019-09-17 alle 09.27.01.png

 

Allora li ho provati tutti : il 7 e il 12 non funzionano, tutti gli altri si, però solo dietro, alcuni meno qualità e alcuni di più : i migliori 16 e 17, il 16 mi dà però "Uscita digitale" in più. 

 

Questo è il Report

 

Per ora con il 16 la situazione è questa :

 

349875257_Senzatitolo.thumb.png.dae8c7d58150829905dbb1662b210988.png

 

 Per la parte davanti come risolvo ?

 

 

Share this post


Link to post
Share on other sites
2 minutes ago, MARZILLO said:

ho paura che applealc non gestisce lo switch frontale....spero di sbagliarmi....codec commander è caricato

come è la qualità del suono?

Ho attaccato delle AKG da Studio e per ora il 16 sembra il migliore qualità/volume.

 

Ricordo che VoodooHDA faceva sentire il frontale e il retro no, questo vuol dire che le porte funzionano e come, è che si deve trovare il modo per farle sentire tutte e due insieme :unsure: Se li mettiamo d'accordo mi esce bene anche tutta la parte Audio lol

Share this post


Link to post
Share on other sites

adesso l'audio è OK i kext sono tutti caricati

 

tutto il tempo "perso" è stato dovuto al fatto del casino prima hai creato e poi risolto con il nostro aiuto... ovvio che se avessimo l'hardware tra le mani io o Marzillo... 10 minuti et voilà

 

ora hai audio nativo apple, per averlo sul frontale, occorre essere di un livello ancora superiore, si deve agire sui pin

 

prova a vedere se nel BIOS è possibile settare tipo audio sul frontale, cioè HDA o AC97 e se si, prova a cambiare

@Natty ora per usare una metafora per spiegare bene quello che intendo, tu sei come un autista di BUS cileno dopo 8 boccali di birra, che vorrebbe guidare una ferrari settata a puntino ancora meglio di quella di vettel... :hysterical::shock:

 

bisogna che ti accontenti e dai tempo al tempo per la tua eventuale crescita e ulteriore sviluppo kext ;)

Share this post


Link to post
Share on other sites
3 hours ago, iCanaro said:

adesso l'audio è OK i kext sono tutti caricati

 

tutto il tempo "perso" è stato dovuto al fatto del casino prima hai creato e poi risolto con il nostro aiuto... ovvio che se avessimo l'hardware tra le mani io o Marzillo... 10 minuti et voilà

 

ora hai audio nativo apple, per averlo sul frontale, occorre essere di un livello ancora superiore, si deve agire sui pin

 

prova a vedere se nel BIOS è possibile settare tipo audio sul frontale, cioè HDA o AC97 e se si, prova a cambiare

@Natty ora per usare una metafora per spiegare bene quello che intendo, tu sei come un autista di BUS cileno dopo 8 boccali di birra, che vorrebbe guidare una ferrari settata a puntino ancora meglio di quella di vettel... :hysterical::shock:

 

bisogna che ti accontenti e dai tempo al tempo per la tua eventuale crescita e ulteriore sviluppo kext ;)

Cioè quindi senza creare il casino di VoodooHDA e mettendo direttamente i kexts del forum, avrei comunque avuto il problema del frontale, mi stai dicendo questo ? Perchè se riformattare e re-installare risolve, ci penso su.

 

Comunque si , nel mio BIOS antiquato della mia scheda madre di cartone, girando un pó ho trovato proprio questa cosa :


7362DD83-6880-487A-8B5A-820DF06C8705.thumb.jpeg.6a5b78cbc6f1b68452cdbf66b9141c88.jpeg

 

Era impostato su HD Audio, ho messo su AC97, non è cambiato nulla.

 

 

Edited by Natty

Share this post


Link to post
Share on other sites
3 minutes ago, iCanaro said:

OK era un tentativo da fare

Anzi, ora funziona di dietro ma solo se imposto Auricolari, mentre prima andava con Altoparlanti interni e non con Auricolari, ma non so se è molto importante

 

869892384_Senzatitolo.png.6bc0335115db7464bc29a1ee1813a851.thumb.png.d3ede26cfe9ca3fb6d3b2ce2c57945d7.png

 

Se avete altre idee, parlate :D

 

EDIT.

 

Lascio così o riavvio e rimetto HD Audio ?

Edited by Natty

Share this post


Link to post
Share on other sites
21 hours ago, iCanaro said:

rimetti HD Audio

Menomale, per un attimo pensavo dovessi riprovare tutti i layout anche con AC97 :unsure:

 

@iCanaro @MARZILLO https://www.macos86.it/viewtopic.php?f=26&t=1683

Questa pagina che mi avete linkato è per UEFI, io ho Legacy, a cosa serve ? Cioè non mi aiutano per il problema del doppio entries di Windows mi dicono è per solo UEFI

 

 

p.s. Chiedo aiuto per l'aggiornamento 004 di High Sierra. Premo aggiorna, scarica 1,88GB e mi chiede questo :

 

496039057_Senzatitolo.thumb.png.0c8df2587c4b725692b3ac244fa55761.png

 

Premo "RIAVVIA" e :

 

35B025E4-AB05-44EA-A706-06BE1FE48E50.thumb.jpeg.1a3ef9c0326a681a29fad5ae04b45876.jpeg

 

Al riavvio è così :

 

589260550_2.thumb.png.8295cd248df3c6386781c0ff3986cc97.png

 

Ho installato 4 volte ma ancora mi chiede l'aggiornamento nell'app store e il mio macOS risulta non aggiornato, starò mica dimenticando qualcosa oltre che scaricare e installare ?

Edited by Natty

Share this post


Link to post
Share on other sites

per la doppia entries al momento te la tieni così

 

per l'aggiornamento te lo avevo già detto e te lo ripeto, NON lo hai eseguito... questa volta vedi di memorizzare la cosa.

 

Per portarlo a termine, al riavvio dovrai avere una nuova entries che ti dice install macOS high sierra 

se NON ce l'hai devi modificare il config, fai backup, duplica vedi un po' tu.. poi da GUI togli tutte le entries, e rimetti su auto-scan >> yes

 

così facendo la entries dell'aggiornamento ti dovrebbe comparire e la dovrai selezionare per 2 volte, visto che esegue un ulteriore riavvio

 

tutto chiaro ora?!

Share this post


Link to post
Share on other sites
5 minutes ago, iCanaro said:

per la doppia entries al momento te la tieni così

 

per l'aggiornamento te lo avevo già detto e te lo ripeto, NON lo hai eseguito... questa volta vedi di memorizzare la cosa.

 

Per portarlo a termine, al riavvio dovrai avere una nuova entries che ti dice install macOS high sierra 

se NON ce l'hai devi modificare il config, fai backup, duplica vedi un po' tu.. poi da GUI togli tutte le entries, e rimetti su auto-scan >> yes

 

così facendo la entries dell'aggiornamento ti dovrebbe comparire e la dovrai selezionare per 2 volte, visto che esegue un ulteriore riavvio

 

tutto chiaro ora?!

Bene, io ero rimasto al mio Yosemite che non si poteva aggiornare per nessuna ragione a questo che invece è studiato per essere aggiornato, grande io avrei aggiornato a vuoto ogni giorno come uno scienziato :unsure:

 

Prima di far sparire tutte le custom mi ricordo che avevo questa entries, ora faccio

Edited by Natty

Share this post


Link to post
Share on other sites

eri rimasto parecchio indietro allora eh

 

perché si insiste per installazioni vanilla e kext in EFI... per il semplice motivo che poi è più facile da gestire quando si necessita aiuto ed un hack configurato a modo lo puoi usare come un vero mac

 

dovresti cambiare nick, da natty a capoccione :shock::hysterical: nel senso che per far entrare qualcosa li, ce ne vuole eh! :gathering:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×