Jump to content
DerNuntius

HDMI not working on Dell Latitude E5440 running 10.14.6

9 posts in this topic

Recommended Posts

Hi,

 

Finally I finished the installation of 10.14.6 on my Dell E5440. Everything works just fine, but HDMI will not work. Every time I plug it in, it causes a grey screen on my laptop monitor. Also on boot up. I attached my EFI Folder, maybe someone can help me. I searched a bit and read something about Azul Framebuffer Kext.

 

Thank you for helping.

Greedings,

Hugo

 

 

CLOVER.zip

Edited by DerNuntius
Grammar

Share this post


Link to post
Share on other sites
Advertisement

All seems Ok in your Clover Properties injection, though a zipped copy of your IOReg output would help to verify this. Maybe you should just remove that old and now unnecessary _DSM method in the IGPU section of your patched DSDT.

 

Edited by Hervé

Share this post


Link to post
Share on other sites

Hmm... on looking closer, I'm doubtful about some of those device properties injection you've configured in Clover for your HD4400 iGPU: it seems you want to set FB@1 to connector-type HDMI 00080000 and FB@2 to connector-type DP 00040000; yet, IOReg shows them both set to 00080000. I don't believe you apply the necessary patches to the Azul framebuffer..

 

If you look into layout #12 0x0a260006 of 10.14.6's Azul framebuffer kext, you'll see:

0600260A 01030303 00000002 00003001
00006000 00000060 D90A0000 D90A0000
00000000 00000000 00000800 02000000
30000000 01050900 00040000 87000000
02040900 00040000 87000000 FF000000
01000000 40000000 0F000000 01010000
04000000 00000000 0E000000 00000000

 

Now, it's long been known and documented (here for instance) that, in order to get HDMI output working on mobile HD4200/HD4400/HD4600 (including audio), the following patch needs to be applied to layout 0x0a260006:

             \/     \/
find:    01050900 00040000 87000000
replace: 01051200 00080000 87000000
             /\     /\

 

Try the following:

  1. remove or comment out all those "framebuffer-con..." entries you inject as device properties in your Clover config
  2. add the following Azul framebuffer on-the-fly patches to the Kernel & Kexts Patches of your Clover config
Kext: AppleIntelFramebufferAzul
Find:    0600260A0103030300000002000030010000600000000060D90A0000D90A00000000000000000000000008000200000030000000010509000004000087000000
Replace: 0600260A0103030300000002000030010000600000000060D90A0000D90A00000000000000000000000008000200000030000000010512000008000087000000

 

I'm pretty sure your HDMI output will be fully functional thereafter.

 

Edited by Hervé

Share this post


Link to post
Share on other sites

I tried it but it didn' work. Instead of a grey screen there's a blank screen. Maybe Im to dumb to inject the Kext properly. Can you inject it for me?

Share this post


Link to post
Share on other sites

What do you mean "inject the kext" ? All you have to do is what I listed in my previous answer. I'm sure you can perfectly do that on your own...

 

Is your E5440 fitted only with Intel iGPU or does it have the nVidia dGPU too? In case you have the dGPU model, it may well be that HDMI is wired to the dGPU.

Edited by Hervé

Share this post


Link to post
Share on other sites

Now it works. I patched the Framebuffer and the gpu with coping the on the fly patch from another config.plist that I downloaded from osxlatitude.com.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By aaroncete17
      Can someone help me to detect the graph please

    • By Ragimund (HP Z820)
      Hi All,
       
      My current and my First Hackintosh Mojave (HP Z820) has 3rd party Usb Controller : "Texas Instruments xHCI Host Controller".
       
      I have in...
      Front panel : 1 x USB2.0 + 2 x USB3.0
      Back Panel : 4 x USB2.0 + 2 x USB3.0
       
      They all work but as "USB2.0 mode" ie Slow.
      I have plenty of external USB3.0 Hard drives full of video material from my shootings on my trips.
      Idea was to use Hackintosh for editing (Final Cut Pro X) but this transfer is really slooow 
       
      I have read that it's possible to get NON-Intel USB3.0 to work, plenty of articles here, but this is my First Hackintosh and I'm a Noob ! 
       
      In my Clover /kext/other is no UsbInjectAll.kext (didn't help), but I downloaded Rehabs GenericUSBXCHI.kext (RehabMan-Generic-USB-2015-1215) there.
      I also managed to download IORegistryExplorer app.
      -The Hackintool shows only USB2.0 (screenshot attached) - no usb3.0.
      -The IOReq shows USB3.0 (I think) - but how to verify that USB3.0 ports are really USB3.0 and "high speed". (IOReq file attached)
       
      If this needs some "patching" or something it's out of my Noob league
      I have now build this Desktop about week, reading plenty of thing that I don't fully understand and trying to "copy & learn" from Masters...
       
      Can anyone help ?
       
       

      MacPro_IOReq.zip
    • By Ragimund (HP Z820)
      Hi All,
       
      I have old HP Z820 (my first Hackintosh, Mojave) and I have in SMBIOS set value MacPro 6,1 like in Sierra and High Sierra guides for HP Z820.
      But when I googled Geekbench 5 results (is this Bad/Average/Good?) for my CPU type to see others results, I find different results for Product type.
       
      I looked for Xeon E5-2695 v2 12 Core Ivy Bridge EP (I have double, so 24 Core) and found Windows and macOS results.
      I think that those macOS E5-2695 v2 devices were Hackintosh's.
       
      But there were types like :
       
      -MacPro 1,1
      -MacPro 5,1
      -MacPro 6,1
      -iMac 14,2
      -iMac 16,2
      -iMac 18,3
      -iMac 19,2
       
      Why so many ? Is there some benefits with "newer one" or are they build with some Clover "Default value" or what ?
      Should I stay with my MacPro 6,1 setting in Mojave 10.14.6 ?
       
      -Noob 
       
    • By guira
      Hey all, im new in Hackintosh world, I managed to install macOS Mojave in ASUS laptop x555LA, WIFI,HDMI,INTEL graphics, touchpad, laptop keyboard, ethernet, sound( barely, have to change it every time i run the laptop) is WORKING (after to much hours :D), also clover starts well without USB connected.
      Now my problem is that in clover, USB mouse and USB keyboard works perfectly but when MacOS load, don't know why, they stop working(just touchpad and lap keyboard working), I tried all to repair this but I can't, anyone can help me? also brightness not working but not a problem, just want USB keyboard and USB mouse working.
      AH and sorry for my English, im trying my best :D.
      btw, USB mouse and keyboard worked  when installing Mojave, but never worked in desktop or in login.
      Thanks so much , if u need more info I will be here!
    • By e97
      HackPro X99 System
      Until Apple blesses us with the MacPro7,1 – this is for those that require tools to do their work.
      An appropriate bicycle for the mind.
       
       

       

       

       
      Specs:
       
      CPU: Intel Xeon E5-2678 v3 (12 core, 2.5 GHz / 3.3 GHz Boost)
      Motherboard: SZMZ X99-8D3
      RAM: 16GB DDR3-14900R 1866Mhz ECC RDIMM modules
      GPU: Radeon RX Vega 64 8GB
      Storage: Phison E12 m.2 NVMe PCI-E 3.0 x4 SSD
      Water blocks: BARROW CPU + GPU
      Radiator: 360mm x 25mm slim
      Pump: DDC
       
      Case dimensions: 431 mm x 342 mm x 177 mm
       
       
       
      XCPM OFF
       

       
      XCPM ON
       

       
      OpenCL
       

       
       
       
      iMacPro1,1
       

       
       

       
      OpenCL
       

       
       
      NVMe
       

       
       
      Win 10 x64 v1809
       
      AIDA64 - Cache & Memory
       

       
       
      Download:  https://github.com/xe97/X99-8D3-Clover
       
       
       
       
       
      Anyone else I forgot
       
       
×