Jump to content
Sign in to follow this  
Followers 0
Vyzantion

SATA kext / Still waiting for root device

6 posts in this topic

Recommended Posts

Posted (edited)

I can not manage to install Catalina on this legacy Asus machine that runs Mojave fine. When the installer boots up, DiskUtility does not see the internal hard-drives, neither the master SATA one or the the slave, ATA one. I have discussed this already on the Clover section with Slice, he told that some kext seems to have changed from Mojave to Catalina, he told me to use IOReg. Since then, I have postponed my work on Catalina due to the issues regarding the Mojave supplemental updates.

I have decided to start a new topic in here, due to visibility reasons and some new turn. The latest version of the dosdude1 patcher for unsupported Macs, discussed on Macrumors forums, patches the installer so that DiskUtility sees the internal hard-drives, I am able to install Catalina but, on first boot, the OS gets into a kernal panic with the message ”still waiting for root device”. I have searched online for this error, I have found Information regarding previous macOS versions with solutions that seem to have little to no relevance for the present issue.

Before installation finishes, I receive a message like ”Installation finished on Macintosh HD Data”, instead of ”Installation finished on Macintosh HD”. I admit this split between the two in Catalina still confuses me, perhaps this is how it was suppose to be? Perhaps something that was suppose to end up on Macintosh HD ends in Macintosh HD Data?

I admit the DVD-Rom and hard-drives are wired kinda of weird by some guy in a PC service, he said this is the optimum combination, something the ATA hard-drive is slave to the DVD-Rom. Perhaps this causes confusion into Catalina? On Mojave this configuration was fine. 

Probably the solution suggested by Slice is the best, to replace one or more kext from Catalina with the Mojave versions of them. I do not know yet how to identify and replace them. If any other solutions seem possible, I am open to them.

Specs:

Asus P5P41TED motherboard.

Intel Core 2 Duo E 8500 

2 gb ram DDR 3

Edited by Vyzantion

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)

From what you said, I can only get the content of the EFI partition from the pen drive and the config.plist from it. I need guidance to do the rest, But first I guess need to re-install Mojave on the machine, in order to get some information (like from IOReg). I use FakeSMC, the Realtek Ethernet kext and Voodoo PS2 kext added in Clover. Clover is installer almost default, I just add to install Clover in the ESP. After putting the kexts on the EFI kext folder, I edit the config.plist via Clover Configurator to add verbose mode and Inject Nvidia. That is about it.

I am not familiar with the EC patch, I have watched mostly the Macrumors thread on unsupported Macs for Catalina, so far. This issue is present on Catalina patched with the dosdude1 method, since vanilla Catalina installer does not see the hard drives at all. (Even if I have had upgraded the GPU was talked a while ago and got Mojave vanilla to work, at this point I would still be forced to use the dosdude1 app in order to get the Catalina installer to see the internal hard-drives).

What I am trying to do is pretty tricky, since it is based on two methods used to install Catalina on different unsupported hardware. Probably I would need to get a way to make the internal hard-drives visible without the dosdude1 app. especially since on the Macrumors thread I could not get any answers.

I have just finished another attempt to install, this time on Macintosh HD Data. The same error.

Edited by Vyzantion

Share this post


Link to post
Share on other sites

In previous macOS editions, there were some problems with hard-drives invisible to DiskUtility, solved by adding some kexts in Clover for SATA. I have not found any Information on this for Catalina, if I could solve the issue of invisibility of the hard-drives in vanilla Catalina, I could drop the dosdude1 patcher. 

Share this post


Link to post
Share on other sites

I have created the installation pen drive two times, first with the RMC patch, that behaves like vanilla Catalina, with hard-drives invisible on the installer (EFI1) and the second time, with the dosdude1 patch (EFI2), I shall attach them to this thread. 

Also saved a file from IORegistryExplorer 3.0.2 on Mojave, on next posts I shall attach the EFI portion content in both situations. I do not know all the technical details because I had not need in the past to use them on the configuration, but I am willing to learn what I need to make it work. 

Note that AHCI is probably the only options, since I see no option in BIOS to change it and  High Sierra and Mojave worked without ever having to worry about it.

@Hervé Is that file what was needed?

Vyzantine’s iMac. IO!.ioreg

EFI1, from the RMC patched Catalina. 

EFI 1.zip

 

Edited by Vyzantion

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Vyzantion
      I would like to try to install Catalina on a 64 GB flash drive, in order to bypass the SATA issue. I so thay many managed to do that on external SSDs.
      Actualy, already tried it. The first step finished ok, just it took much longer. After first booting from the target flash drive from the installing flash drive, it blocked on something like ”installer will create a non-removeable partition”. Perhaps if I waiting long enough, I would have passed that phase, but there were already some 15 minutes since it blocked.
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/forum/download/file.php?id=25033
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/download/file.php?id=24376
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By FreeJHack
      MacOS does not support natively the keyboard backlight for non-Apple hardware.
      I wrote an open source Kext project (ClevoService) to perform this task on Clevo laptops.
      It's fully working on my Clevo P9XXEN_EF_ED laptop with Mojave (18G95) and it should works on many other Clevo laptops.
       
      If you own a Clevo laptop with full color backlight keyboard, take a look at:
      https://github.com/FreeJHack/ClevoService
       
      The big advantage is that the backlight function is fully controlled from the numeric keypad and it's saved between boot/reboot and sleep/wake.
      You can change color, backlight level and ON/OFF.
      For the installation, download the kext from release page and follow the instruction given in the GitHub repository.
    • By Drovosek
      Hey. I found a repository with modified voodoops2controller kext. Finalized it sysctl and kprinssu and the-darkvoid based on the kext from RehabMan.
      https://github.com/syscl/OS-X-Voodoo-PS2-Controller
       
      This kext almost like VoodooPS2Trackpad from acidanthera.
      https://github.com/acidanthera/VoodooPS2
      https://applelife.ru/threads/acidanthera-voodoops2trackpad-dlja-synaptics.2944059/
       
      I attach the compiled version.
      https://vk.com/doc183234383_514349114

      P.S. If you try it, then naturally remove other kexts for the touchpad and keyboard and, first install via KextUtility. If it works fine, then remove it from /S/L/E and throw in /kexts/Other
      VoodooPS2Controller modified syscl.zip
      P. P. S.
      I wanted to upload this archive to the forum in the "Downloads" section to where the cupcakes are located, but I didn't see a button to create a theme there. Also I have there is no opportunity to leave comments. Why?
      It would be nice if someone moved this kext there, too.
×