Jump to content
AudioGod

AudioGod's Aorus Z390 Pro Patched DSDT Mini Guide and Discussion

1,774 posts in this topic

Recommended Posts

1 minute ago, Cass67 said:

 

yeah

The z390 pro is a tricky little board when it comes to having the igpu enabled but most people have it working fine without Ma.efi on here. 

Share this post


Link to post
Share on other sites
Advertisement
Just now, AudioGod said:

The z390 pro is a tricky little board when it comes to having the igpu enabled but most people have it working fine without Ma.efi on here. 

Yah, its proven to be a pain in the hole getting rid of ma or before that the free2000 driver.  Cant really complain though, everything else works ..  Only posted this here for others to try if all else fails for them like it did for me.

Share this post


Link to post
Share on other sites
10 minutes ago, Cass67 said:

Yah, its proven to be a pain in the hole getting rid of ma or before that the free2000 driver.  Cant really complain though, everything else works ..  Only posted this here for others to try if all else fails for them like it did for me.


it’s why I haven’t updated the thread with new EFIs yet, until I find a more solid solution for you guys I’m abit stuck.

Share this post


Link to post
Share on other sites
Just now, AudioGod said:


it’s why I haven’t updated the thread with new EFIs yet, until I find a more solid solution for you guys I’m abit stuck.

 

Try changing the dvmt value to 32M and removing the driver :)

 

Im not sure how much that value is actually used these days from what i read.  From what i can tell the max allocation is what modern Windows uses and scales up to when needed and most of us probably have a dedicated GPU of sorts anyway so its probably moot whats put here for those who have a dedicated GPU.

 

I also could never figure out how to boot to efi shell (im on OC) to get the memory map to work out a proper slide value so i did not need to change this value, hacking around with various slide values never seemed to work either anyway for me with 64M in place.  32M is my sweet spot (it boots anyway multiple times) and what ill live with for now until i find issues with it down the road.

 

Share this post


Link to post
Share on other sites
4 minutes ago, Cass67 said:

 

Try changing the dvmt value to 32M and removing the driver :)

 

Im not sure how much that value is actually used these days from what i read.  From what i can tell the max allocation is what modern Windows uses and scales up to when needed and most of us probably have a dedicated GPU of sorts anyway so its probably moot whats put here for those who have a dedicated GPU.

 

I also could never figure out how to boot to efi shell (im on OC) to get the memory map to work out a proper slide value so i did not need to change this value, hacking around with various slide values never seemed to work either anyway for me with 64M in place.  32M is my sweet spot (it boots anyway multiple times) and what ill live with for now until i find issues with it down the road.

 


if you check my z390 master thread it says to do exactly that if you can’t get it to boot or you can go with igpu disabled and change your shiki value too 144, that works perfectly too but you lose quick sync 

the master board plays very friendly with the igpu enabled so I updated that one a while ago now.

 

When you do check your custom slide value you will find that slide on the z390 pro always ends up being slide=0 

 

Edited by AudioGod

Share this post


Link to post
Share on other sites
5 minutes ago, AudioGod said:


if you check my z390 master thread it says to do exactly that if you can’t get it to boot or you can go with igpu disabled and change your shiki value too 144, that works perfectly too but you lose quick sync 

the master board plays very friendly with the igpu enabled so I updated that one a while ago now.

 

When you do check your custom slide value you will find that slide on the z390 pro always ends up being slide=0 

 

 

Yeah just checked the master thread and you do indeed say reduce to 32M, well that advice seems to work for this board too... iGPU enabled and 32M preallocated works for me.   Guess i need to start reading both threads consistently since the info is split between them and could be relevant for either  :) 

 

Im not sure what your other issues are relating to this board preventing the release of the new EFI you mentioned.

 

Interesting point on the slide value, i guess i'll not bother any more trying to work out how to get to efishell .. slide=0 and above including messing with the custom slide flags seem not to work on this board in my tests.

 

Share this post


Link to post
Share on other sites
25 minutes ago, Cass67 said:

 

Yeah just checked the master thread and you do indeed say reduce to 32M, well that advice seems to work for this board too... iGPU enabled and 32M preallocated works for me.   Guess i need to start reading both threads consistently since the info is split between them and could be relevant for either  :) 

 

Im not sure what your other issues are relating to this board preventing the release of the new EFI you mentioned.

 

Interesting point on the slide value, i guess i'll not bother any more trying to work out how to get to efishell .. slide=0 and above including messing with the custom slide flags seem not to work on this board in my tests.

 

 

Il update this thread, your not meant to have to check both threads buddy that's totally my bad.

It's hard for me to maintain two threads when I no longer use the Z390 Pro myself anymore so I Lean on other people like poor @texem to test out stuff for me but he's bit fed up of doing it for me now days (and who can blame him?) so its slowed me right down on this thread.

Now that @larabee has returned and when hes feeling up for it he might help me out again with double checking it all with me.

Apologies for the delay but I will get it all sorted out and updated on here ASAP. :thumbsup_anim:

Edited by AudioGod

Share this post


Link to post
Share on other sites
11 minutes ago, AudioGod said:

 

Il update this thread, your not meant to have to check both threads buddy that's totally my bad.

It's hard for me to maintain two threads when I no longer use the Z390 Pro myself anymore so I Lean on other people like poor @texem to test out stuff for me but he's bit fed up of doing it for me now days (and who can blame him?) so its slowed me right down on this thread.

 Now that @larabee has returned and hes feeling up for it he might help me out again with double checking it all with me.

Apologies for the delay but I will get it all sorted out and updated on here ASAP. :thumbsup_anim:

 

Meh, its no hardship checking 2 places, i read a lot more threads on here so one more is no problem... Id also not be too hard on yourself about working on multiple devices, especially since you no longer have the pro board any more, we should all be happy you're still updating this given the constraints you have right now.

 

I'll look forward to what your going to release next but right now i have a practically perfect system in regards to whats working, nothing i can think of is a problem outside your favourite subject of safari and drm ;) Which i read will be fixed on 10.15.4.  Not sure what else needs to be updated here outside of new Opencore's or Clovers...  Maybe your fancy DSDT'less EFI would be good to look at ;)

 

EDIT - I don't have much time outside work to help you test but if you need something and i can help if no one else is available, ping me and ill see what i can do !!

 

Cheers

Edited by Cass67

Share this post


Link to post
Share on other sites
17 minutes ago, Cass67 said:

nothing i can think of is a problem outside your favourite subject of safari and drm ;) Which i read will be fixed on 10.15.4. 

 

:hysterical::hysterical: Thats the first DRM comment that's made me laugh so big up you brother...lol

I only ever got fed up about it because I always knew it was something apple needed to fix and people went that little bit too nuts about it trying to find a fix when all the time i knew there wouldn't be one until apple sorted it out.

Im over it now and don't get crazy at the mere mention of DRM anymore as long as it doesn't turn into a 10 page assay of nonsense about it. :hysterical: 

Edited by AudioGod

Share this post


Link to post
Share on other sites

Hello, would the folder "Aorus Z390 Pro RX Polaris F12d EFI .zip" for the 12b Bios work with a installer for 10.15.3 Catalina? This is the version that I have been able to download via "software update tool".

 

If not, how may I get a 10.15.2 installer

 

Thanks!

Share this post


Link to post
Share on other sites
25 minutes ago, JanRocker said:

Hello, would the folder "Aorus Z390 Pro RX Polaris F12d EFI .zip" for the 12b Bios work with a installer for 10.15.3 Catalina? This is the version that I have been able to download via "software update tool".

 

If not, how may I get a 10.15.2 installer

 

Thanks!

Yes no problems with 10.15.3 install away :thumbsup_anim:

Share this post


Link to post
Share on other sites

NEW Clover Major EFI, 14th February 2020 

(Use With Bios Revision F12d)

 

VERY IMPORTANT NOTICE

PLEASE NOTE IT HAS BEEN DISCOVERED THAT THE DRIVER MemoryAllocation.EFI IS MADE FROM THE SAME CODE AS THE FREE2000.EFI DRIVER AND IS POTENTIALLY HARMFUL TO YOUR SYSTEM SO I HAVE DECIDED TO DROP THE DRIVER FROM MY EFIs.

 

You will need to preform a full bios reset by removing all power to the system and then removing the motherboards internal battery for a few minutes then put it all back and load back in your bios profile and continue as normal.

 

If you find your unable to boot up with the new EFI and the IGPU enabled then you can try dropping the IGPU memory from 64mb to 32mb or if that doesn't work you can disable the IGPU and change the shiki boot argument to shikigva=144

 

The EFI and DSDT has now been updated to the my latest version.

Changes made include,

New DSDT's For bios revision F12d ONLY

MemoryAllocation.efi Removed

OcQuirks Revision 15

AppleALC-1.4.6

VirtualSMC 1.11

Clover Updated too Revision 5103

Plus other minor tweaks to the clover config

 

Clover EFI Update - 14/02/2020 - Use with Bios revision F12d Only or Replace with the older F11 DSDT if you don't want to update the bios

 

Z390 Pro Navi Vega Clover EFI 140220.zip 14/02/2020 Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI

Z390 Pro Polaris Clover EFI 140220.zip - 14/02/2020 RX5XX Polaris DSDT EFI

HD630 Z390 Pro F12d EFI 140220.zip - 14/02/2020 IGPU Only EFI. SMBIOS MacMini 8,1 

Edited by AudioGod

Share this post


Link to post
Share on other sites
55 minutes ago, AudioGod said:

You will need to preform a full bios reset by removing all power to the system and then removing the motherboards internal battery for a few minutes then put it all back and load back in your bios profile and continue as normal.

Hello, is it necessary to perform this for a brand new z390 Pro?

Share this post


Link to post
Share on other sites
5 minutes ago, JanRocker said:

Hello, is it necessary to perform this for a brand new z390 Pro?

 

If you have never had an EFI on it before then no you should be fine but if it won't boot then that's what you got to do to get it going.

Share this post


Link to post
Share on other sites
5 hours ago, AudioGod said:

 

Il update this thread, your not meant to have to check both threads buddy that's totally my bad.

It's hard for me to maintain two threads when I no longer use the Z390 Pro myself anymore so I Lean on other people like poor @texem to test out stuff for me but he's bit fed up of doing it for me now days (and who can blame him?) so its slowed me right down on this thread.

Now that @larabee has returned and when hes feeling up for it he might help me out again with double checking it all with me.

Apologies for the delay but I will get it all sorted out and updated on here ASAP. :thumbsup_anim:

Wow, really? You've already switched boards? What are you using now?

Share this post


Link to post
Share on other sites
1 minute ago, pkdesign said:

Wow, really? You've already switched boards? What are you using now?

I switched to the Z390 Master ages ago now.

Share this post


Link to post
Share on other sites

FYI: I do not use MA.efi and the only boot argument I have is darkwake=3 (based on @holyfield post) and I may remove that as well since I can't get sleep to work properly on my system no matter what I do. Probably the combination of peripherals and devices, etc, that I use. No matter, sleep is nice but not very necessary for me.

 

EDIT:
I should clarify that with darkwake=3, I do get sleep with no issue. I just have a problem with external hard drives not disconnecting properly.

 

 

I have no shiki values since I don’t care about DRM in my browsers. I am still on Mojave (no plans to update to Catallina) so that is why this may not matter.

 

So far I have a rock solid system (fingers crossed) and everything works great. BUT, to each his own and every system is different for sure. I know the reason I have such a stable system is the hard work of @AudioGod with the support  of @MaLd0n and his DSDT, and everyone else associated with getting this board up and running. :thumbsup_anim:

 

 

Edited by pkdesign

Share this post


Link to post
Share on other sites
47 minutes ago, JanRocker said:

One silly question. Is this installation a Vanilla one? Sorry if this is stupid xD

About as much as it can be yes it is.

 

vanilla that is not stupid :hysterical:

Edited by AudioGod

Share this post


Link to post
Share on other sites
5 hours ago, pkdesign said:

EDIT:
Is should clarify that with darkwake=3, I do get sleep with no issue. I just have a problem with external hard drives not disconnecting properly.

You'd likely have those on a real Mac as well. That has nothing to do with how the EFI is setup and everything to do with your external drives and how their firmware handles power loss. Most handle it like ass. Lacie, WD, they are all a hot mess.

Share this post


Link to post
Share on other sites

More silly questions.

 

I plan on installing two separate ssd, one for macos and the other for Windows.

 

Patching the DSDT of the MB could affect Windows in some way?

 

Thanks again!!!

Share this post


Link to post
Share on other sites
3 minutes ago, JanRocker said:

More silly questions.

 

I plan on installing two separate ssd, one for macos and the other for Windows.

 

Patching the DSDT of the MB could affect Windows in some way?

 

Thanks again!!!

If you use a custom DSDT with Clover or stock OpenCore then yes... What OS you select in the boot menu will take on the properties of what custom DSDT changes you made.  In this case if you don't want this use the UEFI boot picker you're MB provides.

 

On the other hand, with the NDK custom OpenCore release, it patches this behaviour out and you can choose (i think(it may be default behaviour)) not to have DSDT changes affect other OS's.  

 

Either way i never had an issue that i know about using Clover with a DSDT and picking Windows or Linux from the Clover boot screen or indeed nowadays since i use stock OpenCore i never have to worry about it as i use the MB UEFI boot menu to boot other OS when i need it.  I never looked very much to the custom NDK version as i prefer stock OC and im OK using the MB boot selector to boot which drive i need.

 

 

 

Share this post


Link to post
Share on other sites

Both Clover and OC provide a way to ignore patching anything if Windows is loaded. Please read each one's documentation on how to implement.

 

With that said, if the DSDT is set up correctly (and this is), then it won't matter. Nothing will apply to Windows. It would only affect those with an already busted build held together by duct tape.

Share this post


Link to post
Share on other sites
11 hours ago, AudioGod said:

 

If you have never had an EFI on it before then no you should be fine but if it won't boot then that's what you got to do to get it going.

Hi @AudioGodCould you please clarify the meaning of "never had an EFI on it"? I just remove MemoryAllocation.efi from EFI folder and add slide=0 argument in clover boot args and system boots fine as before without BIOS reset. Should I still need to reset my F12d BIOS(MSR unlocked) to avoid any potential problems in future?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11c, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9600K, 9700K, 9900K, 9900KS
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Nitro+ RX 5700 XT ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      CLOVER EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11c to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f11c.zip - Aorus Z390 Master Bios F11c 
       
      Use this folder with fully patched DSDT
      Current EFI 
      Updated 04/02/2020
      EFI Update - 04/02/2020 - Use with Bios revision F11c Only or Replace with the older F10 DSDT if you don't want to update the bios
      AG Clover Z390 Master Navi Vega EFI.zip - Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI
      AG Clover Z390 Master Polaris EFI.zip - RX5XX Polaris DSDT EFI
       
       
      CFG Unlock (MSR) F11c BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      ADDITIONAL DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - OpenCore No DSDT and Done the way OpenCore intended it (04/02/2020)
       

      Alternative EFI 2 - N-D-K Fork of OpenCore (04/02/2020)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11C)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

    • By ricardos7
      Boa tarde a todos, estou fazendo um hack em um notebook Dell 5557, as configurações estão abaixo.
      Preciso de ajuda para terminar alguns detalhes que nÃo consegui, alguém poderia ajudar?
       
      bem com a minha pasta EFI que pode ser baixada nesse post vc poderá fazer o seu hack mais facilmente nesse modelo,
      pois quase tudo ja esta configurado e pronto pra uso.
       
      ESPECIFICAÇÕES TÉCNICAS
      Processador Intel Core i7 - 6ª Geração Intel Core i7-6500U
      Velocidade: 2.5 GHz até 3.1 GHz com Max Turbo Cache: 4Mb
      Memória RAM Quantidade: 16GB DDR3L 1600MHz (2X8).
      Armazenamento Capacidade: 240 GB SSD
      Tela Tamanho:15.6” Resolução: FULL HD 1920x1080p Touch
      Webcam integrada de alta definição (720p) com microfone digital
      Gráfico Integrado Intel HD 520
      NVIDIA® GeForce 930M com 4GB DDR3 Dedicada
      Áudio Realteck ALC255

      Dell Wireless 1707 WiFi, chip ar9565
      1x  HDMI 1.4ª
      2x USB 3.0
      1x USB 2.0
      1x Ethernet 10/100 RJ-45
      1x Entrada de Cartão 5 em 1 (SD, SD 3.0, SDHC, MS e MS PRO)
      Leitor de Cartão
      Tipo: SD, SDHC, SD3.0, MS, MS Pro
      Alimentação Bivolt 3 células 43Wh
       
       
      O QUE NÃO FUNCIONA?
      BRILHO DA TELA
      BLUETOOTH
      SONO (Hibernação)
      HDMI (audio) video funciona mais a tela do note fica preta ao conectar o cabo HDMI
      GRAFICOS DEDICADOS NVIDEA 930M (DESATIVADO)
       
      O QUE FUNCIONA?
       
      GRAFICOS INTEL
      WI-FI - a intel original foi substituída pela DELL dw1707 ar9565
      AUDIO
      TECLADO
      TRACKPAD (com gestos)
      TOUCHSCREEN (com alguns gestos)
      TECLAS  DE ATALHO
      PLACA DE REDE RJ45
      GERENCIAMENTO DE ENERGIA
       
      OBS. PARA DESATIVAR OS GRÁFICOS FOI USANDO UMA SSDT EM CONJUNTO COM A DSDT-5 E 7, DEPOIS DE APLICADO ALGUNS PACHES.
       
      A DSDT E AS SSDT
      PACHS BASICOS APLICADOS.
      Aparentemente o gerenciamento de energia está funcionando bem, pelo menos o processador parece esta bem estável.
       

       
      PASTA OTHER CLOVER (DEPOIS DESSA IMAGEM FOI ADICIONADO MAIS DUAS KEXT QUE NAO ESTAO PRESENTES NA IMAGEM, PARA FUNCIONAR
      O TOUCH E PARA O WIFI CONSEGUIR ENCONTRAR AS REDES.
       

       
      EFI 
       

       
       
       
       
      ESTAREI DEIXANDO UM LINK PARA DOWNLOAD DA MINHA PASTA EFI, CASO ALGUEM ESTEJA FAZENDO ESSE MESMO HACK ESSA PASTA PODERÁ AJUDAR.
       
      ATENÇÃO
       
      LEMBRANDO QUE OS ARQUIVOS DSDT E SSDT, SSDT DE 5 A 8 SÃO DO MEU NOTEBOOK, QUEM FOR USAR DEVER EXTRAIR E CONSTRUIR SEUS PRÓPRIOS DSDT E SSDT.
      O SSDT-EC E O SSDT-PNLF PODEM SER USADOS POIS SÃO GENERICOS.
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F PARA COLOCAR NO PENDRIVER DE INSTALAÇÃO.
      https://drive.google.com/open?id=1nPM2CNgpr7cwOkjwj7UReziqrh9xjtf1
      SE NAO SUBIR COM A Config.plist INICIAL SELECIONE A Config2.plist
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F (EM USO) 14/02/2020
      https://drive.google.com/open?id=1US7j-YlufrFTasLihmUZwElyV4jBfHDg
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F (ANTIGA)
      https://drive.google.com/open?id=1Q2tnoqQZ9K44Bv6k2k1yauaHCAop_ZyW
       
      QUEM PUDER AJUDAR A CORRIGIR OS PROBLEMAS RESTANTE EU AGRADEÇO, OBRIGADO.
       
       

    • By Krani93
      Hi guys,
       
      I'm trying to install Catalina on a Lenovo m720q (i5-8600T with B360).
      After some other issues I'm know stuck at attached screen.
      Im using latest opencore version and have my EFI folder attached.
       
      Can someone help me I've got no clue what to try next :/ 
       
       
      Cheers!

      EFI.7z
    • By MaLd0n
      ---TUTORIAL---
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Original Post--
      https://www.olarila.com/topic/6531-olarila-hackbeast-z390-designare-thunderbolt-full-dsdt-patches-clover-opencore/
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://www.olarila.com/topic/6364-mojave-catalina-on-mobos-series-100200300-with-opencore-bootloader/
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
×