Jump to content
AudioGod

AudioGod's Aorus Z390 Pro Patched DSDT Mini Guide and Discussion

1,834 posts in this topic

Recommended Posts

Nope. It does detect my TM backup but the EFI Partition is empty and I'd actually like to remove that. But no, it doesn't automatically detect W10.

5 hours ago, hungrywallet said:

 

There's a kext that fixes that.  I have it installed on my system.  However I'm still on Clover.

 

SystemProfilerMemoryFixup.kext

Cool, but once you try OC, you can't go back to Clover

Edited by Tiem

Share this post


Link to post
Share on other sites
Advertisement
48 minutes ago, Tiem said:

Nope. It does detect my TM backup but the EFI Partition is empty and I'd actually like to remove that. But no, it doesn't automatically detect W10.

Cool, but once you try OC, you can't go back to Clover


How strange, it should be showing a option called boot camp and that boots you into windows.

sounds like a problem for @texem to solve.

 

Do you prefer OpenCore to Clover?

Edited by AudioGod

Share this post


Link to post
Share on other sites

Ya I love OC. Clover ran just fine no real issues with it. I just like how clean OC feels. Really hyped to see it mature if it’s still this good at v0.5 :D

Share this post


Link to post
Share on other sites
37 minutes ago, AudioGod said:


 it should be showing a option called boot camp and that boots you into windows.

 

Does for me .. seems fine !!

Share this post


Link to post
Share on other sites
3 hours ago, AudioGod said:

@tasc how you finding opencore?

do you prefer it too clover?

 

Haven't convinced myself I need to try it yet, given clover is working just fine. So for now, staying on clover until there is a reason to switch. Also, don't want to screw up my work machine! :P

Share this post


Link to post
Share on other sites
3 hours ago, Tiem said:

Cool, but once you try OC, you can't go back to Clover

What do you mean? I booted with OpenCore on a USB flash drive, then booted using Clover after.

Share this post


Link to post
Share on other sites
Just now, pkdesign said:

What do you mean? I booted with OpenCore on a USB flash drive, then booted using Clover after.

I think he means that he likes OC so much more he doesn’t want to use clover again...

Share this post


Link to post
Share on other sites

Yes what AG said. TBH Clover is great. I had no issues with it. Aside from some cosmetic stuff it worked great. Definitely better boot loader on the front side. Can’t wait till OC develops themes!

 

But OC does support macOS more natively. And I know this sounds dumb but I always hated how Clover would inject it’s details into the system profiler. OC feels really just like native macOS. Not like Clover running macOS if that makes sense.

Share this post


Link to post
Share on other sites

@AudioGod the funniest thing is that I was able to use your EFI on three different mainboards with no fuzz at all. Your EFI also works on MSI Z370 Pro-A and ASUS ROG STRIX H370-I Gaming. I thought you should know. And thanks again for your great work. :thumbsup_anim:

Share this post


Link to post
Share on other sites
3 minutes ago, Ralle said:

@AudioGod the funniest thing is that I was able to use your EFI on three different mainboards with no fuzz at all. Your EFI also works on MSI Z370 Pro-A and ASUS ROG STRIX H370-I Gaming. I thought you should know. And thanks again for your great work. :thumbsup_anim:

Blimey, that is cool but be warned the dsdt is not made for any other motherboard so while it might look fine I bet under the hood is a different story. Check your logs and io reg to see what I mean.

Share this post


Link to post
Share on other sites
36 minutes ago, AudioGod said:

Blimey, that is cool but be warned the dsdt is not made for any other motherboard so while it might look fine I bet under the hood is a different story. Check your logs and io reg to see what I mean.

Will do :yes:

Share this post


Link to post
Share on other sites
16 minutes ago, Ralle said:

Will do :yes:


What you should do is using my EFI just remove the dsdt and ssdt and put in a request with MaLd0n to create new and correct DSDTs and SSDTs for your systems and that way they will all be spot on perfect.


 

To Create Your Own Patched DSDT Message MaLd0n using the link bellow

https://olarila.com/forum/viewtopic.php?f=19&t=1131 

(If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)

 

Edited by AudioGod

Share this post


Link to post
Share on other sites

I haven't checked the forum in a few weeks, but I just noticed there is a new firmware F12d for my motherboard and updated EFI etc.  (Attempted to update clover and was given an incompatible warning.)  I am currently running Aorus Pro Z390 F11 bios, iMacPro1,1 without trouble, so I am curious if there is a good reason to update, or just leave well enough alone right now?

 

Any advice what NOT to do if I update my bios and EFI.  ha. Thanks!

 

* Just did the update worked great. :)  As I have a dual boot into windows, I have to reset my boot options to default boot my Mac drive.  I am having an issue with Sidecar not connecting "device timed out".  Still looking into that.  Handoff etc works fine.

Edited by Hifi33
Updated to latest firmware.

Share this post


Link to post
Share on other sites

Thanks for your help with this! I just built my first hackintosh, and everything is working great, with the exception of the microphone. I have audio, but just not input. I used the Aorus Z390 Pro Vega Navi VII F12d EFI .zip . Would you be able to guide me a little bit? I am totally lost. thank you very much in advance!

Share this post


Link to post
Share on other sites
On 1/16/2020 at 11:32 AM, AudioGod said:

 

hey bud as soon as I'm free I will give you a message. 

 

@AudioGod after I spent more than 2 weeks to fix the unbootable mojave it is finally working again with Catalina and the customized efi that was sent before by you.  Not sure if I ever want to touch any efi files and/or even upgrade the clover lol :hysterical:

 

anyway thanks to you and my next task is to add a separate SSD for Windows dedicated disk.  Once that is done, I will install Windows and report back to you on the HDMI audio issue.  

Share this post


Link to post
Share on other sites

Updated Bios Settings - 19/01/20

 

• Boot -> Windows 8/10 Features -> Win 8/10WHQL

• Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled

 

Share this post


Link to post
Share on other sites
23 hours ago, AudioGod said:

Updated Bios Settings - 19/01/20

 

• Boot -> Windows 8/10 Features -> Win 8/10WHQL

• Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled

 

When I wake up my mackintosh from sleep the keyboard with usb cable isn't working I need to reconnect.

but my mouse with usb receiver works, any idea?

Share this post


Link to post
Share on other sites

Just providing an update on how sleep and shutdown all worked now.

 

Shutdown: I have to insert the slide=0 to config.plist and downloaded the EmuVariableUefi-64.efi and put it in \EFI\Clover\drivers\UEFI

Sleep: The reason it didn't work last time because i had hibernate disabled. By reinstalling a fresh copy of Catalina, now sleeps completely put the computer to sleep and wake by keyboard/mouse.

 

I also went and gotten a 750W 80 Plus Gold Certified PSU and overlocked my i5-9600k to 4.8Ghz, didn't want to press too much.

 

Everything working smoothly here.

Share this post


Link to post
Share on other sites
4 hours ago, c1ru said:

When I wake up my mackintosh from sleep the keyboard with usb cable isn't working I need to reconnect.

but my mouse with usb receiver works, any idea?

When it’s asleep press a key on the keyboard and see if the hack wakes up, if it does then when you get to the lock screen and the keyboard isn’t functioning try pressing a key and wait a few seconds and then try again and the keyboard should wake up.

the same thing happens to my Corsair keyboard (rgb) and I’m yet to figure out how to resolve it.

if anybody else knows whos reading this knows how to fix it then please do tell?

Edited by AudioGod

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites
On 1/17/2020 at 12:23 PM, tasc said:

 

Thanks @pkdesign, setting Platform Feature to 0x00 fixed it.

 

I happened to be in an Apple store over the weekend and checked an iMacPro, and there actually is no memory tab on "About this Mac" - memory classified as not upgradeable. Now the iMac19,1 that does show memory tab. So score one for Clover, it's doing the right thing with regards to iMacPro.

Share this post


Link to post
Share on other sites
7 hours ago, AudioGod said:

When it’s asleep press a key on the keyboard and see if the hack wakes up, if it does then when you get to the lock screen and the keyboard isn’t functioning try pressing a key and wait a few seconds and then try again and the keyboard should wake up.

the same thing happens to my Corsair keyboard (rgb) and I’m yet to figure out how to resolve it.

if anybody else knows whos reading this knows how to fix it then please do tell?

Same happens with the Bluetooth Keyboard. Although the keyboard can wake up the hackintosh, it may not get keystrokes for the password immediately. This actually happens on my MacBook Pro as well, although the lag on th a hackintosh is a bit longer sometimes

Edited by WizeMan

Share this post


Link to post
Share on other sites
5 hours ago, hungrywallet said:

I don't know why everyone is losing their sh*t over this. It worked on the z390 before all this. And tbh, it doesn't really matter as much as everyone wants to believe. So you get KP logs. Outside of that, does it really matter.

Edited by Tiem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

  • Similar Content

    • By Tderosin990
      Hey there, I’m pretty new here. I wanted to boot into macos. I created the boot file and got it to the installation. It says MacOS installed and it need to reboot, but when it reboots, it shows me errors and says that it cannot finish installing. What do I do? i have an inspirion 5559 with Intel core i5, 8 gb ram. Can I even install Mac on this laptop? I’ve done the research and it boots to the installation. 

    • By fercho3138
      Hi!
      So I've successfully built my rig and installed Mac os
      Gigabyte Aorus Z390 Pro Wifi Intel Core i7 9700k Ballistix Sport 32gb Samsung evo 500gb nv Sapphire Radeon RX 580 Pulse Corsair h60 The thing is that I got it running perfectly, even performed some heavy video renderings with no problem but sometimes it just restarts on its own, sometimes when I'm using Chrome, sometimes when I'm editing or whatever other task. Last time it happened I got the forbidden sign on the screen so I tried to boot up again using the -v flag and I got the "Couldn't allocate runtime area" message, which is very strange because I had no problems in booting up the system after I made my configurations in the config.plist

      Please someone give me some help with this problem, I'm completly stucked!!
      config.plist
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11c, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9600K, 9700K, 9900K, 9900KS
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Nitro+ RX 5700 XT ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      CLOVER EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11c to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f11c.zip - Aorus Z390 Master Bios F11c 
       
      Use this folder with fully patched DSDT
      Current EFI 
      Updated 04/02/2020
      EFI Update - 04/02/2020 - Use with Bios revision F11c Only or Replace with the older F10 DSDT if you don't want to update the bios
      AG Clover Z390 Master Navi Vega EFI.zip - Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI
      AG Clover Z390 Master Polaris EFI.zip - RX5XX Polaris DSDT EFI
       
       
      CFG Unlock (MSR) F11c BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      ADDITIONAL DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - OpenCore No DSDT and Done the way OpenCore intended it (04/02/2020)
       

      Alternative EFI 2 - N-D-K Fork of OpenCore (04/02/2020)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11C)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

    • By ricardos7
      Boa tarde a todos, estou fazendo um hack em um notebook Dell 5557, as configurações estão abaixo.
      Preciso de ajuda para terminar alguns detalhes que nÃo consegui, alguém poderia ajudar?
       
      bem com a minha pasta EFI que pode ser baixada nesse post vc poderá fazer o seu hack mais facilmente nesse modelo,
      pois quase tudo ja esta configurado e pronto pra uso.
       
      ESPECIFICAÇÕES TÉCNICAS
      Processador Intel Core i7 - 6ª Geração Intel Core i7-6500U
      Velocidade: 2.5 GHz até 3.1 GHz com Max Turbo Cache: 4Mb
      Memória RAM Quantidade: 16GB DDR3L 1600MHz (2X8).
      Armazenamento Capacidade: 240 GB SSD
      Tela Tamanho:15.6” Resolução: FULL HD 1920x1080p Touch
      Webcam integrada de alta definição (720p) com microfone digital
      Gráfico Integrado Intel HD 520
      NVIDIA® GeForce 930M com 4GB DDR3 Dedicada
      Áudio Realteck ALC255

      Dell Wireless 1707 WiFi, chip ar9565
      1x  HDMI 1.4ª
      2x USB 3.0
      1x USB 2.0
      1x Ethernet 10/100 RJ-45
      1x Entrada de Cartão 5 em 1 (SD, SD 3.0, SDHC, MS e MS PRO)
      Leitor de Cartão
      Tipo: SD, SDHC, SD3.0, MS, MS Pro
      Alimentação Bivolt 3 células 43Wh
       
       
      O QUE NÃO FUNCIONA?
      BRILHO DA TELA
      BLUETOOTH
      SONO (Hibernação)
      HDMI (audio) video funciona mais a tela do note fica preta ao conectar o cabo HDMI
      GRAFICOS DEDICADOS NVIDEA 930M (DESATIVADO)
       
      O QUE FUNCIONA?
       
      GRAFICOS INTEL
      WI-FI - a intel original foi substituída pela DELL dw1707 ar9565
      AUDIO
      TECLADO
      TRACKPAD (com gestos)
      TOUCHSCREEN (com alguns gestos)
      TECLAS  DE ATALHO
      PLACA DE REDE RJ45
      GERENCIAMENTO DE ENERGIA
       
      OBS. PARA DESATIVAR OS GRÁFICOS FOI USANDO UMA SSDT EM CONJUNTO COM A DSDT-5 E 7, DEPOIS DE APLICADO ALGUNS PACHES.
       
      A DSDT E AS SSDT
      PACHS BASICOS APLICADOS.
      Aparentemente o gerenciamento de energia está funcionando bem, pelo menos o processador parece esta bem estável.
       

       
      PASTA OTHER CLOVER (DEPOIS DESSA IMAGEM FOI ADICIONADO MAIS DUAS KEXT QUE NAO ESTAO PRESENTES NA IMAGEM, PARA FUNCIONAR
      O TOUCH E PARA O WIFI CONSEGUIR ENCONTRAR AS REDES.
       

       
      EFI 
       

       
       
       
       
      ESTAREI DEIXANDO UM LINK PARA DOWNLOAD DA MINHA PASTA EFI, CASO ALGUEM ESTEJA FAZENDO ESSE MESMO HACK ESSA PASTA PODERÁ AJUDAR.
       
      ATENÇÃO
       
      LEMBRANDO QUE OS ARQUIVOS DSDT E SSDT, SSDT DE 5 A 8 SÃO DO MEU NOTEBOOK, QUEM FOR USAR DEVER EXTRAIR E CONSTRUIR SEUS PRÓPRIOS DSDT E SSDT.
      O SSDT-EC E O SSDT-PNLF PODEM SER USADOS POIS SÃO GENERICOS.
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F PARA COLOCAR NO PENDRIVER DE INSTALAÇÃO.
      https://drive.google.com/open?id=1nPM2CNgpr7cwOkjwj7UReziqrh9xjtf1
      SE NAO SUBIR COM A Config.plist INICIAL SELECIONE A Config2.plist
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F (EM USO) 14/02/2020
      https://drive.google.com/open?id=1US7j-YlufrFTasLihmUZwElyV4jBfHDg
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F (ANTIGA)
      https://drive.google.com/open?id=1Q2tnoqQZ9K44Bv6k2k1yauaHCAop_ZyW
       
      QUEM PUDER AJUDAR A CORRIGIR OS PROBLEMAS RESTANTE EU AGRADEÇO, OBRIGADO.
       
       

×