Jump to content
AudioGod

AudioGod's Aorus Z390 Pro Patched DSDT Mini Guide and Discussion

1,794 posts in this topic

Recommended Posts

36 minutes ago, Tiem said:

I'm 99.9% sure it should be there. Not-upgradable typically applies to memory that is soldered to the board (like the Air). And even then it should list it no?

 

In any case, the iMac19,1 has 4 slots and despite being just hard to get to, is actually just regular DDR4. Crucial sells upgrades for it: https://www.crucial.com/usa/en/compatible-upgrade-for/Apple/imac-(retina-5k,-27-inch,-2019)-imac-19,1

@tasc @Tiem It’s a bug in clover nothing else, been happening for ages...lol

dont be trying to start a next DRMGate please you two over somthing cosmetic....:hysterical:

Edited by AudioGod

Share this post


Link to post
Share on other sites
Advertisement

TBH , friends .. in the name of AudioGod, me and others  : please do not ride on this cosmetic problem and plz do not expect a fix. What about trying to fix it for yourself and post your results here ?

 

Thanks :) be cool .

 

Share this post


Link to post
Share on other sites
1 hour ago, texem said:

TBH , friends .. in the name of AudioGod, me and others  : please do not ride on this cosmetic problem and plz do not expect a fix. What about trying to fix it for yourself and post your results here ?

 

Thanks :) be cool .

 


@texem amen brother :hysterical:

 

My last words on this too,

@Tiem @tasc It started many revisions ago on clover and you can patch it back with a bit of effort in the device properties in your clover config but it’s just not worth it. We discovered It way back when we were all on glasgoods thread. Old old news now my friends and really not worth fussing over. Just use the EFI you prefer and ENJOY :startreck:

Edited by AudioGod

Share this post


Link to post
Share on other sites

Weird... I'll try reinstalling the bios then. :/

I see you uploaded a new bios profile.
I'll try that. Thanks!

 

EDIT:
Problem persists. Has there been a new Catalina installer update in the last few weeks?

Edited by vyu01773

Share this post


Link to post
Share on other sites
31 minutes ago, vyu01773 said:

Weird... I'll try reinstalling the bios then. :/

I see you uploaded a new bios profile.
I'll try that. Thanks!

 

EDIT:
Problem persists. Has there been a new Catalina installer update in the last few weeks?

 

Have you got a GPU installed in the system alongside the igpu?

if you do could you try removing it and try again without it in there?

If you do have a GPU is it a Nvidia one?

Share this post


Link to post
Share on other sites

There is no dGPU installed. I have a fenvi wifi card tho. I already unplugged the USB part and tried w/o case USB.

Share this post


Link to post
Share on other sites
12 minutes ago, vyu01773 said:

There is no dGPU installed. I have a fenvi wifi card tho. I already unplugged the USB part and tried w/o case USB.

 

what CPU are you using again?

Share this post


Link to post
Share on other sites
4 hours ago, Tiem said:

I'm 99.9% sure it should be there. Not-upgradable typically applies to memory that is soldered to the board (like the Air). And even then it should list it no?

 

In any case, the iMac19,1 has 4 slots and despite being just hard to get to, is actually just regular DDR4. Crucial sells upgrades for it: https://www.crucial.com/usa/en/compatible-upgrade-for/Apple/imac-(retina-5k,-27-inch,-2019)-imac-19,1

 

There's a kext that fixes that.  I have it installed on my system.  However I'm still on Clover.

 

SystemProfilerMemoryFixup.kext

Share this post


Link to post
Share on other sites

I missed that the i9-9900k has "UHD" instead of "HD" graphics. Tho this doesn't really seam related to me ._.

Share this post


Link to post
Share on other sites
2 hours ago, hungrywallet said:

 

There's a kext that fixes that.  I have it installed on my system.  However I'm still on Clover.

 

SystemProfilerMemoryFixup.kext

There is a setting in Clover that does this. Mine is set to 0x00 and I see Memory Tabs. AudioGod's config has this set to 0x22:

212422276_ScreenShot2020-01-17at11_17_44AM.jpg.30c093750f62bcbcb77d9b727a3e4f45.jpg

 

 

——————

I updated my BIOS to F12c this morning and updated with new DSDT. Everything works great. I even tried OpenCore on a USB drive but, oof, that interface is ug-ly. Will stick with Clover until they figure that part out. But it did work. I didn’t try booting into Windows but I've been told it will work.

 

Thanks AudioGod...again!

Edited by pkdesign

Share this post


Link to post
Share on other sites
46 minutes ago, vyu01773 said:

I missed that the i9-9900k has "UHD" instead of "HD" graphics. Tho this doesn't really seam related to me ._.

 

@vyu01773 Give this EFI a try and let me know if its working for you now please buddy?

make sure your using the latest bios revision F12d

 

 

 

I'm waiting on your result cos if that doesn't work I have a different one to try so do let me know :) 

Edited by AudioGod

Share this post


Link to post
Share on other sites

@pkdesign You are a legend bro, its the auto SMBIOS generator via Clover Configurator Setting that doing that when you select a SMBIOS and generate a serial number, :thumbsup_anim:

 

me, larabee and glassgood were totally convinced it was a bug in clover itself. (how wrong was I?)

 :poster_oops:

 You Live and learn all the time, that's what this thread is here for :)   

Edited by AudioGod

Share this post


Link to post
Share on other sites
1 hour ago, pkdesign said:

There is a setting in Clover that does this. Mine is set to 0x00 and I see Memory Tabs. AudioGod's config has this set to 0x22:

 

 

Thanks @pkdesign, setting Platform Feature to 0x00 fixed it.

Share this post


Link to post
Share on other sites
2 hours ago, pkdesign said:

There is a setting in Clover that does this. Mine is set to 0x00 and I see Memory Tabs. AudioGod's config has this set to 0x22:

 

 

Thanks, now I can get rid of the kext!

Share this post


Link to post
Share on other sites

Super quick question, how do you set up a new entry in the OC boot loader? I'm seeing my Catalina, but OC is not detecting my Windows.

Share this post


Link to post
Share on other sites
2 minutes ago, Tiem said:

Super quick question, how do you set up a new entry in the OC boot loader? I'm seeing my Catalina, but OC is not detecting my Windows.

Hi bro,

is it not listed in the bootloader as boot camp?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By fercho3138
      Hi!
      So I've successfully built my rig and installed Mac os
      Gigabyte Aorus Z390 Pro Wifi Intel Core i7 9700k Ballistix Sport 32gb Samsung evo 500gb nv Sapphire Radeon RX 580 Pulse Corsair h60 The thing is that I got it running perfectly, even performed some heavy video renderings with no problem but sometimes it just restarts on its own, sometimes when I'm using Chrome, sometimes when I'm editing or whatever other task. Last time it happened I got the forbidden sign on the screen so I tried to boot up again using the -v flag and I got the "Couldn't allocate runtime area" message, which is very strange because I had no problems in booting up the system after I made my configurations in the config.plist

      Please someone give me some help with this problem, I'm completly stucked!!
      config.plist
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11c, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9600K, 9700K, 9900K, 9900KS
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Nitro+ RX 5700 XT ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      CLOVER EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11c to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f11c.zip - Aorus Z390 Master Bios F11c 
       
      Use this folder with fully patched DSDT
      Current EFI 
      Updated 04/02/2020
      EFI Update - 04/02/2020 - Use with Bios revision F11c Only or Replace with the older F10 DSDT if you don't want to update the bios
      AG Clover Z390 Master Navi Vega EFI.zip - Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI
      AG Clover Z390 Master Polaris EFI.zip - RX5XX Polaris DSDT EFI
       
       
      CFG Unlock (MSR) F11c BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      ADDITIONAL DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - OpenCore No DSDT and Done the way OpenCore intended it (04/02/2020)
       

      Alternative EFI 2 - N-D-K Fork of OpenCore (04/02/2020)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11C)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

    • By ricardos7
      Boa tarde a todos, estou fazendo um hack em um notebook Dell 5557, as configurações estão abaixo.
      Preciso de ajuda para terminar alguns detalhes que nÃo consegui, alguém poderia ajudar?
       
      bem com a minha pasta EFI que pode ser baixada nesse post vc poderá fazer o seu hack mais facilmente nesse modelo,
      pois quase tudo ja esta configurado e pronto pra uso.
       
      ESPECIFICAÇÕES TÉCNICAS
      Processador Intel Core i7 - 6ª Geração Intel Core i7-6500U
      Velocidade: 2.5 GHz até 3.1 GHz com Max Turbo Cache: 4Mb
      Memória RAM Quantidade: 16GB DDR3L 1600MHz (2X8).
      Armazenamento Capacidade: 240 GB SSD
      Tela Tamanho:15.6” Resolução: FULL HD 1920x1080p Touch
      Webcam integrada de alta definição (720p) com microfone digital
      Gráfico Integrado Intel HD 520
      NVIDIA® GeForce 930M com 4GB DDR3 Dedicada
      Áudio Realteck ALC255

      Dell Wireless 1707 WiFi, chip ar9565
      1x  HDMI 1.4ª
      2x USB 3.0
      1x USB 2.0
      1x Ethernet 10/100 RJ-45
      1x Entrada de Cartão 5 em 1 (SD, SD 3.0, SDHC, MS e MS PRO)
      Leitor de Cartão
      Tipo: SD, SDHC, SD3.0, MS, MS Pro
      Alimentação Bivolt 3 células 43Wh
       
       
      O QUE NÃO FUNCIONA?
      BRILHO DA TELA
      BLUETOOTH
      SONO (Hibernação)
      HDMI (audio) video funciona mais a tela do note fica preta ao conectar o cabo HDMI
      GRAFICOS DEDICADOS NVIDEA 930M (DESATIVADO)
       
      O QUE FUNCIONA?
       
      GRAFICOS INTEL
      WI-FI - a intel original foi substituída pela DELL dw1707 ar9565
      AUDIO
      TECLADO
      TRACKPAD (com gestos)
      TOUCHSCREEN (com alguns gestos)
      TECLAS  DE ATALHO
      PLACA DE REDE RJ45
      GERENCIAMENTO DE ENERGIA
       
      OBS. PARA DESATIVAR OS GRÁFICOS FOI USANDO UMA SSDT EM CONJUNTO COM A DSDT-5 E 7, DEPOIS DE APLICADO ALGUNS PACHES.
       
      A DSDT E AS SSDT
      PACHS BASICOS APLICADOS.
      Aparentemente o gerenciamento de energia está funcionando bem, pelo menos o processador parece esta bem estável.
       

       
      PASTA OTHER CLOVER (DEPOIS DESSA IMAGEM FOI ADICIONADO MAIS DUAS KEXT QUE NAO ESTAO PRESENTES NA IMAGEM, PARA FUNCIONAR
      O TOUCH E PARA O WIFI CONSEGUIR ENCONTRAR AS REDES.
       

       
      EFI 
       

       
       
       
       
      ESTAREI DEIXANDO UM LINK PARA DOWNLOAD DA MINHA PASTA EFI, CASO ALGUEM ESTEJA FAZENDO ESSE MESMO HACK ESSA PASTA PODERÁ AJUDAR.
       
      ATENÇÃO
       
      LEMBRANDO QUE OS ARQUIVOS DSDT E SSDT, SSDT DE 5 A 8 SÃO DO MEU NOTEBOOK, QUEM FOR USAR DEVER EXTRAIR E CONSTRUIR SEUS PRÓPRIOS DSDT E SSDT.
      O SSDT-EC E O SSDT-PNLF PODEM SER USADOS POIS SÃO GENERICOS.
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F PARA COLOCAR NO PENDRIVER DE INSTALAÇÃO.
      https://drive.google.com/open?id=1nPM2CNgpr7cwOkjwj7UReziqrh9xjtf1
      SE NAO SUBIR COM A Config.plist INICIAL SELECIONE A Config2.plist
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F (EM USO) 14/02/2020
      https://drive.google.com/open?id=1US7j-YlufrFTasLihmUZwElyV4jBfHDg
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F (ANTIGA)
      https://drive.google.com/open?id=1Q2tnoqQZ9K44Bv6k2k1yauaHCAop_ZyW
       
      QUEM PUDER AJUDAR A CORRIGIR OS PROBLEMAS RESTANTE EU AGRADEÇO, OBRIGADO.
       
       

    • By Krani93
      Hi guys,
       
      I'm trying to install Catalina on a Lenovo m720q (i5-8600T with B360).
      After some other issues I'm know stuck at attached screen.
      Im using latest opencore version and have my EFI folder attached.
       
      Can someone help me I've got no clue what to try next :/ 
       
       
      Cheers!

      EFI.7z
×