Jump to content
AudioGod

AudioGod's Aorus Z390 Pro Patched DSDT Mini Guide and Discussion

519 posts in this topic

Recommended Posts

Advertisement
Posted (edited)
16 minutes ago, ilcondannato said:

i5 9600k confirmed working with @AudioGod efi and DSDT for 580 here. :thumbsup_anim:

Thanks for letting me know.

Il add it to the list. :)

Edited by AudioGod

Share this post


Link to post
Share on other sites
11 minutes ago, AudioGod said:

Thanks for letting me know.

Il add it to the list. :)

 

 

So...download efi folder...delete DSDT (think for Vega...) and replace with rx DSDT downloaded from ur post...all seems work perfectly... only added mob,serial,smuuid ;-)

 

Share this post


Link to post
Share on other sites
14 minutes ago, ilcondannato said:

 

 

So...download efi folder...delete DSDT (think for Vega...) and replace with rx DSDT downloaded from ur post...all seems work perfectly... only added mob,serial,smuuid ;-)

 

 

Perfect, Enjoy Buddy

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/21/2019 at 10:51 PM, tasc said:

 I've always had CSM support enabled in my bios without issue, so not sure if that has any effect on the build stability.

 

 

Me too. If CSM Support is disabled I can't get a video signal out of the RX580... and since the iGPU is disabled that means I have to reset the CMOS to get back into the bios.

 

On 8/22/2019 at 9:42 AM, MaLd0n said:

HERE

 

1- DSDT for Vega and VII

DSDT.VEGA.VII.zip

 

2- DSDT for RX Series, Nvidia and others

DSDT.RXxxx.NVIDIA.zip

 

Thank you so much for all the work you're doing!

 

On 8/22/2019 at 12:17 PM, AudioGod said:

 

Hey Buddy,

Change your DSDT over to the new one for your GPU listed in my guide :) 

 

 

Just did - the RX580 shows up in the PCI cards now. Thanks!

 

So far today - had a kernel panic while watching Plex Media Player for about 5 minutes. This is different from the white-screen freeze in that it actually rebooted the computer and presented the KP notice.

 

Since then, the hack has been rock solid - played the same Plex file for about 45 minutes and it went without a hitch. Played some YouTube in the background while working for an hour and no issues. :)

 

I forgot to mention earlier - your DSDT enabled the HDMI ports on the RX580 now. Previously I could only use the DisplayPorts. Nice!

Edited by hackinbot

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, hackinbot said:

 

Me too. If CSM Support is disabled I can't get a video signal out of the RX580... and since the iGPU is disabled that means I have to reset the CMOS to get back into the bios.

 

 

You can have CSM Enabled, It really boils down to what gpu your using.

With the my pulse vega56 if I have CSM enabled then my clover boot screen is stuck on the lowest res possible but with it Disabled I get native 4K for my monitor at the clover boot page, that’s why I have it listed as disabled for my build. I will update the the guide now to point that out. :thumbsup_anim: 

Edited by AudioGod

Share this post


Link to post
Share on other sites
10 hours ago, hackinbot said:

 

Me too. If CSM Support is disabled I can't get a video signal out of the RX580... and since the iGPU is disabled that means I have to reset the CMOS to get back into the bios.

 

 

 

 

I went ahead and disabled CSM support so my BIOS settings match the guide, everything working normally with the RX560.

Share this post


Link to post
Share on other sites
On 8/21/2019 at 10:58 PM, AudioGod said:

 BIOS  CSM Support  Disabled  (Enabled If your using a AMD RX GPU)

 

 

Not really .. depends on the card type/BIOS. I am on Sapphire RX580 pulse and have CSM disabled : Aorus Logo and Clover with 4K resolution.

 

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/21/2019 at 10:58 PM, AudioGod said:

 Power  Platform Power Management  Enabled

 

pwrmgmnt.thumb.jpg.7fb57d0f899286aca175cede8b2819b7.jpg

 

How are your ASMP settings below and .. is there any need for enabling PWR mgmnt at all  ?  IMHO it's handled by OS 

 

And one other point that possibly can be enlightened by @MaLd0n 

 

In your patched DSDT there is a different definition for GNVS ( thats for native NVRAM) 

 

OperationRegion (GNVS, SystemMemory, 0x3E4BE000, 0x0866)
 

origin DSDT:

 

OperationRegion (GNVS, SystemMemory, 0x3E4C1000, 0x0866)
 

The address changes if you have other settings in BIOS and/or other hardware setup. Now, is this handled by Clover "Regions" patch or should we pay attention to this ?

 

 

 

 

Edited by texem

Share this post


Link to post
Share on other sites
Posted (edited)
55 minutes ago, texem said:

 

Not really .. depends on the card type/BIOS. I am on Sapphire RX580 pulse and have CSM disabled : Aorus Logo and Clover with 4K resolution.

 

 

Fair point. Ok il change that now....lol

 

If you check a few posts up I basically say the same thing too, then I changed my guide to say enable for RX after talking to one of the gurus on here :)

Edited by AudioGod

Share this post


Link to post
Share on other sites
39 minutes ago, texem said:

 

pwrmgmnt.thumb.jpg.7fb57d0f899286aca175cede8b2819b7.jpg

 

How are your ASMP settings below and .. is there any need for enabling PWR mgmnt at all  ?

IMHO it's handled by OS 

 

I have DMI ASPM set to disabled.

Also you should disable RC6 too.

Share this post


Link to post
Share on other sites
Posted (edited)
26 minutes ago, AudioGod said:

I have DMI ASPM set to disabled.

Also you should disable RC6 too.

 

Ah .. thanks. In this case just disable the Powermanagement because all 3 options are disabled .. :)

 

btw: just updated above with Q regarding "OperationRegions" .

Wondering if @MaLd0n can help 

 

Edited by texem

Share this post


Link to post
Share on other sites
On 8/22/2019 at 3:16 PM, panosru said:

1. If you have TP-Link Archer T6E PCI-E WiFi card and your system does not recognise your WiFi card with this EFI, then download and add to your kexts AirportBrcmFixup, that will make your WiFi work again.

 

I have no problem with WIFI, BUT the bluetooth is working 50% of time, I mean now for example is NOT working anymore,

pci card is in pci slot 4, with bluetooth cable connected to usb2

 

I just added Vega powertable and now is not working anymore, i got this

WHY?!? (on windows is working correctly)

 

1620175388_Screenshot2019-08-25at11_46_34.png.7e5250c80b472c3879cf89b6fdc64f36.png

 

 

 

On 8/22/2019 at 3:16 PM, panosru said:

4. (EXPERIMENTAL) If you have iStat Menus and you want to have your GPU temperature on your menu bar, VirtualSMC does not support it yet; thus you have to remove VirtualSMC and add FakeSMC. The reason I say it is experimental is because it is reported that FakeSMC is not as stable as VirtualSMC is, in case you face any crashes or kernel panics, then just revert back to VirtualSMC.

 

Tried removing VIrtualSMC e putting all the FakeSmc kext,

I don't see any GPU temps, GPU die is not even anymore present in iStats menu 

Share this post


Link to post
Share on other sites
Posted (edited)
11 minutes ago, gino8080 said:

 

I have no problem with WIFI, BUT the bluetooth is working 50% of time, I mean now for example is NOT working anymore,

pci card is in pci slot 4, with bluetooth cable connected to usb2

 

I just added Vega powertable and now is not working anymore, i got this

WHY?!? (on windows is working correctly)

 

1620175388_Screenshot2019-08-25at11_46_34.png.7e5250c80b472c3879cf89b6fdc64f36.png

 

Check the Bluetooth Internal USB cable where it connects to the motherboard and make sure all the tiny cables going into the plug are ok. It’s super easy to break one off when you remove the plug from the board so lightly wiggle them and make sure they are all connected properly.

 

also if you want to use fakesmc and all its sensors then you need to put all of the fake fakesmc kexts inc the sensor kexts into your clover kext folder and then reboot and then check your i stats again.

Edited by AudioGod

Share this post


Link to post
Share on other sites
30 minutes ago, AudioGod said:

 

Check the Bluetooth Internal USB cable where it connects to the motherboard and make sure all the tiny cables going into the plug are ok. It’s super easy to break one off when you remove the plug from the board so lightly wiggle them and make sure they are all connected properly.

 

I just unplug/plug the microsd to usb from motherboard, and now i'ts working both in windows and Mac

I suppose the cable or the usb mobo port is not working good :wacko: ?

 

32 minutes ago, AudioGod said:

also if you want to use fakesmc and all its sensors then you need to put all of the fake fakesmc kexts inc the sensor kexts into your clover kext folder and then reboot and then check your i stats again.

 

I already putted ALL the fakesmc kexts

1064868688_Screenshot2019-08-25at12_32_07.png.8f315d69452fbf3ca42cad5566bd5dc5.png

I'll do another try and let you know

 

thx

 

Share this post


Link to post
Share on other sites
6 minutes ago, gino8080 said:

 

I just unplug/plug the microsd to usb from motherboard, and now i'ts working both in windows and Mac

I suppose the cable or the usb mobo port is not working good :wacko: ?

 

The usb cable that comes with those WiFi Bluetooth combo cards tends to be cheap and nasty and easy to break. I’ve seen it happen many times but luckily you can buy a replacement from eBay cheap or if you have a usb cable spare from a Corsair liquid cooler then use that instead.

 

https://rover.ebay.com/rover/0/0/0?mpre=https%3A%2F%2Fwww.ebay.co.uk%2Fulk%2Fitm%2F401790050830

 

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, gino8080 said:

 

I just unplug/plug the microsd to usb from motherboard, and now i'ts working both in windows and Mac

I suppose the cable or the usb mobo port is not working good :wacko: ?

 

 

I already putted ALL the fakesmc kexts

1064868688_Screenshot2019-08-25at12_32_07.png.8f315d69452fbf3ca42cad5566bd5dc5.png

I'll do another try and let you know

 

thx

 

 

 

Uhm...but...you've selected the sensor in stat menu's?

...cioè...gli hai detto che vuoi vedere la temperatura del die?!

 

1683396991_Schermata2019-08-25alle16_54_33.png.9c837d88cc06a6d53dee6b1d8a83927e.png

 

 

after put "GPU Die" I see...

 

1477356452_Schermata2019-08-25alle16_57_18.png.69420fab7173720ffc9931bf6478548c.png

 

 

BTW........

 

 

Just update to Catalina B6 10.15 release 19A536g

 

Confirmed all working with @AudioGod EFI and DSDT (RX series)

 

Cheers!

 

:thumbsup_anim: :dev:

 

850376836_Schermata2019-08-25alle16_59_57.png.c825ead3d47681c4f343cb67ffad89db.png

Edited by ilcondannato

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, AudioGod said:

 

The usb cable that comes with those WiFi Bluetooth combo cards tends to be cheap and nasty and easy to break. I’ve seen it happen many times but luckily you can buy a replacement from eBay cheap or if you have a usb cable spare from a Corsair liquid cooler then use that instead.

 

https://rover.ebay.com/rover/0/0/0?mpre=https%3A%2F%2Fwww.ebay.co.uk%2Fulk%2Fitm%2F401790050830

 

If I HOT unplug and replug the microusb connector from the pci (when mac or windows is running)

 

I got bluetooth working

 

then after 3/4 reboot or myabe after a sleep / awake it does NOT work anymore

I have to unplug / replug

 

why? maybe something related to power / UPS ?

 

 

53 minutes ago, ilcondannato said:

 

 

Uhm...but...you've selected the sensor in stat menu's?

...cioè...gli hai detto che vuoi vedere la temperatura del die?!

 

1683396991_Schermata2019-08-25alle16_54_33.png.9c837d88cc06a6d53dee6b1d8a83927e.png

 

 

after put "GPU Die" I see...

 

1477356452_Schermata2019-08-25alle16_57_18.png.69420fab7173720ffc9931bf6478548c.png

 

 

 

Sure This is my EFI atm:

1484342033_Screenshot2019-08-25at17_42_26.png.d41d8bcbeddb2bf3c5145c0f8d6e20d8.png

 

1794611006_Screenshot2019-08-25at17_51_08.png.c0a8988d77f3749e31ca533b503e3b82.png

1272920563_Screenshot2019-08-25at17_46_41.png.c2b1fe01d38221b6e48f7c63134696e9.png

and I don't have anymore the GPU DIE sensor to drag (i had when using VirtualSMC but it was always without values)

ITALIAN: "Certo ma no mi appare proprio il cazzillo da draggare, prima usando VirtualSmc mi appariva ma era sempre senza valore)

 

Edited by gino8080
added screenshot

Share this post


Link to post
Share on other sites
1 hour ago, ilcondannato said:

Just update to Catalina B6 10.15 release 19A536g

 

Confirmed all working with @AudioGod EFI and DSDT (RX series)

 

Cheers!

 

:thumbsup_anim: :dev:

 

850376836_Schermata2019-08-25alle16_59_57.png.c825ead3d47681c4f343cb67ffad89db.png

 

My EFI is indeed Catalina ready, Im glad it worked for you. :) 

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, gino8080 said:

 

and I don't have anymore the GPU DIE sensor to drag (i had when using VirtualSMC but it was always without values)

ITALIAN: "Certo ma no mi appare proprio il cazzillo da draggare, prima usando VirtualSmc mi appariva ma era sempre senza valore)

 

 

 

Think only way's is uninstall and then reboot/reinstall istat... (I've 6.31 and it work well...)

 

...maybe iStat hate ur Vega LoL ...or it only work with downtown hackintosh for "no money people with RX" ahahahahahah xD

 

btw...I don't use FileVault...and I don't use script in the guide...but all works well and great...

ps on catalina, wake are "one key" start...no double (one for wake one for enter) like Mojave...and...no more {censored} message "usb not eject properly" after wake!!!! (for me patch in Glasgod guide don't work in Mojave)

so...

at this point...definitely my first work goes on this build.

Ps Pr AE and Capture 1 definitely goes on here!

Start producing lol

:thumbsup_anim:

 

Edited by ilcondannato

Share this post


Link to post
Share on other sites

I'm having daily kernel panics, based on the panic log I guess it has to do with hands off app I am using... anyone else experience same issues with this app?

 

I like this app, I'm using it because I want to have a control for incoming and outgoing connections of my system 

 

attached latest kernel panic log

 

Thanks!

Kernel_2019-08-25-194043_Panagiotis-Hackintosh.panic

Share this post


Link to post
Share on other sites
I'm having daily kernel panics, based on the panic log I guess it has to do with hands off app I am using... anyone else experience same issues with this app?
 
I like this app, I'm using it because I want to have a control for incoming and outgoing connections of my system 
 
attached latest kernel panic log
 
Thanks!
Kernel_2019-08-25-194043_Panagiotis-Hackintosh.panic


I’ve used Little Snitch since years and never got a problem


Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

I used to use Little Snitch, I will give it a try and see if it will solve the issue. 

 

Mostly I care to know based on the log if indeed hands off causing the kernel panic. I couldn't find anything else to blame, at first I though that FakeSMC might cause the issue but noting in the logs indicated FakeSMC, and I used FakeSMC before and it worked fine...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By BuXb
      SleepOnLowBattery (“SOLB”)
      by BugsB, based on a script by Toggi3 * + more code snippets from the www
       
      For those of us whose HackBook (or even real MacBook) doesn't automatically and properly go into power saving mode on very low battery but just powers down coldly, crashing macOS: “SOLB”, a small and RAM/ CPU wise very low footprint AppleScript based utility that checks the battery level every 2 minutes, running via daemon in the background.
       
      You can choose between two versions, either with or without sound. Both display a notification in the top right of your screen.
       
      Between ≤10 and >8% battery charge:

       
      Between ≤8 and >5% battery charge:

       
      On ≤ 5% battery charge you will see a 10 seconds countdown dialog box in 1 second intervals:

       

       
      which you can cancel, or have your your *ac*Book be sent to sleep when down to 0.
       
      The version with sound uses the pleasant macOS US female voice Allison. If the lady is not installed, you can download "her" via System Preferences, Accessibility, Speech (pane tab should get opened by the install script), click onto the two arrows to the right of System Voice, Customize, English (Unites States) -- Female, activate Allison, OK (macOS downloads voices to /System/Library/Speech/Voices - Allison consumes 120 MB).
       
      If you want to see/ see and listen first, disconnect your Mac from its power supply and double click the “run Demo” file in either folder, with or without sound.
       
      The launcher is installed per user, so one user can use the script with and another user the script without sound.
       
      Run your desired install.command, with or without sound. The script should be active right away without restart.
       
      Regarding the sound version, you can also:
      - download any other English voice of your liking and edit the name inside the script at the very top
      - download any language voice and translate the text inside the script
      Edit with Apple Script Editor, save, install, reboot.
       
      Tested working in macOS High Sierra 10.13.6, Mojave 10.14.6 and Catalina 10.15.1.
      Please feedback if this utility also works for you.
       
      If you have ideas, experience bugs, etc., please contribute as precise, succinct, productive and friendly as possible. In case of a bug, always include your version of macOS for me or others to try and help. Thank you.
       
      ENJOY
       
      VERSION HISTORY:
      2019-11-15 v. 1.1
          •    BUG FIX: changed all occurrences of ExternalChargeCapable to ExternalConnected in all Apple Script .scpt files (SleepOnLowBattery.scpt, SleepOnLowBatterySound.scpt, demo.scpt) to restore functionality
          •    IMPROVEMENT: made queries of MaxCapacity and CurrentCapacity more compatible to work with hopefully any system
          •    NEW: added Catalina compatibility to install scripts; verified Mojave compatibility
          •    NEW: Sound script uses voice Allison if installed, otherwise automatically defaults back to another English standard voice (Daniel, Alex or Fred)
       
      2018-11-10 v.1.0
          •    initial version
       
      IDEAS TO IMPLEMENT IN FUTURE RELEASES:
      Have the sound version install script check if Allison is installed, and if not, offer to download and install it. Purely cosmetic: find a way to have the display notification in the top right of the screen not display the Script Editor icon but the one of the utility without turning the utility into an app but by maintaining a script to keep the load footprint low. This is currently neither possible with an Apple Script nor with an Apple Script Bundle file, only with the script compiled into an app. One possibility might be a Perl approach, if someone volunteers. ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      * Thanks to Toggi3 for the base script:
      https://hints.macworld.com/article.php?story=20110219013713667
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      THE CODE (of the version with sound):
      install.command:
       
      LaunchAgent SleepOnLowBatterySound.plist:
       
      Script SleepOnLowBatterySound.scpt:
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
       
      SleepOnLowBattery (SOLB) by BugsB v.1.1 (2019-11-15).zip
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/viewtopic.php?f=28&t=10578
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By kelvin henrique
      Faz pouco menos de uma semana que estou tentando dar boot usando um pendrive no lenovo g40-80, mas todas as vezes que tento algum kernel panic diferente acontece, não entendo tanto de hackintosh mas pelo que li tanto aqui no forum quanto em outros sites me fizeram constatar que talvez o erro seja falta de kexts, alguem possui os kexts para esse notebook ??
       
      primeiro erro que tive era porque estava usando um pendrive de 8gb, o recomendado é 16 no minimo pelo oque vi, fui la, comprei um de 32, mudou o kernel panic mas era só um dos erros resolvidos.
       
      especificações dele:
      Processador: Intel Core i3-5005U
      Grafico: Intel HD Graphics 5500
      originalmente ele vinha com um hd de 500gb e 4gb de ram, mudei pra um ssd de 128gb e 8 gb de ram
       
      ja percebi que unico problema desse notebook é que a placa de wifi não vai funcionar, mas quanto a isso não tem problema pois se conseguir mesmo instalar o mac eu comprou outra
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F10, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.1Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Nitro+ SE Vega56 ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Mojave
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      CLOVER EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F10 to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f10.zip - Z390 MASTER Bios Revision F10
       
      Use this folder with igpu Enabled in bios for working Sidecar (Updated 1st Nov)
      AudioGods Z390 Master Vega Navi EFI.zip - Vega 56/64 Navi & Radeon VII DSDT
      AudioGods Z390 Master RX EFI.zip - RX Series DSDT
       
       
      ADDITIONAL DSDT's  (A big thanks to @MaLd0n for compiling these DSDT's)

       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://olarila.com/forum/viewtopic.php?f=19&t=1131 
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F10)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Other OS
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 512MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Disabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS
       

       

       

       

       

       

       

       

       

       

       
       
×