Jump to content
AudioGod

AudioGod's Aorus Z390 Pro Patched DSDT Mini Guide and Discussion

519 posts in this topic

Recommended Posts

24 minutes ago, AudioGod said:

@glasgood I hope your good buddy, Could you do me a favour and expand your guide say its for the z390 pro and also the z390 master please? 

Everything is exactly the same with this board and your guide its just a different efi and dsdt so I made a new mini guide for it. :)

 

Done :thumbsup_anim:

Share this post


Link to post
Share on other sites
Advertisement
5 hours ago, AudioGod said:


VirtualSMC.EFI is not needed as it makes no difference if you use it or not  with my EFI so why have the extra UEFI file if you don’t need it?

one of the goals for when I put this EFI together was to keep the EFI as minimal as possible when it comes to drivers and kexts. The DSDT and SSDT do most of the work so my advise is to try my EFI as is instead of bloating with stuff that’s not needed but saying that if you like VirtualSMC.EFI in there then add away my friend  :) 

 

Update - A fresh boot of Catalina doesn’t need shikgvga=1 to get DRM+ to work on my system. I’m doing a fresh instal as a test and it’s perfect for me with the EFI exactly how it is with no changes needed. Have you used a different bios setup or something?

 

Thanks for clarifying.  I'm not too experienced with Hackintosh yet so I have a lot to learn.  I'll go ahead and remove the unnecessary EFI when I get home.  Thanks for all your work. 

Share this post


Link to post
Share on other sites
8 hours ago, AudioGod said:

Update - A fresh boot of Catalina doesn’t need shikgvga=1 to get DRM+ to work on my system. I’m doing a fresh instal as a test and it’s perfect for me with the EFI exactly how it is with no changes needed. Have you used a different bios setup or something?

 

 

I think the reason some of us may be requiring shikigva=1 for DRM+ may be because of differences in video cards and we would be running the SSDT for RX series. @hungrywallet I'm curious what video card you are running and if you are using the Vega/Navi SSDT versus the RX SSDT. That's the only difference I can see causing this...

Share this post


Link to post
Share on other sites
9 minutes ago, tasc said:

 

I think the reason some of us may be requiring shikigva=1 for DRM+ may be because of differences in video cards and we would be running the SSDT for RX series. @hungrywallet I'm curious what video card you are running and if you are using the Vega/Navi SSDT versus the RX SSDT. That's the only difference I can see causing this...

 

Good hypothesis. Here are one data point: Radeon VII and Vega56 works perfectly fine. I plugged in my RX 570 and it works too. 

Share this post


Link to post
Share on other sites
9 minutes ago, larabee said:

 

Good hypothesis. Here are one data point: Radeon VII and Vega56 works perfectly fine. I plugged in my RX 570 and it works too. 

 

Interesting, thanks for checking that @larabee. When you plugged in your RX570, did you also switch your SSDT to the RX version? Also, are you running 19,1 SMBIOS with enabled iGPU?

 

Share this post


Link to post
Share on other sites
26 minutes ago, tasc said:

 

I think the reason some of us may be requiring shikigva=1 for DRM+ may be because of differences in video cards and we would be running the SSDT for RX series. @hungrywallet I'm curious what video card you are running and if you are using the Vega/Navi SSDT versus the RX SSDT. That's the only difference I can see causing this...

 

I'm using a Sapphire RX580 8GB Nitro with the new 19,1 EFI for RX series.  It's paired with a 9900K, 64GB DDR4 and our board.

Share this post


Link to post
Share on other sites
46 minutes ago, AudioGod said:

@hungrywallet @tasc have both of you got Above 4G Decoding Enabled in the bios?

disable it if you do and try again without shikivga=1

I believe I have it disabled but I will confirm and share my bios settings with you guys when I get home.

 

edit: {censored}, just seen that I can get the Wifi edition of this motherboard with integrated Intel CNVi 2x2 802.11ac wireless for cheaper than what I got my current board.  Would this guide still be valid if I decided to to exchange it for the Wifi version?

Edited by hungrywallet

Share this post


Link to post
Share on other sites
2 hours ago, AudioGod said:

@hungrywallet @tasc have both of you got Above 4G Decoding Enabled in the bios?

disable it if you do and try again without shikivga=1

 

Above 4G Decoding has always been disabled on my board.  @hungrywallet funny side note, I also had the opportunity to get the wifi board cheaper than the pro but went with the pro anyways because that's what the guide was using (and I don't need wifi).

Share this post


Link to post
Share on other sites
3 hours ago, tasc said:

 

Interesting, thanks for checking that @larabee. When you plugged in your RX570, did you also switch your SSDT to the RX version? Also, are you running 19,1 SMBIOS with enabled iGPU?

 

 

Yes I will need to switch to RX version, I have friends running RX580 and he has to do a clean installation to get the DRM to work. 

I tested it on both Pro 1,1 and the 19,1. So far, 100% of Apple paid services are working fine. 

 

@hungrywallet the layout of the PCI-E lane of the wifi version is different so it needs to get DSDT patched again. You can run the DSDT extraction and send to @AudioGod to make sure it's working well. If you want to change board, I suggest you do an upgrade to the Master. Damn fine board. 

 

 

 

Share this post


Link to post
Share on other sites
5 hours ago, larabee said:

 

Yes I will need to switch to RX version, I have friends running RX580 and he has to do a clean installation to get the DRM to work. 

I tested it on both Pro 1,1 and the 19,1. So far, 100% of Apple paid services are working fine. 

 

@hungrywallet the layout of the PCI-E lane of the wifi version is different so it needs to get DSDT patched again. You can run the DSDT extraction and send to @AudioGod to make sure it's working well. If you want to change board, I suggest you do an upgrade to the Master. Damn fine board. 

 

Does the boards WiFi work with Mac? I'm assuming it does being that it's integrated but again I could be wrong.  Either way I think I'll just stick to the Pro.

 

Share this post


Link to post
Share on other sites
4 minutes ago, hungrywallet said:

 

Does the boards WiFi work with Mac? I'm assuming it does being that it's integrated but again I could be wrong.  Either way I think I'll just stick to the Pro.

 

 

There is a tiny slot on the top of the board that you can take the wifi module out. That's where the PCI-E layout is changed. 

Share this post


Link to post
Share on other sites
28 minutes ago, hungrywallet said:

 

Does the boards WiFi work with Mac? I'm assuming it does being that it's integrated but again I could be wrong.  Either way I think I'll just stick to the Pro.

 

No I’m afraid not, you would need a dsdt with the WiFi patched out.

stick to the board you have and get a pcie WiFi/Bluetooth card that works out the box.

Edited by AudioGod

Share this post


Link to post
Share on other sites

Any reason why I can’t boot with the following,

 

Settings -> IO Ports -> DVMT Pre-Allocated -> 64M

 

I have to set it to 32M in order to not get the stop sign.

Share this post


Link to post
Share on other sites
1 hour ago, hungrywallet said:

Any reason why I can’t boot with the following,

 

Settings -> IO Ports -> DVMT Pre-Allocated -> 64M

 

I have to set it to 32M in order to not get the stop sign.

Interesting, if you reset the board and then load back in your settings with it set too 64mb it should work.

its a nvram conflict that’s happening to you (failure to allocate memory kp)

 

@hungrywallet change DVMT Pre-Allocated -> 64M and DVMT TotalGFX0-Allocated -> Max plus Aperture Size -> 512MB and tell me if that’s better for you please bud?

 

Edited by AudioGod

Share this post


Link to post
Share on other sites
1 hour ago, AudioGod said:

Interesting, if you reset the board and then load back in your settings with it set too 64mb it should work.

its a nvram conflict that’s happening to you (failure to allocate memory kp)

 

@hungrywallet change DVMT Pre-Allocated -> 64M and DVMT TotalGFX0-Allocated -> Max plus Aperture Size -> 512MB and tell me if that’s better for you please bud?

 

 

Reseting the bios worked.  I loaded the CFG unlock profile in your original post, changed a few bios settings and set it to 64M, Max, 512MB and it booted up.

Share this post


Link to post
Share on other sites
On 11/7/2019 at 5:43 PM, texem said:

Thank you for this!!! I was able to boot, after adding agdpmod=pikera to the config.plist for my Vega 64 to work. Maybe OpenCore will help with my sleep issues. I am also thinking about going to the F11 UEFI BIOS next and will be using your files for that as well!

 

Edit: Additionally I would love to find out how to have OpenCore auto boot to my Mac SSD Nevermind I figured that out (set it in system preferences)

Edited by laxattack

Share this post


Link to post
Share on other sites
3 hours ago, laxattack said:

Thank you for this!!! I was able to boot, after adding agdpmod=pikera to the config.plist for my Vega 64 to work. Maybe OpenCore will help with my sleep issues. I am also thinking about going to the F11 UEFI BIOS next and will be using your files for that as well!

 

Edit: Additionally I would love to find out how to have OpenCore auto boot to my Mac SSD Nevermind I figured that out (set it in system preferences)

 

nice to hear it works somewhere else ;-) Well take it as an experimental release, f.i. you may not be able to boot Windows from OC because the modified DSDT is not compatible to Win but loaded all the time and therefore you should boot Win via UEFI directly.

And my rig sometimes suffers from Bluetooth lagging or unresponsive after wake from sleep despite of my PCIe BCM card.

 

  

Share this post


Link to post
Share on other sites
44 minutes ago, texem said:

 

nice to hear it works somewhere else ;-) Well take it as an experimental release, f.i. you may not be able to boot Windows from OC because the modified DSDT is not compatible to Win but loaded all the time and therefore you should boot Win via UEFI directly.

And my rig sometimes suffers from Bluetooth lagging or unresponsive after wake from sleep despite of my PCIe BCM card.

 

  

I actually just upgraded to F11 and OpenCore 0.5.3, and I had to make sure my iGPU was disabled, but it also works so far, I have to test to see if I can boot windows now ;-) thanks again!

Share this post


Link to post
Share on other sites

Is anyone able to say how they managed to get Netflix on Safari (DRM) working on the iMac 19,1 SMBios with iGPU enabled?

I can only get DRM (Netflix on safari) working using iMacPro1,1 with iGPU disabled but then I can't use Intel Quicksync.

 

I have tried with various ig-platform-ids, 3E980003 with 19,1 definition, then also 3E910003, 3E920003 and then also letting Whatevergreen decide automatically which defaults to 3E910003. I also tried shikgvga=1 and slide=0 with no luck.

 

I also tried various bios options. Enabling / disabling 'Above 4G decoding', setting iGPU DVMT Preallocated to 64MB, 128MB, 192MB then RC6 (render standby) enabled / disabled, then also various power management settings, Native ASPM enabled / disabled, ASPM, PCIE Native Power Management etc all with no luck.

 

I am aware this guide uses a patched DSDT, what patches do you use specifically for the iGPU and the Navi 5700XT?

 

Many thanks in advance :D

Share this post


Link to post
Share on other sites
54 minutes ago, unknown1221 said:

 

I am aware this guide uses a patched DSDT, what patches do you use specifically for the iGPU and the Navi 5700XT?

 

Many thanks in advance :D

 

I think there appears to be a small error in the DSDT. You can use hackintool to manually patch your iGPU to match device ID. We appear to have 3 most common iGPU from Core i3 8xxx, Core i7 8700K, and the i9 9900K. Those 3 have different device id for iGPU, and therefore DSDT must be made for those 3 too. @AudioGod and @MaLd0n is currently looking at this. 

In the meantime, you can use Hackintool to patch your device. Link to the tutorial is as followings: 

https://olarila.com/forum/viewtopic.php?t=9275

Share this post


Link to post
Share on other sites
5 hours ago, larabee said:

 

I think there appears to be a small error in the DSDT. You can use hackintool to manually patch your iGPU to match device ID. We appear to have 3 most common iGPU from Core i3 8xxx, Core i7 8700K, and the i9 9900K. Those 3 have different device id for iGPU, and therefore DSDT must be made for those 3 too. @AudioGod and @MaLd0n is currently looking at this. 

In the meantime, you can use Hackintool to patch your device. Link to the tutorial is as followings: 

https://olarila.com/forum/viewtopic.php?t=9275

I didn't know about that but will try that now. So which Platform ID should I use then from Hackintool for my 8700k?

3E980003, 3E910003 or 3E920003?

 

Many thanks for the tip, I appreciate it :)

Share this post


Link to post
Share on other sites

uhm uhm uhm @AudioGod remember my problem with Netflix+Safari? ...uhm switch from 1.1 to 19.1 and Netflix work great on Safari...but...only for preview...when i switch play, got error (but is for DRM ...this time no freeze at all!) ... lol i watch it in fhd on Chrome + 1080patch LooooL btw it's too strange... maybe i will try with clean install but i think it not resolve this issue... :\ investigate mode turn another time on ON! LoL

Share this post


Link to post
Share on other sites
15 minutes ago, ilcondannato said:

uhm uhm uhm @AudioGod remember my problem with Netflix+Safari? ...uhm switch from 1.1 to 19.1 and Netflix work great on Safari...but...only for preview...when i switch play, got error (but is for DRM ...this time no freeze at all!) ... lol i watch it in fhd on Chrome + 1080patch LooooL btw it's too strange... maybe i will try with clean install but i think it not resolve this issue... :\ investigate mode turn another time on ON! LoL


LoL hey buddy :hysterical:

Yes I found what the problem is last night and will correct it ASAP (it’s a tiny error within the dsdt) 

if you want a short term fix then do what @larabee suggested a couple of posts back but as soon as I can get hold of @MaLd0n  we will resolve it and repair the dsdt. 
Hold Tight mr :thumbsup_anim:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By BuXb
      SleepOnLowBattery (“SOLB”)
      by BugsB, based on a script by Toggi3 * + more code snippets from the www
       
      For those of us whose HackBook (or even real MacBook) doesn't automatically and properly go into power saving mode on very low battery but just powers down coldly, crashing macOS: “SOLB”, a small and RAM/ CPU wise very low footprint AppleScript based utility that checks the battery level every 2 minutes, running via daemon in the background.
       
      You can choose between two versions, either with or without sound. Both display a notification in the top right of your screen.
       
      Between ≤10 and >8% battery charge:

       
      Between ≤8 and >5% battery charge:

       
      On ≤ 5% battery charge you will see a 10 seconds countdown dialog box in 1 second intervals:

       

       
      which you can cancel, or have your your *ac*Book be sent to sleep when down to 0.
       
      The version with sound uses the pleasant macOS US female voice Allison. If the lady is not installed, you can download "her" via System Preferences, Accessibility, Speech (pane tab should get opened by the install script), click onto the two arrows to the right of System Voice, Customize, English (Unites States) -- Female, activate Allison, OK (macOS downloads voices to /System/Library/Speech/Voices - Allison consumes 120 MB).
       
      If you want to see/ see and listen first, disconnect your Mac from its power supply and double click the “run Demo” file in either folder, with or without sound.
       
      The launcher is installed per user, so one user can use the script with and another user the script without sound.
       
      Run your desired install.command, with or without sound. The script should be active right away without restart.
       
      Regarding the sound version, you can also:
      - download any other English voice of your liking and edit the name inside the script at the very top
      - download any language voice and translate the text inside the script
      Edit with Apple Script Editor, save, install, reboot.
       
      Tested working in macOS High Sierra 10.13.6, Mojave 10.14.6 and Catalina 10.15.1.
      Please feedback if this utility also works for you.
       
      If you have ideas, experience bugs, etc., please contribute as precise, succinct, productive and friendly as possible. In case of a bug, always include your version of macOS for me or others to try and help. Thank you.
       
      ENJOY
       
      VERSION HISTORY:
      2019-11-15 v. 1.1
          •    BUG FIX: changed all occurrences of ExternalChargeCapable to ExternalConnected in all Apple Script .scpt files (SleepOnLowBattery.scpt, SleepOnLowBatterySound.scpt, demo.scpt) to restore functionality
          •    IMPROVEMENT: made queries of MaxCapacity and CurrentCapacity more compatible to work with hopefully any system
          •    NEW: added Catalina compatibility to install scripts; verified Mojave compatibility
          •    NEW: Sound script uses voice Allison if installed, otherwise automatically defaults back to another English standard voice (Daniel, Alex or Fred)
       
      2018-11-10 v.1.0
          •    initial version
       
      IDEAS TO IMPLEMENT IN FUTURE RELEASES:
      Have the sound version install script check if Allison is installed, and if not, offer to download and install it. Purely cosmetic: find a way to have the display notification in the top right of the screen not display the Script Editor icon but the one of the utility without turning the utility into an app but by maintaining a script to keep the load footprint low. This is currently neither possible with an Apple Script nor with an Apple Script Bundle file, only with the script compiled into an app. One possibility might be a Perl approach, if someone volunteers. ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      * Thanks to Toggi3 for the base script:
      https://hints.macworld.com/article.php?story=20110219013713667
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      THE CODE (of the version with sound):
      install.command:
       
      LaunchAgent SleepOnLowBatterySound.plist:
       
      Script SleepOnLowBatterySound.scpt:
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
       
      SleepOnLowBattery (SOLB) by BugsB v.1.1 (2019-11-15).zip
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/viewtopic.php?f=28&t=10578
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By kelvin henrique
      Faz pouco menos de uma semana que estou tentando dar boot usando um pendrive no lenovo g40-80, mas todas as vezes que tento algum kernel panic diferente acontece, não entendo tanto de hackintosh mas pelo que li tanto aqui no forum quanto em outros sites me fizeram constatar que talvez o erro seja falta de kexts, alguem possui os kexts para esse notebook ??
       
      primeiro erro que tive era porque estava usando um pendrive de 8gb, o recomendado é 16 no minimo pelo oque vi, fui la, comprei um de 32, mudou o kernel panic mas era só um dos erros resolvidos.
       
      especificações dele:
      Processador: Intel Core i3-5005U
      Grafico: Intel HD Graphics 5500
      originalmente ele vinha com um hd de 500gb e 4gb de ram, mudei pra um ssd de 128gb e 8 gb de ram
       
      ja percebi que unico problema desse notebook é que a placa de wifi não vai funcionar, mas quanto a isso não tem problema pois se conseguir mesmo instalar o mac eu comprou outra
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F10, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.1Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Nitro+ SE Vega56 ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Mojave
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      CLOVER EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F10 to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f10.zip - Z390 MASTER Bios Revision F10
       
      Use this folder with igpu Enabled in bios for working Sidecar (Updated 1st Nov)
      AudioGods Z390 Master Vega Navi EFI.zip - Vega 56/64 Navi & Radeon VII DSDT
      AudioGods Z390 Master RX EFI.zip - RX Series DSDT
       
       
      ADDITIONAL DSDT's  (A big thanks to @MaLd0n for compiling these DSDT's)

       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://olarila.com/forum/viewtopic.php?f=19&t=1131 
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F10)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Other OS
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 512MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Disabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS
       

       

       

       

       

       

       

       

       

       

       
       
×