Jump to content
AudioGod

AudioGod's Aorus Z390 Pro Patched DSDT Mini Guide and Discussion

517 posts in this topic

Recommended Posts

On 10/29/2019 at 8:06 PM, AudioGod said:

I have now updated The EFI again for Catalina 10.15.1 to stop the system going to a black screen at install.

You are now totally safe to update Catalina Using This EFI.

 

Updated 30/10/2019

AudioGods Z390 Pro EFI VEGA Navi Radeon VII F11 DSDT.zip - Use with Bios revision F11 Only (Catalina 10.15.1 Vega, Navi, Radeon VII DSDT Installed) 
AudioGods Z390 PRO EFI RX F11 DSDT.zip - Use with Bios revision F11 Only (Catalina 10.15.1 RX5XX DSDT Installed)

 

PLEASE NOTE - Please flash your motherboard bios to revision F11 to use my current EFI. It’s a major rework of the bios and vital changes have been made to the layout and power tables. New DSDTs have been created and installed into the new EFI’s but will not work correctly with any other bios revision.

 

Latest Gigabyte Z390 PRO BIOS (F11)

mb_bios_z390-aorus-pro_f11.zip

 

Awesome AudioGod! How did you update the Pro EFI? I thought you didn't even have the motherboard anymore!? Also, won't we need to change at least the bios setting for that new bios aperture setting to work with 19,1? If so, do we need slide=0 anymore? Any other bios settings updates?

 

I've updated to 15.1 already, but with this new info I'm planning to try and update BIOS, switch to 19,1 and use your updated EFI.

 

Thanks!

Edited by tasc

Share this post


Link to post
Share on other sites
Advertisement
2 hours ago, tasc said:

 

Awesome AudioGod! How did you update the Pro EFI? I thought you didn't even have the motherboard anymore!? Also, won't we need to change at least the bios setting for that new bios aperture setting to work with 19,1? If so, do we need slide=0 anymore? Any other bios settings updates?

 

I've updated to 15.1 already, but with this new info I'm planning to try and update BIOS, switch to 19,1 and use your updated EFI.

 

Thanks!

 

I extracted my dsdt and sent to him to do the patching by Mald0n. Change your Aperture size from 256mb to 512 mb with the new bios. 

Share this post


Link to post
Share on other sites
54 minutes ago, larabee said:

 

I extracted my dsdt and sent to him to do the patching by Mald0n. Change your Aperture size from 256mb to 512 mb with the new bios. 

 

Ah gotcha, thanks @larabee. Do you have any PCI devices in your machine besides video card? If you're running bluetooth device or wifi, etc, I think I may need a DSDT based on my slimmed down setup.

 

Also noticed a couple new boot arguments, what do these do?

agdpmod=pikera -cdfon

 

Edited by tasc

Share this post


Link to post
Share on other sites
26 minutes ago, tasc said:

 

Ah gotcha, thanks @larabee. Do you have any PCI devices in your machine besides video card? If you're running bluetooth device or wifi, etc, I think I may need a DSDT based on my slimmed down setup.

 

Also noticed a couple new boot arguments, what do these do?


agdpmod=pikera -cdfon

 

 

I don't have any other PCI-E devices that need patching. I have a wifi/bluetooth card that works natively too. When I do the DSDT extraction, I already remove all unnecessary devices out of my system. 

agdpmod=pikera is an argument for WhateverGreen. It replaces board-id with board-ix in the binary file for your graphic card to work properly (only seems to work well if there's only one graphic card in the PCI-E slot)

-cdfon is another WhateverGreen magic to enable HDMI 2.0 on your graphic card. 

 

 

43 minutes ago, jardium666 said:

im testing 

AudioGods Z390 PRO EFI RX F11 DSDT.zip - Use with Bios revision F11 Only (Catalina 10.15.1 RX5XX DSDT Installed)

  

but i can't make to work my both monitors, any advice?

 

btw im using a rx580 red devil

Would you mind elaborating a little bit? Are you having problem with 2 displays? If so, what connectors are you using? Is your system working fine with 1 monitor? 

 

Edited by larabee

Share this post


Link to post
Share on other sites

Thanks for the Catalina update. I would go for Catalina but Motu doesn't have drivers yet. I have the MicroBook IIc. I would go for BIOS F11 cause I have RAM problems with F10 but do you know if BIOS F11 works with your old EFI for Mojave 10.14.6?

Share this post


Link to post
Share on other sites
6 minutes ago, larabee said:

 

I don't have any other PCI-E devices that need patching. I have a wifi/bluetooth card that works natively too. When I do the DSDT extraction, I already remove all unnecessary devices out of my system. 

agdpmod=pikera is an argument for WhateverGreen. It replaces board-id with board-ix in the binary file for your graphic card to work properly (only seems to work well if there's only one graphic card in the PCI-E slot)

-cdfon is another WhateverGreen magic to enable HDMI 2.0 on your graphic card. 

 

 

Would you mind elaborating a little bit? Are you having problem with 2 displays? If so, what connectors are you using? Is your system working fine with 1 monitor? 

 

Sorry for my explanation jejeje

 

i got 2 displays connected with DP, the GF has 3 DP but i just get video from one, can you help me?

Share this post


Link to post
Share on other sites
6 minutes ago, benjiolino said:

Thanks for the Catalina update. I would go for Catalina but Motu doesn't have drivers yet. I have the MicroBook IIc. I would go for BIOS F11 cause I have RAM problems with F10 but do you know if BIOS F11 works with your old EFI for Mojave 10.14.6?

You can use the new EFI with BIOS F11 for Mojave. It works just fine

 

5 minutes ago, jardium666 said:

Sorry for my explanation jejeje

 

i got 2 displays connected with DP, the GF has 3 DP but i just get video from one, can you help me?

The RX580 should work natively without any patch. It may sound silly but did you check the input settings on your monitors to make sure it takes the DP signal. Then try different DP ports.

Double check your bios settings too. 

 

Edited by larabee

Share this post


Link to post
Share on other sites
13 minutes ago, larabee said:

You can use the new EFI with BIOS F11 for Mojave. It works just fine

 

The RX580 should work natively without any patch. It may sound silly but did you check the input settings on your monitors to make sure it takes the DP signal. Then try different DP ports.

Double check your bios settings too. 

 

i did check my bios setting, update my bios and both displays are set in DP input, in  10.15 everything works fine, neither play mp4   on preview

Share this post


Link to post
Share on other sites
9 hours ago, tasc said:

 

Awesome AudioGod! How did you update the Pro EFI? I thought you didn't even have the motherboard anymore!? Also, won't we need to change at least the bios setting for that new bios aperture setting to work with 19,1? If so, do we need slide=0 anymore? Any other bios settings updates?

 

I've updated to 15.1 already, but with this new info I'm planning to try and update BIOS, switch to 19,1 and use your updated EFI.

 

Thanks!


Hi Buddy,

SMBios 19,1 works fine with the efi just enable the igpu and add slide=0 to the boot arguments.

if it fails to boot after you make the changes then don’t panic just pull the battery from the motherboard for a minute or two and that will reset the space free for memory allocation and it will boot again.

also on the new bios raise the bios aperture from 256mb too 512mb (experimental)

Share this post


Link to post
Share on other sites

Ok thanks, I'm up and running on new DSDT and SMBios 19,1. For others making this switch, it's probably a good idea to log out of iCloud, Messages, and Facetime before switching up the SMBios and serial numbers.

 

I remember last time running on iMac19,1 with internal headless graphics, that we had to inject an ig-platform-id into device properties to make things correct: ig-platform-id = 0x3E980003

 

Is this still recommended?

Share this post


Link to post
Share on other sites
 
 
 
 
 
 
 
 
 
7
On 10/30/2019 at 8:16 PM, AudioGod said:

 

For Sidecar to work you need to have your igpu enabled and also use smbios 19,1 plus your need the boot flag slide=0 and then Sidecar will work.

as for you oc, be warned as the new bios is so different that none of the power tables are the same so your overclock will more then likely need fine tuning again because of it. It’s a good thing though as the new bios is miles better :) 

Bios F11, your brand new EFI, but still struggling with Sidecar. With IGPU Enabled got an error as pictured, and with AUTO sidecar doesn't see my ipad (SMBIOS 19.1) 

IMG_7459.JPG

IMG_7461.JPG

Share this post


Link to post
Share on other sites
7 minutes ago, lygi said:

Bios F11, your brand new EFI, but still struggling with Sidecar. With IGPU Enabled got an error as pictured, and with AUTO sidecar doesn't see my ipad (SMBIOS 19.1) 

IMG_7459.JPG

IMG_7461.JPG


You need to add the boot flag slide=0 to your clover config (you can also do it temporarily at the clover start up splash by pressing space and selecting slide=0)

and if it still doesn’t play ball then all you need to do is reset your bios by pulling out its battery from the motherboard for a minute and then load back bios defaults then put your settings back in and done.

igpu enabled in bios 

Edited by AudioGod

Share this post


Link to post
Share on other sites

Slide=0 was already set. Will try the trick with battery

Share this post


Link to post
Share on other sites
3 minutes ago, lygi said:

Slide=0 was already set. Will try the trick with battery

Yes do so that will do it for you.

Share this post


Link to post
Share on other sites

Hello guys!

 

please can you help me with my Pink screen pronlem?

 

I have Catalina 19A602

and 2 monitors attached

main with DVI to HDMI

and the secondary HDMI to HDMI 

and the Original EFI (i mean not the newest one)

 

 

When I awake screens from sleep, i got the secondary or both monitors with all colors PINK!!

after some second and mouse moves, pinks goes away, but the colors seems {censored}ed, white are too brights, like an overexposed photo!

 

Anyone got some hints?

 

maybe i need to update WhaterEvergreen or Lilu? or somehting like that?

 

please help!

 

Screenshot 2019-11-02 at 21.33.34.png

Share this post


Link to post
Share on other sites
2 hours ago, gino8080 said:

Hello guys!

 

please can you help me with my Pink screen pronlem?

 

I have Catalina 19A602

and 2 monitors attached

main with DVI to HDMI

and the secondary HDMI to HDMI 

and the Original EFI (i mean not the newest one)

 

 

When I awake screens from sleep, i got the secondary or both monitors with all colors PINK!!

after some second and mouse moves, pinks goes away, but the colors seems {censored}ed, white are too brights, like an overexposed photo!

 

Anyone got some hints?

 

maybe i need to update WhaterEvergreen or Lilu? or somehting like that?

 

please help!

 

Screenshot 2019-11-02 at 21.33.34.png

 

just updated weg to 1.3.4 and your be fine again bud

Share this post


Link to post
Share on other sites

Has anyone tried to use the new AppleTV app on Catalina? Strangely, I can't play any protected content on my mac (purchased iTunes movies, appleTV+ subscriptions) - the video window loads for a split second and then closes. I can play all the trailers and other unprotected content just fine. 

Share this post


Link to post
Share on other sites
1 minute ago, tasc said:

Has anyone tried to use the new AppleTV app on Catalina? Strangely, I can't play any protected content on my mac (purchased iTunes movies, appleTV+ subscriptions) - the video window loads for a split second and then closes. I can play all the trailers and other unprotected content just fine. 


just a wild guess here but it could have something to do with the T2 chip not being there. You could try changing to smbios 19,1 with or without the igpu enabled and see if that resolves it. (If igpu enabled then add slide=0 and your probably need a battery bios reset to get it to boot in for the first time)

Share this post


Link to post
Share on other sites

I have no problem playing my iTune movie collection in H/Sierra, Mojave or Catalina don't ask about streaming as I've never tried.

Share this post


Link to post
Share on other sites
16 minutes ago, eSaF said:

I have no problem playing my iTune movie collection in H/Sierra, Mojave or Catalina don't ask about streaming as I've never tried.

 

+1

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By BuXb
      SleepOnLowBattery (“SOLB”)
      by BugsB, based on a script by Toggi3 * + more code snippets from the www
       
      For those of us whose HackBook (or even real MacBook) doesn't automatically and properly go into power saving mode on very low battery but just powers down coldly, crashing macOS: “SOLB”, a small and RAM/ CPU wise very low footprint AppleScript based utility that checks the battery level every 2 minutes, running via daemon in the background.
       
      You can choose between two versions, either with or without sound. Both display a notification in the top right of your screen.
       
      Between ≤10 and >8% battery charge:

       
      Between ≤8 and >5% battery charge:

       
      On ≤ 5% battery charge you will see a 10 seconds countdown dialog box in 1 second intervals:

       

       
      which you can cancel, or have your your *ac*Book be sent to sleep when down to 0.
       
      The version with sound uses the pleasant macOS US female voice Allison. If the lady is not installed, you can download "her" via System Preferences, Accessibility, Speech (pane tab should get opened by the install script), click onto the two arrows to the right of System Voice, Customize, English (Unites States) -- Female, activate Allison, OK (macOS downloads voices to /System/Library/Speech/Voices - Allison consumes 120 MB).
       
      If you want to see/ see and listen first, disconnect your Mac from its power supply and double click the “run Demo” file in either folder, with or without sound.
       
      The launcher is installed per user, so one user can use the script with and another user the script without sound.
       
      Run your desired install.command, with or without sound. The script should be active right away without restart.
       
      Regarding the sound version, you can also:
      - download any other English voice of your liking and edit the name inside the script at the very top
      - download any language voice and translate the text inside the script
      Edit with Apple Script Editor, save, install, reboot.
       
      Tested working in macOS High Sierra 10.13.6, Mojave 10.14.6 and Catalina 10.15.1.
      Please feedback if this utility also works for you.
       
      If you have ideas, experience bugs, etc., please contribute as precise, succinct, productive and friendly as possible. In case of a bug, always include your version of macOS for me or others to try and help. Thank you.
       
      ENJOY
       
      VERSION HISTORY:
      2019-11-15 v. 1.1
          •    BUG FIX: changed all occurrences of ExternalChargeCapable to ExternalConnected in all Apple Script .scpt files (SleepOnLowBattery.scpt, SleepOnLowBatterySound.scpt, demo.scpt) to restore functionality
          •    IMPROVEMENT: made queries of MaxCapacity and CurrentCapacity more compatible to work with hopefully any system
          •    NEW: added Catalina compatibility to install scripts; verified Mojave compatibility
          •    NEW: Sound script uses voice Allison if installed, otherwise automatically defaults back to another English standard voice (Daniel, Alex or Fred)
       
      2018-11-10 v.1.0
          •    initial version
       
      IDEAS TO IMPLEMENT IN FUTURE RELEASES:
      Have the sound version install script check if Allison is installed, and if not, offer to download and install it. Purely cosmetic: find a way to have the display notification in the top right of the screen not display the Script Editor icon but the one of the utility without turning the utility into an app but by maintaining a script to keep the load footprint low. This is currently neither possible with an Apple Script nor with an Apple Script Bundle file, only with the script compiled into an app. One possibility might be a Perl approach, if someone volunteers. ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      * Thanks to Toggi3 for the base script:
      https://hints.macworld.com/article.php?story=20110219013713667
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      THE CODE (of the version with sound):
      install.command:
       
      LaunchAgent SleepOnLowBatterySound.plist:
       
      Script SleepOnLowBatterySound.scpt:
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
       
      SleepOnLowBattery (SOLB) by BugsB v.1.1 (2019-11-15).zip
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/viewtopic.php?f=28&t=10578
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By kelvin henrique
      Faz pouco menos de uma semana que estou tentando dar boot usando um pendrive no lenovo g40-80, mas todas as vezes que tento algum kernel panic diferente acontece, não entendo tanto de hackintosh mas pelo que li tanto aqui no forum quanto em outros sites me fizeram constatar que talvez o erro seja falta de kexts, alguem possui os kexts para esse notebook ??
       
      primeiro erro que tive era porque estava usando um pendrive de 8gb, o recomendado é 16 no minimo pelo oque vi, fui la, comprei um de 32, mudou o kernel panic mas era só um dos erros resolvidos.
       
      especificações dele:
      Processador: Intel Core i3-5005U
      Grafico: Intel HD Graphics 5500
      originalmente ele vinha com um hd de 500gb e 4gb de ram, mudei pra um ssd de 128gb e 8 gb de ram
       
      ja percebi que unico problema desse notebook é que a placa de wifi não vai funcionar, mas quanto a isso não tem problema pois se conseguir mesmo instalar o mac eu comprou outra
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F10, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.1Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Nitro+ SE Vega56 ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Mojave
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      CLOVER EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F10 to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f10.zip - Z390 MASTER Bios Revision F10
       
      Use this folder with igpu Enabled in bios for working Sidecar (Updated 1st Nov)
      AudioGods Z390 Master Vega Navi EFI.zip - Vega 56/64 Navi & Radeon VII DSDT
      AudioGods Z390 Master RX EFI.zip - RX Series DSDT
       
       
      ADDITIONAL DSDT's  (A big thanks to @MaLd0n for compiling these DSDT's)

       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://olarila.com/forum/viewtopic.php?f=19&t=1131 
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F10)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Other OS
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 512MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Disabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS
       

       

       

       

       

       

       

       

       

       

       
       
×