Jump to content
Sign in to follow this  
Followers 0
Drovosek

[Success] Catalina - XEON E5 2650 v3 (Haswell) + MSI X99A RAIDER

1 post in this topic

Recommended Posts

Posted (edited)

Unfortunately this is not my PC, I just decided to share the found config successful installation.

https://vk.com/photo-12954845_457251886

 

Hardware:

OS X 10.15.0 Beta 2 
CPU Intel XEON E5 2650 v3
MB MSI X99A RAIDER
AMD Radeon RX VEGA 56 video card
Kingston HyperX Fury DDR4 2133Mhz 20gb memory
Crucial 4gb 2400Mhz
Sound E-MU 0202, Alc892 and AMD DisplayPort Audio
Intel Gigabit LAN network
WI-FI Broadcom BCM94360CS2
BCM20702 BT (trackpad and keyboard work in the BIOS)
BP Enermax Platimax 1000W
AirDrop works.
SSD NVMe Reina 480gb
Samsung 850 Pro 120gb
Dell U2713H monitor
USB 15 ports are registered manually. 3.0 works. 
Services usual, SpeedStep instituted through kekst. 
Sleep is unstable.

 

EFI: https://vk.com/doc207634019_512032268

New EFI: https://vk.com/doc207634019_516702825

 

BymzNF1Vvgk.jpg

EFI.zip

new EFI.zip

Edited by Drovosek
Added new EFI

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By martinmenchon
      Hi everyone I have a fully functional Toshiba LW55-C5320 Hackitonsh Catalina
       
      Working:
      Audio Microphone Integrated Intel Graphics Multitouch gestures Full keyboard working (Using "US-International PC" input sources) USB 3.0 Web camera Volumen Keyboards Wifi and Bluetooth using this card and adaptor (SODIAL Bcm94360Cs2 - Tarjeta de conexión WiFi Bluetooth para MacBook Air  KALEA-INFORMATIQUE - ADAPTATOR BCM94360CS2 BCM943224PCIEBT2 A M2 (M.2 NGFF) A E Key) Sleep with DSDT Patches
        Not Working:
      Card reader (I don't use it, so I didn't try to fix it) HDMI audio (I will try to fix it in the next days)  
      I attached the Clover configuration I made
      I will and post some images of Boot configurations
       

       
      EFI.zip
    • By ludufre
      Installing macOS Catalina on Lenovo ThinkPad L440

       
      There are two version of this laptop:
      - 20AS = Chipset QM87, without Express Card (mine).
      - 20AT = Chipset HM86, with Express Card.
      I strong believe is the same thing...
       

      Changelog:
       
      10/20/2019 20:47h GMT-0
      - Removed AppleBacklightFixup.kext.
      - WhateaverGreen now implements backlight since 1.2.5.
       
      10/20/2019 18:10h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i5-4300M ->  Work. All SpeedStep stages.
      - Video Card: Intel HD4600 ->  Work. QE/CI and Metal.
      - Chipset: Intel QM87 ->  Work.
      - Mini DisplayPort ->  Work. But no audio, yet.
      - VGA ->  Not work. Normal.
      - Audio: ALC292 ->  Work.
      - WiFi/Bluetooth: Intel AC 7260 ->  Not work. Replaced with DW1560 (need whitelist removal).
      - Ethernet: Intel I217-LM ->  Work.
      - Card Reader: Realtek RTS5227 ->  Not work.
      - Keyboard and Touchpad ->  Work.
      - Webcam ->  Work.
      - Fingerprint Reader ->  Not work. Normal.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff and Continuity ->  Work after replaced wireless.
      - Instant Hotspot ->  Not work.
       
       
      Extras
       
      - FullHD 1920x1080 display upgrade: 
      Replaced with AU Optronics B140HAN01.1 30pin eDP (B140HAN01.2 and B140HAN01.3 also compatible).
      Apparently same screen as Dell Latitude E6440, E7440, Lenovo Ideapad U430 and E129.
       
      - CPU upgrade:
      Replaced the stock Intel Core i5 4300M 2.6Ghz (3.3Ghz turbo) 6M cache with Intel Core i7 4700MQ 2.4Ghz (3.4Ghz turbo) 6MB.
      I initially had problems with overheating. The processor ran at full load above 90 degrees.
      After using a quality thermal paste I can work between 70 and 80 degrees.
      Acceptable taking into consideration that the new processor has 47TDP versus 37TDP which is recommended.
      I also had no problem consuming the battery while charging. The original 65W source seems to have figured out.
       
      - Touchpad upgrade:
      Replaced the stock with T460 touchpad.
      This is serious: you have to do it! It should be stock. Touchpad with precision and absurd quality!
      Just do it!
       
      - RAM upgrade:
      16GB (2x8GB). No mistery here. Just upgade.
       
       
      Todo
       
      - Make DP audio work.
      - Make Card Reader work.
      - Make trackpad appear in System Preferences
      - Make Instant Hotspot work.
       
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Mojave install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes.
       


      Install bootloader

      Download the CloverEFI from official repository (used 5097) and install only with these options on "Install macOS Mojave":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended Drivers - AudioDxe (Just to have nice sound on boot)
      - UEFI Drivers - Recommended Drivers - FSInject (I still don't know if it's really necessary)
      - UEFI Drivers - File System drivers - ApfsDriverLoader (Support to APFS partitions)
      - UEFI Drivers - File System drivers - VBoxHfs (Support HFS/HFS+ partitions)
      - UEFI Drivers - Memory fix drivers - AptioMemoryFix (Fix the memory management of de UEFI/BIOS)
       
      FileVault 2
       
      If you plan to use FileVault 2, you need to download additional drivers, since what comes with Clover is not up to date and use VirtualSMC instead of FakeSMC.
      Follow instructions bellow:
       
      From current Clover installation, check these options to USB keyboard/mouse work on password screen:
      - UEFI Drivers - Human Interface Devices - UsbKbDxe
      - UEFI Drivers - Human Interface Devices - UsbMouseDxe
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
       
      Download the versions 2.1.0 and 2.0.9 of AppleSupportPkg from: https://github.com/acidanthera/AppleSupportPkg/releases
      We need the last version of AppleGenericInput.efi that is inside 2.1.0 and last version of AppleUiSupport.efi that is inside 2.0.9.
      Put in /Volumes/EFI/EFI/CLOVER/drivers/UEFI/
       
      VirtualSMC is more compatible than FakeSMC, so download the last version in: https://github.com/acidanthera/VirtualSMC/releases (currently 1.0.8)
      Copy VirtualSmc.efi to /Volumes/EFI/EFI/CLOVER/drivers/UEFI/ and all Kexts to /Volumes/EFI/EFI/CLOVER/kexts/10.15/
       
       
      That's it! FileVault 2 will work without problems.
       

       
       
      Make things works
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      - Replace the /Volumes/EFI/EFI/CLOVER/config.plist with mine attached below
      - Put SSDT-L440.aml attached below in /Volumes/EFI/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.6.2.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Copy the Clover Configurator to flash drive because you will need later.
       
      Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the VirtualSMC from here. I used all Kexts and UEFI driver (put VirutalSmc.efi inside /Volumes/EFI/EFI/drivers/UEFI/) from version 1.0.8 (If you followed the steps to enable FileVault 2 above, skip to the next item).
      - Download the Lilu.kext from here. I used the version 1.3.8.
      - Download the VoodooPS2Controller.kext from here. I used version 2.0.4.
      - Download the IntelMausiEthernet.kext from here. I used the version 2.5.0.
      - Download the AppleALC from here. I used the version 1.4.2.
      - Download the WhateverGreen.kext from here. I used the version 1.3.3.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
       
      Important! If you are coming from my previous Mojave guide, please note that I am using some kexts from other repositories / authors.
       
       
      Wifi and Bluetooth (DW1560 / BCM94352Z)
       
      Unfortunately, some notebook manufacturers are currently blocking the replacement of wireless cards. They want you to only use the models sold by them. And of course, none of them from Lenovo for this notebook model is compatible with MacOS.
       
      If you try to start with an unauthorized wifi card for them, you will receive a screen error:
      1802: Unauthorized network card is plugged in - Power off and remove the network card. Since this check is done directly in the BIOS, the only solution is to modify it.
      But since nothing is easy in this life, there is one small big problem:
      - The BIOS update procedure does not allow you to use modded files as it used to be.
      - You will need to physically reach your BIOS on the motherboard and make use of a USB BIOS reader/writer.
       
      So what you need to do:
      1. Disassembly your laptop;
      2. Dump your BIOS with an USB BIOS reader with SOIC8 clip (to not desolder from the motherboard);
      3. Patch it (Ask on UEFI hack forums over there to someone patch for you. Every dump is unique, so mine don't work to you.);
      4. Fix RSA signature;
      5. Reflash BIOS;
      6. Replace wireless card;
      7. Remount your laptop;
      8. Done.
       
      To fix a Modded BIOS to remove the 5 beeps on boot, you need this guide: https://www.insanelymac.com/forum/topic/337333-guide-fix-insyde-h2o-bios-signature-5-beeps-on-lenovo (traduzido: pt-BR)
       
       
      After replaced the wireless card. Download those Kexts and put in /Volumes/EFI/EFI/CLOVER/kexts/10.15/
       
      - Download the AirportBrcmFixup.kext from here. I used the version 2.0.3. (To enable Wireless)
      - Download the BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM3.kext from here. I used the version 2019-10-17. (To enable Bluetooth)
      - Download the BT4LEContinuityFixup.kext from here. I used the version 1.1.4. (To enable Handoff and Continuity)
       
      Keep in mind that the bluetooth kexts are currently in development and the official releases will be available in future in the repository: https://github.com/acidanthera/BrcmPatchRAM/releases
       
       
      Now you can start the installation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is the latest: 1.93 (J4ET93WW) 

      - Shutdown and insert the flash drive.
      - Power on with F1 pressed to enter BIOS setup.
      - Change value: Config - Intel(R) AMT - Intel(R) AMT Control to DISABLED
      - Change value: Security - Security Chip to DISABLED
      - Change value: Security - Anti-Theft - Intel(R) AT Module Activation to DISABLED
      - Change value: Security - Anti-Theft - Computrace to DISABLED
      - Change value: Security - Secure Boot to DISABLED
      - Change value: Startup - UEFI/Legacy Boot to BOTH, Legacy First and CSM Support = Yes
      - Save & Exit Setup (F10)
       
      - Now, hold the F12
      - In the list, select your flash drive.
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot. Maybe you have to press F12 again and select the flash drive.
      
      The second part of the installation will begin. This will take 16 minutes.
       

      Post installation
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to make the system disk bootable.

      Open the Clover Configurator from flash drive that you copied before.

      Mount and open the flash drive EFI partition. (Inside Clover Configurator, Mount EFI -> Select flash drive in Efi Partitions list -> Mount Partition -> Open Partition)
       
      Copy the EFI folder to desktop.
       
      Go back to Clover Configurator, unmount the EFI partition of the flash drive and mount and open the EFI partition of internal disk.
       
      Move the EFI folder from Desktop to EFI partition of the internal disk.
       
      Eject the flash drive.
       
      Move all Kexts from EFI partition of internal disk to /Library/Extensions and make kext cache, with those commands in Terminal:
      sudo mv -R /Volumes/EFI/EFI/CLOVER/kexts/10.15/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!
       
       
      System Updates
       
      As it comes up it will be inserted here.
       
       

      And last but not least

      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @"Sniki", @Mieze, @headkaze and all others members involved directly or indirectly.
       
       
      Attachments
      config.plist
       
      SSDT-L440.aml
       
    • By ludufre
      Since the Catalina beta 9, FileVault takes about 3 minutes to request the password.
       
      I am currently in a final version 19A602 and the problem continues.
       
      If anyone can take a look, I have attached "gen_debug" before and after disabling FileVault.
      I noticed that if I boot in verbose, the login screen takes the same time, but at left o screen a lot of lines pop up:
      ERROR: LWSmcUINT8ForKey smcProtocol-> SmcReadValue failed for key '... Important: In attachments the Kexts are in /EFI/CLOVER/kexts/10.15/ but the behavior in /Library/Extensions is the same.
       
      Important 2: Tried without UsbKbDxe.efi, UsbMouseDxe.efi, Ps2MouseDxe.efi and same issue.
       
      My laptop is from this guide that I wrote: 
       
      gen_debug.zip
       
       
      [EDIT]
       
      Solved with https://www.reddit.com/r/hackintosh/comments/cre5da/filevault_howto
       
      Basically removes:
       
      AppleImageCodec.efi
      AppleImageLoader.efi
      AppleKeyAggregator.efi
      AppleUITheme.efi
      AptioInputFix.efi
      Ps2MouseDxe.efi
      FirmwareVolume.efi
      SMCHelper.efi
       
      And, add:
       
      AppleGenericInput.efi
      AppleUiSupport.efi
      VirtualSmc.efi
       
      Of course, replace FakeSMC kexts with VirtualSMC kexts.
       
      Now, just 5 seconds to ask password.
    • By Barry_dhb52
      After a quite smooth running /w Mojave (both Clover, OC build), a few days ago I upgraded to Catalina soon after public release, and I found out DP output to black screen, then I switch to HDMI, it works. When DP goes black screen, unplug then plug the cable, screen comes back then gone.
      After a lot of searches, I found out some simalar cases, but none of them have a solution,
      today I was quite happy to find out this post is https://www.tonymacx86.com/threads/majove-to-catalina-displayport-not-working.284983/.
      which solving by swithing to iMac19,1, which I think WEG quite needs an enhancement
      But I tried with no luck.
       
      And I don't know is it relevant to this issue, sometimes wakeup, I got panic, somehow like this:
      Kernel Extensions in backtrace: com.apple.driver.AppleACPIPlatform(6.1)[927FAB0F-5B29-3E31-A1A4-DA7E904986C4]@0xffffff7f96b8c000->0xffffff7f96c26fff dependency: com.apple.iokit.IOACPIFamily(1.4)[9BA2613C-A129-3EDD-8DC1-2CFF6B62B832]@0xffffff7f9528f000 dependency: com.apple.iokit.IOPCIFamily(2.9)[E6E855AD-A5B2-3518-A997-1384B4360708]@0xffffff7f952a1000 dependency: com.apple.driver.AppleSMC(3.1.9)[EB9D605D-85B1-3506-8B2E-ABD195817A4F]@0xffffff7f952de000 whole panic log in attachment 

      My build:
      Asrock z370 gaming itx/ac
      i3 8100
      Only Intel UHD630 with LG UL550 4k monitor
       
       
      Or is there any guide how to do some logging for this issue?
      thanks
      panic-log.txt
      EFI.clover.zip
    • By ajoykarmakar
      I have working Mojave version of Hackintosh and it's working perfectly but when I have upgraded to Catalina it's stuck after reaching 90% of the progress bar. When I verbose the boot I got the IGPU problem and if I pass -disablegfxfirmware then I don't get any error log but the progress bar still stuck on the same position and screen became purple. Am I need anything more patch to get a working Catalina machine with Intel HD 630? If I need then how can I do it?
      My EFI link -
      Download
        
      My computer specification is -
      Motherboard: Gigabyte h110m-h-cf
      CPU: Intel Core i5-7400 CPU@3.00GHZ
      Graphics: 4gb GeForce GT730 DDR3 (I have disabled it)
      Ram - 16gb ddr4
      Monitor - Dell connects through the HDMI port.
×