Jump to content
  1. tonyx86


  2. Max.1974


  3. nmano


  4. Loloflat6


  5. XLR


  6. cecekpawon


  7. Moviemakergr


  8. Cyberdevs


  9. telepati


  10. biricotico


  11. vinhkm6


  12. Matgen84




  14. Allan


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Klaidonis
      I am making a minimal Clover build for the fastest boot possible with the boot6 file in legacy mode.
      While looking at the preboot.log, I noticed that there is a line without explanation (at 0:892). Apparently, whatever it is, the execution time of it is close to 2 seconds, more than 55% of the total logged boot time in the current configuration. This does not change whether I use USB 2 or USB 3 port.
      Is there a way to eliminate or speed up the above? Also, is there anything else you can suggest to improve the performance based on the below log file? Which moment in the boot process corresponds to the start time in preboot.log?  
      The last thing I would like to understand is the delay/timeout after the boot6 file has loaded, and the number 6 disappears from the screen. For about 2 seconds or slightly less, I can press any key, and then it will enter the BIOS-like interface from the boot6 file. Without further knowledge, it seems like those 2 seconds are just delay time, and only after that is CLOVERX64.efi actually started, which, I presume, is approximately when the preboot.log timer starts. So, if the aforementioned is correct, can I get rid of this delay as well? Note that I am using the boot1f32 file to chain-load boot6, which does not include the initial 2-second wait period for a keypress.
      === preboot.log ===
      0:100 0:100 MemLog inited, TSC freq: 2394459554 0:100 0:000 CPU was calibrated with ACPI PM Timer 0:100 0:000 LegacyRegion2: Chipset/proc: 0x0A048086 0:100 0:000 Next Generation Core processors (PAM 0x80-0x86) 0:100 0:000 Test PAM1=(0x41=90, 0x5a=90, 0x81=11, 0x91=00) at chipset 0A048086 0:100 0:000 , Install = Success 0:112 0:012 BiosVideoDriverBindingStart! 0:112 0:000 BiosVideoCheckForVbe 0:112 0:000 EdidOverride not found 0:121 0:009 Edid1+ 0:121 0:000 found Detail Timing 1920x1080 0:121 0:000 timing string after 0xFE:AUO 0:121 0:000 timing string after 0xFE:B156HAN01.2 0:122 0:000 0 1280x1024 attr=9B - ok, edid- 0:122 0:000 1 1024x768 attr=9B - ok, edid-, 1024x768, working, highest, pref=1 0:122 0:000 2 640x480 attr=9B - ok, edid-, 640x480, working 0:122 0:000 3 800x600 attr=9B - ok, edid-, 800x600, working 0:123 0:000 4 1920x1080 attr=9B - ok, edid+, working, highest, pref=4 0:123 0:000 BV new mode: 4 1920x1080 0:398 0:275 SetMode pref 4 (4) = Success 0:892 0:493 VGA Pci.Hdr.Command=6 - not enabled 2:623 1:731 2:623 0:000 Now is 21.02.2020, 13:03:21 (GMT) 2:623 0:000 Starting Clover revision: 5103 (master, commit 3f3b85da0) on CLOVER EFI 2:623 0:000 Build with: [Args: -D NO_GRUB_DRIVERS_EMBEDDED -t GCC53 | -D NO_GRUB_DRIVERS_EMBEDDED --conf=/Users/sergey/src/CloverHackyColor/Conf -D USE_LOW_EBDA -a X64 -b RELEASE -t GCC53 -n 5 | OS: 10.14.6] 2:623 0:000 SelfDevicePath=PcieRoot(0x0)\Pci(0x1D,0x0)\USB(0x0,0x0)\USB(0x4,0x0)\HD(1,MBR,0x04944021,0x3F,0x3BC1042) @940C9698 2:623 0:000 SelfDirPath = \EFI\CLOVER 2:623 0:000 SimpleTextEx Status=Success 2:623 0:000 === [ Get Smbios ] ======================================== 2:623 0:000 Type 16 Index = 0 2:623 0:000 Total Memory Slots Count = 2 2:623 0:000 Type 17 Index = 0 2:623 0:000 SmbiosTable.Type17->Speed = 1600MHz 2:623 0:000 SmbiosTable.Type17->Size = 4096MB 2:623 0:000 SmbiosTable.Type17->Bank/Device = BANK 0 DIMM0 2:623 0:000 SmbiosTable.Type17->Vendor = Hynix 2:623 0:000 SmbiosTable.Type17->SerialNumber = 00000000 2:623 0:000 SmbiosTable.Type17->PartNumber = HMT451S6MFR6A-PB 2:623 0:000 Type 17 Index = 1 2:623 0:000 SmbiosTable.Type17->Speed = 1600MHz 2:623 0:000 SmbiosTable.Type17->Size = 8192MB 2:623 0:000 SmbiosTable.Type17->Bank/Device = BANK 2 DIMM1 2:623 0:000 SmbiosTable.Type17->Vendor = Kingston 2:623 0:000 SmbiosTable.Type17->SerialNumber = 5A060A8A 2:623 0:000 SmbiosTable.Type17->PartNumber = KHX1600C9S3L/8G 2:623 0:000 Boot status=0 2:623 0:000 Running on: 'Aspire V5-573G' with board 'Dazzle_HW' 2:623 0:000 === [ GetCPUProperties ] ================================== 2:623 0:000 CPU Vendor = 756E6547 Model=40651 2:623 0:000 The CPU supported SSE4.1 2:623 0:000 BrandString = Intel(R) Core(TM) i7-4500U CPU @ 1.80GHz 2:623 0:000 The CPU supported turbo 2:623 0:000 MSR 0x35 20004 2:623 0:000 MSR 0xE2 before patch 1E008405 2:623 0:000 MSR 0xE2 is locked, PM patches will be turned on 2:623 0:000 MSR 0xCE 0008083D_F3011800 2:623 0:000 corrected FLEX_RATIO = 0 2:623 0:000 MSR 0x1B0 00000000 2:623 0:000 FSBFrequency = 71 MHz, DMI FSBFrequency = 100 MHz, Corrected FSBFrequency = 100 MHz 2:623 0:000 MaxDiv/MinDiv: 24.0/8 2:623 0:000 Turbo: 27/27/27/30 2:623 0:000 Features: 0xBFEBFBFF 2:623 0:000 Threads: 4 2:623 0:000 Cores: 2 2:623 0:000 FSB: 100 MHz 2:623 0:000 CPU: 1700 MHz 2:623 0:000 TSC: 1700 MHz 2:623 0:000 PIS: 100 MHz 2:623 0:000 ExternalClock: 25 MHz 2:623 0:000 === [ GetDevices ] ======================================== 2:623 0:000 GOP found at: PcieRoot(0x0)/Pci(0x2,0x0)/AcpiAdr(0x80010100) 2:623 0:000 PCI (00|00:00.00) : 8086 0A04 class=060000 2:623 0:000 PCI (00|00:02.00) : 8086 0A16 class=030000 2:623 0:000 - GOP: Provided by device 2:623 0:000 - GFX: Model=Intel HD Graphics 4400 (Intel) 2:623 0:000 PCI (00|00:03.00) : 8086 0A0C class=040300 2:623 0:000 PCI (00|00:14.00) : 8086 9C31 class=0C0330 2:623 0:000 PCI (00|00:16.00) : 8086 9C3A class=078000 2:623 0:000 PCI (00|00:1B.00) : 8086 9C20 class=040300 2:623 0:000 PCI (00|00:1C.00) : 8086 9C10 class=060400 2:623 0:000 PCI (00|00:1C.02) : 8086 9C14 class=060400 2:623 0:000 PCI (00|04:00.00) : 168C 0034 class=028000 2:623 0:000 - WIFI: Vendor=Atheros 2:623 0:000 PCI (00|00:1C.03) : 8086 9C16 class=060400 2:623 0:000 PCI (00|05:00.00) : 10EC 5287 class=FF0000 2:623 0:000 PCI (00|05:00.01) : 10EC 8168 class=020000 2:623 0:000 - LAN: 0 Vendor=Realtek 2:623 0:000 PCI (00|00:1C.04) : 8086 9C18 class=060400 2:624 0:000 PCI (00|01:00.00) : 10DE 0FE4 class=030200 2:624 0:000 PCI (00|00:1D.00) : 8086 9C26 class=0C0320 2:624 0:000 PCI (00|00:1F.00) : 8086 9C43 class=060100 2:624 0:000 PCI (00|00:1F.02) : 8086 9C03 class=010601 2:624 0:000 PCI (00|00:1F.03) : 8086 9C22 class=0C0500 2:624 0:000 === [ GetDefaultSettings ] ================================ 2:624 0:000 Clover load options size = 0 bytes 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Aspire V5-573G--00-00-00-00-00-00. Dir not exists 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Aspire V5-573G. Dir not exists 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Aspire V5-573G-1700. Dir not exists 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Dazzle_HW. Dir not exists 2:624 0:000 CheckOEMPathExists tried EFI\CLOVER\OEM\Dazzle_HW-1700. Dir not exists 2:624 0:000 set OEMPath by default: EFI\CLOVER 2:637 0:012 EFI\CLOVER\config.plist loaded: Success 2:637 0:000 === [ GetListOfThemes ] =================================== 2:637 0:000 === [ Found config plists ] =============================== 2:637 0:000 - config.plist 2:637 0:000 === [ GetEarlyUserSettings ] ============================== 2:637 0:000 timeout set to 0 2:637 0:000 Custom boot CUSTOM_BOOT_DISABLED (0x0) 2:637 0:000 Default theme: embedded 2:637 0:000 === [ LoadDrivers ] ======================================= 2:637 0:000 === [ InitScreen ] ======================================== 2:637 0:000 Console modes reported: 4, available modes: 2:637 0:000 - [01]: 80x25 2:637 0:000 - [02]: 80x50 2:637 0:000 - [03]: 100x31 2:637 0:000 - [04]: 240x56 (current mode) 2:637 0:000 SetScreenResolution: 1920x1080 - already set 2:637 0:000 SetScreenResolution: 1920x1080 - already set 2:637 0:000 reinit: self device path=PcieRoot(0x0)\Pci(0x1D,0x0)\USB(0x0,0x0)\USB(0x4,0x0)\HD(1,MBR,0x04944021,0x3F,0x3BC1042) 2:637 0:000 === [ GetMacAddress ] ===================================== 2:637 0:000 === [ ScanSPD ] =========================================== 2:637 0:000 Scanning SMBus [8086:9C22], mmio: 0xB3619004, ioport: 0x5040, hostc: 0x1 2:656 0:018 Slot: 2 Type 24 8192MB 1600MHz Vendor=Kingston PartNo=KHX1600C9S3L8G SerialNo=050A0006000A080A 2:657 0:000 === [ GetAcpiTablesList ] ================================= 2:657 0:000 Get Acpi Tables List from RSDT: 2:657 0:000 - [00]: FACP ACRPRDCT len=268 2:657 0:000 - [01]: UEFI ACRPRDCT len=566 2:657 0:000 - [02]: FPDT ACRPRDCT len=68 2:657 0:000 - [03]: ASF! ACRPRDCT len=165 2:657 0:000 - [04]: HPET ACRPRDCT len=56 2:657 0:000 - [05]: APIC ACRPRDCT len=140 2:657 0:000 - [06]: MCFG ACRPRDCT len=60 2:657 0:000 - [07]: BOOT ACRPRDCT len=40 2:657 0:000 - [08]: LPIT ACRPRDCT len=148 2:657 0:000 - [09]: ASPT ACRPRDCT len=52 2:657 0:000 - [10]: DBGP ACRPRDCT len=52 2:657 0:000 - [11]: SSDT ACRPRDCT len=1337 2:657 0:000 - [12]: SSDT ACRPRDCT len=2776 2:657 0:000 - [13]: SSDT ACRPRDCT len=12013 2:657 0:000 - [14]: SSDT ACRPRDCT len=11433 2:657 0:000 - [15]: SSDT ACRPRDCT len=2230 2:657 0:000 Calibrated TSC Frequency = 2394459554 = 2394MHz 2:657 0:000 === [ GetUserSettings ] =================================== 2:657 0:000 === [ Found DSDT tables ] ================================= 2:657 0:000 === [ ScanVolumes ] ======================================= 2:657 0:000 Found 8 volumes with blockIO 2:657 0:000 - [00]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0) 2:659 0:001 Result of bootcode detection: bootable Linux (grub,linux) 2:659 0:000 - [01]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x1,0x0,0x0) 2:660 0:001 Result of bootcode detection: bootable unknown (legacy) 2:660 0:000 - [02]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(1,GPT,8017BD66-1E24-4B31-8E09-BC49BECD6CC4,0x800,0x21330000) 2:661 0:001 Result of bootcode detection: bootable Windows (vista,win) 2:661 0:000 - [03]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(2,GPT,82F3B738-65E9-458E-B2F1-BB55D4F00885,0x21331000,0x3D0800) 2:663 0:001 - [04]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(3,GPT,E701DCD8-E3C5-4BFA-B61B-BFF4D80153FD,0x21701800,0x18C4F000) 2:664 0:001 - [05]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(4,GPT,4DB1239A-A9D7-4045-A162-7EF1B3A5913B,0x3A350C21,0x3A3B616E) 2:665 0:001 Result of bootcode detection: bootable Windows (vista,win) 2:665 0:000 - [06]: Volume: PcieRoot(0x0)\Pci(0x1D,0x0)\USB(0x0,0x0)\USB(0x4,0x0) 2:677 0:011 Result of bootcode detection: bootable unknown (legacy) 2:677 0:000 USB volume 2:677 0:000 USB volume 2:677 0:000 - [07]: Volume: PcieRoot(0x0)\Pci(0x1D,0x0)\USB(0x0,0x0)\USB(0x4,0x0)\HD(1,MBR,0x04944021,0x3F,0x3BC1042) 2:688 0:011 Result of bootcode detection: bootable unknown (legacy) 2:688 0:000 USB volume 2:688 0:000 USB volume 2:688 0:000 This is SelfVolume !! 2:688 0:000 PutNvramPlistToRtVars: nvram.plist not found 2:689 0:000 No AudioIoProtocols, status=Not Found 2:689 0:000 === [ InitTheme ] ========================================= 2:689 0:000 use daylight theme 2:689 0:000 using embedded theme 2:689 0:000 got embedded sound 2:689 0:000 Channels: 2 Sample rate: 8000 Hz Bits: 16 2:689 0:000 output to channel 0 with volume 70, len=25600 2:689 0:000 sound channels=2 bits=16 freq=8000 2:689 0:000 sound converted to 48kHz 2:689 0:000 not found AudioIo to play 2:689 0:000 sound play end with status=Not Found 2:690 0:001 Using embedded font: Success 2:691 0:000 theme inited 2:691 0:000 Chosen embedded theme 2:691 0:000 after NVRAM boot-args= 2:691 0:000 === [ Dump SMC keys from NVRAM ] ========================== 2:691 0:000 no AppleSMC protocol 2:691 0:000 Entry scan disabled 2:691 0:000 === [ AddCustomTool ] ===================================== 2:692 0:000 === [ GetEfiBootDeviceFromNvram ] ========================= 2:692 0:000 Default boot entry not found 2:692 0:000 DefaultIndex=-1 and MainMenu.EntryCount=4 2:973 0:281 GUI ready  
    • By Jancey
      I used this command: diskutil info disk0s2 | grep -i "Partition UUID" | rev | cut -d' ' -f 1 | rev

      But I accidentally removed the wrong disk and now my main windows drive is not appearing in the bootloader. I can't figure out how to get it back. I tried resetting my windows drive, but I kept getting an error. I also reset my mac and reinstalled Catalina.
    • By tonyx86
      *** I have started another thread for installing Catalina on the Dell Latitude E6410.  If you were thinking of installing Mojave, but would prefer to skip right to Catalina, click here. ***
      I was inspired by @duduclx post here for installing El Capitan on a Dell Latitude E6410, so I decided to install Mojave 10.14.5 and subsequently 10.14.6.  Everything works perfectly (including sleep).  I'm starting this thread hoping to help others install Mojave on their E6410s.  A brief installation guide is provided later in this first post.  The interested reader is encouraged to read the other posts in this thread to see how this solution evolved and to learn additional tips/details not provided in this first post (including dual-booting with macOS and Windows).
      My system is as follows:
      Dell Latitude E6410 (I7-620m, Nvidia 3100M, 8GB DDR3, 512GB SSD, 1440x900 display, BIOS: A17) MacOS: Mojave 10.14.6 (APFS) (Patched with DosDude Mojave Patcher 1.3.3) MacModel: MacBookPro 6,2 (LPCB._DSM.Name "pci8086,3b09") Kexts: Lilu 1.3.6, VoodooHDA 2.9.2, AirportBrcmFixup 2.0.0, IntelMausiEthernet 2.4.1d1, ACPIBatteryManager 1.90.1, BrcmPatchRam2.kext, BrcmFirmwareRepo.kext, VoodooPS2Controller (the "Refined ALPS Touchpad" version - release 6 developed by @Dr. Hurt and compiled by @bronxteck), not the original version), USBInjectAll (with custom SSDT-UIAC), VoodooSDHC.kext (configured as shown here). Wi-Fi: Broadcom BCM 94352HMB (with AirportBrcmFixup.kext) CLOVER (Legacy): R4961  
      Configuration items that may be different from what you have seen in other E6410 configurations
      Addition of _OFF and _ON methods to _PTS and _WAK methods respectively (to control discrete graphics in order to enable sleep/wake) LPCB._DSM patched with device-id "3b09" AND "name", "pci8086,3b09" for native Nehalem power management with MacBookPro 6,2 ECDV renamed to EC so that AppleBusPowerController loads AGP.VID._DSM patched with device-id "0a29" so that AppleGraphicsPowerManagement loads No CLOVER Generate P or Generate C States (with the correct LPCB._DSM and MacBookPro 6,2, these CLOVER options are unnecessary for this architecture and only limit max multiplier and reduce number of P states) DSDT patched to include HDAU device (device-id 0x0be3)  
      What is NOT working:
      Display brightness can be controlled with keyboard keys, but cannot be controlled with slider in Display settings. Graphics Power Management - AGPM loads (because 10de,0a29 device is injected), but there's no evidence that 3100m frequency and voltage is changing.
        What is NOT tested:
      Smartcard Reader eSata (I have this disabled in my BIOS) Firewire Port (it does appear in the Network settings, just haven't tried it) Microphone Jack PC Card Slot (I have this disabled in my BIOS)  
      What IS working:
      SLEEP IS WORKING! Everything else not mentioned above.   Speedstep/CPUPowerManagement is perfect, system temps are low, CPU multiplier operates as expected, battery life is long Shutdown is fast Display/graphics acceleration is perfect (thanks to DosDude's Mojave patcher) Brightness (adjusted with brightness keys on keyboard) works perfectly Battery Manager works (battery status is displayed in menu bar) simply by installing ACPIBatterManager.kext. Wi-Fi (after changing to Broadcom BCM94352HMB and installing AirportBrcmFixup.kext) Audio (volume adjustable, volume indicator appears in menu bar).  Switched to VoodooHDA from AppleALC after AppleALC caused slow boot due to "IOHDACodecFunction timeout." Ethernet port (with IntelMausiEthernet.kext) Broadcom BCM20702A0 Bluetooth (with BrcmPatchRam2.kext and BrcmFirmwareRepo.kext) Optical Drive External VGA (with corrected NVCAP.  Need NVCAP 04000000 00000100 0E000000 00000007 00000000 (credit: here) for working external VGA display. Headphone jack Display Port (tested using DP > HDMI adapter) Camera SD Card Reader  
      Known issues and their solutions (These issues have all been resolved, with the solutions incorporated into the attached config files.  The issues are listed here for historical purposes and no further work is needed unless stated otherwise).
      Laptop does not sleep on lid close.  Solution is to add Notify (LID0) code to Method (BTNV) in the DSDT.  This is solved in the attached DSDT. Leaving this for historical purposes, but the CLOVER USBFix is no longer necessary after finding that I had incorrectly applied the DSDT _DSM patch for Device (EHC1).  The CLOVER USBFix is not needed after fixing the DSDT..  AAPL,clock-id and device_type do not appear in IORegistry for EHC1.  Solution is to use CLOVER on-the-fly patching/fixing/renaming for EHC1 and EHC2.  Thank you, @feartech, for this tip. ALPS trackpad performance is not good with the "standard" VoodooPS2Controller.kext that I initially used.  Switching to the "Refined ALPS TouchPad driver" is a big improvement.  I've implemented and tested this on my system.  The ALPS version of VoodooPS2Controller.kext mixes up a few keys.  Need to switch the Command and Option keys (System Preferences > Keyboard > Modifier Keys) and change keyboard type to ISO European. This configuration (captured in the attached config files) uses an injected device-id (10de,0a29) for NVidia 3100m to get AGPM to load.  While I haven't observed any performance differences, a better approach may be to inject AGPM properties for device 10de,0a6c (the actual device-id for the 3100m).  This AGPM method is discussed later in this thread.  I have briefly tested this "FakeSMC.kext method" for injecting AGPM attributes without any noticeable changes in laptop/graphics behavior. IOHWControl is not loaded under AGPM (Should be AGP > VID > NVDA,Display-A@0 > NVDATesla > AGPM > gpu-control > IOHWControl as viewed in IORegistryExplorer).  It is loaded on a real MacBookPro6,2 running Mojave and is loaded on this Dell Latitude E6410 running High Sierra.  If I "Inject NVidia" via CLOVER, IOHWControl loads properly. The Dell Latitude DSDT (BIOS A17) has a bug in Method (GNOT).  In the method, the expression  If (LOr (LGreater (OSYS, 0x07D0), LLess (OSYS, 0x07D6))) always evaluates to TRUE, so the patched DSDT has no dependency on the value of OSYS.  I suspect that LOr should be replaced with LAnd, so that this expression is TRUE for variants of Windows 2001 and False for any other OS.  While this may have no affect on MacOS, it makes one wonder how such an obvious bug made it through Dell QA and is still present in BIOS A17.  Also makes one wonder whether the sleep problem (which no one has solved) was fixed in Windows to address another DSDT bug. The assigned value of ACOS and OSYS in the DSDT are conditional on the operating system.  There is no condition for "Darwin."  The solution is to add a condition for "Darwin" (making it equivalent to one of the defined operating systems (e.g. Linux, Win7, etc).  The attached config hard-codes ACOS and OSYS values equivalent to those for Linux.  Another way to handle this (different from the method employed in the attached config files) might be to override _OSI with XOSI (defined in a custom SSDT). The portType of the Internal Bluetooth device is portType=0 which, according to Rehabman's comments in SSDT-UIAC-All.dsl, is an external USB 2 port.  This should be an internal USB port (portType=2).  I learned through trial and error that the HUB1 and HUB2 definitions in Rehabman's SSDT-UIAC-ALL.dsl apply to the ports on the EHCx USB hubs.  The solution is to include the HUB1 definition in SSDT-UIAC.dsl and change portType to 2 for HP15.  This change doesn't appear to affect/fix sleep, but it may prevent instant wake if we get sleep working. There are minor differences between a real MacBookPro6,2 IORegistry dump and this HackBookPro6,2 IORegistry dump that can be resolved with simple DSDT edits.  I am now running with these changes, but haven't found these changes to make any difference in operational behavior.
      Rename Device (AC) -> Device (ADP1) Remove UID from Device (HPET) Add compatible ID "PNP0C01" to Device (HPET) Change ADP1:_STA from 0x0F to 0xFFFFFFFF Enable Ambient Light Sensor and renamed to Device (ALS0) from Device (ALS) Add compatible ID "smc-als" to ALS0 Rename LID -> LID0 Change "name" definitions to Buffers in _DSM methods Rename Device (PBTN) to PWRB Rename Device (SBTN) to (SLPB) Change HDAU.hda-gfx from "onboard-1" to "onboard-2" Change GFX0.hda-gfx from "onboard-1" to "onboard-2" Sleep / Wake does not work with the basic DSDT edits.  I have discovered that Sleep / Wake can be made to work by adding discrete graphics _OFF and _ON methods to _PTS and _WAK methods respectively (borrowed the concept and code from a working E6430 DSDT: Credit here: https://osxlatitude.com/forums/topic/9248-working-sleep-on-intel-hd-and-nvidia-nvs-on-dell-latitude-e6430-optimus-enabled-or-disabled/page/6/. The Clover boot arg should be changed to "darkwake=0" for reasons explained by @holyfield in this thread.  Leaving this for historical purposes: LCD screen is blank when waking laptop by opening lid (screen is not blank when waking with power button).  Solution is to add darkwake=8 to CLOVER boot args.  Thank you @Hervé for this tip.  
      Brief Installation Guide:
      Configure BIOS (version A17) as follows (leave default unless listed here): Boot Sequence: USB, Internal HDD, CD/DVD, Modular Bay HDD; Boot List Option: Legacy; Integrated NIC: Enabled; Parallel Port: Disabled; Serial Port: Disabled; SATA Operation: AHCI; Misc Devices: Enable Modular Bay, Camera, External USB, Microphone, Media Card and 1394; Latitude ON Reader: Disabled; Keyboard Illumination: Auto ALS and Input; Ambient Light Sensor: Enabled; OROM Keyboard Access: Disable; TPM Security: Disable; Computrace: Deactivate; CPU XD Support: Enable; Performance: Enable all options; Power Management: Disable Wake on AC, Disable Wake on LAN/WAN, Express Charge: Standard, Charge Behavior: Enabled; Keypad: Fn Key Only; Mouse/Touchpad: Touchpad/PS-2 Mouse; USB Emulation: Enable Legacy; Fn Key Emulation: Disabled; Fastboot: Thorough; Virtualization: Enable Intel Virtualization, Disable VT for Direct I/O, Disable Trusted Execution; Wireless Switch: Bluetooth and WLAN; Wireless Device Enable: Bluetooth and WLAN;  Create your MacOS installer USB (Use DosDude's Mojave Patcher for Mojave) (start with High Sierra and not Mojave if you're new to hackintosh). Install CLOVER (Legacy) on installer USB using attached EFI as your guide for patched ACPI, kexts and config.plist Install MacOS to your SSD.  When you run DosDude's Mojave Patcher, DO NOT install LegacyUSBInjector.kext - you're going to use Rehabman's USBInjectAll.kext.  Also, do not install the DosDude SIP kext (you're using CLOVER to manage SIP). Install the following kexts in /Library/Extensions:  ACPIBatteryManager.kext, AirportBrcmFixup.kext, BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakeSMC.kext, FakeSMC_ACPISensors.kext, FakeSMC_CPUSensors.kext, FakeSMC_GPUSensors.kext, FakeSMC_LPCSensors.kext, IntelMausiEthernet.kext, Lilu.kext, USBInjectAll.kext, VoodooPS2Controller.kext (the "Refined ALPS Touchpad driver," not the original), VoodooSDHC.kext (configured as shown here). Switch Command and Option keys to compensate for Refined ALPS driver issue (System Preferences > Keyboard > Modifier Keys).  Also change keyboard type to ISO European to fix the [ ` ~ ] key (to the left of the "1" (one) key. Install VoodooHDA Install HWMonitor application  
      Tips for Improved Performance (on this and other older systems)
      System Preferences > Spotlight > Search Results: Uncheck all options System Preferences > Spotlight > Privacy: Add all Volumes System Preferences > Accessibility > Display: Check "Reduce motion" System Preferences > Accessibility > Display: Check "Reduce transparency"  
      Other tips
      If your fan is always running and temps are good, try pressing Fn + z After applying Mojave updates, HWMonitor may not display discrete graphics attributes.  On systems with multiple displays, a second (or third display) may not be active after applying the Mojave update.  The solution to this is to run "sudo kextcache -i /" (in a terminal window) and reboot.  This will usually fix the issue.  If the issue is not fixed, run DosDude's Post Install Utility, apply the Legacy Graphics Patch, reboot and then run "sudo kextcache -i /" if necessary.  
      In addition to those mentioned in this first post and in subsequent posts in this thread, much of this solution for the Latitude E6410 was made possible by the numerous contributions of @RehabMan.  I hope he's doing well, wherever he is.  Hopefully he has long since forgotten what a PIA I was (and still am) as I was (and still am) learning hackOS.  

    • By DanZiRuleZ
      Dear All, 
      trying to install Catalina on my ASUS Z87 Plus, I followed the Haswell guide to the letter, all set up now, USB stick boots ok, Catalina installs on SSD, but then when trying to boot it I am receiving Kernel Panic and no idea how to move forward. 
      Have the debug options, but opencore will only dump boot messages where I don't see much sticking out.
      My last resort would be just installing clover on the already installed SSD's EFI partition, it at all possible. High Sierra is working fine and I did get Clover with Mojave once but stuck with High Sierra with my GTX960 video card...
      Attached is the kernel panic and my EFI setup if anyone can help me troubleshoot.
      Many thanks

    • By gengstapo
      Im having similar issue with my HS setup, dell latitute 3480, i5-7200U
      Once the hdmi plugged in, the laptop display went blank, only could see the external tv
      But, when i put my laptop to sleep & wake up again, both screen got display (hdmi still connected)
      Even the hdmi could be plugged off & in (after sleep), the laptop display is fine
      What could be the culprit?
      Dell’s MacBook Pro IORegistry.zip