Jump to content
DFacco

Problema stranissimo con Clover

18 posts in this topic

Recommended Posts

Salve a tutti,

premetto di essere nuovo in questo mondo dell'hackintosh e, come avrete letto dal titolo, ho un problema molto strano al momento dell'installazione.

 

Creo la chiavetta usb, metto tutti i kext, driver eccetera da un vecchio MacBook Pro ma, quando la vado a mettere sul pc e provo a bootare, Clover non mi trova l'os. In alto c'è lo stemma di clover, in basso i settings ma dove dovrebbero esserci i SO non c'è nulla.

 

Nel pc avevo ssd e hardest per windows ma ho pensato di toglierli per non creare conflitti con un nuovo ssd da 120gb comprato apposta per il Mac OS.

 

La penna usb ho provato a farla in tutti i modi che ho trovato e che mi hanno consigliato: sia con Tino, sia con terminale scrivendo il codice. Ho usato clover per selezionare kext e drivers ma nulla.

 

Questa è la guida che ho seguito inizialmente  https://hackintosher.com/builds/asrock-z370-extreme4-pro4-hackintosh-high-sierra-guide/ 

 

Non so più cosa fare, HELP!

Share this post


Link to post
Share on other sites
Advertisement

Neanche a farlo apposta, appena pubblicato questo thread ho messo un driver in più e ha funzionato (OsxAptioFix3Drv) grazie ad una guida che ho trovato qui sulla forum .

 

Ho selezionato l'installer, inizializzato l'ssd su cui installare l'os e installato. Adesso non mi fa andare avanti però... Mi rimanda a Clover operating system boot manager e ho le seguenti opzioni:

_Boot macOS Install from *penna usb*

_Boot FileVault Preebooter from Preboot (caricamento apple con successive riavvio e siamo da capo)

_Boot macOS Install Prebooter from Preboot (se lo seleziono mi da un simbolo di divieto)

_Boot macOS from Hackintosher (ho chiamato così il mio ssd quindi penso sia questo quello da cliccare ma quando lo seleziono mi appare la mela della apple classica con la barra di caricamento, una vola caricato mi riavvia il pc e siamo da capo)

_Boot Recovery from Recovery

 

Come risolvo? Grazie in anticipo a tutti

Edited by DFacco
Update

Share this post


Link to post
Share on other sites
7 hours ago, iCanaro said:

leggi con attenzione questa guida

posta la EFI (senza la cartella APPLE)

Per fortuna ho seguito questa guida e ha funzionato. Restano solo da risolvere bug grafici da cui non ne sto venendo fuori...

Schermata 2019-07-23 alle 08.53.56.png

Share this post


Link to post
Share on other sites

di cose da sistemare secondo me ne avrai diverse... già dallo screenshot non andiamo bene, quello che vedo è un guazzabuglio senza capo ne coda... conoscendo la fonte, immagino il config... se ti parte è perché hai hardware altamente compatibile

Share this post


Link to post
Share on other sites
27 minutes ago, iCanaro said:

di cose da sistemare secondo me ne avrai diverse... già dallo screenshot non andiamo bene, quello che vedo è un guazzabuglio senza capo ne coda... conoscendo la fonte, immagino il config... se ti parte è perché hai hardware altamente compatibile

da dove posso cominciare? cosa non va?

Share this post


Link to post
Share on other sites

Aggiungo:

_ La risoluzione è 1024x768 (a memoria)

_Non legge il secondo monitor (è collegato e acceso ma 0 segnale video)

Share this post


Link to post
Share on other sites

diciamo che guardavo quello screenshot con gli occhi di 2 anni fa.. era una cosa, con gli occhi e conoscenze attuali rimango stupito ti parta :shock::hysterical: ovvio che se non hai esperienza non vedi i macroscopici problemi che hai, ma nessuno nasce imparato ;)

Share this post


Link to post
Share on other sites

Eppure, incredibilmente, parte :D (probabile che sia perché ho scaricato una cartella eri per il mio stesso hardware)

 

7 minutes ago, iCanaro said:

PS: ieri è uscito il security update vedi di eseguirlo

controlla il setup del BIOS

che poi vediamo di aggiustare quel caos che sono anche già disponibili i webdriver

e posta la EFI senza la cartella APPLE 

Bios già settato bene, mi rimane da capire come fare il security update..

E ovviamente i problemi grafici non indifferenti

Share this post


Link to post
Share on other sites

quella dello screenshot.. andamo bene ahahhaha l'importante è essere convinti.. ti è stato chiesto qualcosa già 2 volte.

 

il security update... linkarti una pagina con il combo andrebbe bene?! ah già fatto.... :hysterical: ma se non hai tempo tu per leggere info inerenti, figurati io.. ;)

Share this post


Link to post
Share on other sites

Nel mio commento non volevo in nessun modo dire che la mia andasse bene , volevo solo sdrammatizzare le 24h infernali che ho impiegato per far partire questo inizio di hackintosh..

 

Spero di aver caricato le foto che mi hai chiesto, altrimenti non ho proprio capito a cosa ti riferisci. 

 

PS: sto scaricando il Security Update

Schermata 2019-07-23 alle 10.33.35.png

Schermata 2019-07-23 alle 10.33.51.png

Share this post


Link to post
Share on other sites

Forse ho capito cosa intendevi, spero di aver caricato la cartella giusta. Ho rimosso "Apple" dal suo interno.

Ho fatto il Security Update e ho avuto i seguenti benefici:

 

_ Funzionano entrambi i monitor: il principale lavora in 1440p a 144hz, il secondario 1080p a 60hz

_ Unico artefatto visivo residuo è quello nella pagina di Log In

 

Rimango in attesasi aiuto , se ne hai voglia, per quanto riguarda questo:

2 hours ago, iCanaro said:

di cose da sistemare secondo me ne avrai diverse... già dallo screenshot non andiamo bene, quello che vedo è un guazzabuglio senza capo ne coda... conoscendo la fonte, immagino il config... se ti parte è perché hai hardware altamente compatibile

 

 

Ti ringrazio perché già adesso ha la "forma" di un Mac ^_^

EFI copia.zip

Share this post


Link to post
Share on other sites

@DFacco ma la integrata l'hai lasciata attiva o no? il monitor lo colleghi alla nVidia 1050Ti o cosa?

 

scaricati i webdriver relativi alla versione di macOS che hai, li trovi sempre dove stava il security update

PS: hai il seriale di un vero mac e questo non va bene, ti sto preparando una EFI un po' aggiustata, il config tutto sommato non era male... :)

Share this post


Link to post
Share on other sites

questa è la tua mobo giusto

https://www.asrock.com/MB/Intel/Z370 Extreme4/index.asp#Specification

 

avevi in EFI praticamente tutti i kext per la LAN, li ho compressi e lasciato attivo il solo IntelMausi, se non fosse quello giusto, lo elimini e decomprimi uno degli altri sino a trovare quello che va bene per te ed elimini quelli non corretti.

 

Aggiornata clover, driver e kext, cambiato seriale, e altre piccole cose.... pendrive per avvii di emergenza e se hai voglia prova... in teoria... sono hack quindi... dovresti andare meglio

installa i webdriver

EFI_Asrock Z370 Extreme4_1050Ti 2.zip

Share this post


Link to post
Share on other sites

ah per i kext non ti sorprendere, non mi sono sbagliato, per la grafica intel, AMD e parte nvidia fa tutto WEG

shiki, nvidiagraphicsfixup, intelgraphicsfixup e altri sono inglobati in WEG ora ;)

Share this post


Link to post
Share on other sites

Sei il numero 1!

 

4 hours ago, iCanaro said:

@DFacco ma la integrata l'hai lasciata attiva o no? il monitor lo colleghi alla nVidia 1050Ti o cosa?

  ho disattivato l'integrata da bios e ho attivato solo la 1050ti. Displayport per il monitor 1440p e hdmi per il 1080p.

 

4 hours ago, iCanaro said:

scaricati i webdriver relativi alla versione di macOS che hai, li trovi sempre dove stava il security update

PS: hai il seriale di un vero mac e questo non va bene, ti sto preparando una EFI un po' aggiustata, il config tutto sommato non era male... :)

i web driver della pagina del Security Update li ho scaricati ma non andavano... boh

 

3 hours ago, iCanaro said:

esattamente 

3 hours ago, iCanaro said:

ah per i kext non ti sorprendere, non mi sono sbagliato, per la grafica intel, AMD e parte nvidia fa tutto WEG

shiki, nvidiagraphicsfixup, intelgraphicsfixup e altri sono inglobati in WEG ora 

di questa parte non ho capito nulla ... :wallbash: :poster_oops:

Share this post


Link to post
Share on other sites

webdriver qui

 

non è niente di difficoltoso da capire, tanti kext obsoleti che avevi nella tua EFI è terminato lo sviluppo come singoli kext e sono stati inglobati in WEG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ludufre
      Installing macOS Catalina 10.15.4 on Gigabyte Z370N WIFI + i7 8700K + UHD 630



      Changelog:
       
      03/24/2020 20:23h GMT-0
      - Update instructions 10.15.4.
       
      01/30/2020 23:54h GMT-0
      - Update instructions 10.15.3.
       
      12/11/2019 03:58h GMT-0
      - Update instructions 10.15.2.
      - Updated EFI folder attached.
       
      11/30/2019 18:03h GMT-0
      - Changed Device -> Graphics platform to fix dual HDMI monitor.
      - Updated EFI folder and config.plist
       
      11/29/2019 21:28h GMT-0
      - Added full EFI folder as requested.
       
      11/27/2019 02:33h GMT-0
      - Added BIOS profiles for ease.
       
      11/25/2019 22:45h GMT-0
      - Fixed wrong ethernet link (IntelMausi.kext).
      - Thanks to @MiMoHo
       
      11/24/2019 04:56h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i7-8700K ->  Work. All SpeedStep stages.
      - Video Card: Intel UHD 630 ->  Work. QE/CI and Metal.
      - Chipset: Intel Z370 ->  Work.
      - HDMI 2.0 (1st) ->  Work.
      - HDMI (2nd) ->  Work.
      - DP ->  Work.
      - Audio: ALC1220 ->  Work.
      - HDMI Audio ->  Work.
      - WiFi/Bluetooth ->  Not work. Replaced with BCM94360CS2.
      - Ethernet (1st) ->  Work.
      - Ethernet (2nd) ->  Work.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Todo
       
      - Empty
       
      What you need to install
       
      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Catalina install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction  This will take about 30 minutes.
       


      Install bootloader
       
      Download the CloverEFI from official repository (used 5099) and install only with these options on "Install macOS Catalina":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended Drivers - FSInject (I still don't know if it's really necessary)
      - UEFI Drivers - File System drivers - ApfsDriverLoader (Support to APFS partitions)
      - UEFI Drivers - File System drivers - VBoxHfs (Support HFS/HFS+ partitions)
      - UEFI Drivers - Memory fix drivers - AptioMemoryFix (Fix the memory management of de UEFI/BIOS)
      - UEFI Drivers - Additional drivers - NvmExpressDxe (If you are going to use NVMe)
       
      FileVault 2
       
      If you plan to use FileVault 2, you need to download additional drivers, since what comes with Clover is not up to date and use VirtualSMC instead of FakeSMC.
      Follow instructions bellow:
       
      From current Clover installation, check these options to USB keyboard/mouse work on password screen:
      - UEFI Drivers - Human Interface Devices - UsbKbDxe
      - UEFI Drivers - Human Interface Devices - UsbMouseDxe
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      Download the versions 2.1.0 and 2.0.9 of AppleSupportPkg from: https://github.com/acidanthera/AppleSupportPkg/releases
      We need the last version of AppleGenericInput.efi that is inside 2.1.0 and last version of AppleUiSupport.efi that is inside 2.0.9.
      OR download attached bellow.
       
      Put in /Volumes/EFI/EFI/CLOVER/drivers/UEFI/
       
      That's it! FileVault 2 will work without problems.
       

       
       
       
      Make things works
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      - Replace the /Volumes/EFI/EFI/CLOVER/config.plist with mine attached below according to your processor version.
      - Put all SSDT-*.aml attached below in /Volumes/EFI/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.8.0.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Copy the Clover Configurator to flash drive because you will need later.
       
      Download those Kexts and put in /Volumes/EFI/EFI/CLOVER/kexts/Other/
       
      - Download the VirtualSMC.kext, SMCProcessor.kext, SMCSuperIO.kext and UEFI driver (put VirutalSmc.efi inside /Volumes/EFI/EFI/drivers/UEFI/). I used the version 1.0.9.
      - Download the Lilu.kext from here. I used the version 1.3.9.
      - Download the WhateverGreen.kext from here. I used the version 1.3.4.
      - Download the AppleALC.kext from here. I used the version 1.4.3.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
      - Download the IntelMausi.kext from here. I used the version 1.0.2.
      - Download the SmallTree-Intel-211-AT-PCIe-GBE.kext attached bellow to enable second ethernet.
       
      Important! If you are coming from my previous Mojave guide, please note that I am using some kexts from other repositories / authors.
       
      Wifi and Bluetooth (BCM94360CS)
       
      Works out of box (plug 'n' play).
       
       
      Now you can start the installation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is F10 (I use an 8th generation processor, so I don't need to upgrade)
       
      You can configure manually or load my BIOS profile.
       
      Manually:
      - Shutdown and insert the flash.
      - Power on with DEL pressed to enter BIOS setup.
      - Change value: BIOS - CSM Support to Disabled
      - Change value: BIOS - Secure Boot to Disabled
      - Change value: Peripherals - Initial Display to IGP
      - Change value: Chipset - VT-d to DISABLE
      - Change value: Chipset - Internal Graphics to ENABLE
      - Save & Exit Setup
       
      or, BIOS profile
      You can use one of my BIOS profiles attached bellow.
      It's two versions. One stock (Geekbench 4: 5840/27384) and another with overclock [5.0 GHz] (Geekbench 4: 6360/30348)
      - Put the profile in the root of the flash drive at EFI partition.
      - Restart with DEL pressed to enter BIOS setup.
      - Go to Save & Exit.
      - Select Load Profiles.
      - Select last option and then the flasdrive in the list.
      - And finally choose MACOS_STOCK or MACOS_5GHZ.
      - Save & Exit Setup
       
      Then:
      - Now, hold the F12
      - In the list, select your flash drive.
      - Choose the flash drive (white icon).
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot. Maybe you have to press ESC again and select the flash drive.
       
      Choose the internal disk (gray hdd icon) if not already selected.

      The second part of the installation will begin. This will take 16 minutes.

       
      Post installation
       
      Bootloader

      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to make the system disk bootable.

      Open the Clover Configurator from flash drive that you copied before.

      Mount and open the flash drive EFI partition. (Inside Clover Configurator, Mount EFI -> Select flash drive in Efi Partitions list -> Mount Partition -> Open Partition)
       
      Copy the EFI folder to desktop.
       
      Go back to Clover Configurator, unmount the EFI partition of the flash drive and mount and open the EFI partition of internal disk.
       
      Move the EFI folder from Desktop to EFI partition of the internal disk.
       
      Eject the flash drive.
       
      Move all Kexts from EFI partition of internal disk to /Library/Extensions and make kext cache, with those commands in Terminal:
      sudo mv -R /Volumes/EFI/EFI/CLOVER/kexts/10.15/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
      Last thing
       
      Run this command in Terminal to disable hibernation (doesn't work in macOS):
      sudo pmset -a hibernatemode 0  
       
      It's done!
       
       
      System Updates
       
      10.15.2
       
      Before install, update the following kexts:
      - Lilu.kext. I used version 1.4.0.
      - WhateverGreen.kext. I used version 1.3.5.
      - AppleALC.kext. I used version 1.4.4.
      (all download links above)
       
      Download the latest CLOVERX64.efi.zip build. I used version 5100.
      Mount EFI partition and unzip to:
      - /Volumes/EFI/EFI/CLOVER/CLOVERX64.efi
      - /Volumes/EFI/EFI/BOOT/BOOTX64.efi (rename the copy of CLOVERX64.efi to BOOTX64.efi
       
      Install update. Will reboot at least four time.
       
       
      10.15.3
       
      Updated with success without changing anything.
       
       
      10.15.4
       
      Before install, update the following kexts:
      - Lilu.kext. I used version 1.4.2.
      - WhateverGreen.kext. I used version 1.3.7.
      - AppleALC.kext. I used version 1.4.7.
      - VirtualSMC.kext. I used version 1.3.7.
      (all download links above)
       
      Download the latest CLOVER installer. I used version 5107.
      - Install respecting the configuration mentioned above in "Install bootloader" section.
       
      Install update. Will reboot at least four time.
       

       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas and all others members involved directly or indirectly.
       
      Attachments
       
      config.plist v2.zip
      EFI v4.zip
      Filevault 2 additional drivers.zip
      SmallTree-Intel-211-AT-PCIe-GBE.kext.zip
      SSDTs.zip
      MACOS_5GHZ
      MACOS_STOCK
       
       
       
    • By _ivan_palmisano_
      Ho provato tutti i modi ma sono arrivato alla conclusione che ha bisogno di una patch DSDT.
      Ciao, ho recentemente un hackintosh nel mio laptop e devo risolvere l'attacco video HDMI che non ha eseguito quando collego il mio laptop alla TV.
      le foto con queste informazioni sono state fatte con un programma quando che avrei vinto 10 nell'altra foto l'informazione di hackintosh.
      Acer Aspire 5741g Modello High Sierra System!
      Caratteristiche:
      CPU: Intel Core I3 350M 2.27Ghz Arrandale 32nm Tecnologia
      Ram: 6: 00GB
      Grafica: Monitor Pnp generico (1366x768 Ghz) 1024mb Nvidia GeForce GT 320M (Acer Incorporated)
      Archiviazione: 465 GB Sata
      Driver Optiocal: Optiarc DVD RW- AS-7585H
      Audio: dispositivo audio ad alta degradazione
      Qualcuno può aiutarmi!?! E 'la terza volta che faccio questo post in questo gruppo visto che sono nuovo nel mondo hackintosh preferisco se qualcuno è capace a risolvere il mio problema che lo faccia in remoto così non faccio sbagli.
    • By Humboldt421
      I would like to use an intel H10 optane SSD module to create a fusion drive container for an osx install. 
      I have an MSI b360i pro AC mobo with intel i5-8400 amd rx580 8gb and 2x 8gb ddr4 2666 
      Its all in a Dan case with the HdPlex 400w Pure DC PSU 
      Its running windows on a Toshiba KXG5A 512 SSD which is fast but i wanted to install osx and I wanted to use a new drive for that, I chose the H10 intel optane drive because from what I gather if I dont use any optane software or bios settings it will appear as two drives to the UEFI firmware, one 32gb Optane drive and the 512 SSD, I wanted to know if I could use this as a fusion drive container. Has anyone done this? Also I need to figure out the DSDT or clover setup to use to make this mobo boot with the hardware I have. I havent built a osx86 box since ML but I think that i can figure it out with some help. Thanks.
    • By gusbemacbe
      Hello,
       
      I am a former user of MacBook and Mac mini. Both died. One in 2014 and another last year.  I will think of giving my Hackintosh-compatible laptop to my brother that I purchased years ago, because he wants to play more than one computer, so he is a Twitch/YouTube streamer and a hardcore gamer and I will not need to lend him many times. If he wants, from my former laptop I will take only one 240GB SSD Samsung Evo with installed Arch Linux and leave one 500GB HDD for him. In the future, I will purchase a new Alienware laptop.
       
      As I got newly graduated, I moved to a new super PC with AMD Ryzen™ 7 2700X CPU and with NVIDIA GeForce™ 1660 Ti GPU. More details, you can see my signature below, that provides the complete details. I own an external SSD m.2 2280 with installed Windows 10.
       
      I will reconsider purchasing 4th drive – an external 480GB SSD m.2 2280 SATA WD Green 545MB/s or an external 1TB SSD SATA WD Green 545MB/s – for installing Hackintosh. But purchasing, I need to make sure.
       
      1. Is it worth to install Hackintosh on an external SSD m.2 2280? If I partition two partitions, one for Insansely's MyHack/Chameleon/Clover and another for Hackintosh and my new super-PC boot is natively BIOS and Grub, is it worth? Maybe I will try to install reFind on Arch Linux to replace the Grub if it is worth.
      2. I know that it will run on macOS High Sierra, Mojave and Catalina, but if I need Metal 2 to run the latest version of Sketch (the which I own an original licence) and of other apps the which I own original licences? Is NVIDIA GeForce™ 1660 Ti compatible with Metal 2?
      3. Since it be an external SSD, will I able to run Hackintosh as a portable OS in other computers?
       
       
×