Jump to content
newapple4g

Cant boot to Mojave after installation - ASUS Zenbook 533FD

2 posts in this topic

Recommended Posts

Few days ago I bought ASUS Zenbook 533FD for my CS classes. I wanted to install mac OS Mojave, so I tried to do it. It's been a while since I installed Hackintosh to PC. The last successful one was Mojave on my HP Envy 17. I researched about some new info about hackintoshing new PCs because my old one was 5 years old. I had found some difficulties as:

Spoofing IGPU( My laptop come with i7-8565U(Whiskey Lake-U) which is not natively supported in macOS as its IGPU (UHD 620)). I tried to use Rehabman's clover config and it's boot installer.

I2C Touchpad(ELAN 1200) instead of PS2 Trackpad(I used external mouse instead of internal one)

Lot's of DSDT patches to be applied.

I managed to install it and boot. But there is no sound, no touchpad, WIFI, lots of other things and the worst one is no QE/CI.

I tried to look at other builds with almost same configuration except CPU. I found guides with models ASUS Q405UA and one with Zenbook models before 2018. But there is no change. Then I tried to find some other configurations with just same CPU. I had found one in one reddit threads. I tried it with some modifications and it gets QE/CI. But after restarting it something goes wrong, so I cant boot and something damaged my SSD. So I need to reinstall macOS. The latter configuration of QE/CI is gone.

Then comes another treat before macOS can be installed ASUS BIOS update. After it I had noticed some ACPI errors while booting verbose in CLOVER. I hardly managed to reinstall it and even boot first time. But after the restart of it after install Android Tether driver for macOS(I don't have Ethernet at home), I can't boot it. I don't know what to do what configuration to use, it's new for me to work with such hardware. Also I need some help for post install.

Also I tried to remove FakeSMC and use VirtualSMC, use configs from guides to boot, nothing helps. It either shows errors like in screenshot below, just shows black screen.


There is my CLOVER Setup with dumped ACPI and minimal kexts from Rehabman's Laptop install guide and screenshot from clover bootloader in attachments below:

 

 

clover-log.jpg

CLOVER-INST.zip

Share this post


Link to post
Share on other sites
Advertisement
4 hours ago, newapple4g said:

I had installed Mojave using Rehabman's Laptop guide with UHD630 config file. But now I can't boot Mojave. I tried many variations of config.plist files but nothing works it gets black screen or show error like in attached image file. Also I tried some already build configs, from laptops similar to mine except CPU and AUDIO. But they also don't work. The main difficulty is that my CPU is whiskey lake i7-8565U. I tried to find builds with that build to use correct spoofing configurations but I can't get correct configurations. Somehow I get booted first startup by playing in settings but now I can't boot using the same configuration. I even get full QE/CI but after second boot it gone. Now I just cant boot vanilla Mojave after installation. I have other hackintosh build so I can get it worked if I just need some macOS device.

 

 This is my CLOVER Setup with dumped ACPI and minimal kexts from guide - CLOVER-INST.zip

Configurations that I tried:

 

 

Also I tried VirtualSMC instead of FakeSMC, modified Rehabman's plist, used plist from sources mentioned above without DSDT files, but nothing works. I just wonder how I booted it once. Also I think it can be by ASUS BIOS update (no way to downgrade, but I am not sure if it is the cause),  because I hadn't noticed ACPI errors before it.

 

P.S. Sorry for my bad English

Please read our Rules on why we don't support TonyMac's methods.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×