Jump to content
Spike32

Problemi con trackpad e hdmi

32 posts in this topic

Recommended Posts

Salve a tutti, non so cos'è successo ma ho sempre usato ApplePS2SmartTouchpad per trackpad e tastiera e adesso ha deciso di non funzionare più. Sto provando ad usare VoodooPS2Controller ma neanche funziona.

Inoltre prima il mio notebook lo usavo con un monitor esterno senza problemi via HDMI, e quando chiudevo lo schermo del portatile lo schermo interno si disabilitava mostrando solo quello esterno, adesso anche se lo chiudo resta attivo non capisco il perché.

Qualcuno potrebbe aiutarmi?

debug_16663.zip

Share this post


Link to post
Share on other sites
Advertisement
48 minutes ago, gengik84 said:

cosa hai modificato rispetto a prima?

poi prova voodooPS2 acidanthera...

Non va neanche quello... Comunque ho anche problemi con lo stato della batteria, mi segna che è in carica anche se non lo è e molte volte la percentuale non si aggiorna. So il funzionamento della batteria è strettamente legato con trackpad e tastiera, magari si può provare a risolvere quello e vedere se il trackpad va

Share this post


Link to post
Share on other sites

il trackpad legato alla batteria... questa mi giunge nuova... 

 

sono hack non è magia, un giorno va bene e il giorno dopo magicamente sorgono problemi, ci sono state sicuramente delle cause.

 

come mai è presente nvram.plist? non hai la NVRAM nativa e hai installato gli rc.script???

 

in patched tutti quei file .aml da dove saltano fuori? è farina del tuo sacco o è roba pescata in rete e messa li un po' a caso???

 

tutti i kext li hai in EFI o hai anche della roba piazzata il L/E e S/L/E???

 

ecco cosa fare in caso di problemi

visto il config... grafica attivata sia da properties che da ig-platform e fakeID

 

Tanto per iniziare dalla GUI di clover pigia F11 così resettiamo la NVRAM

poi controlla leggendo questa guida se è nativa o meno e NB prima si rimuovono gli rc.script

 

poi secondo me vi è parecchio da lavorare sulla tua configurazione

 

Share this post


Link to post
Share on other sites
17 hours ago, gengik84 said:

il trackpad legato alla batteria?

 

14 hours ago, iCanaro said:

il trackpad legato alla batteria... questa mi giunge nuova... 

 

sono hack non è magia, un giorno va bene e il giorno dopo magicamente sorgono problemi, ci sono state sicuramente delle cause.

 

come mai è presente nvram.plist? non hai la NVRAM nativa e hai installato gli rc.script???

 

in patched tutti quei file .aml da dove saltano fuori? è farina del tuo sacco o è roba pescata in rete e messa li un po' a caso???

 

tutti i kext li hai in EFI o hai anche della roba piazzata il L/E e S/L/E???

 

ecco cosa fare in caso di problemi

visto il config... grafica attivata sia da properties che da ig-platform e fakeID

 

Tanto per iniziare dalla GUI di clover pigia F11 così resettiamo la NVRAM

poi controlla leggendo questa guida se è nativa o meno e NB prima si rimuovono gli rc.script

 

poi secondo me vi è parecchio da lavorare sulla tua configurazione

 

"battery and trackpad work hand in hand"

Non l'ho inventato io ma l'ho trovato ahaha

Comunque non sono un esperto di hackintosh, se potete darmi una mano a sistemare quello che non va ve ne sono grato

Share this post


Link to post
Share on other sites
14 hours ago, iCanaro said:

il trackpad legato alla batteria... questa mi giunge nuova... 

 

sono hack non è magia, un giorno va bene e il giorno dopo magicamente sorgono problemi, ci sono state sicuramente delle cause.

 

come mai è presente nvram.plist? non hai la NVRAM nativa e hai installato gli rc.script???

 

in patched tutti quei file .aml da dove saltano fuori? è farina del tuo sacco o è roba pescata in rete e messa li un po' a caso???

 

tutti i kext li hai in EFI o hai anche della roba piazzata il L/E e S/L/E???

 

ecco cosa fare in caso di problemi

visto il config... grafica attivata sia da properties che da ig-platform e fakeID

 

Tanto per iniziare dalla GUI di clover pigia F11 così resettiamo la NVRAM

poi controlla leggendo questa guida se è nativa o meno e NB prima si rimuovono gli rc.script

 

poi secondo me vi è parecchio da lavorare sulla tua configurazione

 

la NVRAM è nativa

Share this post


Link to post
Share on other sites

per "farsi" un'hackintosh occorre diventare esperti, non l'ha mica ordinato il dottore o è una questione di vita o di morte :D

 

bene se hai eliminato gli rc.script e nvram.plist e la NVRAM è nativa e l'hai resettata ora come andiamo, è cambiao qualcosa?t

Share this post


Link to post
Share on other sites

 

3 hours ago, iCanaro said:

per "farsi" un'hackintosh occorre diventare esperti, non l'ha mica ordinato il dottore o è una questione di vita o di morte :D

Infatti io sono quì per capire e imparare :)

 

3 hours ago, iCanaro said:

bene se hai eliminato gli rc.script e nvram.plist e la NVRAM è nativa e l'hai resettata ora come andiamo, è cambiao qualcosa?t

Tutto come prima ahahha

Edited by Spike32

Share this post


Link to post
Share on other sites

si però rimane sempre inevasa la domanda come mai prima andava ed a un certo punto ha smesso di andare?

come detto, non è magia ma azioni e reazioni... viene proprio in mente niente????

Share this post


Link to post
Share on other sites

poi io non metto mano a quel che per me è un gran casino... prepara pendrive di emergenza perfettamente funzionante poi eventualmente si potrà rifare una EFI exnovo e vedere se si riesce concludere qualcosa.

Share this post


Link to post
Share on other sites
9 hours ago, iCanaro said:

si però rimane sempre inevasa la domanda come mai prima andava ed a un certo punto ha smesso di andare?

come detto, non è magia ma azioni e reazioni... viene proprio in mente niente????

So bene che non è magia, ma ti posso assicurare che non ho mosso nulla, anche perché se tutto funzionava non vedo il motivo per cui avrei dovuto toccare qualcosa

8 hours ago, iCanaro said:

poi io non metto mano a quel che per me è un gran casino... prepara pendrive di emergenza perfettamente funzionante poi eventualmente si potrà rifare una EFI exnovo e vedere se si riesce concludere qualcosa.

Potresti gentilmente dirmi come mai è tutto un casino?

31 minutes ago, iCanaro said:

Dimenticavo... cosa devi fare TU post installazione

Ora ci do un'occhiata

Share this post


Link to post
Share on other sites

Come immaginavo, il classico accrocchio con kext in EFI, L/E e S/L/E :blink:

se ti becca gengik come minimo ti dice di rifare tutto da capo con il metodo vanilla come da guida che forse si fa prima.

 

Se non vuoi reinstallare exnovo occorre rimuovere tutti i kext aggiuntivi che tu hai messo in L/E e S/L/E

vanno lasciati solo ed esclusivamente in EFI tranne qualche caso particolare, quando li elimini poi prima di riavviare apri terminale e

 

sudo kextcache -i /

 

quelli evidenziati sono una base di partenza... e non ho guardato S/L/E

cmq visto che li hai installati tu, dovresti sapere cosa hai fatto.. credo :lol:

 

 

 

 

Schermata 2019-07-22 alle 11.13.11.png

Share this post


Link to post
Share on other sites
3 minutes ago, iCanaro said:

Come immaginavo, il classico accrocchio con kext in EFI, L/E e S/L/E :blink:

se ti becca gengik come minimo ti dice di rifare tutto da capo con il metodo vanilla come da guida che forse si fa prima.

 

Se non vuoi reinstallare exnovo occorre rimuovere tutti i kext aggiuntivi che tu hai messo in L/E e S/L/E

vanno lasciati solo ed esclusivamente in EFI tranne qualche caso particolare, quando li elimini poi prima di riavviare apri terminale e

 

sudo kextcache -i /

 

quelli evidenziati sono una base di partenza... e non ho guardato S/L/E

cmq visto che li hai installati tu, dovresti sapere cosa hai fatto.. credo :lol:

 

 

 

 

Schermata 2019-07-22 alle 11.13.11.png

Si so di averli installati e so cosa ho fatto, e so anche che è il modo corretto di installare i kexts, in Clover andrebbero lasciati solo quelli "fondamentali".

In /S/L/E ho solo CodecCommander.kext che è l'unico che va lasciato lì...

Non è sbagliato averli tutti in Clover?

Share this post


Link to post
Share on other sites

sono stili o filosofie differenti che se fatte a modo hanno una loro logica, ma NON è il tuo caso, tu hai solo del casino con gli stessi kext messi un po' ovunque e così facendo si sovraccarica il kernel e si possono ingenerare problemi casuali.

 

Io come filosofia uso tutti i kext in EFI e ciò mi permette grande libertà e maneggevolezza, nel senso che posso cambiare setup al volo aggiungendo/rimuovendo kext dalla EFI e inoltre il macOS installato posso clonarlo su qualsiasi altro hack, settare la EFI in maniera corretta e questi poi parte sul nuovo hardware cose se fosse stato appena installato... non so' se hai vagamente capito la libertà che si ha con i kext in EFI.

Vedi hack in firma e non li ho messi tutti in quanto ho finito righe e caratteri :shock::hysterical: sono tutti strutturati in questo modo.

 

Poi va benissimo mettere i kext in L/E e S/L/E (da catalina qui NON sarà più possibile metterli) basta che uno sappia cosa stà facendo e se fatto a modo si ottiene egualmente un bell'hack efficiente e funzionale.

Share this post


Link to post
Share on other sites
9 minutes ago, iCanaro said:

sono stili o filosofie differenti che se fatte a modo hanno una loro logica, ma NON è il tuo caso, tu hai solo del casino con gli stessi kext messi un po' ovunque e così facendo si sovraccarica il kernel e si possono ingenerare problemi casuali.

 

Io come filosofia uso tutti i kext in EFI e ciò mi permette grande libertà e maneggevolezza, nel senso che posso cambiare setup al volo aggiungendo/rimuovendo kext dalla EFI e inoltre il macOS installato posso clonarlo su qualsiasi altro hack, settare la EFI in maniera corretta e questi poi parte sul nuovo hardware cose se fosse stato appena installato... non so' se hai vagamente capito la libertà che si ha con i kext in EFI.

Vedi hack in firma e non li ho messi tutti in quanto ho finito righe e caratteri :shock::hysterical: sono tutti strutturati in questo modo.

 

Poi va benissimo mettere i kext in L/E e S/L/E (da catalina qui NON sarà più possibile metterli) basta che uno sappia cosa stà facendo e se fatto a modo si ottiene egualmente un bell'hack efficiente e funzionale.

Ok si in fatto di mobilità e maneggevolezza assolutamente, però il sistema operativo nativamente vuole i kexts in /L/E per vari motivi, quali sicurezza, stabilità, funzionamento, ecc...

Infatti se in macOS installi i driver di un qualche hardware esterno questi automaticamente andranno in /L/E.

Non fraintendere, non sono qui per fare il professore che ti fa la lezione, è solo quello che so essere corretto...

Detto questo, perché NON è il mio caso? Nel senso, i miei kexts sono in /L/E, cosa c'è di sbagliato?

Altra domanda, se faccio questo cambio e li metto tutti in EFI dovrei risolvere? Non credo

Edited by Spike32

Share this post


Link to post
Share on other sites

tutte palle... ovvio che applicativi e software vari se necessita installeranno i kext in L/E ma qui stiamo parlando di kext per adattare l'hardware a macOS e se iniettati da EFI è molto ma molto meglio.

 

Poi si vede che non hai capito bene.. basta che apri i report di hack_info e lo vedi da solo hai gli stessi kext in EFI e L/E e non ho controllato S/L/E

 

Doppi o tripli NON va bene... devi caricare 1 kext e basta e se lo fai da EFI poi è molto più agevole apportare modifiche e migliorie piuttosto che installarli per poi magari dooverli rimuovere e ricostruire la kextcache

 

se tu poi sei convinto... io non ho obiezioni, prova a farlo andare a modo a chiacchere l'hack invece di cercare di operare una qualche scelta :P:angel:

 

 

Share this post


Link to post
Share on other sites
2 minutes ago, iCanaro said:

hai gli stessi kext in EFI e L/E

Certo che alcuni sono duplicati, per quanto ne so quelli "fondamentali" vanno lasciati in entrambi i posti.

3 minutes ago, iCanaro said:

prova a farlo andare a modo a chiacchere l'hack invece di cercare di operare una qualche scelta

Preferisco prima "chiacchierare" per capire invece di "operare" senza sapere nulla.

7 minutes ago, iCanaro said:

e non ho controllato S/L/E

Ti ripeto, in /S/L/E ho solo CodecCommander.kext che è quello il suo posto.

5 minutes ago, iCanaro said:

tutte palle...

...kext's installed in /L/E are loaded into MacOS's kernel memory... Everything running in kernel memory (including kexts) is actively managed and monitored by MacOS...

 

Ad ogni modo, faccio questa prova, li metto tutti in EFI e ti faccio sapere
 

Share this post


Link to post
Share on other sites

La cosa strana è che nelle impostazioni del trackpad mi fa vedere tutte le opzioni, quindi in qualche modo qualcosa la sta facendo il kext 

Screenshot 2019-07-22 at 18.39.14.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

×