Jump to content

1,149 posts in this topic

Recommended Posts

Posted (edited)

First beta... macOS Catalina 10.15 beta (19A471t)  Release Notes!!!

 

Useful information:

 

macOSDeveloperBetaAccessUtility.dmg.zip (thanks to gengik84)

Clover r4945 (thanks to Cyberdevs)

Lilu_plugins (thanks to gengik84)

Port Limit Patch (thanks to daliansky)

older non metal nVidia and Intel cards (thanks to fusion71au)

MBR installation on macOS Catalina (thanks to crazybirdy) - workaround!!!

Mac Downloader (thanks to ricoc90)

 

Edited by gengik84
Added Mac Downloader

Share this post


Link to post
Share on other sites
Advertisement

Discord channel is up just for the os on the IM discord 

Share this post


Link to post
Share on other sites
2 minutes ago, Wayang-NT said:

1273157554_ScreenShot17.thumb.png.c8afa82aaf5c45ad3024653421d743cf.png

Waiting for someone to publish the developer beta utility on a public site.

 

Share this post


Link to post
Share on other sites

Our discord has the tool lets start!

Share this post


Link to post
Share on other sites

downloading now on my hack, praying it works still running clover..

Share this post


Link to post
Share on other sites

hi...

is this script valid for the "Catalina" ?

 

curl -O https://raw.githubusercontent.com/Gengik84/MacOS_Updater/master/MacOS_Updater && chmod +x ./MacOS_Updater && sh ./MacOS_Updater

 

c.frio

Share this post


Link to post
Share on other sites
Posted (edited)

Hey guys, I’m on the business trip and nowhere near a computer can any of you check if the cpu_max_limit of 64 cores is still there in the kernel?

Edited by Balamut

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, TheRacerMaster said:

Extracted from InstallESD.dmg/Packages/Core.pkg:

kernel.zip

Thanks a lot!

 

9 hours ago, Riley Freeman said:

Well, kext injection usually breaks with major OS versions. Mojave was pretty quick to get up and running last year. Hopefully it won't take long to fix Catalina.

EDIT: Please see https://sourceforge.net/p/cloverefiboot/code/4938/

 

Looks like the logic has slightly been changed, please try this kernel patch (temporarily) with Clover KernelToPatch:

 

find

00 85 C0 0F 84 87 00 00 00 49

 

repl

00 85 C0 90 90 90 90 90 90 49

 

Hopefully Clover kext injection works after patching, if it does, I will update the source.

Edited by PMheart

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By eliot6001
      I don't know whether my LAN device will work on MAC and Which version of mac but i still want to run MAC on my PC, Also i checked my CPU-GPU and it turned out that i can Run MAX High sierra but i realized that some people have trouble with Sound and Internet connection so Here's the NAME of my LAN device:
       
      PCI\VEN_10EC&DEV_8136&SUBSYS_012310EC&REV_05\4&45F2A70&0&00E1 as (LAN DEVICE took the name from device manager in  windows). 
      also from compatibleIds i got this:
      PCI\VEN_10EC&DEV_8136&REV_05
       
      Is it Supported on any version of macOS ?
    • By Aldaro
      I have been running macOS Mojave on my system for 3 months and everything was working pretty well.  After taking an update for clover, my entire system got wrecked, and I cannot even boot to an installation environment anymore (which I really need to do since I am starting back at square one).  I still have the old EFI folder backed up, but I know it'll only be a matter of time before Apple introduces an update that requires me to update Clover in order to work correctly.  I have tried all the available memory fixes, but none of them seem to work.  I was previously using the original osxaptiofix; so, I gave v2, and v3 a try, but to no success.  I read somewhere on the main discussion board for clover that AptioMemoryFix was no longer going to be supported and I therefor decided to skip over it (not to mention it isn't even available in newer clover installation packages).
       
      System specs:
      Motherboard: GIGABYTE Z390 M GAMING
      CPU Intel core i5 9600k @ stock 3.7GHz
      RAM 32GB DDR4 2667MHz
      GPU AMD Radeon RX 580 with 8GB of GDDR5
      SSD Intel 660p 512GB NVME
      NIC: Intel i210 10/100/1000 as it is natively supported in macOS
       
      I have been using the iMac 19,1 SMBIOs as I built this machine to match it as close as humanly possible.  As for my UEFI settings, I did the usual:
      Disabled Windows specific features and secure boot
      Enabled XHCI hand off
      Enabled Above 4G decoding
      Disabled onboard NIC since it is made irrelevant by my intel i210
       
      --INJECT KEXTS--
      FakeSMC
      Lilu
      WhateverGreen
      AppleALC
      USBInjectAll -- WITH PATCHED SSDT in /EFI/CLOVER/ACPI/patched
      Below are images of the errors I am receiving when trying to boot the macOS Mojave installer.
       
      with original osxaptiomemoryfix

       
      osxaptiofixv2

       
      osxaptiofixv3

       
      Anyway, if somebody can help me figure out what's going on, that'd be greatly appreciated.  My ultimate goal is to get an install with minimal clover patches as to be better prepared when the winds of change from Apple come roaring.
       
      p.s: I have also attached a copy of my EFI folder
       
       
      EFI.zip
    • By kalpesh2804
      Laptop Inbuilt Wifi and Battery Indicator not working in Catalina. (HP Pavilion 15t-au 100 Laptop)
       
       
      Laptop Config:
      HP Pavilion 15t-au100 * i7-7500u 2.90Ghz * Intel HD 620 Graphic Adapter * Intel Dual Band Wireless AC-3168 * Kingston SATA3 SSD 500 GB * HP Camera
×