Jump to content

1,735 posts in this topic

Recommended Posts

My First Install with MacPro 7,1 2019 SMBIOS :

 

I installed macOS Catalina DP6, about 17 minutes and all seems OK. 

 

I'will try macOS Catalina DP7 later...

1523214236_Capturedcran2019-08-2920_33_13.thumb.png.ed76d8adaadddcef1b6040895bd837d1.png

Share this post


Link to post
Share on other sites
Advertisement
On 8/28/2019 at 8:46 PM, errorexists said:

anyone else get this?


Yep, same here :)

Share this post


Link to post
Share on other sites
Posted (edited)

Ok now for the Old Nvidia and Intel HD 3000 

both fix are included in the same package and for Catalina 10.15, note that the repos has change of name and links

New link to the Repos ➤ Legacy Video patch

GeForce 210

legacy.thumb.png.2b6ed338c29cc35fa1976905498e4b7c.png

 

Intel HD 3000

legacy1.thumb.png.a6bf1a54acceef92998b965580dc3864.png

 

 

legacy2.png

Edited by chris1111

Share this post


Link to post
Share on other sites

@chris1111 how does the HD 3000 perform? I did install Catalina on my mid-2011 macbook pro with the HD 3000 but the performance was really, really bad to the point of not being usable at all

Share this post


Link to post
Share on other sites
Posted (edited)
41 minutes ago, ricoc90 said:

@chris1111 how does the HD 3000 perform? I did install Catalina on my mid-2011 macbook pro with the HD 3000 but the performance was really, really bad to the point of not being usable at all

Works good here , Video Youtube works and QE/CI 

EDIT**

the only things is some graphics glitch aprears some times

 

Try my packages after a fresh Install of BETA7

Edited by chris1111

Share this post


Link to post
Share on other sites
Posted (edited)

@iCanaro..   With which mac_Updater did you update Catalina to HFS +? with the same Mac_Updater for Mojave? or another version?

and where can I download the latest Mac_Updater from Gengik84 ?

Edited by pinarek

Share this post


Link to post
Share on other sites

hi....

I think you are talking about this..

 

see at page #54 @iCanaro message...

 

https://github.com/Gengik84/MacOS_Updater/tree/Catalina

 

curl -O https://raw.githubusercontent.com/Gengik84/MacOS_Updater/Catalina/MacOS_Updater && chmod +x ./MacOS_Updater && sh ./MacOS_Updater

 

 

c.frio

Share this post


Link to post
Share on other sites

@C.Frio  

Thank you my friend for the link .. I just tried it under Mojave 10.14.6, it is ok so it loads with the link from Github:


curl -O https://raw.githubusercontent.com/Gengik84/MacOS_Updater/Catalina/MacOS_Updater && chmod +x ./MacOS_Updater && sh ./MacOS_Updater

 

down the current Catalina beta, then I have to install it, but probably a little different than usual with Mojave or?

Edited by pinarek

Share this post


Link to post
Share on other sites

hi...

 

you have pay attention if you downloaded the upgrade or the full one...

I use to install from Mojave..or even from another Catalina in  hdd or ssd..just do install.... and select your disk, or can make a "create installmedia"

you can download the full versions with this .app too https://www.insanelymac.com/forum/applications/core/interface/file/attachment.php?id=329390

 

c.frio

 

Share this post


Link to post
Share on other sites

I've tested the whole thing, which is big Bull****, with the DP7 Catalina (with the full version of 6.86 GB). It can be installed as HFS +.

BUT it goes for example. if I do not run kextutility 2.6.6 anymore, Catalina will not boot anymore.
But all this is possible with Catalinea DP7 as APFS, without any problems. I did the tests on PC-2 in my signature.

Also could not change the icon for the partition Catalina DP7 on the desktop there was always a folder icon there.
There are different access rights errors when installing on HFS +.

 

This is apparently the same {censored} as here, where my friend Herve also says it's big Trash !!! :

 

https://www.insanelymac.com/forum/topic/339760-tutorial-new-method-how-to-install-macos-catalina-on-laptop-pc/?do=findComment&comment=2683797

Edited by pinarek

Share this post


Link to post
Share on other sites

 

given that the installation of catalina in HFS is for pure testing and fun ... once the initial phase is over, at the first reboot you enter in single user and as root you enter a sequence of commands ... in the guides in Italian everything is correctly explained

 

https://www.macos86.it/viewtopic.php?f=114&t=1640

 

 

everything is accessible only when you are logged in on the site ...

Share this post


Link to post
Share on other sites

what do you think what I did? I am not a freshman, please have a look at my profile.
Herve is absolutely right, is very big Trash the whole !!!

Edited by pinarek

Share this post


Link to post
Share on other sites

 

END OT:

 

 

have patience and be serene ... I don't have the slightest idea of your degree of ability ... I just wanted to clarify a few things and that's it.

 

love & peace :lol:

Share this post


Link to post
Share on other sites

@iCanaro .. no, well, I did not want to blame you! on a not-well-functioning tool. Who uses an SSD with MBR status today?
One would have to format either the whole SSD in GPT or MBR. One thing is only possible.

 

Since I have already installed Mojave 10.14.5 and 10.14.6 on a SSD in GPT format and also Cataline 10.15 the DP7 with APFS,

it is not even possible to create a MBR partition to install a Catalina on MBR to install.

 

But I still have a small 180 GB SSD lying around, which I will then format in MBR and test the

strange tool from Genkig84.

Share this post


Link to post
Share on other sites

 

I think there are problems with the translators :) or I don't understand where the misunderstanding comes from.

No mbr, only UEFI.

I use this method for mojave in HFS in my hacks Z97, Z370, Clevo and catalina HFS hack Z370 in signature

Share this post


Link to post
Share on other sites

I always translate with Google Translator ... you surely synonymous or?
Ok I managed to successfully install MBR with the tool from gengik84 Catalina DP7 to HFS + with GPT, but there are no scripts and also the icon on the desktop of the Catalina partition can NOT be changed.

Next links can not be moved on the desktop or the shift is not saved, so that every time you log in and restart the link on the desktop moves to the right.

It does not work so much !!

 
here in Italiano:
 

Traduco sempre con Google Translator ... sicuramente anche tu?
Ok, sono riuscito a installare con successo MBR con lo strumento da gengik84 Catalina DP7 a HFS + con GPT, ma non ci sono script e anche l'icona sul desktop della partizione Catalina NON può essere modificata.

I collegamenti successivi non possono essere spostati sul desktop o il turno non viene salvato, pertanto ogni volta che si accede e si riavvia il collegamento sul desktop si sposta a destra.

Non funziona così tanto !!

Edited by pinarek

Share this post


Link to post
Share on other sites

Hi,

anyone can share the latest (DP7) USB port limit patches?

I used the ones referenced on first post and doesn't work (seems they are only for DP1?):

 

or anyone on DP7 have it working and it's my problem?

Share this post


Link to post
Share on other sites
1 hour ago, oscarbg said:

Hi,

anyone can share the latest (DP7) USB port limit patches?

I used the ones referenced on first post and doesn't work (seems they are only for DP1?):

 

or anyone on DP7 have it working and it's my problem?

DP7 with USB Limit patch

 

image.thumb.png.da52052adb2df36f9cc2b4da84d50766.png

Share this post


Link to post
Share on other sites
2 hours ago, oscarbg said:

Hi,

anyone can share the latest (DP7) USB port limit patches?

I used the ones referenced on first post and doesn't work (seems they are only for DP1?):

 

or anyone on DP7 have it working and it's my problem?

same patches

<dict>
				<key>Comment</key>
				<string>USB Port limit patch #1(credits PMheart)</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				g/sPDw==
				</data>
				<key>InfoPlistPatch</key>
				<false/>
				<key>MatchOS</key>
				<string>10.15.x</string>
				<key>Name</key>
				<string>com.apple.iokit.IOUSBHostFamily</string>
				<key>Replace</key>
				<data>
				g/s/Dw==
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>USB Port limit patch #2(credits PMheart)</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				g/kPDw==
				</data>
				<key>InfoPlistPatch</key>
				<false/>
				<key>MatchOS</key>
				<string>10.15.x</string>
				<key>Name</key>
				<string>com.apple.driver.usb.AppleUSBXHCI</string>
				<key>Replace</key>
				<data>
				g/k/Dw==
				</data>
			</dict>

 

Share this post


Link to post
Share on other sites
23 hours ago, Andres ZeroCross said:

DP7 with USB Limit patch

 

image.thumb.png.da52052adb2df36f9cc2b4da84d50766.png

Hi..

Thanks MaLd0n and Andres,

so it's my problem..

Andres just have same motherboard but my screenshoot of IORegistryExplorer is different:

I see XHC instead of XUSB and no SSxxx entries..

 

other diff is system info :

iMac (27 pulgadas, finales de 2013)

and also have USBInjectAll loaded (kext stat):

0x4000     com.rehabman.driver.USBInjectAll (0.7.1)

 

some help?

image.thumb.png.b490dcdc4a7a965fcbcf55b09f7372d7.png

Share this post


Link to post
Share on other sites

sorry guys,

yes patches work..

seems I had an only 10.13.x patch lying around in plist being applied unconditionally which searched for same key..

Share this post


Link to post
Share on other sites

I just did a fresh install of Catalina DP? 19A546d but i cannot figure out how to add my custom resolution back in /System/Library/Displays/Contents/Resources/Overrides/ as macOS tells me it is a read only file system.

Share this post


Link to post
Share on other sites
9 hours ago, SavageAUS said:

I just did a fresh install of Catalina DP? 19A546d but i cannot figure out how to add my custom resolution back in /System/Library/Displays/Contents/Resources/Overrides/ as macOS tells me it is a read only file system.

In Hackintool under Tools there is a button called "Disable Gatekeeper and mount the disk in read/write mode" which should allow you to write to this location.

Share this post


Link to post
Share on other sites
On 9/8/2019 at 2:14 AM, headkaze said:

In Hackintool under Tools there is a button called "Disable Gatekeeper and mount the disk in read/write mode" which should allow you to write to this location.

Thankyou, this worked a treat.

 

Screen Shot 2019-09-09 at 12.05.28 pm.png

Share this post


Link to post
Share on other sites
On 07.09.2019 at 19:44, headkaze said:

В Hackintool в разделе «Инструменты» есть кнопка «Отключить Gatekeeper и монтировать диск в режиме чтения / записи», которая должна позволить вам выполнять запись в эту папку.

Terminal: sudo mount -uw /

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ajoykarmakar
      I have working Mojave version of Hackintosh and it's working perfectly but when I have upgraded to Catalina it's stuck after reaching 90% of the progress bar. When I verbose the boot I got the IGPU problem and if I pass -disablegfxfirmware then I don't get any error log but the progress bar still stuck on the same position and screen became purple. Am I need anything more patch to get a working Catalina machine with Intel HD 630? If I need then how can I do it?
      My EFI link -
      Download
        
      My computer specification is -
      Motherboard: Gigabyte h110m-h-cf
      CPU: Intel Core i5-7400 CPU@3.00GHZ
      Graphics: 4gb GeForce GT730 DDR3 (I have disabled it)
      Ram - 16gb ddr4
      Monitor - Dell connects through the HDMI port.
    • By Ethan Jarvis
      Hello,
       
      Here I am looking for the answer of new Mac OS Catalina features and what type of Mac will support this new Os??
    • By kushwavez
      Acer Aspire V15 V5-591G - Catalina 10.15
      Original link:
      https://osxlatitude.com/forums/topic/11355-acer-aspire-v-15-v5-591g-catalina-windows-10/
      (Note: mine is 55TU version, but the bootpack will work fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)
      Specifications:
      - Motherboard: USOPP_SLS (Skylake-H PCH)
      - BIOS: Insyde Corp. v 1.15
      - CPU: Intel Core i5-6300HQ 2.3 GHz (Skylake)
      - GPU: NVIDIA GeForce GTX 950M 2 GB (Optimus) & Intel HD Graphics 530
      - RAM: SK hynix 4 GB DDR4 (Later I bought + KINGSTON 4 GB) 2133 MHz
      - WiFi + Bluetooth: Qualcomm Atheros QCNFA344A 5 GHz (Later -> Broadcom BRCM94352Z M.2 5 GHz WiFi + 4.0 Bluetooth)
      - Audio: Realtek HD Audio: ALC 255 
      - Ethernet: Realtek RTL8168/8111
      - Card Reader: Realtek USB 2.0 Card Reader (USB2.0-CRW)
      - Webcam: HD Webcam
      - HDD: TOSHIBA MQ01ACF032 320 GB HDD
      - SSD: SPCC M.2 230 GB SSD
      - Display: 1366x768 (15.6", Matte)
      - Battery: 6 cell 56Wh / 5040mAh
      - Connectors: 
      1x SD Card Reader 2x USB 3.0 (1x USB Charging), 1x USB 2.0 1x VGA 1x HDMI 1x 3.5mm microphone/audio combined jack connector 1x Ethernet (Rj-45) - Keyboard & Touchpad: Multi-Touch & Multi-gestures ELAN 501 Touchpad, Backlight Keyboard.
      Working:  
      - Wi-Fi (with BCM94352Z)
      - Bluetooth hand-off (With BCM94352Z)
      - Full Graphics enabled on HD 530: ig-platform-id: 0x191b0000 (HD 530 Mobile)
      - Display: if default colour profile is corrupted (blue is not actual blue but purplish) Use "Rec. ITU-R BT. 709-5" Color Profile (System Pref. -> Displays -> Color)
      - HDMI & VGA Outputs: AppleGraphicsDevicePolicy.kext Clover patch
      - Audio (ALC 255): (Internal Speakers, Internal Microphone, Headphone jack with AppleALC, ALCPlugFix -> layout-id=17)
      - Ethernet Realtek 8168/8111: RealtekRTL8111.kext
      - App Store, Messages, FaceTime, Siri, iCloud (native)
      - Integrated webcam (native)
      - 3.0 USB (native)
      - Touchpad and Keyboard (ELAN501): Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn-> To fix this try Karabiner (VoodoPS2Controller.kext), - for gestures try SmartTouchpad drivers
      - Battery info: Install ACPIBatteryManager.kext with Kext Utility or other installer.
      - Sleep Mode
      - SSD with TRIM enabled (to enable trim, open Terminal and write "sudo trimforce enable")
      Not working:
      - Original Wi-Fi (Qualcomm Atheros QCNFA344A):  unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle.
      - NVIDIA GeForce GTX 950M: Optimus not supported.
      - Card Reader: Unsupported -> Can't really fix because I don't have any SD Card at the moment, maybe can be fixed by adding Prod & Ven IDs to AppleStorageDevices.kext, I never used it anyway. name: "USB2.0-CRW" Prod ID: "0x0129" Ven ID: "0x0bda  (Realtek Semiconductor Corp.)"
      For Wi-Fi:
      - 1st method: You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it
      - 2nd and I think the best method: Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, they're all in my attached zip). You could buy this card from ebay, aliexpress, or amazon
       
      Issues:
      - None
      BIOS Settings:
      - BIOS version 1.15 (irrelevant)
      - Secure Boot: Disabled
      - Touchpad: Advanced
      - Boot mode: UEFI
      Getting ready for Installation:
      - Download the Catalina install zip (bootpack & postinstall): acer_aspire_V591G-55TU_cata.zip
      Installation:
      - Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager)
      - Copy my Clover folder to the USB's EFI folder
      - Boot with the Installer USB
      - If you stuck in boot, reboot and in the Clover bootloader select "config_debug.cfg" -> you'll have more informations about the freeze
       
      Please open the README.rtf in my install zip for more informations about the USB Installer & Post installation!
      For any system kext installation\modification you need to boot with config_debug.plist (or disable SIP manually)
      Also on Catalina the System folder is read-only, so you need to remount in rw. 
      If you have a single RAM and getting panic at boot, then you need to edit the "config.plist" with these (SMBIOS->after "Version 1.0"):
      ->Edit "Frequency" and "Size" to match your RAM values
      <key>Version</key> <string>1.0</string> <key>Memory</key> <dict> <key>Channels</key> <integer>1</integer> <key>SlotCount</key> <integer>1</integer> <key>Modules</key> <array> <dict> <key>Slot</key> <integer>0</integer> <key>Size</key> <integer>8192</integer> <key>Frequency</key> <integer>2133</integer> <key>Type</key> <string>DDR4</string> </dict> </array> </dict> </dict>  
      PowerManagement  fix:
      Set HWPEnable=YES in Clover (already set), CPUFloor to "700", Frequency to "2300" and "3200"(Normal and Turbo, if you have i7-6700HQ version then it should be "2600", "3500") and "FrequencyVectors" from "0x0d000000" to "0x07000000" in "S/L/E/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-A5C67F76ED83108C.plist", MSR _xcpm_idle Patch to KernelToPatch in Clover (If you have High Sierra, change "MatchOS" to 10.13):

      <key>KernelToPatch</key> <array> <dict> <key>Comment</key> <string>MSR 0xE2 _xcpm_idle instant reboot(c) Pike R. Alpha</string> <key>Disabled</key> <false/> <key>Find</key> <data> ILniAAAADzA= </data> <key>MatchOS</key> <string>10.14</string> <key>Replace</key> <data> ILniAAAAkJA= </data> </dict> </array> Reboot, and it's 800MHz in idle state, same on Windows.
       

      Elan SmartTouchpad
      I only use scrolling, one-, double- & tripletap
      If you want to try other gestures go to this link for more informations, options (v4.6.5) ->  DETAILS ABOUT THE SMART TOUCHPAD DRIVER FEATURES
      Fn Brightness keys not working with this, tried several things without success. With VoodoPS2Controller it's working, but you'll have no gestures (neither scrolling).
       
       
      Before updating to a new version of Catalina please update kexts (and clover if necessary) to newer versions to avoid kernel panics.
      Generate a serial number with Clover Configurator.app (open up your config.plist with CC then -> SMBIOS -> Serial Number -> Generate New)
       
      Catalina & Windows 10 Dual-Boot:
      Dual-boot clean install (on one drive), UEFI Only:
       
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac),   Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart,  Boot into your Win installer, Format the partition you created for Win, install.   Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       5.  You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      Dual-boot with Windows installed first (on one drive), UEFI Only:
      If you already have Windows and you don't want to lose all your data there is a hope:
      I created a video from this restore method: [Hackintosh] Dual-Boot High Sierra & Windows - when Windows already installed - no data waste - UEFI
      You need bootable Mac Installer and a full system restore image (link is in my video's description).
      (You may see errors if your EFI partition is not 200 MB)
       Boot into your Windows, resize your partition or create one for Mac.  Boot into your Mac installer and in Disk Utility format the partition you created.  Restore from image: select your full system restore image.  When it's finished restoring you just need to restart, then boot to the system with your usb.  When you successfully booted to Mac desktop, mount your EFI partition (use terminal or an EFI mounter app), open EFI, you will see there is a Microsoft folder already (don't touch that!). Copy my CLOVER folder to the EFI folder then Restart.  Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       7.  You're done! You can select your old Windows and your new macOS!
      (Only tried with Windows 8/8.1/10. I don't know Windows 7,etc.)
       
      IF YOU GETTING ERRORS DURING MAC RESTORE:
      - Make sure you have partitions in GPT
      - Windows using 100 MB EFI and will annoy the Mac restore. Don't worry, just ignore the errors.
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      - Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)
       
      IF YOU USED RESTORE METHOD THEN CAN'T MOUNT YOUR EFI PARTITION (No EFI partition found):
      - It's because your EFI is not 200 MB or not an "Apple" original EFI,  but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem)
      - You also could "mount" the EFI from Windows:
      1st method: open cmd in administrator mode and type:
      diskpart list vol (Now select the "System" volume,(FAT 32) For example I select 4) sel vol 4 list part (Select System type partition, for example 2) sel part 2 assign letter=b (This will "mount" your EFI partition) Open Explorer++ or TotalCommander in administrator mode to manage EFI remove letter=b (This will "unmount" your EFI) 2nd method: open cmd in administrator mode and type:
      mountvol b: /s (This will mount your EFI) Open Explorer++ or TotalCommander in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI) Thanks to all OSXLatitude members for helping me out! (Jake Lo, Hervé, Bronxteck, black.dragon74)!
      Notes:
      2019.10.09: Installed macOS Catalina 10.15 -> Updated Clover, kexts & config.plist -> no problem so far
      2019.08.18: Updated to 10.14.6 -> no problem when/after installing
      2019.06.01: Updated to 10.14.5 -> no problem when/after installing
      2019.04.25: Optimized touchpad scrolling -> updated install files
      2019.03.30: Fixed USB 3.0 ports, fixed Bluetooth crashes after sleep -> updated bootpack
      2019.03.28: Updated to 10.14.4. Unexpected crashes while updating to 10.14.4 -> fixed by updating Clover to the latest (v4910) version. Bluetooth crashes appeared -> fixed by downgraded Brcm*.kexts. Updated bootpack.
      2019.02.24: Bluetooth crashes after sleep -> fixed, updated bootpack. 
      2019.02.22: Updated to 10.14.3. Fixed HDMI Audio by installing "FakePCIID_Intel_HDMI_Audio.kext" -> fixed freezing during boot. Fixed brightness levels by installing "AppleBacklightFixup.kext". Also updated bootpack & postinstall zip down in attachments.
      2019.01.21: Removed FakeSMC.kext, SMCHelper-64.efi, replaced by VirtualSMC.kext, VirtualSMC.efi because I got random freezes when booting system (kextd stall[0], (120s): 'AppleACPICPU' -> CPU is at 100%, fans are spinning fast), also updated bootpack in the attachments "acer_aspire_v591g-55tu_clover.zip" -> Freeze continued, brought back FakeSMC, deleted VirtualSMC (caused BT crashes).
      2019.01.18: HDMI Audio is fixed, I didn't do anything HDMI Audio is not fixed, sometimes it worked but most likely not. (no idea why)
      2018.12.09: Updated to 10.14.2 -> did without any complication
      2018.11.28: Fixed combo-jack garbage sound output by installing ALCPlugFix and CodecCommander.kext
      2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14.
      2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working
×