Jump to content
About Just Joined group Read more... ×
fantomas

[pre-release] macOS Catalina

1,709 posts in this topic

Recommended Posts

Just now, Sherlocks said:

 

in installer boot?

did you try all kexts except fakesmc?

also try some disabled your custom ssdt

ivy system?

in Install Update or Installer boot

its the same blocking

I try only FakeSMC

Yes Ivy system Intel HD 4000

Share this post


Link to post
Share on other sites
Advertisement
in Install Update or Installer boot
its the same blocking
I try only FakeSMC
Yes Ivy system Intel HD 4000
PCI Configuration issue?
when checked screenshot, most of screenshot show stop after PCI part.
also can't see "DSMOS has arrived" message

나의 SM-N960N 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

In my HP EliteBook 2570p with Catalina Beta 5 no problem, the installation and boot-up was ok, and everything is working.

 

But in my desktop build I have the same problem as chris1111 and others, it seems to stuck in PCI Configuration end and the hard disk is idle.

I have no idea with Beta 5 in Desktop, because as others the Beta 4 was ok.

 

 

 

Captura de pantalla 2019-08-01 a las 15.21.37.png

Captura de pantalla 2019-08-01 a las 15.16.30.png

Edited by asdesoso

Share this post


Link to post
Share on other sites
10 minutes ago, Sherlocks said:

also can't see "DSMOS has arrived" message


Because it doesn't get that far. It hangs before the Mac Framework gets a chance to initialize.

I took a screenshot from a successfull DP4 boot to compare. DP5 hangs at the apfs_module_start line

IMG_2826_2.thumb.png.9ba6e4238cc98132f7ada17dec307847.png

Share this post


Link to post
Share on other sites
8 hours ago, Matgen84 said:

Hi @MaLd0n

 

I try your EFI folder (with and without SSDT6) on my Aorus Master. I don't have USB2 port active, USB2 device connected in USB3 don't appears in Catalina Finder and in Terminal. Problem my combo (Keyboard+mouse) is connected in Rear USB2 port.

 

Sorry for my poor english

 

 

don't use it, is a z390 gaming

Share this post


Link to post
Share on other sites

@chris1111 I got mine booting:

  1. I blocked the injection of any kext other than Lilu+VirtualSMC
  2. I Removed the DSDT and SSDT
  3. Unplugged all HDDs other than macOS

Share this post


Link to post
Share on other sites
1 minute ago, ricoc90 said:

@chris1111 I got mine booting:

  1. I blocked the injection of any kext other than Lilu+VirtualSMC
  2. I Removed the DSDT and SSDT
  3. Unplugged all HDDs other than macOS

I wil try that thanks ;)

Share this post


Link to post
Share on other sites
46 minutes ago, MaLd0n said:

don't use it, is a z390 gaming

 

Thanks :) How to have equivalent from your EFI Folder with DSDT+SSDT for my Z390 Aorus Master mobo (BIOS F9). 

a iMac19,1 properties that work a real native without whatevergreen, etc

 

 

Edited by Matgen84

Share this post


Link to post
Share on other sites
18 minutes ago, chris1111 said:

I wil try that thanks ;)


I'm going to install it on my probook now

Edit: install done on my Precision. Turns out removing DSDT+SSDT was sufficient, no need to block the injection of kexts
1575223033_Schermafbeelding2019-08-01om16_55_06.png.cb79eb39e6ee8d5afb42d57822ce7e45.png
 

Edited by ricoc90

Share this post


Link to post
Share on other sites
3 hours ago, chris1111 said:

in Install Update or Installer boot

its the same blocking

I try only FakeSMC

Yes Ivy system Intel HD 4000

check ur Embedded Controller Device, PNP0C09 and rename it to EC, Skylake+ need inject usbx with correct properties, skylake- just rename or create device(create only if u don't see AppleACPIEC load)

 

change EC0 to EC
4543305f 
45435f5f 

change H_EC to EC
485f4543 
45435f5f 

change ECDV to EC
45434456 
45435f5f

 

Share this post


Link to post
Share on other sites
26 minutes ago, MaLd0n said:

check ur Embedded Controller Device, PNP0C09 and rename it to EC, Skylake+ need inject usbx for correct properties, skylake- just rename or create device(create only if u don't see AppleACPIEC load)

 


change EC0 to EC
4543305f 
45435f5f 

change H_EC to EC
485f4543 
45435f5f 

change ECDV to EC
45434456 
45435f5f

 

I alway see AppleACPIEC load on that machine

 

Please take a look to my DSDT

 

 

Edited by chris1111

Share this post


Link to post
Share on other sites
3 minutes ago, chris1111 said:

I alway see AppleACPIEC load on that machine

 

Please take a look to my DSDT

 

patched.zip

use ec0 to ec patch

 

change EC0 to EC
4543305f 
45435f5f

 

Share this post


Link to post
Share on other sites
Just now, MaLd0n said:

use ec0 to ec patch

 


change EC0 to EC
4543305f 
45435f5f

 

Iam not an expert DSDT like you :D

 

please take a look to my DSDT 

Share this post


Link to post
Share on other sites
2 minutes ago, chris1111 said:

Iam not an expert DSDT like you :D

 

please take a look to my DSDT 


It's a Clover patch. Add it to Clover->ACPI :)

Share this post


Link to post
Share on other sites
6 minutes ago, ricoc90 said:


It's a Clover patch. Add it to Clover->ACPI :)

Ok sorry I am tired almost all night to trying to fix this 

Share this post


Link to post
Share on other sites
24 minutes ago, MaLd0n said:

change H_EC to EC 485f4543 45435f5f


Works on my Precision T1700, thanks buddy :thumbsup_anim:

Share this post


Link to post
Share on other sites
55 minutes ago, MaLd0n said:

notebook need use clover/oc for some renames, have a SSDT dependencies and bootloaderr rename it in all tables

You are the MAN :yes: :D

 

Thats work with FakeSMC :guitar: Now I Will try my DSDT :thumbsup_anim:

Edit **** 

Done!

108525445_Capturedcranle2019-08-0112_01_35.png.c517c2d1ba78c6f49d75f6c318ed6684.png

Edited by chris1111
Edit ****  Done!

Share this post


Link to post
Share on other sites
1 hour ago, chris1111 said:

You are the MAN :yes: :D

 

Thats work with FakeSMC :guitar: Now I Will try my DSDT :thumbsup_anim:

Edit **** 

Done!

108525445_Capturedcranle2019-08-0112_01_35.png.c517c2d1ba78c6f49d75f6c318ed6684.png

 

How did you passed the PCI Configuration end with your Probook? In my desktop build can´t pass this, but in my HP EliteBook 2570P no problem with Beta 5 update.

Thanks.

Edited by asdesoso

Share this post


Link to post
Share on other sites
12 minutes ago, asdesoso said:

 

How did you passed the PCI Configuration end with your Probook? In my desktop build can´t pass this, but in my HP EliteBook 2570P no problem with Beta 5 update.

Thanks.

 see here

https://www.insanelymac.com/forum/topic/339035-pre-release-macos-catalina/?do=findComment&comment=2683791

Share this post


Link to post
Share on other sites

After update to beta 5  my Hp4540s is extremely slow and stuck at this point, the patch is already present on my acpi clover config, anyone with this notebook has same issue.

change EC0 to EC
4543305f 
45435f5f

IMG_1502.thumb.jpg.b921a6608a4c08b6728a5cda8b88617b.jpg

 

 

Edited by mick3lson

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By cranuaed
      Hi, everyone. I have my Hackintosh almost 100% working except for one minor issue that I can't seem to resolve.
       
      I have two monitors connected via DP->HDMI cables (no DP inputs on my monitors). If I boot with just one of them connected, everything works and I can connect the other one after booting. But if I try to boot with both connected, I get stuck with a black screen after the
      IOConsoleUsers: gIOScreenLock... message, before the Apple logo and progress bar appear.
       
      I have tried all the fixes I could find from the OpenCore install guide and WhateverGreen's FAQs, including:
      CSM both on and off in BIOS Patching VRAM Patching connector type to HDMI Adding -igfxmlr boot argument  
      Anything else to try? The system is still perfectly usable, but it's annoying having to disconnect a monitor any time I need to reboot.
       
      Thanks in advance for any help.
    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
        1 -Create a USB bootable
       
      Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers
       
      Catalina
      installScript_allfullapp.zip
       
      Big Sur
      installScript_1016fullapp.zip
       
      Credits: crazybirdy
       
      Copy Catalina / Big Sur installer to Applications folder, open terminal and run
       
      Catalina
       
       
      Big Sur
       
       
      If you want check one step by step, check here
       
      -Opencore Vanilla Tutorial
      https://tinyurl.com/ycvcnp8h
       
      2- EFI folder USB installation
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/y6avuxsv
       
       
      3- EFI folder SSD
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD 
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD
      https://tinyurl.com/y6avuxsv
       
      4- Start Fine Tune
       
      Run this app and post full dump here for full ACPI solution
       
      RunMe.app
      https://tinyurl.com/y9562hz7
       
       
      If you like a SSDT way, here we go
      SSDT-OLARILA.aml.zip
       
      5- USB Solution
      USB INTEL SERIE 400.zip
       
      Use these kexts, enable XHCI port limit patch and follow this tutorial for remap USB ports
       
       
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -HDMI / HDAU  
      --SCREENSHOTS--































      -If you want to buy me a beer - Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By tapochek2004
      Hello. I am experiencing a problem with my Catalina vanilla installation.
      My Dell 7567's screen is constantly blinking. This started in the installer and persisted after successful installation. Apart from the mentioned, the system is working perfectly fine.
      I am able to disable the backlight completely by pressing F11/brightness down button. I am barely able to see the on-screen text using a desk lamp afterwards.
      I have tried installing AppleBacklightFixup.kext, Lilu.kext and WhateverGreen.kext and setting my SMBIOS to iMac18,1 but none of those proposed solutions have helped me so far.
      To illustrate the problem, I have recorded a video (link) of my laptop booting into the installer and then shutting down. I have also included my CLOVER folder.
       
      I would appreciate any help or advice.
       
      Best regards, Luka
      CLOVER.zip
    • By y010204025
      Update: On October 24, 2020, using clover to solve the macOS11 beta10 boot problem, you can now enjoy macOS11beta10, and the compatibility of subsequent versions is not guaranteed.
      HIDPI uses a modified version. You can directly execute the hidpi script to get a better experience. If you lose the repair, it is not within the scope of my support.
      Support upgrades without destroying the integrity of the original image.
      There seems to be a problem with the shortcut keys. If you can help solve it, thank you for your contribution.
       
      Perhaps it was the first NEC (Lenovo) Lavie Z HZ550 to install hackintosh. I hope more people who like Lavie Z series can experience Hackintosh at HZ550. She is really great.
       
      I found HZ550 & HZ750 on the Chinese website, which is amazing. It weighs only 790g, 13.3 inches, and the standard 2k screen, which is too attractive to me. I am a Hackintosh enthusiast. I think HZ550 or HZ750 with MacOS is the best Unfortunately, the Lavie Z series is not listed in China, only exists in the Japanese and American markets, and in the Japanese market is the NEC brand, while the American market uses the Lenovo logo.
       
      Fortunately, I got an HZ550 from Taobao. Yes, not HZ750. In comparison, HZ750 has more touch screens and 360 ° flip. These are hard to attract me. More importantly, HZ750 is about 200g heavier than HZ550 That's why I chose HZ550. Well, because he is only 2,000 RMB.
       
      The specific introduction can refer to NEC Japan official website:http://nec-lavie.jp/products/hz13b/
       
      The HZ550 hardware list I obtained:
                                    
                       -/+:.          ningnan@ningnandeMacBook-Air
                      :++++.          OS: 64bit Mac OS X 10.15.5 19F96
                     /+++/.           Kernel: x86_64 Darwin 19.5.0
             .:-::- .+/:-``.::-       Uptime: 19m
          .:/++++++/::::/++++++/:`    Packages: 1
        .:///////////////////////:`   Shell: zsh 5.7.1
        ////////////////////////`     Resolution: 3840x2160
       -+++++++++++++++++++++++`      DE: Aqua
       /++++++++++++++++++++++/       WM: Quartz Compositor
       /sssssssssssssssssssssss.      WM Theme: Blue (Dark)
       :ssssssssssssssssssssssss-     Disk: 11G / 108G (12%)
        osssssssssssssssssssssssso/`  CPU: Intel Core i7-5500U @ 2.40GHz
        `syyyyyyyyyyyyyyyyyyyyyyyy+`  GPU: Intel Iris Graphics 6100
         `ossssssssssssssssssssss/    RAM: 4376MiB / 8192MiB
           :ooooooooooooooooooo+.    
            `:+oo+/:-..-:/+o+/-     
       
       
      Advantages: small size, light weight, 2K screen, 8G memory, 512g SSD, keyboard feels good, and wireless network card can be replaced, which is unimaginable in today's thin and light books.
      Disadvantages: The sound is small, almost the same as the mosquitoes.
       
      Ok, bragging is over!
      In order to use the wireless network, I changed the wireless network card from inter 7265 to BCM94352ZAE. Some people called it DW1560. It is uncomfortable that in China, this card and his elder brother DW1830 were hyped to a high price of 480RMB. of. Fortunately, I bought it early, and this card is also very stable under win10, and there is no high delay and outage. The hard disk should be PM951 of Samsung, not PM981, which is lucky.   Before installing Hackintosh: You need to prepare a 16G U disk, SanDisk is not a rough choice for making MacOS installation disk, I used the latest MacOS Catalina 10.15.5, got config.plist from Rehabman, and put together an EFI, the latest version of clover and kext drivers. Thanks to Rehabman and the developers of the Black Apple community. I do n’t like that OC team very much.
      Make an installation disk: If you have a computer running MacOS, you can use the command line to make it, if you do n’t have a computer running MacOS, you can try VMware, I know that the insanelymac forum allows discussion, or use ether to write the image to U disk, use the EFI I provided to boot into the installation process.   BIOS setting: Press F12 at boot to enter the BIOS settings, Tab switches to "Security-Secure boot", set to "DISable", this is what we need, and switch to "Boot -Boot devices", set the U disk as the first boot item You can directly enter the clover guide interface, please follow it for google it.
      It is worth noting that the remaining space of your EFI partition needs to be greater than 200M, otherwise, the disk format will be wrong. In addition, the format partition format is APFS, do not choose to encrypt, your data is not valuable, at least you must have this awareness of Hackintosh, the file safe is also the same, do not enable, do not use to find your mac, otherwise, change the machine, OK .   Fortunately, no additional ssdt patch is required. All the patch functions are implemented through clover. The flat Apple is turned on. This is to solve the problem of the flower screen. You can find a solution yourself.
      Experience your black apple, this will bring a better experience than MacBook Pro.  
       
×