Jump to content
fantomas

[pre-release] macOS Catalina

1,735 posts in this topic

Recommended Posts

1 hour ago, Sherlocks said:

thanks a lotemoji3.png

 

can you test lapic ifx under mojave? etc yosemite or snow leopard, lion

 

나의 SM-N960N 의 Tapatalk에서 보냄

 

 

 

@Sherlocks

 

I have only Mojave 10.14.6 beta 2, Catalina beta 2 and Sierra 10.12.5 and this fix correctly boots all three.

 

i don't have Yosemite, lion or other installs so cant test .

 

Regards

Share this post


Link to post
Share on other sites
Advertisement
@Sherlocks
 
I have only Mojave 10.14.6 beta 2, Catalina beta 2 and Sierra 10.12.5 and this fix correctly boots all three.
 
i don't have Yosemite, lion or other installs so cant test .
 
Regards
okay i will improve logic for all mac os.
i think we don't need lapic fix for all catalina or next macos like opencore bootloader

나의 SM-N960N 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites
2 hours ago, mashuk12 said:

bro please create OpenCore bootloader for me and send me 

iam tried to try for boot but can't boot my pc

Gigabyte H110M Motherboard

Pentium G4400 processor

 

Sorry, there is no short cut. You have to try understand how it works, there is very well documented Configuration.pdf and SampleFull.plist in Docs. If you don't I wouldn't  recommend it in that early stage of development and wait till 1.0.0 release. Good luck.

Your Pentium is Skylike so patch from my config probably won't work.

Edited by hardcorehenry

Share this post


Link to post
Share on other sites
2 hours ago, macq said:

@chris1111

Do these patches from Asentientbot affect the battery and trackpad in some manner.

I mean is the trackpad affect in some way by iousb*.kexts or iohid.kexts.?

I am not able to get trackpad going by rehabmans vodoopscontroller.kext as before.

I now need the vodooi2c one to get the trackpad pref.pane going in Catalina and nearly all works except dragging function (with and without)locking.

Is there a kext or plugin I an use from Mojave to get drag option functioning.

 

Thanks

I don't have laptop with the HD 3000 to test VoodooPS2

I don't have issue Drag drop file to other folder if this is what you said ? even with the magicMousse, for me VoodooPS2Controller works good on HP ProBook 6570B

 

For the Battery I don't know I am really busy at this time to see everything in Catalina

 

Edited by chris1111

Share this post


Link to post
Share on other sites

Anyone have an idea how to enable 4k on my RX 580?  I have WEG 1.3.0 and it shows as loaded when I do a kextstat.  I added the -cdfon boot flag to config.plist to see if that was it but no go.  4K works fine in Mojave for me without -cdfon.

 

Here is a screen shot of the system report for the card, it is only outputting 1080p right now.

 

 

Thanks

 

John

Screen Shot 2019-06-21 at 7.31.27 AM.png

Share this post


Link to post
Share on other sites
6 minutes ago, norton287 said:

Anyone have an idea how to enable 4k on my RX 580?  I have WEG 1.3.0 and it shows as loaded when I do a kextstat.  I added the -cdfon boot flag to config.plist to see if that was it but no go.  4K works fine in Mojave for me without -cdfon.

 

Here is a screen shot of the system report for the card, it is only outputting 1080p right now.

 

 

Thanks

 

John

 

Have you tried changing scaling values in System Preferences -> Displays -> Scaled, and selecting the right resolution?

Edited by arsradu

Share this post


Link to post
Share on other sites
14 minutes ago, arsradu said:

 

Have you tried changing scaling values in System Preferences -> Displays -> Scaled, and selecting the right resolution?

 

HA! Thank you very much!  Just did that and it looks a lot better.  Never had to do that before with my card.

 

Thanks again.

 

John

Share this post


Link to post
Share on other sites
27 minutes ago, norton287 said:

 

HA! Thank you very much!  Just did that and it looks a lot better.  Never had to do that before with my card.

 

Thanks again.

 

John

Yeah, for some reason, it does the same thing in my case, as well. Same for the Display Profiles... I had to check and uncheck the box for "Show profiles for this display only" in order to change the default one which looks absolutely horrifying in my opinion. :) So...yeah, looks like a bug to me. It's probably gonna be fixed with future updated. But in the meantime, you know how to fix it yourself. :) 

Edited by arsradu

Share this post


Link to post
Share on other sites
On 6/20/2019 at 2:59 AM, hardcorehenry said:

Macos Catalina installed with Open Core on very unsupported graphic Radeon and Pentium CPU. Thanks @ASentientBot for your patch and of course Open Core Developers for your amazing work.524407296_ScreenShot2019-06-19at19_59_53.png.78bf9e46e504b857f263c667059e764f.png2052305910_ScreenShot2019-06-19at20_01_03.png.1a9b29669b20ab03a45e3030e73c774e.png

Thanks for the same patches which got GTX 260M working with OpenGL function in Asus G51J laptop for the first time at Catalina beta 2. Cinebench R15 got rather good score too !

Screen Shot 2019-06-21 at 8.51.08 PM.png

Screen Shot 2019-06-21 at 9.20.13 PM.png

Edited by jsl2000

Share this post


Link to post
Share on other sites
10 hours ago, Sherlocks said:

both catalina and mojave right?
i did cleanup source for future.
i just need to check again about current source


나의 SM-N960N 의 Tapatalk에서 보냄
 

Yes it is working on both and thanks again ;-)

Share this post


Link to post
Share on other sites
1 hour ago, jsl2000 said:

Thanks for the same patches which got GTX 260M working with OpenGL function in Asus G51J laptop for the first time at Catalina beta 2. Cinebench R15 got rather good score too !

Screen Shot 2019-06-21 at 8.51.08 PM.png

Screen Shot 2019-06-21 at 9.20.13 PM.png

Shouldn't your OpenGL score be higher, I have only 512 vram1990207741_ScreenShot2019-06-21at16_54_10.png.e6950d64cc74cceaf0bbfeaec25f6635.png

Share this post


Link to post
Share on other sites

Hi guys good afternoon to all,

Two quick questions... in my real Mac with macOS Catalina, the app books have two tabs with other and because of that my books are duplicated, anyone knows how to solve this?

Other strange thing that happens is the trash I can't empty the trash... 

Thanks in Advance

Captura de ecrã 2019-06-21, às 17.29.05.png

Share this post


Link to post
Share on other sites
20 minutes ago, MorenoAv said:

Hi guys good afternoon to all,

Two quick questions... in my real Mac with macOS Catalina, the app books have two tabs with other and because of that my books are duplicated, anyone knows how to solve this?

Other strange thing that happens is the trash I can't empty the trash... 

Thanks in Advance

Captura de ecrã 2019-06-21, às 17.29.05.png

 

Hi

 

To empty Trash: 

  • In Terminal: type sudo rm -R 
  • Control-click on your Trash icon to open it
  • Select all of the files in your trash folder
  • Drag the files into the Terminal window
  • Hit Enter
  • Enter your administrator password
  • Hit enter again

Share this post


Link to post
Share on other sites
3 hours ago, gorki75 said:

Hello, I have installed your package, and at the restart it stops to put the user password, I put it and it leaves the graph and returns to the password posicions, ... so on

regards

You have install macOS Catalina Beta 1 ? I hope because its work only on Beta1

For Beta 2 its here ➜ Catalina Beta 2

 

Edited by chris1111

Share this post


Link to post
Share on other sites
9 hours ago, DocXavier said:

Hello guys,

 

is night shift working right for you?

 

Thanks¡¡¡

It does not work for me.

Share this post


Link to post
Share on other sites
3 hours ago, Jai_Arun said:

Catalina is blocking DRM plugins; can't play Netflix/primevideo now, tried Safari and Firefox - also tried the fix mentioned here https://bugzilla.mozilla.org/show_bug.cgi?id=1558924

nothing is fixed for me even after. Anyone else experiencing this?

 

 

 

 

try chrome ... for me work netflix with google chrome ... install siverlight first ...

Share this post


Link to post
Share on other sites
14 minutes ago, corint1 said:

 

 

try chrome ... for me work netflix with google chrome ... install siverlight first ...

 

Yeah Chrome + Silverlight works, confirmed thanks!

 

I just prefer Firefox for privacy reasons and hope it gets fixed in the next update, as far as I know this is not specific to hackintoshes, it is a macOS issue with allowing the .dylib to be accessed for widevine

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By midi-sama
      After a long time of cooking this computer up with a lot of stuff, I'm finally releasing my guide for this P50 with OpenCore.
       
      Lenovo ThinkPad P50 macOS Install with OpenCore
       
      This thread may be used for questions/corrections/additions. Good Luck.
    • By Simon's InsaneMac
      Hi, I'm kind of lost when scrolling to Clover Configurator, so I decided to use an EFI from the web and just configure the most basic stuff. But that sadly didn't work, im always getting the attached screen IMG_0054.HEIC (and I don't know whether all the errors are listed, as I can't scroll). 
      Anyways I thought it'd be better to do a custom setup. Can anyone give me some help with what to choose in the settings? Here's my rig:
      i7 8700k
      Asus z370-G (Rog Strix)
      gtx 1060 6gb
      samsung ssd (SATA)
      WD hard drive
       
      Your help would be much appreciated!
    • By kushwavez
      A really good motherboard with macOS compatible bult-in Wifi & Bluetooth

      ASUS Z170-Deluxe (with Wifi)
      BIOS: v3801
      CPU: i7-6700K 4.0 to 4.2 GHz (w/o OC)
      RAM: 1x 16 GB Corsair DDR4 2400 MHz
      GPU: Intel HD 530 (Headless) & ASUS Radeon RX 5700 OC 8 GB
      Audio: ALC 1150
      Ethernet: I219V2, I211-AT
      WiFi & Bluetooth: Broadcom BCM94360HMB Half-Mini-PCI-E
      More Specs: https://www.asus.com/Motherboards/Z170-DELUXE/specifications/
       
      Catalina 10.15.4 - Windows 10
      What is working:
      BCM94360HMB Wifi and Bluetooth AirDrop, Handoff, FaceTime, Messages, App Store, iCloud, etc. Intel HD 530 (QE/CI tested, but now I'm using it in headless) Sleep RX 5700 (QE/CI with 2 1080p monitors connected) Sound USB Ports Two Ethernet ports macOS with a light OC (4.12 GHz - 4.5 Ghz, XMP, ASUS optimal) No problem so far ASUS HyperKit with a KINGSTON NVMe SSD - 250 GB  
      What is not working:
      -  
       
      Not tested:
      VideoProc says that Hardware Decoding\Encoding is fully supported and enabled on both HD 530 and RX 5700 but I didn't test it Thunderbolt (no equipment)  
      Issues:
      None  
      BIOS Settings:
      Boot\CSM (Compatibility Support Module): Launch CSM: Disabled Boot\Secure Boot: OS type: Other OS Secure Boot State: Disabled Advanced\System agent (sa) Configuration: VT-d: Enabled Graphics Configuration: Primary Display: Auto iGPU Multi-monitor: Enabled RC6(Render Standby): Enabled DVMT Pre-Allocated: 128M Advanced\PCH Storage Configuration: SATA Mode Selection: AHCI HyperKit: Enable (if you have NVMe SSD with ASUS HyperKit) Advanced\CPU Configuration: Intel Virtualization Technology: Enabled CPU- Power Management Control: Intel SpeedStep: Enabled CPU- C-States: Enabled Intel SpeedShift: Enabled  
      Getting ready for installation:
      Download the bootpack (Clover v5106): Click here -> asus-z170_clover_5107.zip  
      Installation:
      Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager) Copy my Clover folder to the USB's EFI folder Boot with the Installer USB If you have any problem (kp or freeze) boot with config_debug.plist to see what causes the issue  
      Post Installation:
      Download Clover Configurator and generate a new Serial Number for yourself  
      Some pictures:
       

       




       
       
       
      Catalina & Windows 10 Dual-Boot (clean install, on one drive):
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac)
       Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart
      Boot into your Win installer, Format the partition you created for Win, install. 
      Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type: 
      bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi  
      You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)  
      Mounting EFI from Windows:
      Open cmd in administrator mode and type: mountvol b: /s (This will mount your EFI) Open Total Commander or Explorer++ in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI)  
      Notes:
       
      2020.03.26: Updated to 10.15.4 -> Updated WhateverGreen, Lilu -> Updated Clover to v5107
      2020.03.23: Removed "EmuVariableUefi.efi" -> deleted, caused false nvram map, now it's native, updated Clover to v5106
      2020.02.11: Updated to 10.15.3 -> No problem when/after installing
      2020.01.19: Added ASUS HyperKit NVMe SSD to the "What is working" list
      2020.01.12: Tested system with OC, added more informations to BIOS settings
      2020.01.11: Added SmallTreeIntel82576.kext for 2nd Ethernet, Tested Ethernet ports
      2020.01.11: First upload
       
    • By Rohan20
      Opencore is running really really slow on Catalina 10.15.4. So It was running perfectly before I put the ssdt-pnlf for enabling Brightness control. it is running really slow and I verified my config with the sanity checker and its all correct. can someone please help. I am attaching my oc folder.

       
      https://www.dropbox.com/s/drkek0eaz19ina5/OC.zip?dl=0
       
×