Jump to content
fantomas

[pre-release] macOS Catalina

1,710 posts in this topic

Recommended Posts

Advertisement

so to sum it up, first i upgraded it from latest beta mojave 

 

1869597452_Image6-4-19at2_42AM.thumb.jpg.b389710e08fbb4c9b44d3293f6b25a6b.jpg

 

 

-- aaand bugs i noticed 

 

everything that is saved on desktop disappears immediately.

my i7 9700k is recognized as i9 probably as 9900k, idk for sure too lazy to check cpu list.

WEG is dead so is h264, didn't tried new whatevergreen compiled kext.

My WIFI is also dead, net is working though intelmausi.

 

gonna play with it some more to find if there's anything more.
 

Share this post


Link to post
Share on other sites

Installed it on my laptop as an upgrade over 10.14.5. A couple of issues so far:

 

No WiFi (BCM4322)

 

Trackpad is registering the slightest tap as a click (VoodooPS2).

 

 

Share this post


Link to post
Share on other sites

Well it's done, macOS Catalina, up and almost running... I have no audio and my graphics are glitchy... and the worst of it all don't boot without safe mode... 

Captura de ecrã 2019-06-04, às 00.14.49.png

Captura de ecrã 2019-06-04, às 00.15.37.png

Captura de ecrã 2019-06-04, às 00.15.54.png

Captura de ecrã 2019-06-04, às 00.16.22.png

Share this post


Link to post
Share on other sites
1 minute ago, ITzTravelInTime said:

Here i am, i finished baout 2 hours ago and i already experienced some stability issues with safari crashing the windowserver, so be carefoul with safari

How are you fix the audio? tks!!! 

Share this post


Link to post
Share on other sites
Just now, errorexists said:

-alcbeta and -lilubeta  should not be needed

 

-alcbeta and -lilubeta works with latest release of Lilu and AppleALC here

Share this post


Link to post
Share on other sites

At first the problems are like a never ending story ... now is the CC That don't mount the partitions ... lol

The other problem that annoys me the most are the glitches in the graphics if you notice in my fist picture it shows UHD630 Graphics 1536, but I have no acceleration and it was supposed to be working perfectly... grrrr

Edited by MorenoAv

Share this post


Link to post
Share on other sites

AirportBrcmFixup refuse to load. I am using OpenCore, have not tried Clover. I have compile all kexts from latest commits(Allow loading on 10.15 without `-lilubetaall`).

 

Same EFI configuration loads up everything on 10.14, including AirportBrcmFixup.

 

WiFi card is: 14E4:43B1/BCM4352/ASUS PCE-AC56

Edited by Hackmac101

Share this post


Link to post
Share on other sites

Alternative method to create a Catalina installer app

Download the Python script here https://github.com/munki/macadmin-scripts/blob/master/installinstallmacos.py

Run the script using the new update catalog url https://swscan.apple.com/content/catalogs/others/index-10.15seed-10.15-10.14-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz

sudo /usr/bin/python installinstallmacos.py --raw --seedprogram DeveloperSeed --catalogurl https://swscan.apple.com/content/catalogs/others/index-10.15seed-10.15-10.14-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz

 

Share this post


Link to post
Share on other sites

Here's my submission to add to the few laptops on this thread. To be honest, this was the easiest upgrade of macOS on a hackintosh I've ever had. I just ran the installer, and everything worked, which is pretty surprising considering I was upgrading from macOS Sierra. My ALPS touchpad works flawlessly with multitouch, and Audio works with my ALC292.

 

Now my big gripe, the performance. I had upgraded to Mojave Beta 1, and then a month later went back to Sierra due to the performance issues I faced, and I feel like it has gotten worse with Catalina. I think this is because of APFS, or maybe it's just because it's a beta and I should just wait for a full release. If anyone has a short term solution I can apply, though, I'd be happy to try anything (anything that isn't installing an SSD or upgrading RAM) because the last 2 macOS updates have made my hackintosh unusable.

Screen Shot 2019-06-03 at 8.35.09 PM.png

Share this post


Link to post
Share on other sites
1 hour ago, errorexists said:

-alcbeta and -lilubeta  should not be needed

 

Thanks @errorexists but im try your kext, without success...so many thanks to efforts !!!! Someone try play something with iTunes, especially radio stations? 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By acsapos
      Hello dear insanelymac family!
      My plan for this week, to build a hackintosh. I'm trying, reading a lot of forums, posts, but i cant go forward. I tried OpenCore, Clover, and [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] too. I have an Opencore right now, because this loader went longer than the others, and its easy to configure in my opinion. So, the problem is.. When i boot up to my installer USB, it will always stop somewhere after about 10 seconds. Always changing positions, like in the middle of a text, etc. You can see the screen on the image what i uploaded. I tried a lot of things, but somehow, nothing is happening. CPU: Xeon 2620-v3 GPU: XFX RX 580 XXX Edition 8GB RAM: 2 x 8GB DDR4 2400Mhz Motherboard: Killsre X99-D4 (bought from aliexpress) Guide followed: I followed the Dortaina's Opencore guide / HASWELL-E What part I got an issue with: Booting up to my Installer USB What files/config I am using: My entire EFI uploaded to this post Extra Info: I cant get to open the installer overall, the longest what i reached what you see on the imgur link. I have an opencore file with some LOG(uploaded) Thanks in advance, for any help. I would really appreciate that. David acsapos-EFI.rar


      opencore-2020-08-11-020217.txt
    • By chris1111
      Here my theme of OC 
       
      ### Dark version Selector Low

      Resources-Dark-S-Low.zip
       
      ### Dark version Selector Top

      Resources-Dark-S-Top.zip
       
      ### Dark version Selector GreenLight

      Resources-Dark-S-Green-Light.zip
       
      ### Light version Selector Low

      Resources-Light-S-Low.zip
       
      ### Light version Selector Top

      Resources-Light-S-Top.zip
       
       
      ### OC-Grey

      OC-Grey.zip
       
      ### OC-Blue

      OC-Blue.zip
       
      ### OC-White

      OC-White.zip
       
      ### OC-Blues

      OC-Blues.zip
    • By Dradis
      I finally got my Opencore Hackintosh up and running, but I'm still having trouble with the USB ports.  My USB 2.0 Ports work just fine, but my 3.0 ports don't work at all.  Absolutely nothing happens when I plug anything into a 3.0 port.  I'm trying to follow the guides for mapping USB ports, but one of the first steps is to use Hackintool to identify your ports. Hackintool shows that I have no USB ports at all, not even the ones that work.  Btw, a flash drive and my keyboard were plugged into USB 2.0 ports and working at the time this screen shot was taken.  USBInjectAll.kext is in use.  Kernel > Quirks > XHCIPortLimit is set to TRUE in config.plist.  Can anyone please tell me how to make these USB ports work?  Thank you.  
      System:   
      Asus Prime B460M-A  
      Intel i5 10400  
      Intel UHD 630 iGPU  
      Opencore 0.6.0   
      macOS 10.15.6

    • By jrbros1
      Hi there,
       
      So I have my Windows computer, used a USB with Clover setup to boot into Mojave OS that I installed on the SD card in the computer. The world was a great place and all was well!

      Then I did the steps to partition the pc system to now include the additional drive that I would put Clover on. Here's where I messed up: Instead of directly copying over the full Clover folder into the EFI folder of the new drive (which just had the Boot & Microsoft folders in it), I replaced the EFI's boot folder with Clover's boot folder. So the EFI folder now contains a Microsoft folder, a Clover folder, and Clover's Boot folder only.

      Now, I only can access the Clover boot up menu, the macOS, but no Windows at all. Even if I go into BIOS and pick Windows Boot Manager or Partition 1 for the start up, I get a black screen for both. I can still access the macOS as well as Shell, but I don't know what that does other than displaying all of the yellow text fly by..

      Is there a kind soul out there that can help me get Windows back to boot? Keep in mind I'm a bit of a newbie here so laying out the common-sense steps would be helpful!

      Thank you in advance!
    • By jlvlnzl
      Hi,
      I'm getting an error when i try to install Catalina 10.5.6 Install on HP 800 G1 SFF Haswell.
      This happens on the first reboot after installing MacOS (see atached image).
      I'm using Opencore 0.6.0.
      config.plist checked with opencore.slowgeek.com
       
      HP 800 G1 SFF
      i7 4785t Haswell
      Intel hd4600 (using just iGPU)
       
      I attached EFI, log error opencore, error capture.
       
      Anything help will be gratefull!!!
       
       
       
       
       
       
      EFI.rar
      opencore-2020-08-11-025646.txt
      opencore-2020-08-11-030700.txt
      config.plist

×