Jump to content

1,735 posts in this topic

Recommended Posts

Posted (edited)

Is it just me or? When I try to move HD icon on desktop it starts to copy it. It happens only with HD icons.

Screenshot 2019-06-06 at 00.23.44.png

Edited by dzontra

Share this post


Link to post
Share on other sites
Advertisement
1 minute ago, dzontra said:

Is it just me or? When I try to move HD icon on desktop it starts to copy it. It happens only with HD icons.

Screenshot 2019-06-06 at 00.23.44.png

its a bug does it for me also

Share this post


Link to post
Share on other sites
14 hours ago, asdesoso said:

Hi, anyone has tested the Atheros AR9280 in Catalina? In Mojave I need to extract from High Sierra´s IO80211Family.kext the AirPortAtheros40.kext from 10.13.6 and put it into the Mojave´s IO80211Family.kext > Plugins and reinstall the kext, with this method I was able to work AR9280 in Mojave without any problem. At the moment I can´t try it.

 

Thanks in advance.

 

10 hours ago, asdesoso said:

Hi, is the same procedure as the AR9287?

Best regards.

 

2 hours ago, GremekHombre said:

Did anyone get to work AR9285 with Catalina? Seems to AirPortAtheros40.kext from High Sierra doesn't work.

 

Just adding AirPortAtheros40.kext plugin kext from High Sierra doesn't work because it fails to link in the pre-linked kernel ---> need to also replace entire IO80211Family.kext with older version.

 

I used @parrotgeek1’s BCM4321fix ---> basically allows the IO80211Family.kext wifi driver from El Capitan to work in newer macOS eg High Sierra, Mojave, Catalina.  Therefore it supports all the deprecated wifi cards that lost support in newer macOS eg BCM94321, Atheros cards needing AirPortAtheros40.kext like AR9287, AR9285, AR9280 :thumbsup_anim:.

 

BCM4321fix.zip

Share this post


Link to post
Share on other sites
2 hours ago, telepati said:

 

It's great. did you upgrade with USB installer or just starts installer.app from the applications folder?

It does not matter, it is essentially the same procedure after the first one reboot.

I follow the apple original way with installer.

Share this post


Link to post
Share on other sites
28 minutes ago, dzontra said:

Is it just me or? When I try to move HD icon on desktop it starts to copy it. It happens only with HD icons.

Screenshot 2019-06-06 at 00.23.44.png

Same :D

Share this post


Link to post
Share on other sites
Posted (edited)

With IGPU enabled, I have a KP during initialization:
 

Quote

 

[IGPU] Will NOT fallback to host=side scheduling if graphics firmware fails to load

[IGPU] Scheduler fail Coalescing Enabled.

[IGPU] Scheduler Page fault Handling Enabled.

[IGPU] Scheduler Stamp Event Wait Notify Disabled

[IGPU] Scheduler Single Channel Index Disabled

[IGPU] Scheduler Channel Wait for Complete Disabled

[IGPU] Scheduler: Process CSB using HWS.

[IGPU] Scheduler: PM notify enabled

panic(cpu 1 caller 0xfffff79F11200350): "Unsupported GraphicsSchedulerSelect=2\n"@sk1/IntelAccelerator.cpp:2067

 

 

 

 

Catalina boots fine with IGPU disabled and my discrete R280X only. Running Clover r4940, Lilu 1.3.6, WEG 1.2.9, flags "-v -lilubetaall" set on config file.

On Mojave, both IGPU and discrete works fine. Any hints?

 

[EDIT] Seems someone forgot to renew the SSL Certificates for the site. It literally just expired ;)

Edited by Alex HQuest

Share this post


Link to post
Share on other sites
3 hours ago, lvs1974 said:

Can somebody test attached version of AirportBrcmFixup under 10.15?

Thank you in advance for any reports.

 

PS: to get logs please add -brcmfxdbg into boot-args

2.0.2 (DEBUG).zip

Tested and working now, thank you. No more KP and WiFi works as it did in Mojave.

Share this post


Link to post
Share on other sites
But no bluetooth for me...

Same, no Bluetooth but that’s nothing to do with AirportFixup. That’s rehabmans kexts.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Alex HQuest said:

With IGPU enabled, I have a KP during initialization:
 

 

Catalina boots fine with IGPU disabled and my discrete R280X only. Running Clover r4940, Lilu 1.3.6, WEG 1.2.9, flags "-v -lilubetaall" set on config file.

On Mojave, both IGPU and discrete works fine. Any hints?

 

[EDIT] Seems someone forgot to renew the SSL Certificates for the site. It literally just expired ;)

 

Whatevergreen has been updated to 1.3.0 and it avoids the problem you have (at least it did for me.). It has been posted several times already above (alone and as a part of the Lilu Plugins.)

Edited by mnfesq

Share this post


Link to post
Share on other sites
4 hours ago, lvs1974 said:

Can somebody test attached version of AirportBrcmFixup under 10.15?

Thank you in advance for any reports.

 

PS: to get logs please add -brcmfxdbg into boot-args

2.0.2 (DEBUG).zip

 

thank you so much

here is log

Spoiler

2019-06-06 10:03:00.970036+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) found com.apple.driver.AirPort.BrcmNIC
2019-06-06 10:03:00.971208+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) all patches are successfuly applied to com.apple.driver.AirPort.BrcmNIC
2019-06-06 10:03:00.971378+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) wowl disable patch is successfuly applied to com.apple.driver.AirPort.BrcmNIC
2019-06-06 10:03:00.971991+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) gIOCatalogue->startMatching(OSSymbol const*) successful
2019-06-06 10:03:00.972161+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) gIOCatalogue->startMatching(OSSymbol const*) successful
2019-06-06 10:03:00.972244+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) gIOCatalogue->startMatching(OSSymbol const*) successful
2019-06-06 10:03:00.976219+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) FakeBrcm::init(): FakeBrcm disabled
2019-06-06 10:03:00.976227+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) FakeBrcm::free()
2019-06-06 10:03:00.976262+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) probe is called, service name is AirPort_BrcmNIC, provider name is ARPT
2019-06-06 10:03:00.976268+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:   iokit @ (DBG) getOSData device-id has 43B1 value
2019-06-06 10:03:00.976272+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:   iokit @ (DBG) getOSData vendor-id has 14E4 value
2019-06-06 10:03:00.976329+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) PCIHookManager::hookProvider: hook is not required since vendor-id && device-id are the same
2019-06-06 10:03:00.976355+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) probe is finished with result success
2019-06-06 10:03:00.976392+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) probe is called, service name is AirPort_BrcmNIC, provider name is ARPT
2019-06-06 10:03:00.976397+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:   iokit @ (DBG) getOSData device-id has 43B1 value
2019-06-06 10:03:00.976401+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:   iokit @ (DBG) getOSData vendor-id has 14E4 value
2019-06-06 10:03:00.976467+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) PCIHookManager::hookProvider: hook is not required since vendor-id && device-id are the same
2019-06-06 10:03:00.976484+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) probe is finished with result success
2019-06-06 10:03:00.976498+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) start is called, service name is AirPort_BrcmNIC, provider name is ARPT
2019-06-06 10:03:00.976506+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) brcmfx-country in ioreg is set to #a
2019-06-06 10:03:00.976512+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:   iokit @ (DBG) getOSData device-id has 43B1 value
2019-06-06 10:03:00.976517+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:   iokit @ (DBG) getOSData vendor-id has 14E4 value
2019-06-06 10:03:00.976576+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) PCIHookManager::hookProvider: hook is not required since vendor-id && device-id are the same
2019-06-06 10:03:01.125032+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) siPmuFvcoPllreg2, original chip identificator = 4352
2019-06-06 10:03:01.125309+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) wlc_set_countrycode_rev2 is called, a3 = -1, country_code = US
2019-06-06 10:03:01.125314+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) country code is overrided in ioreg
2019-06-06 10:03:01.125432+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) country code is changed from US to #a, result = 0
2019-06-06 10:03:01.235185+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) newVendorString is called
2019-06-06 10:03:01.238621+0900  localhost kernel[0]: (kernel) AirportBrcmFixup:  BRCMFX @ (DBG) start is finished with result 1

 

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, lvs1974 said:

Can somebody test attached version of AirportBrcmFixup under 10.15?

Thank you in advance for any reports.

 

PS: to get logs please add -brcmfxdbg into boot-args

2.0.2 (DEBUG).zip

 

Working good here with BrcmBluethootInjector now only both kexts for Mojave and Catalina :)

Thanks a lot

Edited by chris1111

Share this post


Link to post
Share on other sites
15 minutes ago, chris1111 said:

 

Working good here with BrcmBluethootInjector now only both kexts for Mojave and Catalina :)

Thanks a lot

I tried BrcmBluetoothInjector 2.2.10 and just only AirDrop works, I can’t even connect to my bluetooth headset. 

Share this post


Link to post
Share on other sites
2 minutes ago, superzeldalink said:

I tried BrcmBluetoothInjector 2.2.10 and just only AirDrop works, I can’t even connect to my bluetooth headset. 

air drop is relate to WIFI, if you have WIFI air drop works

Share this post


Link to post
Share on other sites
9 minutes ago, chris1111 said:

air drop is relate to WIFI, if you have WIFI air drop works

But Bluetooth is needed for finding each other. Am I right ? 
Also Continuity Camera works

Share this post


Link to post
Share on other sites
12 hours ago, telepati said:

Guys, how do you upgrade without losing your data? I tried but I think messed up a little. I create a USB installer and boot from it and try to install over my Mojave but it always stuck. Are you using a different way?

 

12 hours ago, chris1111 said:

use another SSD or another partition

 

I tried too. The file structure is way different - it makes a smallish system volume and another data volume. Some of my data went over ok but it wiped out all the apps. This was an update from the sys prefs. So I did a clean install still using sys prefs update and then migrated my stuff from Mojave. Seems ok but I'm getting a 5 minute wait between verbose boot and the apple logo just before the boot finish. On warm boot only. Cold boot seems fast the few times I've tried it. On the Zenbook only because I'm on holiday in China right now lol.

So I think the new 2 volume method makes straight updates a bit useless. Clean install with migrate is good. 

12 hours ago, telepati said:

Guys, how do you upgrade without losing your data? I tried but I think messed up a little. I create a USB installer and boot from it and try to install over my Mojave but it always stuck. Are you using a different way?

 

12 hours ago, chris1111 said:

use another SSD or another partition

 

I tried too. The file structure is way different - it makes a smallish system volume and another data volume. Some of my data went over ok but it wiped out all the apps. This was an update from the sys prefs. So I did a clean install still using sys prefs update and then migrated my stuff from Mojave. Seems ok but I'm getting a 5 minute wait between verbose boot and the apple logo just before the boot finish. On warm boot only. Cold boot seems fast the few times I've tried it. On the Zenbook only because I'm on holiday in China right now lol.

So I think the new 2 volume method makes straight updates a bit useless. Clean install with migrate is good. 

Share this post


Link to post
Share on other sites
1 hour ago, mnfesq said:

 

Whatevergreen has been updated to 1.3.0 and it avoids the problem you have (at least it did for me.). It has been posted several times already above (alone and as a part of the Lilu Plugins.)

I clearly missed this. Looked only at the official distribution storage at Github. But indeed, it did the trick. Thanks for pointing out.

Share this post


Link to post
Share on other sites

hi there, is someone able to install macOS catalina on Hp notebook 15. cant get to the installer kind of kernelLapic is not working for me but when i pass cpus=1 boot arg on start then i can easily boot into installer but after that it's stuck "Estimate remaining time" and stck there forever. so stuck here and hope for developers to update kernel Lapic issue.

 

Specs:

intel core i5 4210U with intel HD4400 8GB ram 

 

can someone help me to install macOS catalina, it'll be great. and yes im using the latest clover build.

Share this post


Link to post
Share on other sites
hi there, is someone able to install macOS catalina on Hp notebook 15. cant get to the installer kind of kernelLapic is not working for me but when i pass cpus=1 boot arg on start then i can easily boot into installer but after that it's stuck "Estimate remaining time" and stck there forever. so stuck here and hope for developers to update kernel Lapic issue.
 
Specs:
intel core i5 4210U with intel HD4400 8GB ram 
 
can someone help me to install macOS catalina, it'll be great. and yes im using the latest clover build.
did you try kernellapic fix option in config?

나의 SM-N960N 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites
Posted (edited)

yes i check that option but still getting KP on boot when but boot fine with cpus=1 boot arg

 

now im trying this patch of your's

 

Please try this kernel patch for 10.15 Beta 1:

9E 00 00 74 0E 8B -> 9E 00 00 EB 22 8B

 

 

Edited by kidooe

Share this post


Link to post
Share on other sites
10 minutes ago, kidooe said:

yes i check that option but still getting KP on boot when but boot fine with cpus=1 boot arg

  

 now im trying this patch of your's

  

Please try this kernel patch for 10.15 Beta 1:

 9E 00 00 74 0E 8B -> 9E 00 00 EB 22 8B

 

 

Hi, yes! I am extremely wondering if it works, thanks!

Share this post


Link to post
Share on other sites
Posted (edited)
37 minutes ago, Sherlocks said:

did you try kernellapic fix option in config?

나의 SM-N960N 의 Tapatalk에서 보냄
 

 

12 minutes ago, PMheart said:

Hi, yes! I am extremely wondering if it works, thanks!

@PMheart

 

Same here I need cpus=1 for installer to proceed and even with it , process hangs at kextd (240s) stalls:ACPICPU

Specs in signature, currently running 1014.6b

 

Any help suggestions

Thanks

 

Edited by macq

Share this post


Link to post
Share on other sites
yes i check that option but still getting KP on boot when but boot fine with cpus=1 boot arg
 
now im trying this patch of your's
 

Please try this kernel patch for 10.15 Beta 1:

9E 00 00 74 0E 8B -> 9E 00 00 EB 22 8B

 

 
strangely reported lapicfix work from user.

나의 SM-N960N 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By crazybirdy
      Patched OSInstaller.framework to allow macOS 10.15 installation on MBR HFS+ partition.
       
      Please read Readme-10.15.pdf first.
       
      How to finish the Catalina installation.
      1. Use EasyMBR-Installer1015 to make USB Catalina Installer.
      2. Boot to USB Catalina Installer, open Utilities -> Disk Utility, format as MBR HFS+. 
          Install Catalina to blank MBR HFS+ "Target" partition.
      3. Boot to USB Catalina Installer, open Utilities -> Terminal, run the script command:
          copytempdata
      4. Boot to "Target" MBR HFS+ partition on single user mode (-s), run the script command:
          hfsupdatecache
      5. Reboot to "Target" MBR HFS+ partition, setup user name and login, finish the installation.
       
      Also, you need to setup Clover as BooterConfig=0x28, CsrActiveConfig=0x67
       
      ----------------------------------------------------------------------------------------------
      List of known issues:
      1. Some app-pkg-installers can't install to HFS+, but install to APFS fine.
      ----------------------------------------------------------------------------------------------
       
      What is this patched OSInstaller doing?
      1. Pass the MBR check, allow macOS 10.15 installation on MBR partition.
      2. Pass the Firmware check, bypass the error of "An error occurred while verifying firmware".
      3. Pass auto-convert to APFS , "ConvertToAPFS=false" is no longer worked with 10.15.
      4. This MBR-Manual-Method will never convert to APFS, and will always install as HFS+ partition.
      5. This MBR-Manual-Method works with both MBR HFS+ and GPT HFS+ partition (GPT+recovery).
      No longer need to set new SMbiosversion, FirmwareFeatures, and FirmwareFeaturesMask with this MBR-patch.
       
      What's the difference between createinstallmedia method, MBR-Manual-Method, and MBR-Automatic-Method?
      As the following....
      1. createinstallmedia method,
          needs stage 1, stage 2 installation process, which is worked with GUID partition only, always convert to APFS format.
      2. MBR-Manual-Method (same as 10.12),
          install via stage 2 manually, which is worked with both MBR HFS+ and GUID HFS+, will never convert the partition format.
          We can manually format as MBR HFS+ or GPT HFS+ on installation screen like as 10.12.
          We can manually select MBR HFS+ partition to install 10.13, 10.14, 10.15 on installation screen now.
          Needn't to update the MBR-Manual-Method files, it will still work on 10.13, 10.14, 10.15 future versions, I think so.
          It can be installed as Fresh installation on formated blank partition only, but can't be installed as update from previous version.
      3. MBR-Automatic-Method (new for 10.13+),
          End of MBR and HFS+, there is no more MBR HFS+ patch available for 10.15 native OSInstaller.

      How to make 10.15 installer for MBR (MBR-Manual-Method)?
      Just use EasyMBR-Installer1015 to make installer, it works with both MBR and GPT.
      Read HowTo inside the dmg first, same as 10.12.
      Read HowTo Q/A Q4. How to patch to work with CPU SSE4.1 only for Mojave, Catalina?
      Read HowTo Q/A Q6. How to download the full installer app via swscan.apple.com, instead of App Store?
      Read HowTo Q/A Q7. How to update 10.15.x combo-update to MBR and GPT with installScript directly?
       
      And, need a SMBIOS supported with /System/Library/CoreServices/PlatformSupport.plist.
       

       
      Q6. How to download the full installer app via swscan.apple.com, instead of App Store?
      A6. Some people download installer app from App Store, and get only 18 MB size, not the complete installer app (5.68 GB). You should boot to 10.12, or 10.13 to download it again from App Store, or use script Q6-DownloadFullApp/installScript_fullapp to download the full installer app via swscan.apple.com.
       

       
    • By martinmenchon
      Hi everyone I have a fully functional Toshiba LW55-C5320 Hackitonsh Catalina
       
      Working:
      Audio Microphone Integrated Intel Graphics Multitouch gestures Full keyboard working (Using "US-International PC" input sources) USB 3.0 Web camera Volumen Keyboards Wifi and Bluetooth using this card and adaptor (SODIAL Bcm94360Cs2 - Tarjeta de conexión WiFi Bluetooth para MacBook Air  KALEA-INFORMATIQUE - ADAPTATOR BCM94360CS2 BCM943224PCIEBT2 A M2 (M.2 NGFF) A E Key) Sleep with DSDT Patches
        Not Working:
      Card reader (I don't use it, so I didn't try to fix it) HDMI audio (I will try to fix it in the next days)  
      I attached the Clover configuration I made
      I will and post some images of Boot configurations
       

       
      EFI.zip
    • By ludufre
      Installing macOS Catalina on Lenovo ThinkPad L440

       
      There are two version of this laptop:
      - 20AS = Chipset QM87, without Express Card (mine).
      - 20AT = Chipset HM86, with Express Card.
      I strong believe is the same thing...
       

      Changelog:
       
      10/20/2019 20:47h GMT-0
      - Removed AppleBacklightFixup.kext.
      - WhateaverGreen now implements backlight since 1.2.5.
       
      10/20/2019 18:10h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i5-4300M ->  Work. All SpeedStep stages.
      - Video Card: Intel HD4600 ->  Work. QE/CI and Metal.
      - Chipset: Intel QM87 ->  Work.
      - Mini DisplayPort ->  Work. But no audio, yet.
      - VGA ->  Not work. Normal.
      - Audio: ALC292 ->  Work.
      - WiFi/Bluetooth: Intel AC 7260 ->  Not work. Replaced with DW1560 (need whitelist removal).
      - Ethernet: Intel I217-LM ->  Work.
      - Card Reader: Realtek RTS5227 ->  Not work.
      - Keyboard and Touchpad ->  Work.
      - Webcam ->  Work.
      - Fingerprint Reader ->  Not work. Normal.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff and Continuity ->  Work after replaced wireless.
      - Instant Hotspot ->  Not work.
       
       
      Extras
       
      - FullHD 1920x1080 display upgrade: 
      Replaced with AU Optronics B140HAN01.1 30pin eDP (B140HAN01.2 and B140HAN01.3 also compatible).
      Apparently same screen as Dell Latitude E6440, E7440, Lenovo Ideapad U430 and E129.
       
      - CPU upgrade:
      Replaced the stock Intel Core i5 4300M 2.6Ghz (3.3Ghz turbo) 6M cache with Intel Core i7 4700MQ 2.4Ghz (3.4Ghz turbo) 6MB.
      I initially had problems with overheating. The processor ran at full load above 90 degrees.
      After using a quality thermal paste I can work between 70 and 80 degrees.
      Acceptable taking into consideration that the new processor has 47TDP versus 37TDP which is recommended.
      I also had no problem consuming the battery while charging. The original 65W source seems to have figured out.
       
      - Touchpad upgrade:
      Replaced the stock with T460 touchpad.
      This is serious: you have to do it! It should be stock. Touchpad with precision and absurd quality!
      Just do it!
       
      - RAM upgrade:
      16GB (2x8GB). No mistery here. Just upgade.
       
       
      Todo
       
      - Make DP audio work.
      - Make Card Reader work.
      - Make trackpad appear in System Preferences
      - Make Instant Hotspot work.
       
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Mojave install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes.
       


      Install bootloader

      Download the CloverEFI from official repository (used 5097) and install only with these options on "Install macOS Mojave":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended Drivers - AudioDxe (Just to have nice sound on boot)
      - UEFI Drivers - Recommended Drivers - FSInject (I still don't know if it's really necessary)
      - UEFI Drivers - File System drivers - ApfsDriverLoader (Support to APFS partitions)
      - UEFI Drivers - File System drivers - VBoxHfs (Support HFS/HFS+ partitions)
      - UEFI Drivers - Memory fix drivers - AptioMemoryFix (Fix the memory management of de UEFI/BIOS)
       
      FileVault 2
       
      If you plan to use FileVault 2, you need to download additional drivers, since what comes with Clover is not up to date and use VirtualSMC instead of FakeSMC.
      Follow instructions bellow:
       
      From current Clover installation, check these options to USB keyboard/mouse work on password screen:
      - UEFI Drivers - Human Interface Devices - UsbKbDxe
      - UEFI Drivers - Human Interface Devices - UsbMouseDxe
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
       
      Download the versions 2.1.0 and 2.0.9 of AppleSupportPkg from: https://github.com/acidanthera/AppleSupportPkg/releases
      We need the last version of AppleGenericInput.efi that is inside 2.1.0 and last version of AppleUiSupport.efi that is inside 2.0.9.
      Put in /Volumes/EFI/EFI/CLOVER/drivers/UEFI/
       
      VirtualSMC is more compatible than FakeSMC, so download the last version in: https://github.com/acidanthera/VirtualSMC/releases (currently 1.0.8)
      Copy VirtualSmc.efi to /Volumes/EFI/EFI/CLOVER/drivers/UEFI/ and all Kexts to /Volumes/EFI/EFI/CLOVER/kexts/10.15/
       
       
      That's it! FileVault 2 will work without problems.
       

       
       
      Make things works
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      - Replace the /Volumes/EFI/EFI/CLOVER/config.plist with mine attached below
      - Put SSDT-L440.aml attached below in /Volumes/EFI/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.6.2.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Copy the Clover Configurator to flash drive because you will need later.
       
      Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the VirtualSMC from here. I used all Kexts and UEFI driver (put VirutalSmc.efi inside /Volumes/EFI/EFI/drivers/UEFI/) from version 1.0.8 (If you followed the steps to enable FileVault 2 above, skip to the next item).
      - Download the Lilu.kext from here. I used the version 1.3.8.
      - Download the VoodooPS2Controller.kext from here. I used version 2.0.4.
      - Download the IntelMausiEthernet.kext from here. I used the version 2.5.0.
      - Download the AppleALC from here. I used the version 1.4.2.
      - Download the WhateverGreen.kext from here. I used the version 1.3.3.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
       
      Important! If you are coming from my previous Mojave guide, please note that I am using some kexts from other repositories / authors.
       
       
      Wifi and Bluetooth (DW1560 / BCM94352Z)
       
      Unfortunately, some notebook manufacturers are currently blocking the replacement of wireless cards. They want you to only use the models sold by them. And of course, none of them from Lenovo for this notebook model is compatible with MacOS.
       
      If you try to start with an unauthorized wifi card for them, you will receive a screen error:
      1802: Unauthorized network card is plugged in - Power off and remove the network card. Since this check is done directly in the BIOS, the only solution is to modify it.
      But since nothing is easy in this life, there is one small big problem:
      - The BIOS update procedure does not allow you to use modded files as it used to be.
      - You will need to physically reach your BIOS on the motherboard and make use of a USB BIOS reader/writer.
       
      So what you need to do:
      1. Disassembly your laptop;
      2. Dump your BIOS with an USB BIOS reader with SOIC8 clip (to not desolder from the motherboard);
      3. Patch it (Ask on UEFI hack forums over there to someone patch for you. Every dump is unique, so mine don't work to you.);
      4. Fix RSA signature;
      5. Reflash BIOS;
      6. Replace wireless card;
      7. Remount your laptop;
      8. Done.
       
      To fix a Modded BIOS to remove the 5 beeps on boot, you need this guide: https://www.insanelymac.com/forum/topic/337333-guide-fix-insyde-h2o-bios-signature-5-beeps-on-lenovo (traduzido: pt-BR)
       
       
      After replaced the wireless card. Download those Kexts and put in /Volumes/EFI/EFI/CLOVER/kexts/10.15/
       
      - Download the AirportBrcmFixup.kext from here. I used the version 2.0.3. (To enable Wireless)
      - Download the BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM3.kext from here. I used the version 2019-10-17. (To enable Bluetooth)
      - Download the BT4LEContinuityFixup.kext from here. I used the version 1.1.4. (To enable Handoff and Continuity)
       
      Keep in mind that the bluetooth kexts are currently in development and the official releases will be available in future in the repository: https://github.com/acidanthera/BrcmPatchRAM/releases
       
       
      Now you can start the installation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is the latest: 1.93 (J4ET93WW) 

      - Shutdown and insert the flash drive.
      - Power on with F1 pressed to enter BIOS setup.
      - Change value: Config - Intel(R) AMT - Intel(R) AMT Control to DISABLED
      - Change value: Security - Security Chip to DISABLED
      - Change value: Security - Anti-Theft - Intel(R) AT Module Activation to DISABLED
      - Change value: Security - Anti-Theft - Computrace to DISABLED
      - Change value: Security - Secure Boot to DISABLED
      - Change value: Startup - UEFI/Legacy Boot to BOTH, Legacy First and CSM Support = Yes
      - Save & Exit Setup (F10)
       
      - Now, hold the F12
      - In the list, select your flash drive.
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot. Maybe you have to press F12 again and select the flash drive.
      
      The second part of the installation will begin. This will take 16 minutes.
       

      Post installation
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to make the system disk bootable.

      Open the Clover Configurator from flash drive that you copied before.

      Mount and open the flash drive EFI partition. (Inside Clover Configurator, Mount EFI -> Select flash drive in Efi Partitions list -> Mount Partition -> Open Partition)
       
      Copy the EFI folder to desktop.
       
      Go back to Clover Configurator, unmount the EFI partition of the flash drive and mount and open the EFI partition of internal disk.
       
      Move the EFI folder from Desktop to EFI partition of the internal disk.
       
      Eject the flash drive.
       
      Move all Kexts from EFI partition of internal disk to /Library/Extensions and make kext cache, with those commands in Terminal:
      sudo mv -R /Volumes/EFI/EFI/CLOVER/kexts/10.15/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!
       
       
      System Updates
       
      As it comes up it will be inserted here.
       
       

      And last but not least

      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @"Sniki", @Mieze, @headkaze and all others members involved directly or indirectly.
       
       
      Attachments
      config.plist
       
      SSDT-L440.aml
       
    • By ludufre
      Since the Catalina beta 9, FileVault takes about 3 minutes to request the password.
       
      I am currently in a final version 19A602 and the problem continues.
       
      If anyone can take a look, I have attached "gen_debug" before and after disabling FileVault.
      I noticed that if I boot in verbose, the login screen takes the same time, but at left o screen a lot of lines pop up:
      ERROR: LWSmcUINT8ForKey smcProtocol-> SmcReadValue failed for key '... Important: In attachments the Kexts are in /EFI/CLOVER/kexts/10.15/ but the behavior in /Library/Extensions is the same.
       
      Important 2: Tried without UsbKbDxe.efi, UsbMouseDxe.efi, Ps2MouseDxe.efi and same issue.
       
      My laptop is from this guide that I wrote: 
       
      gen_debug.zip
       
       
      [EDIT]
       
      Solved with https://www.reddit.com/r/hackintosh/comments/cre5da/filevault_howto
       
      Basically removes:
       
      AppleImageCodec.efi
      AppleImageLoader.efi
      AppleKeyAggregator.efi
      AppleUITheme.efi
      AptioInputFix.efi
      Ps2MouseDxe.efi
      FirmwareVolume.efi
      SMCHelper.efi
       
      And, add:
       
      AppleGenericInput.efi
      AppleUiSupport.efi
      VirtualSmc.efi
       
      Of course, replace FakeSMC kexts with VirtualSMC kexts.
       
      Now, just 5 seconds to ask password.
×