Jump to content
  1. BlackPilot

    BlackPilot

  2. DichVuSeo

    DichVuSeo

  3. crusher

    crusher

  4. telepati

    telepati

  5. Cyberdevs

    Cyberdevs

  6. Allan

    Allan

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By freshynek
      Hi guys,
      I need help with Mojave installation error. Hardware: ASUS H81M-Plus with Haswell refres i5-4460 processor with intel HD4600 graphics. UEFI bios has been correctly set up. Just after the start of installation, it gets stuck at XCPM: registered. When creating the install USB, I used Clover 5100.
      Thank you.
       

      EFI.zip
    • By hackinhacker
      First time trying hackintosh.  Upon Mojave (10.14.6) installation on my pc, it first reboots then goes to panic state...  Here is my BIOS settings, config.plist, and list of kexts.  Can someone please help?  
       
      my machine spec:
       
      MOBO:  Gigabyte Z390 Pro 
      CPU:  i5 9600k
      GPU:  Sapphire Radeon Pulse RX 570 4GB
      Memory:  Crucial 2 X 16GB 2666 Mhz
       
      BIOS setting
      • Save & Exit → Load Optimized Defaults
      • Chipset → Vt-d → Disabled 
      • Chipset → Internal Graphics → Disabled
      • Chipset → Above 4G Decoding → Disabled 
      • BIOS → Windows 8/10 Features → Other OS
      • BIOS → CSM Support → DISABLED  
      • Initial Display Output → PCIe 1 Slot
      • Trusted Computing → Security Device Support →  Disable
      • USB Configuration → Legacy USB Support →  Enabled
      • USB Configuration → XHCI Hand-off →  Enabled
      • Network Stack Configuration → Network Stack →  Disabled
      • SATA And RST Configuration → SATA Mode Selection →  AHCI
      • Extreme Memory Profile (X.M.P) → Disabled ( Optionally, can be enabled after macOS is installed, your choice )
       
       
      config.plist.1211.plist.zip
      kext.zip

    • By tonyx86
      I was inspired by @duduclx post here for installing El Capitan on a Dell Latitude E6410, so I decided to install Mojave 10.14.5 and subsequently 10.14.6.  Everything works perfectly (including sleep).  I'm starting this thread hoping to help others install Mojave on their E6410s.  A brief installation guide is provided later in this first post.  The interested reader is encouraged to read the other posts in this thread to see how this solution evolved and to learn additional tips/details not provided in this first post (including dual-booting with macOS and Windows).
       
      My system is as follows:
      Dell Latitude E6410 (I7-620m, Nvidia 3100M, 8GB DDR3, 512GB SSD, 1440x900 display, BIOS: A17) MacOS: Mojave 10.14.6 (APFS) (Patched with DosDude Mojave Patcher 1.3.3) MacModel: MacBookPro 6,2 (LPCB._DSM.Name "pci8086,3b09") Kexts: Lilu 1.3.6, VoodooHDA 2.9.2, AirportBrcmFixup 2.0.0, IntelMausiEthernet 2.4.1d1, ACPIBatteryManager 1.90.1, BrcmPatchRam2.kext, BrcmFirmwareRepo.kext, VoodooPS2Controller (the "Refined ALPS Touchpad" version - release 6 developed by @Dr. Hurt and compiled by @bronxteck), not the original version), USBInjectAll (with custom SSDT-UIAC), VoodooSDHC.kext (configured as shown here). Wi-Fi: Broadcom BCM 94352HMB (with AirportBrcmFixup.kext) CLOVER (Legacy): R4961  
      Configuration items that may be different from what you have seen in other E6410 configurations
      Addition of _OFF and _ON methods to _PTS and _WAK methods respectively (to control discrete graphics in order to enable sleep/wake) LPCB._DSM patched with device-id "3b09" AND "name", "pci8086,3b09" for native Nehalem power management with MacBookPro 6,2 ECDV renamed to EC so that AppleBusPowerController loads AGP.VID._DSM patched with device-id "0a29" so that AppleGraphicsPowerManagement loads No CLOVER Generate P or Generate C States (with the correct LPCB._DSM and MacBookPro 6,2, these CLOVER options are unnecessary for this architecture and only limit max multiplier and reduce number of P states) DSDT patched to include HDAU device (device-id 0x0be3)  
      What is NOT working:
      Display brightness can be controlled with keyboard keys, but cannot be controlled with slider in Display settings. Graphics Power Management - AGPM loads (because 10de,0a29 device is injected), but there's no evidence that 3100m frequency and voltage is changing.
        What is NOT tested:
      Smartcard Reader eSata (I have this disabled in my BIOS) Firewire Port (it does appear in the Network settings, just haven't tried it) Microphone Jack PC Card Slot (I have this disabled in my BIOS)  
      What IS working:
      SLEEP IS WORKING! Everything else not mentioned above.   Speedstep/CPUPowerManagement is perfect, system temps are low, CPU multiplier operates as expected, battery life is long Shutdown is fast Display/graphics acceleration is perfect (thanks to DosDude's Mojave patcher) Brightness (adjusted with brightness keys on keyboard) works perfectly Battery Manager works (battery status is displayed in menu bar) simply by installing ACPIBatterManager.kext. Wi-Fi (after changing to Broadcom BCM94352HMB and installing AirportBrcmFixup.kext) Audio (volume adjustable, volume indicator appears in menu bar).  Switched to VoodooHDA from AppleALC after AppleALC caused slow boot due to "IOHDACodecFunction timeout." Ethernet port (with IntelMausiEthernet.kext) Broadcom BCM20702A0 Bluetooth (with BrcmPatchRam2.kext and BrcmFirmwareRepo.kext) Optical Drive External VGA (with corrected NVCAP.  Need NVCAP 04000000 00000100 0E000000 00000007 00000000 (credit: here) for working external VGA display. Headphone jack Display Port (tested using DP > HDMI adapter) Camera SD Card Reader  
      Known issues and their solutions (These issues have all been resolved, with the solutions incorporated into the attached config files.  The issues are listed here for historical purposes and no further work is needed unless stated otherwise).
      AAPL,clock-id and device_type do not appear in IORegistry for EHC1.  Solution is to use CLOVER on-the-fly patching/fixing/renaming for EHC1 and EHC2.  Thank you, @feartech, for this tip. ALPS trackpad performance is not good with the "standard" VoodooPS2Controller.kext that I initially used.  Switching to the "Refined ALPS TouchPad driver" is a big improvement.  I've implemented and tested this on my system.  The ALPS version of VoodooPS2Controller.kext mixes up a few keys.  Need to switch the Command and Option keys (System Preferences > Keyboard > Modifier Keys) and change keyboard type to ISO European. This configuration (captured in the attached config files) uses an injected device-id (10de,0a29) for NVidia 3100m to get AGPM to load.  While I haven't observed any performance differences, a better approach may be to inject AGPM properties for device 10de,0a6c (the actual device-id for the 3100m).  This AGPM method is discussed later in this thread.  I have briefly tested this "FakeSMC.kext method" for injecting AGPM attributes without any noticeable changes in laptop/graphics behavior. IOHWControl is not loaded under AGPM (Should be AGP > VID > NVDA,Display-A@0 > NVDATesla > AGPM > gpu-control > IOHWControl as viewed in IORegistryExplorer).  It is loaded on a real MacBookPro6,2 running Mojave and is loaded on this Dell Latitude E6410 running High Sierra.  If I "Inject NVidia" via CLOVER, IOHWControl loads properly. The Dell Latitude DSDT (BIOS A17) has a bug in Method (GNOT).  In the method, the expression  If (LOr (LGreater (OSYS, 0x07D0), LLess (OSYS, 0x07D6))) always evaluates to TRUE, so the patched DSDT has no dependency on the value of OSYS.  I suspect that LOr should be replaced with LAnd, so that this expression is TRUE for variants of Windows 2001 and False for any other OS.  While this may have no affect on MacOS, it makes one wonder how such an obvious bug made it through Dell QA and is still present in BIOS A17.  Also makes one wonder whether the sleep problem (which no one has solved) was fixed in Windows to address another DSDT bug. The assigned value of ACOS and OSYS in the DSDT are conditional on the operating system.  There is no condition for "Darwin."  The solution is to add a condition for "Darwin" (making it equivalent to one of the defined operating systems (e.g. Linux, Win7, etc).  The attached config hard-codes ACOS and OSYS values equivalent to those for Linux.  Another way to handle this (different from the method employed in the attached config files) might be to override _OSI with XOSI (defined in a custom SSDT). The portType of the Internal Bluetooth device is portType=0 which, according to Rehabman's comments in SSDT-UIAC-All.dsl, is an external USB 2 port.  This should be an internal USB port (portType=2).  I learned through trial and error that the HUB1 and HUB2 definitions in Rehabman's SSDT-UIAC-ALL.dsl apply to the ports on the EHCx USB hubs.  The solution is to include the HUB1 definition in SSDT-UIAC.dsl and change portType to 2 for HP15.  This change doesn't appear to affect/fix sleep, but it may prevent instant wake if we get sleep working. There are minor differences between a real MacBookPro6,2 IORegistry dump and this HackBookPro6,2 IORegistry dump that can be resolved with simple DSDT edits.  I am now running with these changes, but haven't found these changes to make any difference in operational behavior.
      Rename Device (AC) -> Device (ADP1) Remove UID from Device (HPET) Add compatible ID "PNP0C01" to Device (HPET) Change ADP1:_STA from 0x0F to 0xFFFFFFFF Enable Ambient Light Sensor and renamed to Device (ALS0) from Device (ALS) Add compatible ID "smc-als" to ALS0 Rename LID -> LID0 Change "name" definitions to Buffers in _DSM methods Rename Device (PBTN) to PWRB Rename Device (SBTN) to (SLPB) Change HDAU.hda-gfx from "onboard-1" to "onboard-2" Change GFX0.hda-gfx from "onboard-1" to "onboard-2" Sleep / Wake does not work with the basic DSDT edits.  I have discovered that Sleep / Wake can be made to work by adding discrete graphics _OFF and _ON methods to _PTS and _WAK methods respectively (borrowed the concept and code from a working E6430 DSDT: Credit here: https://osxlatitude.com/forums/topic/9248-working-sleep-on-intel-hd-and-nvidia-nvs-on-dell-latitude-e6430-optimus-enabled-or-disabled/page/6/. LCD screen is blank when waking laptop by opening lid (screen is not blank when waking with power button).  Solution is to add darkwake=8 to CLOVER boot args.  Thank you @Hervé for this tip.  
      Brief Installation Guide:
      Configure BIOS (version A17) as follows (leave default unless listed here): Boot Sequence: USB, Internal HDD, CD/DVD, Modular Bay HDD; Boot List Option: Legacy; Integrated NIC: Enabled; Parallel Port: Disabled; Serial Port: Disabled; SATA Operation: AHCI; Misc Devices: Enable Modular Bay, Camera, External USB, Microphone, Media Card and 1394; Latitude ON Reader: Disabled; Keyboard Illumination: Auto ALS and Input; Ambient Light Sensor: Enabled; OROM Keyboard Access: Disable; TPM Security: Disable; Computrace: Deactivate; CPU XD Support: Enable; Performance: Enable all options; Power Management: Disable Wake on AC, Disable Wake on LAN/WAN, Express Charge: Standard, Charge Behavior: Enabled; Keypad: Fn Key Only; Mouse/Touchpad: Touchpad/PS-2 Mouse; USB Emulation: Enable Legacy; Fn Key Emulation: Disabled; Fastboot: Thorough; Virtualization: Enable Intel Virtualization, Disable VT for Direct I/O, Disable Trusted Execution; Wireless Switch: Bluetooth and WLAN; Wireless Device Enable: Bluetooth and WLAN;  Create your MacOS installer USB (Use DosDude's Mojave Patcher for Mojave) (start with High Sierra and not Mojave if you're new to hackintosh). Install CLOVER (Legacy) on installer USB using attached EFI as your guide for patched ACPI, kexts and config.plist Install MacOS to your SSD.  When you run DosDude's Mojave Patcher, DO NOT install LegacyUSBInjector.kext - you're going to use Rehabman's USBInjectAll.kext.  Also, do not install the DosDude SIP kext (you're using CLOVER to manage SIP). Install the following kexts in /Library/Extensions:  ACPIBatteryManager.kext, AirportBrcmFixup.kext, BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakeSMC.kext, FakeSMC_ACPISensors.kext, FakeSMC_CPUSensors.kext, FakeSMC_GPUSensors.kext, FakeSMC_LPCSensors.kext, IntelMausiEthernet.kext, Lilu.kext, USBInjectAll.kext, VoodooPS2Controller.kext (the "Refined ALPS Touchpad driver," not the original), VoodooSDHC.kext (configured as shown here). Switch Command and Option keys to compensate for Refined ALPS driver issue (System Preferences > Keyboard > Modifier Keys).  Also change keyboard type to ISO European to fix the [ ` ~ ] key (to the left of the "1" (one) key. Install VoodooHDA Install HWMonitor application  
      Tips for Improved Performance (on this and other older systems)
      System Preferences > Spotlight > Search Results: Uncheck all options System Preferences > Spotlight > Privacy: Add all Volumes System Preferences > Accessibility > Display: Check "Reduce motion" System Preferences > Accessibility > Display: Check "Reduce transparency"  
      Other tips
      If your fan is always running and temps are good, try pressing Fn + z After applying Mojave updates, HWMonitor may not display discrete graphics attributes.  On systems with multiple displays, a second (or third display) may not be active after applying the Mojave update.  The solution to this is to run "sudo kextcache -i /" (in a terminal window) and reboot.  This will usually fix the issue.  If the issue is not fixed, run DosDude's Post Install Utility, apply the Legacy Graphics Patch, reboot and then run "sudo kextcache -i /" if necessary.  
      Credits
      In addition to those mentioned in this first post and in subsequent posts in this thread, much of this solution for the Latitude E6410 was made possible by the numerous contributions of @RehabMan.  I hope he's doing well, wherever he is.  Hopefully he has long since forgotten what a PIA I was (and still am) as I was (and still am) learning hackOS.

      E6410.zip
    • By gusbemacbe
      Hello,
       
      I am a former user of MacBook and Mac mini. Both died. One in 2014 and another last year.  I will think of giving my Hackintosh-compatible laptop to my brother that I purchased years ago, because he wants to play more than one computer, so he is a Twitch/YouTube streamer and a hardcore gamer and I will not need to lend him many times. If he wants, from my former laptop I will take only one 240GB SSD Samsung Evo with installed Arch Linux and leave one 500GB HDD for him. In the future, I will purchase a new Alienware laptop.
       
      As I got newly graduated, I moved to a new super PC with AMD Ryzen™ 7 2700X CPU and with NVIDIA GeForce™ 1660 Ti GPU. More details, you can see my signature below, that provides the complete details. I own an external SSD m.2 2280 with installed Windows 10.
       
      I will reconsider purchasing 4th drive – an external 480GB SSD m.2 2280 SATA WD Green 545MB/s or an external 1TB SSD SATA WD Green 545MB/s – for installing Hackintosh. But purchasing, I need to make sure.
       
      1. Is it worth to install Hackintosh on an external SSD m.2 2280? If I partition two partitions, one for Insansely's MyHack/Chameleon/Clover and another for Hackintosh and my new super-PC boot is natively BIOS and Grub, is it worth? Maybe I will try to install reFind on Arch Linux to replace the Grub if it is worth.
      2. I know that it will run on macOS High Sierra, Mojave and Catalina, but if I need Metal 2 to run the latest version of Sketch (the which I own an original licence) and of other apps the which I own original licences? Is NVIDIA GeForce™ 1660 Ti compatible with Metal 2?
      3. Since it be an external SSD, will I able to run Hackintosh as a portable OS in other computers?
       
       
    • By verdazil
      This is not intended to be a complete and comprehensive installation guide. There are many installation guides on the forum and installing macOS is no different from installing on other desktop builds. Rather, this is supplemental information specific to the my hardware listed below. I hope you find this information useful and this will save you a little time.
       
      Hardware
      MB: Huananzhi X79-ZD3
      CPU: Intel® Xeon E5-2689, 1.2-3.6 GHz
      Chipset: Sandy Bridge-E Q65 (C600/C200)
      Memory: Samsung 4x8 Gb ECC/REG DDR3, 1866 MHz
      Video: Saphire Nitro+ Radeon RX 590
      Monitor: BENQ-BL2711U + LG TV 42LF650V
      SSD + HDD: NVMe M.2 Samsung 970 EVO 250 Gb + HDD Seagate 2 Tb
      WiFi: Fenvi FV-T919 BCM94360CD
      Mac model: MacPro6,1
      MacOS version tested: Mojave 10.14.6 (18G1012)
       
      What works?
      - Video: 4K x 60Hz on BENQ-BL2711U + Full HD x 60Hz on LG TV 42LF650V
      - Sound: audio jack + HDMI audio on both monitors
      - Wi-Fi (out of the box)
      - USB2 && USB3 ports
      - LAN
      - Bluetooth (out of the box)
       
      What does not work?
      - Sleep mode: not tested / I don't need
       
      BIOS Configuration, what's important:
      Bios Version: 4.6.5.4
      Legacy USB Support: [Enabled]
      XHCI Hand-off: [Enabled]
      EHCI Hand-off: [Enabled]
      USB Mass Storage Driver Support: [Enabled]
      Hyper-threading: [Enabled]
      Active Processor Cores: [All]
      Serial Port: [Disabled]
      Intel(R) VT-d : [Disabled]
      Launch CSM: [Enabled]
      Boot option filter: [UEFI only]
      Launch Storage OpROM policy : [UEFI only]
      Launch Video OpROM policy : [UEFI only]
       
      Here is what I used to install and configure the system:
      Clover: make with Clover Builder https://github.com/Dids/clover-builder/releases Audio: https://github.com/vit9696/AppleALC Video: https://github.com/acidanthera/WhateverGreen/releases USB: https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads + PMHeart/DalianSky patches LAN: http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/ CPU Power management: https://www.insanelymac.com/forum/topic/324270-sandy-bridge-e-ivy-bridge-e-power-management-1013-appstore-release   Clover configuration:
      Clover version: v2.5k r5088
      You can get the configuration file and the necessary kexts from the link at the end of the message
      Note: you must insert your own SeralNumber && MLB && ROM && SmUUID in the config.plist file.
       
      How to use
      To make a bootable flash drive, you can use my EFI directory (link at the end of the message). Tested for Mojave 10.14.6 installation.
      https://drive.google.com/file/d/1tjbwuUWg_PlQCVt5PTRFG6HsNby_BcgN
×