Jump to content

5,066 posts in this topic

Recommended Posts

Advertisement
31 minutes ago, Download-Fritz said:

Just for things to be clear, this Discord server is not related to anything Acidanthera and is not an official OpenCore resource

Just to be clear, where it might not be the "Official OpenCore" Discord server for "Acidanthera" group, it is where most normal users can come and ask for questions and get help with the basic understanding of using OpenCore. Where as the official Discord server for OpenCore for the "Acidanthera" team I am sure is private to a very few developers and very few "trusted" testers.

Share this post


Link to post
Share on other sites
6 hours ago, Pavo said:

Just to be clear, where it might not be the "Official OpenCore" Discord server for "Acidanthera" group, it is where most normal users can come and ask for questions and get help with the basic understanding of using OpenCore. Where as the official Discord server for OpenCore for the "Acidanthera" team I am sure is private to a very few developers and very few "trusted" testers.

And to be clear, we were the only discord group to adopt Opencore from the very start since 0.0.1, @Download-Fritz @vit9696 We are not expecting an endorsement, but we have had hundreds of successful Opencore builds via this channel. It's an English support channel and everyone is welcome for opencore support, but our policy is for everyone to read the official documentation before asking for help.

Share this post


Link to post
Share on other sites

That comment has been made as a reaction to the question refering to "the OpenCore Discord". There is no such thing, and neither do we want anyone to believe there is, nor do we believe that you claim to be, yet the question may suggest exactly that to unexperienced users.

There is no official Discord server for OpenCore or Acidanthera, not in public and not in private. Infact, I do not know most Acidanthera members, "trusted testers" and such myself at all.

 

@Pavo @MacProDude I'd like to ask you to try to interpret statements in "good faith" because nobody is interested in drama around a software project.

Share this post


Link to post
Share on other sites
9 hours ago, Download-Fritz said:

There is no official Discord server for OpenCore or Acidanthera, not in public and not in private. Infact, I do not know most Acidanthera members, "trusted testers" and such myself at all.

Many thanks, it answers my curious. Now may I ask about "config.plist - Misc - Entries"...

With 10.13.6 (HFS+) I'm able to boot using this custom "Path":

PciRoot(0x0)/Pci(0x1F,0x2)/Sata(0x0,0xFFFF,0x0)/HD(3,GPT,C456A6F1-04EB-46FC-9D03-A72480F3FC3B,0x50EA800,0xBF68000)/\System\Library\CoreServices\boot.efi

But with 10.14.x - 10.15 (APFS) it won't boot with:

PciRoot(0x0)/Pci(0x1F,0x2)/Sata(0x0,0xFFFF,0x0)/HD(5,GPT,82C9F5B0-9BE3-4ABC-9DC1-D0241EEB93B2,0x11188800,0x4082800)/VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,42110296967A1A469B7D207A294F0602)/\A3897DBE-ECFB-4EF4-91EC-0F7E28C2E7F3\System\Library\CoreServices\boot.efi

These paths are taken from OpenCore boot logs when using "Misc - Security - ScanPolicy: 0x003F0002" < This one actually works just fine, but on my case I'm trying with Custom Entries and prevent OC from scanning with ScanPolicy=0x00000001.

Is it possible using custom path for APFS volume, or.. if not; is it bcoz APFS Volume actually not exist (virtual)..?

 

Edited by Badruzeus

Share this post


Link to post
Share on other sites
10 hours ago, Download-Fritz said:

That comment has been made as a reaction to the question refering to "the OpenCore Discord". There is no such thing, and neither do we want anyone to believe there is, nor do we believe that you claim to be, yet the question may suggest exactly that to unexperienced users.

There is no official Discord server for OpenCore or Acidanthera, not in public and not in private. Infact, I do not know most Acidanthera members, "trusted testers" and such myself at all.

 

@Pavo @MacProDude I'd like to ask you to try to interpret statements in "good faith" because nobody is interested in drama around a software project.

Great! I didn't ask for official sponsoring of the channel or the guide, Users have options, and they are there for people if they want to read or join. As for drama, no one is causing drama. :thumbsup_anim:

Share this post


Link to post
Share on other sites
3 hours ago, Badruzeus said:

Many thanks, it answers my curious. Now may I ask about "config.plist - Misc - Entries"...

With 10.13.6 (HFS+) I'm able to boot using this custom "Path":


PciRoot(0x0)/Pci(0x1F,0x2)/Sata(0x0,0xFFFF,0x0)/HD(3,GPT,C456A6F1-04EB-46FC-9D03-A72480F3FC3B,0x50EA800,0xBF68000)/\System\Library\CoreServices\boot.efi

But with 10.14.x - 10.15 (APFS) it won't boot with:


PciRoot(0x0)/Pci(0x1F,0x2)/Sata(0x0,0xFFFF,0x0)/HD(5,GPT,82C9F5B0-9BE3-4ABC-9DC1-D0241EEB93B2,0x11188800,0x4082800)/VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,42110296967A1A469B7D207A294F0602)/\A3897DBE-ECFB-4EF4-91EC-0F7E28C2E7F3\System\Library\CoreServices\boot.efi

These paths are taken from OpenCore boot logs when using "Misc - Security - ScanPolicy: 0x003F0002" < This one actually works just fine, but on my case I'm trying with Custom Entries and prevent OC from scanning with ScanPolicy=0x00000001.

Is it possible using custom path for APFS volume, or.. if not; is it bcoz APFS Volume actually not exist (virtual)..?

 

I think on APFS, they are using Prebooter path instead, I had my custom entries work fines with default scan policy.

Share this post


Link to post
Share on other sites

Dear all,

 

I'm quite new to OpenCore and try to get it work on my Hackintosh.

My config is quite common:

  • Asus Z170 ProGaming board
  • Intel Core i5 6600K CPU
  • AMD Radeon 5700 GPU (but it is disconnected at the moment until I manage to update to Catalina last version)
  • USB Steelseries Keyboard

I folowed the Insanelymac tutorial to prepare my open core EFI folder.

All is fresly downloaded from yesterday

Opencorepkg 0.5.1

with kext:

  • lilu,
  • whatever green,
  • applealc,
  • virtualsmc,
  • smcprocessor
  • smcsuperio

The driver I added are:

  • Apfsdriverloader
  • FwRuntimeservices
  • UsbKbDxe
  • VBoxHfs
  • VirtualSMC

And I use the ACPI files:

  • SSDT-EC-USBX
  • SSDT-PLUG

All of them are the latest released.

I've configured my config.plist according to the Skylake recommendation.

 

I've attached my config.plist

I manage to see the bootloader with the different partitions but when it comes to select the one the keyboard is not responding even so backlighted.

Any idea?

Share this post


Link to post
Share on other sites

@Elende

Don't use UsbKbDxe.efi and KeySupport=yes at the same time.

Delete UsbKbDxe.efi or set all NO in Input section. (Decide as works for you better.)


Replace VBoxHfs.efi on HfsPlus.efi

VBoxHfs.efi it is license it is pure, but it is very slow therefore problems with boot RecoveryHD (dmg).

Edited by Andrey1970

Share this post


Link to post
Share on other sites
 
 
 
 
 
3
On 10/21/2019 at 1:35 PM, NavHac said:

Hi, trying to move my old build from clover to opencore. But opencore just freeze "Prelinked status - Success" nothing happened after that, the Same machine is booting Catalina just fine with clover.

Attached screenshot of last error, my config.plist, last opencore boot log and EFI directory.

Need help in diagnosing what I am doing wrong.

 

 

config.plist

EFI.zip

opencore-2019-10-21-074411.txt

 

Not able to boot till yet. Any help?

Share this post


Link to post
Share on other sites

Cound someone just give a more specific description about what is "AppleBootPolicy"?

There is little information about it, I don't know whether we should use it in a hackintosh VM.

The offical description is here: "Ensures APFS compatibility on VMs or legacy Macs"

Share this post


Link to post
Share on other sites

Does anybody know how boot selection is supposed to work and why it doesn't work with emulated nvram (i.e. using LegacyEnable and LogoutHook, tried with and without DisableVariableWrite)?

 

I have a B360 mainboard, so no native working nvram in macOS. NVRAM is working under Windows 10 with the startup disk selection in the bootcamp control panel, and when I use that it sets Boot0080 and BootOrder appropriately. Under macOS, however, startup disk only seems to set efi-boot-device. Boot0080 does not change, nor is it created when it doesn't exist, while from what I read that is expected to happen?

 

(I'd specifically like macOS updates to reboot to the installer and back again automatically)

Share this post


Link to post
Share on other sites

Emulated NVRAM doesn’t work that way, it does what is outlined in the nvram.plist file. So..... in order for that to work, you would have to have something that will write to the nvram.plist every time you did an update or used Startup Disk for the boot order to change in the nvram.plist file. 

Share this post


Link to post
Share on other sites
Just now, AliPas52 said:

I have the same problem, you can help me solve it

Not sure what works for me will work for you. Share your config and hardware info.

 

Share this post


Link to post
Share on other sites
7 hours ago, Andrey1970 said:

@Elende

Don't use UsbKbDxe.efi and KeySupport=yes at the same time.

Delete UsbKbDxe.efi or set all NO in Input section. (Decide as works for you better.)


Replace VBoxHfs.efi on HfsPlus.efi

VBoxHfs.efi it is license it is pure, but it is very slow therefore problems with boot RecoveryHD (dmg).

Why is VboxHFS in the sampleconfig.plist if we are suppose to use HFSPlus? or did i miss read what you said.

Share this post


Link to post
Share on other sites

Question to the Devs!

 

Where should I install 3rd party kext.

As I understand from Clover all 3rd party kext should be installed in L/E except for basic/critical kext you need for booting into MacOS Installer,Recovery or Updater, kexts like FakeSMC and some other kext we need injected before running them. 

Shall we have the same approach in OC or is it good enough to just keep the kexts in EFI/OC/Kexts?

For me everything is working with the kexts in EFI/OC/Kexts but what is the most correct way?

Edited by obus

Share this post


Link to post
Share on other sites

@MacPato™ HFSPlus is proprietary and not licensed for redistribution, but superiour performing

@obus I have heard the LE recommendation a bunch but never once a satisfying argument for that. We recommend injection especially looking into the future and in regards to SIP state.

Edited by Download-Fritz

Share this post


Link to post
Share on other sites

Hi,

 

I recently switched from Clover to OpenCore, everything works great (sleep, power management, etc ...) and I decided to stay with OC. Today I updated from 10.15 to 10.15.1 and in one of the several reboots of the upgrade procedure I got the error showed in the attached jpg.

 

It was not a big problem because simply rebooting, entering manually in the picker and selecting the disk "Install macOS" made the update to continue and the process went ok.

 

In my pursuit for the perfect vanilla system I wonder if this is the expected behavior or if I should modify any option to avoid that error. I have searched info about the error but I have not found anything that seems relevant.

 

I take this opportunity to thank the entire community, especially the developers for these incredible tools.

 

Regards

screenshot.jpg

Edited by zaborrilla
corrected typo

Share this post


Link to post
Share on other sites

Ha-ha. Native Apple Bless protocol works 100%. Tried to update your AMI firmware with Apple ROM:hysterical:

 

It happened because of outdated Apple Boot ROM version in OpenCore. Either you use outdated BIOSVersion with Automatic-false in PlatformInfo->SMBIOS, or (if you use Automatic=true) BIOSVersion in OpenCore sources are outdated.  

Share this post


Link to post
Share on other sites
2 hours ago, MacPato™ said:

Why is VboxHFS in the sampleconfig.plist if we are suppose to use HFSPlus? or did i miss read what you said.

 

https://github.com/acidanthera/OpenCorePkg/blob/master/Docs/Sample.plist#L726

We can't load HfsPlus.efi on AppleSupportPkg, but you know where to take it.

Edited by Andrey1970

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By STLVNUB
      Script file to clone and help build Clover, Opencore (official and unofficial) repos
      Script will create link to itself in /usr/local/bin/bob
      Wouldn't hurt to check there are no "Bob"'s there, i "Hope" there isn't.
      Then you only need to type bob. and a parameter
      "n" for NDK repo, unofficial
      "a" for ACID repo, official
      "c" for CLOVER
      It also takes "all" for ALL, if your game
       
      Easier typing bob than.....usual stuff
      Enjoy
       
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
       
      ---TUTORIAL---
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Original Post--
      https://www.olarila.com/topic/6531-olarila-hackbeast-z390-designare-thunderbolt-full-dsdt-patches-clover-opencore/
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://www.olarila.com/topic/6364-mojave-catalina-on-mobos-series-100200300-with-opencore-bootloader/
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By heiza
      Ryzen 7 2700X
      ASUS Prime X470 Pro
      32GB G.Skill Ripjaws V DDR4-3200
      ASRock Phantom Gaming Vega 56
       
      My motherboard doesn’t have an option for 4G encoding. And boot modes are listed as ”Windows UEFI Mode” and “Other OS”.
       
    • By ashcliffe
      I converted boot from Clover to OC 0.5.8. Everything is fine. I even solved few sleep/wake problems I have.
       
      I use Catalina disk as a primary boot. OC kicks in regardless whether I use windows or OSX. Every time boot occurs I get this file in the EFI partition. It is supposed to show boot errors, missing drivers, etc.
      In my case I cannot figure out why it shows every time. 
       
      Please, take a look. maybe you can at least decipher it and send me in the right direction. Oh, yeah: SIP is at 0x67
      Thanks in advance
      opencore-2020-05-17-230104.txt
×