Jump to content

740 posts in this topic

Recommended Posts

Posted (edited)

@vit9696 says. (Machine translation)

 

OpenCore — this name of the loader for macOS behind authorship of iNDi and other of HermitCrabs Lab. The project died, without having managed to be born, but his ideas regenerated within the Acidanthera project. As the result, under the same name was born the new loader which has incorporated the best parts of the predecessor: OpenCore II.
 

Edited by Andrey1970

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)
21 hours ago, Andrey1970 said:

1250754316_2019-05-2118_40_21.png.aeaef19bf6623394329e06316b08e655.png

Hi @Andrey1970

for testing I have put csr-active-config in NVRAM/Block

In system I have in my signature I have had many problem to recover it also replacing config.plist with previous working one .

resetting nvram didn't help. always problem with Nvidia kext (black screen with signal in login screen)

Have you some advice to recover from a similar problem error?

I have also a little remaining part to solve (see attached pictures)..but system is working well now

Screen_Shot_2019-05-22_at_2_47.48_PM.thumb.png.281287ac19045dac49232f97d3fa123e.png

 

Edited by fabiosun

Share this post


Link to post
Share on other sites
Posted (edited)

No, it confuses me the fact I have had problem with nvram (and nvidia web driver not loaded) also when I have delete csr-active-config block on config.plist..

and, I have no idea the way I have my system up again (deleting kext repairing permission clover reset nvram and so on)

 

Edited by fabiosun

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, vandroiy2012 said:

@fabiosun 

 

Just use


csrutil disable/enable

in recovery. 

 

Don't need to insert this in config.plist. 

 

It just works like on real mac. 

Thank you , I have read previous @vit9696 message.. but in error case I had..this was not working... works!

Edited by fabiosun

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Andrey1970 said:

That web-driver was always, add nvda_drv in the Block too.

734961068_2019-05-2217_28_03.png.0a2a4bc8a1514e5c5ca053d3724ea5e5.png

sorry..

if I set enable sip via recover as advised..

is there a way to have Nvidia web driver loaded correctly?

Edited by fabiosun

Share this post


Link to post
Share on other sites
6 minutes ago, Andrey1970 said:

You have modified web-driver? If yes, that needs to be disable SIP.

I should guess that you do.

 

no..original web in HS 10.13.6..

 

Share this post


Link to post
Share on other sites
On 4/29/2019 at 1:32 PM, PMheart said:

Could you please try if these two patches work? (which is supposed to perform the same thing as what FakeCPUID in Clover does)

 


#1

Base: _cpuid_set_info
Comment: FakeCPUID - Model 0xE (0x5E, SKL), 10.14
Count: 1
Enabled: YES
Find: 89C1C0E904880D
Identifier: kernel
Limit: 0
Mask: (LEAVE THIS EMPTY)
MatchKernel: 18.
Replace: B90E000000880D
ReplaceMask: (LEAVE THIS EMPTY)
Skip: 0

#2

Base: _cpuid_set_info
Comment: FakeCPUID - Ext 0x5 (0x5E, SKL), 10.14
Count: 1
Enabled: YES
Find: 89C1C1E91080
Identifier: kernel
Limit: 0
Mask: (LEAVE THIS EMPTY)
MatchKernel: 18.
Replace: B90500000080
ReplaceMask: (LEAVE THIS EMPTY)
Skip: 0

 

 

What should I change for my CPU (G4560, Kaby Lake) to make this patch work? In Clover I need FakeCPUID 0x0106E3 (usual suggestion, 0x0306A0, never worked for me). I use iMac18,2 SMBios.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Guys,

Good night, someone could take a look at my config.plist and help me with the following problems

1 MY resolution is enormous 

2 I don t have sound

3 my bluetooth don t detect my Magic Mouse keyboard and trackpad.

Thanks in Advance

config.plist.zip

And now I have graphic glitches too...

Edited by MorenoAv

Share this post


Link to post
Share on other sites

Now i am in windows 10 and all is well the OC Bootloader work in booting windows 10 and the resolution is well and all works well, i think...

Share this post


Link to post
Share on other sites
14 hours ago, Morpheus NS said:

 

What should I change for my CPU (G4560, Kaby Lake) to make this patch work? In Clover I need FakeCPUID 0x0106E3 (usual suggestion, 0x0306A0, never worked for me). I use iMac18,2 SMBios.

Hi,

 

If what you need is 0x0106E3 in Clover, this is the equivalent for you:

#1

Base: _cpuid_set_info
Comment: FakeCPUID - Model 0xE (0x1E, Lynnfield), 10.14
Count: 1
Enabled: YES
Find: 89C1C0E904880D
Identifier: kernel
Limit: 0
Mask: (LEAVE THIS EMPTY)
MatchKernel: 18.
Replace: B90E000000880D
ReplaceMask: (LEAVE THIS EMPTY)
Skip: 0
#2

Base: _cpuid_set_info
Comment: FakeCPUID - Ext 0x1 (0x1E, Lynnfield), 10.14
Count: 1
Enabled: YES
Find: 89C1C1E91080
Identifier: kernel
Limit: 0
Mask: (LEAVE THIS EMPTY)
MatchKernel: 18.
Replace: B90100000080
ReplaceMask: (LEAVE THIS EMPTY)
Skip: 0

 

Confirmed under 10.14.5 (18F132).

Enjoy. :)

 

PMheart

Share this post


Link to post
Share on other sites
17 hours ago, MorenoAv said:

Hi Guys,

Good night, someone could take a look at my config.plist and help me with the following problems

1 MY resolution is enormous 

2 I don t have sound

3 my bluetooth don t detect my Magic Mouse keyboard and trackpad.

Thanks in Advance

config.plist.zip

And now I have graphic glitches too...

 Hope someone could help me, I know that you are all busy, but a little help is welcome...

Thanks

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, PMheart said:

Confirmed under 10.14.5 (18F132).

Enjoy. :)

 

PMheart

 

Thank you, it worked! First time I've successfully booted my existing macOS partition with OC... now I have to figure out power management.

 

EDIT: I had to boot without my WiFi dongle because with it I get spammed with "bEndControlEvent = 0" messages

Edited by Morpheus NS

Share this post


Link to post
Share on other sites

 

21 hours ago, MorenoAv said:

Hi Guys,

Good night, someone could take a look at my config.plist and help me with the following problems

1 MY resolution is enormous 

2 I don t have sound

3 my bluetooth don t detect my Magic Mouse keyboard and trackpad.

Thanks in Advance

config.plist.zip

And now I have graphic glitches too...

 

Verify that you inject layout-id, device-id and AAPL,ig-platform-id via ACPI (DSDT) and/or take a look at your DeviceProperties.

Share this post


Link to post
Share on other sites

Hi @uglyJoe,

Thanks for your response, but I have taken my clover SSDT-UIAC.aml and put it in the OC but didn't solve the problem... I have first to learn more about creating a config.plist that works, and then switch for good to OC, in the meantime I'll stick with clover and all works good... 

Thanks anyway...

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/22/2019 at 6:11 PM, Andrey1970 said:

You have modified web-driver? If yes, that needs to be disable SIP.

I should guess that you do.

 

Hi

No OC related problem..nvidia Pascal does not allow SIP enabled with web drivers installed in my case..Maxwell nvidia card allows SIP enabled

thanks @foskvsand @iCanaro for testing in their systems

 

Edited by fabiosun

Share this post


Link to post
Share on other sites

Hi,

Have anyone tried OC on Core2Duo machine? It sounds very interesting, thanks to the Developers: THCL and all the others! ^_^

Share this post


Link to post
Share on other sites
Posted (edited)

this is so called legacy boot USB

yes i did it but no success i have created  Legacy Booting USB i don,t know it is good enough but  as  soon i am trying to boot from usb  getting this red screen 

attached are the files which i am usingimageproxy.jpg.6b52b7ac9f5ce7f16df1d7efc241858b.jpg

Archive.zip

Edited by Rockey12

Share this post


Link to post
Share on other sites

i think we need a proper installer package  which makes things much  easier for  legacy booting any help would be grateful

Share this post


Link to post
Share on other sites

I believe that something is wrong, because the first time i've tried macOS High Sierra, i had the same screen. But in the case of my pavilion dv6-1380ek, i can boot using clover on GPT drive using UEFI installation, and I'm running High Sierra successfully with UEFI and all things are working well.

Now for the OC, let's try it.

Share this post


Link to post
Share on other sites
Posted (edited)
Quote
20 hours ago, Rockey12 said:

this is so called legacy boot USB

yes i did it but no success i have created  Legacy Booting USB i don,t know it is good enough but  as  soon i am trying to boot from usb  getting this red screen 

attached are the files which i am usingimageproxy.jpg.6b52b7ac9f5ce7f16df1d7efc241858b.jpg

Archive.zip

 

 

I think you're missing some drivers, as HfsPlus, and the config.plist have to be cleaned from unused. The boot file not folder also need to be deleted maybe, I think it cause conflict with OC as its clover?

 

In my case, these settings are primordial to let the laptop to boot, and do not know how to add them into the config:

 

Quote

		<key>HaltEnabler</key>
		<true/>
		<key>PatchAPIC</key>
		<true/>

 

 

 

Quote

	<key>Devices</key>
	<dict>
		<key>Inject</key>
		<true/>
		<key>USB</key>
		<dict>
			<key>AddClockID</key>
			<true/>
			<key>FixOwnership</key>
			<true/>
			<key>HighCurrent</key>
			<true/>
			<key>NameEH00</key>
			<false/>
		</dict>
	</dict>

 

 

 

Quote

	<key>Graphics</key>
	<dict>
		<key>EDID</key>
		<dict>
			<key>Inject</key>
			<false/>
		</dict>
		<key>FBName</key>
		<string>Shrike</string>
		<key>Inject</key>
		<dict>
			<key>ATI</key>
			<false/>
			<key>Intel</key>
			<false/>
		</dict>
		<key>LoadVBios</key>
		<false/>
		<key>PatchVBios</key>
		<true/>
		<key>RadeonDeInit</key>
		<false/>
	</dict>

 

 

 

Quote

<key>KernelAndKextPatches</key>
	<dict>
		<key>KernelLapic</key>
		<true/>

 

 

 

Edited by ammoune78

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By vit9696
      OpenCorePkg / Documentation / Configuration Template / Bugtracker   Discussion and installation should be done in a separate thread! This thread is for development only!
      Current status as of April 2019: Support for UEFI and DuetPkg (legacy) booting APFS and HFS+ compatibility ACPI patcher (adding, dropping, binary patching, relocation) Apple-compatible bless implementation DeviceProperties injection DataHub and SMBIOS generation Symbolic kext and kernel patcher Direct kext injection/patching/blocking within prelinkedkernel Installation/Recovery/FileVault 2 support  Configuration in config.plist with open documentation Simple boot picker for quick launch Direct boot from dmg images  
      Known defects live here.  
      For those, who are not familiar with the history, OpenCore is a project initially born in HermitCrabs Lab that unfortunately almost died before its birth. This release is both a rebirth and a complete rewrite of OpenCore, which brings a number of new ideas, and tries to preserve the smart moves incorporated by iNDi and his team. Other than that, I wish to express my deepest words of gratitude to Acidanthera and WWHC members: your participation was and remains the key for project success, and you are simply the best.
    • By cvad
      View File Bootdisk Utility
      Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      Enjoy...
       
      For more information and complete instructions please see this topic.
       
       
       
       
      Feel free to "Rate File"
      Submitter cvad Submitted 04/28/2013 Category Bootloaders  
    • By ErmaC
      Slice is glad to present a new EFI bootloader.
      CLOVER
      Now version 2 rEFIt based.


      It is open source based on different projects: Chameleon, rEFIt, XNU, VirtualBox. The main is EDK2 latest revision.
      I also want to thank all who help Slice with the development. Credits and copyrights remain in the sources.
      http://cloverefiboot.sourceforge.net/

      Main features:


      If you have a question please provide outputs from DarwinDumper (formed from Trauma tool). Thanks Trauma!
      Continued by blackosx and STLVNUB.
      CloverGrower Downloads Installation How to do UEFI boot How to use - common words Calculator for Automatic DSDT fix Instructions for GraphicsInjector ATIConnector patching Any kexts patching with some Samples CustomEDID Hiding unnecessary menu entries Instruction for DSDT corrections to do DeviceInjection works Development Themes About kexts injection Instructions for P- and C-states generator Patching DSDT to get Sleep working CPU settings and geekbench ACPI tables loading DSDTmini Custom SMBios F.A.Q. iCloudFix Using mouse. How to make orange icons to be metallic How to make software RAID (by Magnifico) How to modify InstallESD.dmg (by shiecldk) Config.plist settings Using extra kexts and skipping kernelcache Choosing EFI drivers Configuration files Automatic config.plist creating Custom DSDT patches How to do sleep/wake working with UEFI BOOT DeviceID substitution (FakeID) Using Custom OS Icons Hibernation Floating regions Error allocating pages while starting OS -----------------
×