Jump to content

3,188 posts in this topic

Recommended Posts

14 minutes ago, hardcorehenry said:

Here you might find interesting info and you might want to take a look at this repository and the way HPET is disabled via small SSDT, don't know if it cause any problems in Windows, you'd have to check it.

 

I don't use Windows, so not an issue. I see in IOReg that HPET came back anyway (must have been loaded by another kext later?)

Real issue has nothing to do with HPET in fact, but that the sound system is not working without this "hack" (AppleHDA not loading).

 

Share this post


Link to post
Share on other sites
Advertisement

Over the past week, many many hours (too many), I'm still unable to get my ASUS Gryphon Z97 machine to even boot with OpenCore. 

 

I configured the OpenCore config.plist exactly as displayed on:
https://khronokernel-2.gitbook.io/opencore-vanilla-desktop-guide/config.plist/haswell

 

Since that base didn't work, changed a million settings, and nothing will get this hardware to boot, OpenCore Menu just hangs in most cases.

 

Maybe this ASUS Gryphon Z97 board is just buggy, not entirely surprised. I had 2 Z87 Gryphon's replaced and 3 Z97 Gryphons replaced because none of them were able to power/charge iPads on any USB port albeit ASUS product market say the USB ports have special additional power for this function, it never worked in any OS. Not even Android devices when connected ever get recognised!! Also strange random things happen with Video Cards in different PCI slots, monitors connected would switch around constantly, left would be boot screen, the right would be boot screen (Windows and Mac) sometimes no monitor will get signal if video card in last PCIe slot. Nvidia blamed Asus, Asus blamed Nvidia, sigh, Windows and Hackintosh.


I have a Clover config working but can't get SATA Hot Plug working though.

 

MaciASL won't compile my system DSDT or SSDT, some compile errors.

 

Is there a Linux equivalent to MaciASL I could try test if compile on a Linux Live Boot?

 

I attach Asus_Gryphon_Z97_MaciASL.dsl_aml_Files.zip with my System DSDT.dsl and System SSDT-1.dsl that won't compile and all the aml files that did compile.

 

Attach my working Clover EFI folder.

 

Attach a fresh new OpenCore Builder EFI folder, untouched.

 

Anyone able to take a look?

 

I trashed all the previous config files and decide to start fresh.

 

wetransfer.com link for Clover EFI folder:

EFI-Clover-Mojave-Gryphon-Z97-RX580-Working-Full_HW_Accell_H264_HVEC.zip

 

https://we.tl/t-kwvnMvgNCO

Asus_Gryphon_Z97_MaciASL.dsl_aml_Files.zip

OpenCore-ASUS_Gryphon_Z97_Build.zip

Share this post


Link to post
Share on other sites
5 hours ago, DanielMac said:

 

OK, so after hours of googling, it looks like OpenCore has a bug/issue/feature (whatever you want to call it), but the problem is that it doesn't load AppleHDA and so I get no sound.

 

Do I need to open a bugtracker ticket somewhere for this?

 

I have found a temporary solution, which is kind of weird, but OpenCore loads AppleHDA if I block a kext (I block HPET for what it's worth).

 

I can give complete specs of my machine if required. Would be great if OpenCore could be fixed so I don't need this workaround.

 

 

Fix HPET in ACPI. (Add IRQ in HPET)

For example:

2091822797_2019-12-2017_04_06.png.cf601d682c12426a508d8c94b272dc04.png

Edited by Andrey1970

Share this post


Link to post
Share on other sites

I thought I was ready for Catalina 10.15.2 from Mojave 10.14.6 but it seems I didn't read enough. Im sure I've missed something simple. I get to the progress bar then I just reboot.

 

Attached are two screen shots I grabbed with the fast scrolling in -v along with my current EFI. 

 

For what its worth I can reset NVRAM and enter Recovery. Im currently reinstalling from here now.

 

One note, even though I've renamed the drive to "Catalina", the OS shows up in Picker as Mojave. Im assuming this is my best lead. Any help is more than welcome.

IMG_0186.JPG

IMG_0188 2.JPG

OC EFI 20191207 2.zip

Share this post


Link to post
Share on other sites
41 minutes ago, NorthAmTrans said:

I thought I was ready for Catalina 10.15.2 from Mojave 10.14.6 but it seems I didn't read enough. Im sure I've missed something simple. I get to the progress bar then I just reboot.

 

Attached are two screen shots I grabbed with the fast scrolling in -v along with my current EFI. 

 

For what its worth I can reset NVRAM and enter Recovery. Im currently reinstalling from here now.

 

One note, even though I've renamed the drive to "Catalina", the OS shows up in Picker as Mojave. Im assuming this is my best lead. Any help is more than welcome. 

OC EFI 20191207 2.zip try this but not sure why you have a ACPI/whatever kexts

Share this post


Link to post
Share on other sites
20 minutes ago, errorexists said:

OC EFI 20191207 2.zip try this but not sure why you have a ACPI/whatever kexts

 

Still no go. This is a new one for me.

 

I use WEG for my RX580 though it's not completely necessary I guess. Do you not?

 

Hmm any other ideas?

 

EDIT: 

00:000 00:000 OCC: No compatible mode for 1900x1600@0 (max: 0) resolution
00:056 00:056 OC: Changed resolution to 1900x1600@0 (max: 0) from 1900x1600 - Not Found
09:384 09:327 OC: Nested ReRun is not supported
09:701 00:317 BS: Failed to start OpenCore image - Already started
09:760 00:058 BS: Failed to load OpenCore from disk - Already started
09:814 00:054 OC: Boot failed - Not Found
09:871 00:057 OCB: StartImage failed - Not Found
 

Edited by NorthAmTrans

Share this post


Link to post
Share on other sites
12 minutes ago, NorthAmTrans said:

 

Still no go. This is a new one for me.

 

I use WEG for my RX580 though it's not completely necessary I guess. Do you not?

 

Hmm any other ideas?

the only thing i can think of you bios is not correct an these 2 kexts in pic an for bios


update to current bios (2401) adjust
Boot/secure boot
os type other

key management clear secure boot keys
Adanced/system agent
VT-d disable
above 4g doesnt matter
Graphics configuration/ primary Display PCIE
PCH storage config / SATA mode selection/AHCI

image.png.37a14b79309dcf1f85e01c74a71960b2.png

 

an block out these ssdt
image.thumb.png.26ef19afed4371f16fdb3a8623f9400f.png

Share this post


Link to post
Share on other sites
24 minutes ago, errorexists said:

the only thing i can think of you bios is not correct an these 2 kexts in pic an for bios


update to current bios (2401) adjust
Boot/secure boot
os type other

key management clear secure boot keys
Adanced/system agent
VT-d disable
above 4g doesnt matter
Graphics configuration/ primary Display PCIE
PCH storage config / SATA mode selection/AHCI

image.png.37a14b79309dcf1f85e01c74a71960b2.png

 

an block out these ssdt
image.thumb.png.26ef19afed4371f16fdb3a8623f9400f.png

 

Bios is updated and I tried slimming down the ACPI patches as well. So strange.

 

I feel like there's one more step to the installation that isn't launching. 

Share this post


Link to post
Share on other sites
9 minutes ago, NorthAmTrans said:

Bios is updated and I tried slimming down the ACPI patches as well. So strange.

 

I feel like there's one more step to the installation that isn't launching. 

you should have a running system before attempting to use opencore an must be functioning first on an established machine

Share this post


Link to post
Share on other sites
1 minute ago, errorexists said:

you should have a running system before attempting to use opencore an must be functioning first on an established machine

 

Sorry I don't think I gave you enough info here. My apologies.

 

This is was a fully functioning Mojave 10.14.6 machine with OC 0.5.4. I started at 0.5.0 and have been following along with each update. 

 

I've been waiting on a piece of software to become compatible with Catalina to update and it finally did yesterday. Yay!

 

So in short I've got an established system and working EFI, I'm just for some reason getting caught up here. Also, I receive the same error with Clover.

 

@Pavo, have you come across this? If you don't have time for this then just ignore the tag.

Share this post


Link to post
Share on other sites
On 12/19/2019 at 4:19 PM, Erroruser said:

no one will be able to help you if you do not set your signature to know what your specs are

Not sure why was it not visible. So here is the issue. When booted normally and I grep the CPU info everything appears correctly.

When I boot through OC the CPU frequency is improperly set in about this mac and grepped.:
 

g5@G5s-Mac-Pro ~ % sysctl -a | grep cpu
hw.ncpu: 24
hw.activecpu: 24
hw.physicalcpu: 12
hw.physicalcpu_max: 12
hw.logicalcpu: 24
hw.logicalcpu_max: 24
hw.cputype: 7
hw.cpusubtype: 4
hw.cpu64bit_capable: 1
hw.cpufamily: 1463508716
hw.cpufrequency: 3500000000
hw.cpufrequency_min: 3500000000
hw.cpufrequency_max: 3500000000
hw.cputhreadtype: 1
machdep.cpu.max_basic: 11
machdep.cpu.max_ext: 2147483656
machdep.cpu.vendor: GenuineIntel
machdep.cpu.brand_string: Intel(R) Xeon(R) CPU           X5690  @ 3.47GHz
machdep.cpu.family: 6
machdep.cpu.model: 44
machdep.cpu.extmodel: 2
machdep.cpu.extfamily: 0
machdep.cpu.stepping: 2
machdep.cpu.feature_bits: 188838921972218879
machdep.cpu.extfeature_bits: 5034215680
machdep.cpu.signature: 132802
machdep.cpu.brand: 0
machdep.cpu.features: FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT PSE36 CLFSH DS ACPI MMX FXSR SSE SSE2 SS HTT TM PBE SSE3 PCLMULQDQ DTES64 MON DSCPL VMX SMX EST TM2 SSSE3 CX16 TPR PDCM SSE4.1 SSE4.2 POPCNT AES PCID
machdep.cpu.extfeatures: SYSCALL XD 1GBPAGE EM64T LAHF RDTSCP TSCI
machdep.cpu.logical_per_package: 32
machdep.cpu.cores_per_package: 16
machdep.cpu.microcode_version: 0
machdep.cpu.processor_flag: 0
machdep.cpu.mwait.linesize_min: 64
machdep.cpu.mwait.linesize_max: 64
machdep.cpu.mwait.extensions: 3
machdep.cpu.mwait.sub_Cstates: 4384
machdep.cpu.thermal.sensor: 1
machdep.cpu.thermal.dynamic_acceleration: 1
machdep.cpu.thermal.invariant_APIC_timer: 1
machdep.cpu.thermal.thresholds: 2
machdep.cpu.thermal.ACNT_MCNT: 1
machdep.cpu.thermal.core_power_limits: 0
machdep.cpu.thermal.fine_grain_clock_mod: 0
machdep.cpu.thermal.package_thermal_intr: 0
machdep.cpu.thermal.hardware_feedback: 0
machdep.cpu.thermal.energy_policy: 0
machdep.cpu.arch_perf.version: 3
machdep.cpu.arch_perf.number: 4
machdep.cpu.arch_perf.width: 48
machdep.cpu.arch_perf.events_number: 7
machdep.cpu.arch_perf.events: 4
machdep.cpu.arch_perf.fixed_number: 3
machdep.cpu.arch_perf.fixed_width: 48
machdep.cpu.cache.linesize: 64
machdep.cpu.cache.L2_associativity: 8
machdep.cpu.cache.size: 256
machdep.cpu.tlb.inst.small: 64
machdep.cpu.tlb.inst.large: 7
machdep.cpu.tlb.data.small: 64
machdep.cpu.tlb.data.large: 32
machdep.cpu.tlb.shared: 512
machdep.cpu.address_bits.physical: 40
machdep.cpu.address_bits.virtual: 48
machdep.cpu.core_count: 6
machdep.cpu.thread_count: 12
machdep.cpu.tsc_ccc.numerator: 0
machdep.cpu.tsc_ccc.denominator: 0
machdep.xcpm.cpu_thermal_level: 0

As you can see the CPU frequency is

 hw.cpufrequency: 3500000000
hw.cpufrequency_min: 3500000000

Yet it is read properly from OCCPU at boot:

00:000 00:000 OC: OpenCore is now loading (Vault: 0/0, Sign 0/0)...
00:060 00:060 OC: Boot timestamp - 2019.12.19 20:42:34
00:129 00:069 OCCPU: Hypervisor: 0
00:188 00:058 OCCPU: Found Intel(R) Xeon(R) CPU           X5690  @ 3.47GHz
00:251 00:062 OCCPU: Signature 206C2 Stepping 2 Model 2C Family 6 Type 0 ExtModel 2 ExtFamily 0
00:310 00:059 OCCPU: Detected Apple Processor Type: 05 -> 0501
00:368 00:058 OCCPU: Ratio Min 12 Max 26 Current 0 Turbo 28 28 27 27
00:428 00:059 OCCPU: Timer address is 408 from LPC
00:587 00:159 OCCPU: CPUFrequencyFromTSC  3457998909Hz  3457MHz
00:645 00:057 OCCPU: CPUFrequency  3457998909Hz  3457MHz
00:704 00:059 OCCPU: FSBFrequency   132999958Hz   132MHz
00:763 00:058 OCCPU: Pkg 1 Cores 6 Threads 12

Also the microcode version is 0 instead of 31.

Share this post


Link to post
Share on other sites
4 hours ago, NorthAmTrans said:

 

Sorry I don't think I gave you enough info here. My apologies.

 

This is was a fully functioning Mojave 10.14.6 machine with OC 0.5.4. I started at 0.5.0 and have been following along with each update. 

 

I've been waiting on a piece of software to become compatible with Catalina to update and it finally did yesterday. Yay!

 

So in short I've got an established system and working EFI, I'm just for some reason getting caught up here. Also, I receive the same error with Clover.

 

@Pavo, have you come across this? If you don't have time for this then just ignore the tag.

Update: I disabled SATA in my bios and everything is fine. Likely due to my rename of SAT0 to SATA.

 

@Erroruser when you sent me back an adjusted config, why did you enable Legacy Schema?

Share this post


Link to post
Share on other sites

My windows partition stopped booting after using opencore. I narrowed this down to and UEFI variable called MonotonicCounter-8be4df61-93ca-11d2-aa0d-00e098032b8c that is being created by simply using booting opencore. To fix windows I have to remove this variable from linux (cd /sys/firmware/efivars && chattr -i Mono.. && rm -f Mono...)

 

Why does opencore do this? What is this used for and where is the code that is creating this actually located?

 

Kind regars

 

Mustafa

 

Share this post


Link to post
Share on other sites
35 minutes ago, vit9696 said:

Hi, that's not us, but perhaps your BIOS firmware. We do not create anything alike, and code search gives no findings in our repositories aside EDK II copy, which part we do not use (https://github.com/search?q=org%3Aacidanthera+MonotonicCounter&type=Code). 

 

No, I don't think that it is intentional. But then again I never see this problem before using clvoer grub2 etc. I checked the code before I posted and I didn't see anything. Only in Datahub.c was mention of monotonic. But then again edk2 does some strange things, so I will check there.

Share this post


Link to post
Share on other sites

Hi, I have weird issue since catalina. My bios suddenly becomes a black screen I cant enter my bios settigs. The problem is in both opencore and clover. In clover every boot was causing black screen. I succesfully managed to switch opencore and its nvram reset option fixed that black screen issue but after few reboots I'm getting black screen error again when error occurs my bios also removes opencore from boot selection part. Only way to access it again reflashing my nvram with a bios tool. 

I have never experianced that kind of issue before on mojave. 

Device: Asus FX553VD/GL553VD i-7700hq. 

Here is my opencore files.

OpenCoreGL553VD.zip

Edited by valinor61

Share this post


Link to post
Share on other sites

Has anyone had trouble with SATA since moving to Catalina? I get an immediate panic and restart at the progress bar.

 

I can boot with ACHI enabled in bios. However, I as soon as I enable any one of the 6 ports (with or without a drive connected) I get the panic/reboot.

 

Note: the SATA Rename SSDT has no effect here. Please excuse if this has been addressed.

 

 

EFI.zip

Share this post


Link to post
Share on other sites
On 12/20/2019 at 2:55 PM, Andrey1970 said:

 

Fix HPET in ACPI. (Add IRQ in HPET)

For example:

2091822797_2019-12-2017_04_06.png.cf601d682c12426a508d8c94b272dc04.png

 

Thank you very much for your help! I added an IRQ in that IRQNoFlags to:

 {0,8,11,15}

in my case and it worked without blocking the kext. Thank you so much!

 

Share this post


Link to post
Share on other sites
30 minutes ago, tyufhl said:

@DanielMac HPET can be disabled by writing to HPTE = 0

 

Thank you for that information, but I don't understand the implications of disabling HPET. Do I need HPET for something? Why does it take up 4 IRQs?

 

Share this post


Link to post
Share on other sites

Hi @vit9696

Hi @Download-Fritz

I know it is a low priority for your OpenCore's bootloader project but I would like to ask you

AMD TRX40 user of new threadripper3 have the same initial problem (memmap error or an instant reboot if DevirtualizeMMIO is used) after ++++++++endseed stage

this happens with different motherboard and different bios settings and also using all Aptio memory EFI driver available 

 

Do you think this problem could be superated with a new aptiomemory efi driver? Or it is unrelated in your experience?

 

Thank you in advance

 

Share this post


Link to post
Share on other sites

We have no technical information on the matter and we neither have the hardware, nor time or ambition to investigate. If someone researches and describes the issue technically(!) (what causes the bug, not "it reboots when blah blah"), we will merge the fix.

Please do not tag for no reason.

Share this post


Link to post
Share on other sites

Ok sorry for bothering you with my tag

But i see people open issue on openCore GitHub and i think people do not know "what causes the bug" otherwise we could be more useful to debug

thank you for your time

 

Share this post


Link to post
Share on other sites
32 minutes ago, DanielMac said:

 

Thank you for that information, but I don't understand the implications of disabling HPET. Do I need HPET for something? Why does it take up 4 IRQs?

 

if the processor supports XCPM (Xnu CPU Power Management), HPET is not needed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By n.d.k
      After several weeks of testing OC bootloader,  disecting its source code and also Clover's source code as well, I finally switch from Clover to OC as my main bootloader. Wait! don't get the wrong idea that OpenCore is better than Clover. They both work equally well, producing a bootable macOS as an end result with simliar boot time. OC design direction is different with Clover, I believe it's not intended as a Clover replacement, but more narrowing down to macOS specifically. However, macOS is not the only OS that i am using, so, i decided to add some minimal necessary source code modification to the OC to get some of the features I need. I like to share my customized OC forked https://github.com/n-d-k/OpenCorePkg , you have to compile it yourself if you want, i will not provide pre build binary.    
       
      Additional features/changes:
      ============
       
      [ Multi-Boot ]
        - ACPI patches are optional for non macOS with setting ACPI->Quirks->EnableForAll to yes (default is no).
        - Booter Quirtks, SMBIOS and Device Properties patches will only applied to macOS.
          
      [ Hotkeys ]
        - Full functional Hotkeys [1-9] corresponding to Boot Entry's Index number and dedicated W (Windows) / X (macOS) keys can be used without seeing Boot Picker.
        - While in boot picker, F10 can use to take a snapshot of the screen.
                
      [ Ui Boot Picker ]
        - Bios Date/time, auto boot to the same OS or manual set to always boot one OS mode, and OC version are displayed in boot picker.
        - Auto boot to previous booted OS (if Misc->Security->AllowSetDefault is NO/false).
        - macOS Recovery/Tools Entries are hidden by default, use Spacebar in Boot Menu as a toggle on/off to show/hide hidden entries.
                
      [ Custom Entries ]
         - Custom entries are now listed first in picker menu and by the orders they are appeared in Misc->Boot->Entries, before all other entries.
         - Ability to change entry name found by auto scanner by adding custom entry with the exact same device path,
           this will give users the option to complete change how all boot entries listed in Boot Picker.
          
      [ Others ]
         - No verbose apfs.efi driver loading (if using apfs.efi instead of ApfsDriverLoader.efi).
          - ndk-macbuild.tool script are set to compile with latest edk2 (One can easily set to stable edk2 if prefer).
          - NvmExpressDxe driver build script are also available for system without native nvme support. (Compatible with OC and Clover).
       
      Usage:
       - To build OpenCore, run "./ndk-macbuild.tool" at Terminal (require Xcode and Xcode Command Line Tool installed, and open xcode to accept license agreement before compiling).
       - To build NvmExpressDxe driver, run "./buildnvme.sh".
       
      4k screen resolutions

       
       

       
      Customized by @btwise

       
       
       
    • By SniperBuddy
      Hello guys,
      I'm relatively new to the world of hackintosh.
      I'm trying to install the latest Mac OS - Catalina with the help of Opencore, however, this is the error that's displayed while booting from the USB:
       
      https://drive.google.com/open?id=1Xd4V2wZ2fEsgRyfVcXlJHXMPGa85g2s3
       
      You can take a look at my config.plist file from here - https://drive.google.com/file/d/17FZpTcVp4RFSaxdm6yW4uELkt7MaLdmt/view?usp=sharing
       
      I'm using the Acer E575 G laptop with Kabylake (i5 7200u)
       
      Any help would be gladly appreciated!
       
       
       
       
    • By Krani93
      Hi guys,
       
      I'm trying to install Catalina on a Lenovo m720q (i5-8600T with B360).
      After some other issues I'm know stuck at attached screen.
      Im using latest opencore version and have my EFI folder attached.
       
      Can someone help me I've got no clue what to try next :/ 
       
       
      Cheers!

      EFI.7z
    • By BlitzPanzer
      Catalina 10.15.3, OC 0.5.5

      Follow the OpenCore AMD Vanilla Guide, everything works fine iMessage, Siri, FaceTime, Continuity, Airdrop, Audio, WiFi
      But here is the problem
      Once I restart or shutdown and reboot, I will have kernel panic, so i have to reboot once again, then no more kernel panic, straight back to the system.
      Down below are the 3 kernel panic reports I got after I am back to the system, also provided specs, kexts, drivers and config.plist I used.
      Please someone help me with the problem
      Thanks in advanced   

      System Specs
      CPU: Ryzen R5 3600
      MOBO: MSI B450 Mortar Max
      RAM: Kingston HyperX Fury 16GB*2 3200MHz DDR4
      SSD: Kingston A2000 500GB NVMe PCIe
      GPU: Gigabyte RX 570 Gaming 4G v2.0
      PCIe: BCM943602CS Kexts:
      AppleALC
      AppleMCEReporterDisabler
      BrcmBluetoothInjector
      BrcmPatchRAM3
      HDMIAudio
      Lilu
      MacProMemoryNotificationDisabler
      NightShiftUnlocker
      NVMeFix
      RealtekRTL8111
      VirtualSMC
      WhateverGreen Drivers:
      ApfsDriverLoader
      AppleUsbKbDxe
      FwRuntimeServices
      VBoxHfs config.plist:
      https://drive.google.com/file/d/1M22Tvn7W-Zf_b_-J52oLcfjECj5qAcp6/view

      Kernel Panic Report 1
      panic(cpu 0 caller 0xffffff801b8652fa): Kernel trap at 0xffffff7f9f212fe3, type 14=page fault, registers: CR0: 0x000000008001003b, CR2: 0xffffffa3ce87c000, CR3: 0x00000000263ba000, CR4: 0x00000000003406e0 RAX: 0xffffffa3ce87c000, RBX: 0x0000000000005434, RCX: 0x0000000002000000, RDX: 0x0000000003000000 RSP: 0xffffffa3ce75bb60, RBP: 0xffffffa3ce75bb80, RSI: 0xffffff806d3141c0, RDI: 0x0000000000000000 R8: 0x0000000000000001, R9: 0x0000000000000026, R10: 0x00000000f8000000, R11: 0x0000000000000070 R12: 0xffffff805cc7c900, R13: 0xffffff835806f000, R14: 0x0000000000000000, R15: 0xffffff8068d2da50 RFL: 0x0000000000010246, RIP: 0xffffff7f9f212fe3, CS: 0x0000000000000008, SS: 0x0000000000000010 Fault CR2: 0xffffffa3ce87c000, Error code: 0x0000000000000002, Fault CPU: 0x0, PL: 0, VF: 1 Backtrace (CPU 0), Frame : Return Address 0xffffffa3ce75b5c0 : 0xffffff801b73bb2b mach_kernel : _handle_debugger_trap + 0x47b 0xffffffa3ce75b610 : 0xffffff801b8734d5 mach_kernel : _kdp_i386_trap + 0x155 0xffffffa3ce75b650 : 0xffffff801b864f4e mach_kernel : _kernel_trap + 0x4ee 0xffffffa3ce75b6a0 : 0xffffff801b6e2a40 mach_kernel : _return_from_trap + 0xe0 0xffffffa3ce75b6c0 : 0xffffff801b73b217 mach_kernel : _DebuggerTrapWithState + 0x17 0xffffffa3ce75b7c0 : 0xffffff801b73b5fb mach_kernel : _panic_trap_to_debugger + 0x21b 0xffffffa3ce75b810 : 0xffffff801bed2aa9 mach_kernel : _panic + 0x61 0xffffffa3ce75b880 : 0xffffff801b8652fa mach_kernel : _sync_iss_to_iks + 0x2aa 0xffffffa3ce75ba00 : 0xffffff801b864ff8 mach_kernel : _kernel_trap + 0x598 0xffffffa3ce75ba50 : 0xffffff801b6e2a40 mach_kernel : _return_from_trap + 0xe0 0xffffffa3ce75ba70 : 0xffffff7f9f212fe3 com.apple.kext.AMDRadeonX4000 : __ZN29AMDRadeonX4000_AMDHWRegisters4readEj + 0x53 0xffffffa3ce75bb80 : 0xffffff7f9f24a795 com.apple.kext.AMDRadeonX4000 : __ZN28AMDRadeonX4000_AMDVIHardware19getRegisterAperSizeEv + 0x23 0xffffffa3ce75bba0 : 0xffffff7f9f212ef0 com.apple.kext.AMDRadeonX4000 : __ZN29AMDRadeonX4000_AMDHWRegisters4initEP11IOPCIDeviceP30AMDRadeonX4000_IAMDHWInterface + 0xfa 0xffffffa3ce75bbe0 : 0xffffff7f9f2325c1 com.apple.kext.AMDRadeonX4000 : __ZN26AMDRadeonX4000_AMDHardware4initEP11IOPCIDeviceP28AMDRadeonX4000_IAMDHWHandlerRjP16_GART_PARAMETERSP14_FB_PARAMETERS + 0x257 0xffffffa3ce75bc30 : 0xffffff7f9f1b8adb com.apple.kext.AMDRadeonX4000 : __ZN37AMDRadeonX4000_AMDGraphicsAccelerator17createHWInterfaceEP11IOPCIDevice + 0x7b 0xffffffa3ce75bc70 : 0xffffff7f9f1b64be com.apple.kext.AMDRadeonX4000 : __ZN37AMDRadeonX4000_AMDGraphicsAccelerator15configureDeviceEP11IOPCIDevice + 0x10a 0xffffffa3ce75bd00 : 0xffffff7f9f128534 com.apple.iokit.IOAcceleratorFamily2 : __ZN22IOGraphicsAccelerator25startEP9IOService + 0x21e 0xffffffa3ce75bd80 : 0xffffff7f9f1b488e com.apple.kext.AMDRadeonX4000 : __ZN37AMDRadeonX4000_AMDGraphicsAccelerator5startEP9IOService + 0x82 0xffffffa3ce75bde0 : 0xffffff801be1b216 mach_kernel : __ZN9IOService14startCandidateEPS_ + 0xf6 0xffffffa3ce75be40 : 0xffffff801be1adc1 mach_kernel : __ZN9IOService15probeCandidatesEP12OSOrderedSet + 0xb21 0xffffffa3ce75bef0 : 0xffffff801be1a10e mach_kernel : __ZN9IOService14doServiceMatchEj + 0x2ce 0xffffffa3ce75bf50 : 0xffffff801be1c8ad mach_kernel : __ZN15_IOConfigThread4mainEPvi + 0x15d 0xffffffa3ce75bfa0 : 0xffffff801b6e213e mach_kernel : _call_continuation + 0x2e Kernel Extensions in backtrace: com.apple.iokit.IOAcceleratorFamily2(438.3.1)[66992525-3204-3CB0-8F03-4B70031B1CF2]@0xffffff7f9f0f0000->0xffffff7f9f1b2fff dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[A243D030-19AC-30AA-AC70-6C786DF9E6CE]@0xffffff7f9c185000 dependency: com.apple.iokit.IOPCIFamily(2.9)[ADD485B5-3EF8-37C4-B3C5-F86326E497A4]@0xffffff7f9c2f8000 dependency: com.apple.iokit.IOSurface(269.6)[42377B3B-D14A-368E-820F-07E7EA666198]@0xffffff7f9d454000 dependency: com.apple.iokit.IOGraphicsFamily(569.4)[1F9B5D88-52DB-3A16-8373-4F608A3CB2D8]@0xffffff7f9df73000 dependency: com.apple.iokit.IOReportFamily(47)[988360A2-2E10-3014-A119-BE81BC045A10]@0xffffff7f9c228000 com.apple.kext.AMDRadeonX4000(3.0.5)[5FD7AE5F-C03C-34A1-803F-ACA9B68524D0]@0xffffff7f9f1b3000->0xffffff7f9f6f7fff dependency: com.apple.iokit.IOPCIFamily(2.9)[ADD485B5-3EF8-37C4-B3C5-F86326E497A4]@0xffffff7f9c2f8000 dependency: com.apple.iokit.IOSurface(269.6)[42377B3B-D14A-368E-820F-07E7EA666198]@0xffffff7f9d454000 dependency: com.apple.iokit.IOGraphicsFamily(569.4)[1F9B5D88-52DB-3A16-8373-4F608A3CB2D8]@0xffffff7f9df73000 dependency: com.apple.iokit.IOAcceleratorFamily2(438.3.1)[66992525-3204-3CB0-8F03-4B70031B1CF2]@0xffffff7f9f0f0000 BSD process name corresponding to current thread: kernel_task Boot args: debug=0x100 keepsyms=1 alcid=1 -v shikigva=128 Mac OS version: 19D76 Kernel version: Darwin Kernel Version 19.3.0: Thu Jan 9 20:58:23 PST 2020; root:xnu-6153.81.5~1/RELEASE_X86_64 Kernel UUID: A8DDE75C-CD97-3C37-B35D-1070CC50D2CE Kernel slide: 0x000000001b400000 Kernel text base: 0xffffff801b600000 __HIB text base: 0xffffff801b500000 System model name: MacPro7,1 (Mac-27AD2F918AE68F61) System shutdown begun: NO Panic diags file available: NO (0xe00002bc) System uptime in nanoseconds: 47565362999  
      Kernel Panic Report 2
      panic(cpu 10 caller 0xffffff801b8652fa): Kernel trap at 0xffffff7f9e629fe3, type 14=page fault, registers: CR0: 0x000000008001003b, CR2: 0xffffff83d25d2000, CR3: 0x0000000029068000, CR4: 0x00000000003406e0 RAX: 0xffffff83d25d2000, RBX: 0x0000000000005434, RCX: 0x0000000002000000, RDX: 0x0000000003000000 RSP: 0xffffff83d14c3b60, RBP: 0xffffff83d14c3b80, RSI: 0xffffff805f6adb80, RDI: 0x0000000000000000 R8: 0x0000000000000001, R9: 0x0000000000000026, R10: 0x00000000f8000000, R11: 0x0000000000000070 R12: 0xffffff805fba2580, R13: 0xffffff835b02e000, R14: 0x0000000000000000, R15: 0xffffff80631191e0 RFL: 0x0000000000010246, RIP: 0xffffff7f9e629fe3, CS: 0x0000000000000008, SS: 0x0000000000000010 Fault CR2: 0xffffff83d25d2000, Error code: 0x0000000000000002, Fault CPU: 0xa, PL: 0, VF: 1 Backtrace (CPU 10), Frame : Return Address 0xffffff83d14c35c0 : 0xffffff801b73bb2b mach_kernel : _handle_debugger_trap + 0x47b 0xffffff83d14c3610 : 0xffffff801b8734d5 mach_kernel : _kdp_i386_trap + 0x155 0xffffff83d14c3650 : 0xffffff801b864f4e mach_kernel : _kernel_trap + 0x4ee 0xffffff83d14c36a0 : 0xffffff801b6e2a40 mach_kernel : _return_from_trap + 0xe0 0xffffff83d14c36c0 : 0xffffff801b73b217 mach_kernel : _DebuggerTrapWithState + 0x17 0xffffff83d14c37c0 : 0xffffff801b73b5fb mach_kernel : _panic_trap_to_debugger + 0x21b 0xffffff83d14c3810 : 0xffffff801bed2aa9 mach_kernel : _panic + 0x61 0xffffff83d14c3880 : 0xffffff801b8652fa mach_kernel : _sync_iss_to_iks + 0x2aa 0xffffff83d14c3a00 : 0xffffff801b864ff8 mach_kernel : _kernel_trap + 0x598 0xffffff83d14c3a50 : 0xffffff801b6e2a40 mach_kernel : _return_from_trap + 0xe0 0xffffff83d14c3a70 : 0xffffff7f9e629fe3 com.apple.kext.AMDRadeonX4000 : __ZN29AMDRadeonX4000_AMDHWRegisters4readEj + 0x53 0xffffff83d14c3b80 : 0xffffff7f9e661795 com.apple.kext.AMDRadeonX4000 : __ZN28AMDRadeonX4000_AMDVIHardware19getRegisterAperSizeEv + 0x23 0xffffff83d14c3ba0 : 0xffffff7f9e629ef0 com.apple.kext.AMDRadeonX4000 : __ZN29AMDRadeonX4000_AMDHWRegisters4initEP11IOPCIDeviceP30AMDRadeonX4000_IAMDHWInterface + 0xfa 0xffffff83d14c3be0 : 0xffffff7f9e6495c1 com.apple.kext.AMDRadeonX4000 : __ZN26AMDRadeonX4000_AMDHardware4initEP11IOPCIDeviceP28AMDRadeonX4000_IAMDHWHandlerRjP16_GART_PARAMETERSP14_FB_PARAMETERS + 0x257 0xffffff83d14c3c30 : 0xffffff7f9e5cfadb com.apple.kext.AMDRadeonX4000 : __ZN37AMDRadeonX4000_AMDGraphicsAccelerator17createHWInterfaceEP11IOPCIDevice + 0x7b 0xffffff83d14c3c70 : 0xffffff7f9e5cd4be com.apple.kext.AMDRadeonX4000 : __ZN37AMDRadeonX4000_AMDGraphicsAccelerator15configureDeviceEP11IOPCIDevice + 0x10a 0xffffff83d14c3d00 : 0xffffff7f9e52a534 com.apple.iokit.IOAcceleratorFamily2 : __ZN22IOGraphicsAccelerator25startEP9IOService + 0x21e 0xffffff83d14c3d80 : 0xffffff7f9e5cb88e com.apple.kext.AMDRadeonX4000 : __ZN37AMDRadeonX4000_AMDGraphicsAccelerator5startEP9IOService + 0x82 0xffffff83d14c3de0 : 0xffffff801be1b216 mach_kernel : __ZN9IOService14startCandidateEPS_ + 0xf6 0xffffff83d14c3e40 : 0xffffff801be1adc1 mach_kernel : __ZN9IOService15probeCandidatesEP12OSOrderedSet + 0xb21 0xffffff83d14c3ef0 : 0xffffff801be1a10e mach_kernel : __ZN9IOService14doServiceMatchEj + 0x2ce 0xffffff83d14c3f50 : 0xffffff801be1c8ad mach_kernel : __ZN15_IOConfigThread4mainEPvi + 0x15d 0xffffff83d14c3fa0 : 0xffffff801b6e213e mach_kernel : _call_continuation + 0x2e Kernel Extensions in backtrace: com.apple.iokit.IOAcceleratorFamily2(438.3.1)[66992525-3204-3CB0-8F03-4B70031B1CF2]@0xffffff7f9e4f2000->0xffffff7f9e5b5fff dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[A243D030-19AC-30AA-AC70-6C786DF9E6CE]@0xffffff7f9c3f1000 dependency: com.apple.iokit.IOPCIFamily(2.9)[ADD485B5-3EF8-37C4-B3C5-F86326E497A4]@0xffffff7f9c4a6000 dependency: com.apple.iokit.IOSurface(269.6)[42377B3B-D14A-368E-820F-07E7EA666198]@0xffffff7f9e4c1000 dependency: com.apple.iokit.IOGraphicsFamily(569.4)[1F9B5D88-52DB-3A16-8373-4F608A3CB2D8]@0xffffff7f9c793000 dependency: com.apple.iokit.IOReportFamily(47)[988360A2-2E10-3014-A119-BE81BC045A10]@0xffffff7f9c09f000 com.apple.kext.AMDRadeonX4000(3.0.5)[5FD7AE5F-C03C-34A1-803F-ACA9B68524D0]@0xffffff7f9e5ca000->0xffffff7f9eb0efff dependency: com.apple.iokit.IOPCIFamily(2.9)[ADD485B5-3EF8-37C4-B3C5-F86326E497A4]@0xffffff7f9c4a6000 dependency: com.apple.iokit.IOSurface(269.6)[42377B3B-D14A-368E-820F-07E7EA666198]@0xffffff7f9e4c1000 dependency: com.apple.iokit.IOGraphicsFamily(569.4)[1F9B5D88-52DB-3A16-8373-4F608A3CB2D8]@0xffffff7f9c793000 dependency: com.apple.iokit.IOAcceleratorFamily2(438.3.1)[66992525-3204-3CB0-8F03-4B70031B1CF2]@0xffffff7f9e4f2000 BSD process name corresponding to current thread: kernel_task Boot args: debug=0x100 keepsyms=1 alcid=1 -v shikigva=128 Mac OS version: 19D76 Kernel version: Darwin Kernel Version 19.3.0: Thu Jan 9 20:58:23 PST 2020; root:xnu-6153.81.5~1/RELEASE_X86_64 Kernel UUID: A8DDE75C-CD97-3C37-B35D-1070CC50D2CE Kernel slide: 0x000000001b400000 Kernel text base: 0xffffff801b600000 __HIB text base: 0xffffff801b500000 System model name: MacPro7,1 (Mac-27AD2F918AE68F61) System shutdown begun: NO Panic diags file available: NO (0xe00002bc) System uptime in nanoseconds: 38416992755  
      Kernel Panic Report 3
      panic(cpu 8 caller 0xffffff801da652fa): Kernel trap at 0xffffff7fa084dfe3, type 14=page fault, registers: CR0: 0x000000008001003b, CR2: 0xffffff83d44cd000, CR3: 0x000000002b260000, CR4: 0x00000000003406e0 RAX: 0xffffff83d44cd000, RBX: 0x0000000000005434, RCX: 0x0000000002000000, RDX: 0x0000000003000000 RSP: 0xffffff83d319bb60, RBP: 0xffffff83d319bb80, RSI: 0xffffff8066659c00, RDI: 0x0000000000000000 R8: 0x0000000000000001, R9: 0x0000000000000026, R10: 0x00000000f8000000, R11: 0x0000000000000070 R12: 0xffffff8061f35280, R13: 0xffffff835d231000, R14: 0x0000000000000000, R15: 0xffffff806189db90 RFL: 0x0000000000010246, RIP: 0xffffff7fa084dfe3, CS: 0x0000000000000008, SS: 0x0000000000000000 Fault CR2: 0xffffff83d44cd000, Error code: 0x0000000000000002, Fault CPU: 0x8, PL: 0, VF: 1 Backtrace (CPU 8), Frame : Return Address 0xffffff83d319b5c0 : 0xffffff801d93bb2b mach_kernel : _handle_debugger_trap + 0x47b 0xffffff83d319b610 : 0xffffff801da734d5 mach_kernel : _kdp_i386_trap + 0x155 0xffffff83d319b650 : 0xffffff801da64f4e mach_kernel : _kernel_trap + 0x4ee 0xffffff83d319b6a0 : 0xffffff801d8e2a40 mach_kernel : _return_from_trap + 0xe0 0xffffff83d319b6c0 : 0xffffff801d93b217 mach_kernel : _DebuggerTrapWithState + 0x17 0xffffff83d319b7c0 : 0xffffff801d93b5fb mach_kernel : _panic_trap_to_debugger + 0x21b 0xffffff83d319b810 : 0xffffff801e0d2aa9 mach_kernel : _panic + 0x61 0xffffff83d319b880 : 0xffffff801da652fa mach_kernel : _sync_iss_to_iks + 0x2aa 0xffffff83d319ba00 : 0xffffff801da64ff8 mach_kernel : _kernel_trap + 0x598 0xffffff83d319ba50 : 0xffffff801d8e2a40 mach_kernel : _return_from_trap + 0xe0 0xffffff83d319ba70 : 0xffffff7fa084dfe3 com.apple.kext.AMDRadeonX4000 : __ZN29AMDRadeonX4000_AMDHWRegisters4readEj + 0x53 0xffffff83d319bb80 : 0xffffff7fa0885795 com.apple.kext.AMDRadeonX4000 : __ZN28AMDRadeonX4000_AMDVIHardware19getRegisterAperSizeEv + 0x23 0xffffff83d319bba0 : 0xffffff7fa084def0 com.apple.kext.AMDRadeonX4000 : __ZN29AMDRadeonX4000_AMDHWRegisters4initEP11IOPCIDeviceP30AMDRadeonX4000_IAMDHWInterface + 0xfa 0xffffff83d319bbe0 : 0xffffff7fa086d5c1 com.apple.kext.AMDRadeonX4000 : __ZN26AMDRadeonX4000_AMDHardware4initEP11IOPCIDeviceP28AMDRadeonX4000_IAMDHWHandlerRjP16_GART_PARAMETERSP14_FB_PARAMETERS + 0x257 0xffffff83d319bc30 : 0xffffff7fa07f3adb com.apple.kext.AMDRadeonX4000 : __ZN37AMDRadeonX4000_AMDGraphicsAccelerator17createHWInterfaceEP11IOPCIDevice + 0x7b 0xffffff83d319bc70 : 0xffffff7fa07f14be com.apple.kext.AMDRadeonX4000 : __ZN37AMDRadeonX4000_AMDGraphicsAccelerator15configureDeviceEP11IOPCIDevice + 0x10a 0xffffff83d319bd00 : 0xffffff7fa074e534 com.apple.iokit.IOAcceleratorFamily2 : __ZN22IOGraphicsAccelerator25startEP9IOService + 0x21e 0xffffff83d319bd80 : 0xffffff7fa07ef88e com.apple.kext.AMDRadeonX4000 : __ZN37AMDRadeonX4000_AMDGraphicsAccelerator5startEP9IOService + 0x82 0xffffff83d319bde0 : 0xffffff801e01b216 mach_kernel : __ZN9IOService14startCandidateEPS_ + 0xf6 0xffffff83d319be40 : 0xffffff801e01adc1 mach_kernel : __ZN9IOService15probeCandidatesEP12OSOrderedSet + 0xb21 0xffffff83d319bef0 : 0xffffff801e01a10e mach_kernel : __ZN9IOService14doServiceMatchEj + 0x2ce 0xffffff83d319bf50 : 0xffffff801e01c8ad mach_kernel : __ZN15_IOConfigThread4mainEPvi + 0x15d 0xffffff83d319bfa0 : 0xffffff801d8e213e mach_kernel : _call_continuation + 0x2e Kernel Extensions in backtrace: com.apple.iokit.IOAcceleratorFamily2(438.3.1)[66992525-3204-3CB0-8F03-4B70031B1CF2]@0xffffff7fa0716000->0xffffff7fa07d9fff dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[A243D030-19AC-30AA-AC70-6C786DF9E6CE]@0xffffff7f9e5f1000 dependency: com.apple.iokit.IOPCIFamily(2.9)[ADD485B5-3EF8-37C4-B3C5-F86326E497A4]@0xffffff7f9e6a6000 dependency: com.apple.iokit.IOSurface(269.6)[42377B3B-D14A-368E-820F-07E7EA666198]@0xffffff7fa06e5000 dependency: com.apple.iokit.IOGraphicsFamily(569.4)[1F9B5D88-52DB-3A16-8373-4F608A3CB2D8]@0xffffff7f9e993000 dependency: com.apple.iokit.IOReportFamily(47)[988360A2-2E10-3014-A119-BE81BC045A10]@0xffffff7f9e29f000 com.apple.kext.AMDRadeonX4000(3.0.5)[5FD7AE5F-C03C-34A1-803F-ACA9B68524D0]@0xffffff7fa07ee000->0xffffff7fa0d32fff dependency: com.apple.iokit.IOPCIFamily(2.9)[ADD485B5-3EF8-37C4-B3C5-F86326E497A4]@0xffffff7f9e6a6000 dependency: com.apple.iokit.IOSurface(269.6)[42377B3B-D14A-368E-820F-07E7EA666198]@0xffffff7fa06e5000 dependency: com.apple.iokit.IOGraphicsFamily(569.4)[1F9B5D88-52DB-3A16-8373-4F608A3CB2D8]@0xffffff7f9e993000 dependency: com.apple.iokit.IOAcceleratorFamily2(438.3.1)[66992525-3204-3CB0-8F03-4B70031B1CF2]@0xffffff7fa0716000 BSD process name corresponding to current thread: kernel_task Boot args: debug=0x100 keepsyms=1 alcid=1 -v shikigva=128 Mac OS version: 19D76 Kernel version: Darwin Kernel Version 19.3.0: Thu Jan 9 20:58:23 PST 2020; root:xnu-6153.81.5~1/RELEASE_X86_64 Kernel UUID: A8DDE75C-CD97-3C37-B35D-1070CC50D2CE Kernel slide: 0x000000001d600000 Kernel text base: 0xffffff801d800000 __HIB text base: 0xffffff801d700000 System model name: MacPro7,1 (Mac-27AD2F918AE68F61) System shutdown begun: NO Panic diags file available: NO (0xe00002bc) System uptime in nanoseconds: 27776834167  
      config.plist
    • By Trung_Nguyen
      Hi, I'm using a Dell laptop, modeled Latitude E6230, bios version A11(I don't have any batteries to update :'( ).
      I'm using Catalina with OpenCore boot loader. 
      Everything is good, fast boot time.
      But when comes to sleeping there's 2 issues that randomly happen when the sleeping time is long enough:
      - Kernel Panic when sleep: panic log: panic
         This should have something to do with bluetooth, right? I'm using DW380 with BrcmPatchRam3 & BrcmBluetoothInjector.
      - Darkscreen when wakeup:
         After I open the lid, the screen have no backlight, although the UI barely shown.
         All I could do is to use keyboard to enter my password and use hotkey to shutdown the machine and then restart normally.
       
      The EFI/OC folder is attached below, with serial numbers removed.
      Sorry for using .txz format but with .zip, I couldn't get it fit in 10MB. Sorry for any inconvenience.
       
      P/s:If anybody try boot this in the future, please bear in mind that if you inject IO80211Family and AirportBrcm4331 (the one from 10.14.6) to any Recovery or installation media, it will panic the kernel, please disable those 2 before-hand.
       
      Thank you very much
       
      OC.txz
×