Jump to content

7 posts in this topic

Recommended Posts

TLDR: I've gotten myself up a creek without even a working keyboard and mouse. 

 

My setup

 

Asus X99 Deluxe motherboard

Dual Asus Radeon R9 280x GPU's

i7 5930K CPU

G.Skill - Ripjaws Series 32 GB (4 x 8 GB) DDR4-2400 Memory

Highpoint 2721 RAID controller + 4 hard drives

EVO 850 Pro SSD

Mojave 10.14.4

Profile: MacPro6,1

 

I had installed Mojave and had set it up to boot directly into my user account with no need for a password. Both Clover and IORegistryExplorer were set as log-in items. This was because I was working on activating my SS ports. The X99 Deluxe USB ports are set up as follows:

 

USB3_E1 to USB3_E10 at the rear (Asmedia controller)

USB_13 & USB_14 at the rear (Intel)

USB1112 & USB1314 (headers on the motherboard)

USB3_12 & USB3_34 (front)

 

This adds up to potentially 34 ports, far more than I need. I had three patches enabled to remove the 15 port limit but they weren't doing the trick. So I disabled the ten USB3 ports on the rear that are subject to the Asmedia controller in BIOS. I also disabled the Asmedia USB3 controller. All I really need are the four USB3 ports on the front panel, along with one of the motherboard USB2 headers. This should have gotten me down to under 15 ports. One SS port appeared in IORegistryExplorer but I couldn't locate it when I tested every active port.

 

I'm not sure what I did but everything went sideways. I found that I was booting into Mojave, Clover and IORegistryExplorer were launching but the mouse cursor was frozen in the corner and the keyboard was dead. Moving the keyboard and mouse to different ports didn't help. Meanwhile the OS was giving me a message about looking for a BT keyboard which I don't have. 

 

I've tried the following to no avail:

 

-- reinstalling Mojave

-- various combinations of USBInjectAll.kext, XHCI-X99-injector.kext, X99_Injector USB 3.kext, and GenericUSBXHCI.kext

-- resetting the CMOS

-- enabling and disabling the ten Asmedia USB3 ports on the rear

-- enabling and disabling the port limit patches below:

 

449604004_KextstoPatch.thumb.png.431f3623b1eccc06d88012af478b3b83.png

 

637926938_KerneltoPatch.thumb.png.f20c3cf198dbf2175f82a58b4065ec79.png

 

I haven't reflashed my BIOS which is something I do when starting from scratch, although I don't see why it would matter. I'm open to that, burning incense, whatever will help.  In the end, I need at least 1-2 working USB3 ports. But right now, I just need to get my keyboard and mouse working again. I've been going in circles on this all day and could really use some good ideas.

 

Thanks so much.

 

Max

 

config copy.plist

Share this post


Link to post
Share on other sites
Advertisement

Thanks @MaLd0n. If I put RunMe.app on my installer USB, can I boot into recovery mode and run it from the terminal? 

Share this post


Link to post
Share on other sites

My problem is that even though the system boots, I can't actually do anything because the keyboard and mouse are frozen. Moving them to different USB ports hasn't helped so far.

Share this post


Link to post
Share on other sites
Posted (edited)

Resolved by reflashing the BIOS and doing a clean installation to a different drive. This is much better.

 

xhc-ioregistry.png.bdebe8137298b0260b977fdf78c760d9.png

 

I guess the more we mess around with a startup partition, the more likely something like this becomes.

Edited by maxneko
Attachment was omitted.

Share this post


Link to post
Share on other sites
On 4/20/2019 at 1:03 AM, maxneko said:

Resolved by reflashing the BIOS and doing a clean installation to a different drive. This is much better.

 

xhc-ioregistry.png.bdebe8137298b0260b977fdf78c760d9.png

 

I guess the more we mess around with a startup partition, the more likely something like this becomes.

 Help me ASUS x99 Deluxe, HIGH SIERRA 10.3.6 GTX 770 4 gb, USB ports not working properly

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By hungdv
      Hello guys,
      I was try to install MacOS Mojave on my new machine but no luck. Can anyone show me which guide to fit my system, please?please?please?
      + Mobo: GIGABYTE Z390 AORUS ELITE LGA1151v2
      + CPU: Intel Core i5-9600K 3.7GHz
      + iGPU: Sapphire RX 580 Pulse 8GB
      + Drives: SSD Samsung 970 Pro PCIe NVMe V-NAND M.2 2280 512GB
      + Ram: Crucial Ballistix Sport LT 2x8GB Bus 2666 DDR4
      + PSU: Corsair RM650 80 Plus GOLD
      + Case: Corsair 220T White RGB Airflow Tempered Glass
      + Cooler: Cooler Master HYPER 212 BLACK EDTION
      + Dual Band Network Card Broadcom Bcm94360 867Mbps.
    • By Rajan Pandit
      Hai, I have,
      i5 2500k
      GA-z68 AP D3 Rev.1
      Corsair 8 GM Ram
      Gigabyte Radeon RX 560 OC 4G Graphic Card
      500 GB Samsung SSD EVOf
       
      with this configuration I tried to install Mojave but After Apple Logo there was a black screen
      then nothing... please help
      I have create USB with terminal and Install Clover_v2.4k_r4961-Legacy.pkg to activate boot
      then I have recessary kext to EFI/KEXT/OTHER 
      but I am struck at Black Screen after apple logo
    • By Rajan Pandit
      Hai, I have,
      i5 2500k
      GA-z68 AP D3 Rev.1
      Corsair 8 GM Ram
      Gigabyte Radeon RX 560 OC 4G Graphic Card
      500 GB Samsung SSD EVO
      .. I want to install Mojave on this configuration...
      please help. what I need to do... 
      I have downloaded the Installer from APP Store...
      please help
    • By ScoobDoob69
      Hi, everyone so I am currently dual-booting Windows 10 and Linux Mint. I would like to add Mojave and triple boot (without formatting/losing all data from windows and linux).
       
      My Current Specs:
      CPU: Intel Core i7-2600 (not k) Sandy Bridge
      GPU: Aorus Radeon RX570 4GB
      Motherboard: Intel SWQ6710H
      HDD: 4TB Western Digital Blue WD40EZRZ
      Ram: 20GB DDR3 Total (2x 8GB + 2x 2GB)
       
      1. Is it possible to install Mojave on my HDD without wiping Windows 10 or Linux Mint?
      2. What guide is most ideal for my situation? 
       
      If you need any additional information or details, I am more than happy to provide that. I tried multiple guides months ago and could not get the installation to work. 
       
       
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/download/file.php?id=24376
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
×