Jump to content

Can't get Mojave 10.14.4 to boot from SSD

2 posts in this topic

Recommended Posts


  • Lenovo ThinkPad X1 Extreme (laptop)
  • i7-8850H (Coffee Lake)
  • Intel UHD630
  • GTX 1050 Ti with Max-q
  • 4K Touchscreen
  • 2x 2TB EVO 970 SSD (one for Windows and one for macOS)
  • 2x 32GB DATARAM 2666Mhz DDR4 RAM (max for laptop, works in Windows and Ubuntu)
  • Haven't replaced the Wifi card yet for macOS compatible, just using Ethernet for now
  • Everything else is stock
  • macOS Mojave 10.14.4


I am at the phase of installation where I need to setup the macOS installation EFI so that it can be booted from, as opposed to using the USB.


I've tried a few methods. F12 brings you into the boot menu on my laptop. Selecting Mac OS X almost instantly returns you to the boot menu meaning it isn't find anything. I have to go into the USB, Clover, and then Boot macOS from there.


What I've tired:




Installing to the HDD/SSD after installation is very similar to installing to the USB, except that the install target will be your macOS/OS X system volume. Refer back to this section when you get to that stage.


Notes on HDD install:

- select "Install RC scripts on target volume" and/or "Install all RC scripts on all other boot volumes"

- selecting "Install Clover Preference Pane" is optional

- there are also some "Optional RC Scripts" you might want to read about

- if you're installing Clover legacy, check "Install Clover in the ESP"


Not selecting "Install Clover in the ESP" just causes the EFI to be installed to the root directory of the macOS partition and not the EFI partition. Selecting it inserts the EFI into the correct partition, at which point I moved over the necessary config.plist, kexts, and driversUEFI64 files from the USB to the SSD.




Step 5 – Copying the EFI Partition from the Flash Drive to the macOS Mojave Drive


Now that we’re in macOS we want to be able to load macOS without the USB flash drive plug. To be able to boot macOS from the drive it’s installed on the folder in the EFI partition of the flash drive needs to be copied over to the EFI partition of the boot drive.


  1. Open Clover Configurator
  2. Mount the EFI of the USB Flash Drive
  3. Press Open EFI or navigate to the EFI location of the flash drive in Finder
  4. Copy the EFI Folder onto your desktop
  5. Open Finder and Eject All the Flash Drive
  6. Using Clover Configurator Mount the EFI of the drive disk you just installed 7. Mac OS on
  7. Press Open EFI or navigate to the EFI location of the drive in Finder
  8. Delete the mostly empty EFI Folder located on the mounted drive
  9. Paste or Move the EFI  from your Desktop to the EFI partition of the drive /Volumes/EFI/ the existing EFI on the disk


Again, neither of these methods worked. Selecting Mac OS X in the boot menu almost immediately goes back into the menu, meaning it didn't find anything. Have to go into the USB, Clover, and load the Mac OS SSD from there.


Any other suggestions?


Oh, attached is an image of the volumes macOS created when it was installed. I'm moving files into disk1s1.


Thanks again in advance for the help!


Screen Shot 2019-04-09 at 9.31.50 PM.png

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.