Jump to content
outdoormagic

Copying EFI, Clover, and USB drives

5 posts in this topic

Recommended Posts

Short Version:

I have two drives with the exact same EFI folder (and I can boot into Clover from either one), shouldn't I be able to boot into MacOS from either one?

 

More Detail:

I've done a few hacks so far and this never happened. (Gigabyte z370 / 8700k / Vega, Asus z390 / i5-9600k / 1080). Now, I'm setting up a ThinkPad X1 Gen 6. (Yes, I do expect problems on laptops, but that's not the question).

 

Mojave 10.14.4 now boots from the internal SSD. So far, so good. Here's the problem.

 

I installed Mojave on a USB drive (for backup / rescue) and copied the entire EFI partition of my boot drive to the EFI partition on the USB drive. So... I should be able to boot from the USB drive, right? Wrong. Ran Clover installer on the USB itself. Same outcome.

 

With F12, I can boot from the USB into Clover and select the OS on the USB. The boot sequence hangs on End Random Seed, but before the usual '++++++++' line.

So, boot into Clover on internal boot drive, then select OS on USB. Same thing.

 

Read the forums, I saw the posts about AptioMemoryFix, so I tried the various other drivers on the USB. No go.

 

I haven't found the solution yet to the USB boot issue, but what puzzles me is that if I have two drives with the exact same EFI folder (and I can boot into Clover from either one), shouldn't I be able to boot into MacOS from either one?

 

 

Edited by outdoormagic

Share this post


Link to post
Share on other sites
Advertisement
11 hours ago, millusions said:

booting off usb you need to make sure you have USB patches in place. in theory.

 

in practice i found it's a bit random and these days i try to avoid it if i can.

i mean, it worked, but sometimes doesn't.

on further testing i found imac 2013 also has trouble booting from some USB enclosures. it basically refuses to.  sometimes it does, sometimes gets stuck on loading and most times it skips the USB / Start up disk.

which kinda points the finger at the usb enclosures, right?

after that i try to avoid it.

 

instead of Aptiomemory fix try AptiomemoryFix-64

 

Makes sense. I did have AptioMemoryFix-64, indeed, and USB are patches with SSDT. Tried the drive (Samsung flash drive) on another hack and got the interdiction sign. It got further into the boot (with adjusted EFI folder for that second hack), but still failed. Other drives (namely old-school 5400RPM USB 3.0 Seagate drives) work on that second machine. Thanks for sharing your experience.

 

Plan B is to create a small partition, similar to recovery, as alternate boot when updates (OS, kexts, clover) run into trouble.

Share this post


Link to post
Share on other sites
On 4/3/2019 at 5:16 PM, millusions said:

i also use plan B now.

the partition method works well, but doesn't allow for EFI errors.

 

 

Strange. It doesn't work for me. I assumed it would, but it doesn't.

 

The drive is internal and partitioned as: 1 Windows partition, 2 APFS partitions which show up as 2 Volumes in Disk Utility (not 2 partitions), and all appropriate EFI and Recovery partitions. Mojave installed on both MacOS partitions without any problem. Now, I can boot into Clover, but I only see one of the two Volumes. Tried resetting NVRAM, reinstalling Clover, even formatted the whole drive and started from scratch for both Windows 10 and MacOS. Same outcome: I have one bootable Windows 10 and one bootable Mojave, but I don't see the second Mojave install, even with F3. Tried bless on CoreServices of the "invisible" drive, tried selecting the second drive in Startup Disk (I see both volumes there). Both bless and selecting the disk seem to work, but then I get the same outcome in Clover: the boot partition doesn't show up—only one OS X and one Windows (+recovery, legacy, and all that).

 

Doesn't Clover allow for two OS partitions to be on the same physical drive?

Share this post


Link to post
Share on other sites
4 hours ago, millusions said:

yea. that's pretty weird hey.

 

from reading your post my initial thought is Clover configurator/gui.

 

if you saw how many Mac OSX installs i have on each computer you'd laugh at me, i just carbon copy and hold on to 5hit too much.

i even have mavericks, i cant even boot it, nvidia web needs 10.10.

anyway, having said that i've never encountered your problem, have a 300GB partition with 'clone' of this system which boots fine

 

have a look at clover/gui and the 'scan' settings.

 

maybe it's APFS thingo, i dont use APFS, have it on a couple of real Macs i dont see any difference to be honest but apple updates force it pretty much, i dont use it on hacks.

plus HPFS i can read from windows with paragon - but if you do that make sure you have [read only] in registry

 

I would agree. Tried various options on Scan. Nothing worked. I did notice 2 other weird things on Clover, though. If I try to exclude/hide volumes, I can, except for "Windows". Nothing happens. Also, if I update Clover, it resets my gui to the holiday theme. That doesn't happen on my other hacks.

 

I had to go APFS as Mojave won't install on anything else. With HS, I could still use the -donotconvert option, but alas no more. But you're right; might be APFS. However, the Clover weirdness mentioned above makes me suspect my Clover install at this point.

 

I guess that means I have to completely de-install clover and completely re-install from scratch.  :(

 

Stay tuned...

 

 

PS. For reference, here is a thread of others with a similar issue: 

 

Edited by outdoormagic
Added info / reference

Share this post


Link to post
Share on other sites

@millusions, thank you for your help. I got to get all OS X partitions to show by copying apfs.efi to the Clover UEFI 64 Drivers folder. ApfsDriverLoader-64 should have taken care of that, but obviously doesn't fully.

 

As for the USB boot, I think you're right: it depends on the drive. This thumb drive just won't boot (Samsung bar).

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By TimothyF
      My PROBLEM: I followed the Plain Vanilla guide (https://hackintosh.gitbook.io/-r-hackintosh-vanilla-desktop-guide/) to a T in creating the OS X Catalina installer USB. I'm totally new to Hackintosh, and just want an Apple environment to Time Machine migrate my files and system from my ageing MacBook Pro. When I start to use the USB on the target PC (Dell Inspiron 3847 desktop), I ONLY see the Microsoft (which is the original OS, and on a SEPARATE Hard drive from where I want to install Mac OS), ZERO option for installing the OSX Catalina! Please SEE PICTURE link: https://imgur.com/a/FnLB2Q9   I'm a beginner, but I tried to google my problem. The answers were either incomplete, hard for me to understand and put into action, or were outdated and applied to older OSXs. I appreciate any help in diagnosing and solving this problem!   Clover USB specs OS installer used: Catalina (10.15) Clover revision: 5103 Kexts included: ATH9KFixup.kext AppleALC.kext Lilu.kext RealtekRTL8111.kext USBInjectAll.kext VirtualSMC.kext WhateverGreen.kext config.plist: see attached ------------------------------------------ Target Desktop specs: Dell Inspiron 3847 (64 bit) CPU: Intel Core i5-4460, 3.2 GHz, 4 cores Architecture: Haswell GPU: Intel HD 4600 Motherboard: Dell 088DT1 (version A01) Chipset: Intel H81 Install method: with USB, configured with Clover, 100% following Plain Vanilla guide for Desktops RAM: 12 GB, 2 slots Hard drive for installation: SATA HDD 4TB, by HGST LAN: RTL8111/8168/8411 WLAN: AR9565 (atheros) Audio: Realtek ALC661 (not 100% sure this is correct)   ------------------------------------ Attached:
      Screenshot of Clover installer not showing the Mac OSX option
      config.plist of my installer USB
      Clover_Install_Log.txt (not sure if this is relevant)   THANK YOU VERY MUCH!     config.plist
      Clover_Install_Log.txt
    • By Simon's InsaneMac
      Hi, I'm kind of lost when scrolling to Clover Configurator, so I decided to use an EFI from the web and just configure the most basic stuff. But that sadly didn't work, im always getting the attached screen IMG_0054.HEIC (and I don't know whether all the errors are listed, as I can't scroll). 
      Anyways I thought it'd be better to do a custom setup. Can anyone give me some help with what to choose in the settings? Here's my rig:
      i7 8700k
      Asus z370-G (Rog Strix)
      gtx 1060 6gb
      samsung ssd (SATA)
      WD hard drive
       
      Your help would be much appreciated!
    • By Vyzantion
      I have just re-made the Catalina installer, with the updated OS. It could not install from it, like it could not copy. Then I have tried to reinstall Mojave, it worked pretty cleary last year the exact pen drive. It failed as well, saying something like: not package found, contact the system administrator. I was able to boot from USB pen drive Linux and install Windows from DVD. But no macOS from the pen drive, even from what worked fine before. I have reseted the BIOS several times, no succes. The first sign of something wrong was this: When I first tried to boot Catalina, it said something about BIOS (BIOS, not UEFI) reset and enter setup. I hapenned several times on my attempts. If something screwed in my hardware? The USB ports? The BIOS perhaps?
    • By kylon
      A big thanks to wegface for teaching me a lot of things.
       
       
      Tested on Catalina 10.15.4 and Clover EFI 5104 (Catalina Patcher)
       
      Not Working:
      - realtek sd card reader (pm me if you have a fix)
       
      Notes:
      **CPU patches are disabled, if you are using a locked BIOS you must enable them**
       
      Clover EFI:
      - Install it in UEFI Mode and change your hdd partition table to GPT.
      - You will be able to install ANY OS in EFI mode, even if this pc does not support EFI at all! (No guide available for this)
       
      You will need:
      My unlocked BIOS (OPTIONAL) (here) Latest Clover config from CCE Bank (here) (asus k53sj-kylon) Rehabman Voodoo PS2 Controller (here) acidanthera AppleALC (here) acidanthera Lilu (here) acidanthera VirtualSMC (here) acidanthera SMCBatteryManager (here) acidanthera SMCLightSensor (here) acidanthera WhateverGreen (here) Mieze Realtek RTL8111 (here)
    • By Sagnik Ganguly
      Hello I'm Sagnik Ganguly, I'm trying to dual boot macOS 10.14 and Windows 10 (already installed) on a PC with Legacy BIOS. I've two hard drives one in where the windows is installed and another which is converted to GPT to install macOS Mojave 10.14 with a partion of Mac OS Extended (Journal) or APFS but when I went to the Install Disk Selection page, I'm selecting the partition but it says "This version of macOS 10.14 cannot be installed on this computer." can you help me please? 
      P. S. My motherboard doesn't support UEFI. 
      I'm attaching some pictures of the screens.


×