Jump to content
Shaneee

AMD Vanilla Kernel

164 posts in this topic

Recommended Posts

Advertisement
On 10/9/2019 at 1:03 AM, XLNC said:

I have updated the kernel patches on AMD_Vanilla github repo to boot macOS catalina using Clover Bootloader.
https://github.com/AMD-OSX/AMD_Vanilla

- Cheers !

Thanks for this wonderful kernel patching config.plist for Clover at 10.15.0 which worked perfectly in my FX-6300 hackintosh, but always got frozen during booting after loading of apfs as shown here:

How to fix it ?

No such an issue at 10.13.6 and 10.14.6

It seems one patch for My Ryzen 1700X still not worked yet.

Can anyone confirm this patch for Ryzen CPU working at 10.15.0 ?

[Solved]

1. The specific patches of kernel at 10.15.0 created by XLNC are more correct and compatible to both FX-6300 and Ryzen 1700X hackintoshes.

2. After adding SSDT-EC0.aml and AppleMCEReporterDisabler.kext (not essential for FX-6300 hackintosh) properly it can work in Ryzen 1700X hackintosh now !

3. Big thanks for XLNC again, without your excellent patches my Ryzen 1700X can not work by Clover r5095. OpenCore not working in my hackintoshes yet.

IMG_0236.JPG

Screen Shot 2019-10-10 at 6.20.07 PM.png

Edited by jsl2000

Share this post


Link to post
Share on other sites
2 hours ago, jsl2000 said:

It seems one patch for My Ryzen 1700X still not worked yet.

Can anyone confirm this patch for Ryzen CPU working at 10.15.0 ?

 

It seems Clover has been updated to use Mask patching so you should be able to add the patches for OpenCore into Clover now allowing it to boot.

Share this post


Link to post
Share on other sites
1 hour ago, Shaneee said:

 

It seems Clover has been updated to use Mask patching so you should be able to add the patches for OpenCore into Clover now allowing it to boot.

After examination of KernelToPatch in this config.plist I can not find any property related to Mask patching.

It still use specific patch for each special version of Mac OS from 10.13.6 to 10.15.0

Can you show me how to apply mask patching from OpenCore to Clover ?

Share this post


Link to post
Share on other sites
34 minutes ago, jsl2000 said:

After examination of KernelToPatch in this config.plist I can not find any property related to Mask patching.

It still use specific patch for each special version of Mac OS from 10.13.6 to 10.15.0

Can you show me how to apply mask patching from OpenCore to Clover ?

 

See here, https://www.insanelymac.com/forum/topic/304530-clover-change-explanations/?do=findComment&comment=2692774

 

You'll need to build Clover from Slice's GitHub though.

Share this post


Link to post
Share on other sites
23 hours ago, jsl2000 said:

Thanks for this wonderful kernel patching config.plist for Clover at 10.15.0 which worked perfectly in my FX-6300 hackintosh, but always got frozen during booting after loading of apfs as shown here:

How to fix it ?

No such an issue at 10.13.6 and 10.14.6

It seems one patch for My Ryzen 1700X still not worked yet.

Can anyone confirm this patch for Ryzen CPU working at 10.15.0 ?

IMG_0236.JPG

i received this same issue installing on my amd a10 5800k with asus f2a85v-pro motherboard with catalina,,using my sandisk ssd...

Share this post


Link to post
Share on other sites
2 hours ago, cyrhex said:

i received this same issue installing on my amd a10 5800k with asus f2a85v-pro motherboard with catalina,,using my sandisk ssd...

I have solved it already.

Please check my post here (on the above) for your reference.

Edited by jsl2000

Share this post


Link to post
Share on other sites
14 hours ago, jsl2000 said:

Using Clover r5095 and the attached config.plist after applied with Mask patching can not boot now

Previous KernelToPatch still working at 10.13.6 and 10.14.6, but freeze during booting at 10.15.0

config.plist

 

Yes with the Mask patching it should be able to boot 10.13, 10.14 and 10.15

Share this post


Link to post
Share on other sites

Nice work! Catalina runs on a Clover (5070) bootloader.
Still new, but so far fine!

 

Although the installation was done with a black screen :(

Képernyőfotó 2019-10-10 - 16.10.11.png

Share this post


Link to post
Share on other sites
11 hours ago, jsl2000 said:

I have solved it already.

Please check my post here (on the above) for your reference.

can you share the patch you made?

Share this post


Link to post
Share on other sites

I want to  build Nas server.

Any AMD server CPU support AMD vanilla?

Ex

  • AMD EPYC™ 7002 and 7001 series processor family

Share this post


Link to post
Share on other sites
21 hours ago, nmano said:

I want to  build Nas server.

Any AMD server CPU support AMD vanilla?

Ex

  • AMD EPYC™ 7002 and 7001 series processor family

I thing its possible please confirm @Shaneee

Thank you.

https://en.wikichip.org/wiki/amd/epyc

 

472483604_ScreenShot2019-10-14at2_03_58AM.png.29aee64c0ece61da026bf9ec714db4b3.png

Edited by nmano

Share this post


Link to post
Share on other sites
On 10/13/2019 at 10:00 AM, nmano said:

I want to  build Nas server.

Any AMD server CPU support AMD vanilla?

Ex

  • AMD EPYC™ 7002 and 7001 series processor family

 

In theory it should but only one way to find out... Give it a try.

Share this post


Link to post
Share on other sites
15 hours ago, Shaneee said:

 

In theory it should but only one way to find out... Give it a try.

Hi, Shaneee:

I found your Ryzen hackintosh can run well at both 10.15 and 10.15.1 beta now with OpenCore.

My OpenCore can run Z97 and Z370 hackintoshs only, but not in Ryzen 1700X hackintosh.

Can you share your OC config.plist for me ?

Share this post


Link to post
Share on other sites
On October 9, 2019 at 1:03 AM, XLNC said:

I have updated the kernel patches on AMD_Vanilla github repo to boot macOS catalina using Clover Bootloader.
https://github.com/AMD-OSX/AMD_Vanilla

- Cheers !

Thanks.

Any update for 10.15 (19A602) ?

[Solved]

The same patches still work after update.

Edited by jsl2000

Share this post


Link to post
Share on other sites
On 10/11/2019 at 5:45 AM, jsl2000 said:

1. Use patch.plist from https://github.com/AMD-OSX/AMD_Vanilla
Don't modify it & follow its instruction.

2. adding SSDT-EC0.aml in /EFI/CLOVER/ACPI/patched and AppleMCEReporterDisabler.kext in /EFI/CLOVER/kexts/Other

I got it up and running, but I had to add acpi patch to the config.plist, nevertheless, is there any way to run get amd sata controller to work? I just can't get my internal hard disk to be detected in disk utility. So, far only able to install on usb hard disk and usb thumb drive.

Share this post


Link to post
Share on other sites

Unable to boot 10.15.1 beta 2. I need to wait for the new kernel patches for 10.15.1 boot loader clover v2.5k r5093 EFI bootloader ? how can I do the Mask patching ?

Edited by iAstroboyid

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×