Jump to content
licorice_whip

Gigabyte Z87X-UD4H with i7 4770K

26 posts in this topic

Recommended Posts

Hey guys. So quick background. I have a hackintosh using Gigabyte Z87X-UD4H, i7 4770K, RX 560 GPU, 16GB RAM. I had been on Sierra for years and everything worked perfect, including all USB ports and sleep functions. I then updated to Mojave and now sleep functions are all messed up. Sometimes it wakes fine, sometimes it never wakes up or crashes / reboots when trying to sleep. Once this occurred, I decided to start over using the vanilla guide for Haswell chipsets seen here: https://hackintosh.gitbook.io/-r-hackintosh-vanilla-desktop-guide/config.plist-per-hardware/haswell

 

While this improved startup / shutdown speeds, it didn't fix my sleep issues. 

 

My kexts are AppleIntelE1000e.kext, FameSMC.kext, Lilu.kext, NoVPAJpeg.kext, USBInjectrAll.kext, and WhateverGreen.kext. I have Power Nap disabled, and have "Put hard drives to sleep when possible" enabled.

 

I posted this question on Reddit and a user mentioned I need to get a DSDT / SSDT to get this working correctly. Any pointers on how to obtain this, or other next steps?

Share this post


Link to post
Share on other sites
Advertisement
1 hour ago, licorice_whip said:

I had been on Sierra for years and everything worked perfect

Welcome to InsanelyMac

Share this post


Link to post
Share on other sites
8 hours ago, licorice_whip said:

I then updated to Mojave and now sleep functions are all messed up.

Look this: https://olarila.com/forum/viewtopic.php?f=79&t=7370

 

8 hours ago, licorice_whip said:

I posted this question on Reddit and a user mentioned I need to get a DSDT / SSDT to get this working correctly. Any pointers on how to obtain this, or other next steps?

Yes DSDT is mandatory for a good Hack.

Check if you are using the last version of UEFI/Bios, if not, do a upgrade.

 

After that, run this app, and upload the file result here.
RunMe

 

@MaLd0n can patch the DSDT for you ;)

Share this post


Link to post
Share on other sites

Thank you tremendously for the reply! I am running the newest BIOS. I tried running RunMe but after a little while, get the following error continuously: 

 

Saving IOReg...
IOREG dump failed. Retrying
Increased delay x2 for IOREG dump. This will take a while...(33 sec)
IOREG dump failed. Retrying
Increased delay x2 for IOREG dump. This will take a while...(33 sec)
IOREG dump failed. Retrying
Increased delay x2 for IOREG dump. This will take a while...(33 sec)
IOREG dump failed. Retrying
Increased delay x2 for IOREG dump. This will take a while...(33 sec)
IOREG dump failed. Retrying
Increased delay x2 for IOREG dump. This will take a while...(33 sec)
IOREG dump failed. Retrying
Increased delay x2 for IOREG dump. This will take a while...(33 sec)
IOREG dump failed. Retrying
Increased delay x2 for IOREG dump. This will take a while...(33 sec)

 

Any pointers?

Share this post


Link to post
Share on other sites
15 hours ago, licorice_whip said:

Figured it out. Just needed to follow the instructions on this video:

 

At any rate, I'm attaching my files. Thank you for any help!

Send me iMac.zip

 

Edit: Also, thank you @MaLd0n for any help! :)

use only it, full clover folder

CLOVER.zip

 

remove FakePCIID_XHCIMux, dont use any kexts in l/e or s/l/e

 

after reboot, extract new SEND_ME with new files

Share this post


Link to post
Share on other sites
6 hours ago, MaLd0n said:

use only it, full clover folder

CLOVER.zip

 

remove FakePCIID_XHCIMux, dont use any kexts in l/e or s/l/e

 

after reboot, extract new SEND_ME with new files

 

Thank you times a million. I removed my previous clover folder and replaced it with the one you linked. I removed FakePCIID_XHCIMux from the l/e folder. When you say don't use any kexts in the l/e and s/l/e folders, are you meaning I should remove them all?

 

Here's the new SEND_ME. Thanks so much!

Send me iMac.zip

Share this post


Link to post
Share on other sites
13 hours ago, licorice_whip said:

 

Thank you times a million. I removed my previous clover folder and replaced it with the one you linked. I removed FakePCIID_XHCIMux from the l/e folder. When you say don't use any kexts in the l/e and s/l/e folders, are you meaning I should remove them all?

 

Here's the new SEND_ME. Thanks so much!

Send me iMac.zip

all no, just a hackintosh kexts

 

looks good

Share this post


Link to post
Share on other sites
21 minutes ago, MaLd0n said:

all no, just a hackintosh kexts

 

looks good

 

Thank you so much, you are amazing. The computer starts up and shuts down so fast now. Here's to hoping sleep works. Enjoy the beer my friend!

Share this post


Link to post
Share on other sites
54 minutes ago, licorice_whip said:

@MaLd0n, question for you. I'm finding that no USB 3 devices work anymore. Any pointers?

just update patch or exclude unused ports

Share this post


Link to post
Share on other sites

I re-added change XHC1 to XHC and change XHCI to XHC back into the patches section, and got one pair of USB ports in the back, but I don't have the USB header or the other pairs on the motherboard back. Any pointers?

Share this post


Link to post
Share on other sites
3 hours ago, licorice_whip said:

I re-added change XHC1 to XHC and change XHCI to XHC back into the patches section, and got one pair of USB ports in the back, but I don't have the USB header or the other pairs on the motherboard back. Any pointers?

https://olarila.com/forum/viewtopic.php?f=62&t=6539

Share this post


Link to post
Share on other sites

Hey @MaLd0n, thanks, I added the USB entries and have USB 3 working. Now the only issue I'm having is that the computer sometimes has a kernel panic when attempting to sleep. Half the time it sleeps and wakes up fine, but the other half it seems to wake up when I push the power button, but nothing comes up on the screen. When I reboot in verbose mode, it says it rebooted from a kernel panic. Any pointers? Thank you for everything!

Share this post


Link to post
Share on other sites
9 minutes ago, licorice_whip said:

Hey @MaLd0n, thanks, I added the USB entries and have USB 3 working. Now the only issue I'm having is that the computer sometimes has a kernel panic when attempting to sleep. Half the time it sleeps and wakes up fine, but the other half it seems to wake up when I push the power button, but nothing comes up on the screen. When I reboot in verbose mode, it says it rebooted from a kernel panic. Any pointers? Thank you for everything!

post one photo with -v

Share this post


Link to post
Share on other sites

This is what the error report shows... does this have any useful information?

 

Anonymous UUID:       7AF5B311-D0C3-2754-53B0-6FF1488259C7

Sat Mar 23 12:00:36 2019

*** Panic Report ***
panic(cpu 7 caller 0xffffff801de01e33): "a freed zone element has been modified in zone kalloc.48: expected 0xdeadbeefdeadbeef but found 0xdeadbeefccadbeef, bits changed 0x12000000, at offset 8 of 48 in element 0xffffff8061991810, cookies 0x3f0011af7944a812 0x53521dfe04c4305"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/xnu/xnu-4903.241.1/osfmk/kern/zalloc.c:1168
Backtrace (CPU 7), Frame : Return Address
0xffffff8204d9b960 : 0xffffff801ddaeb0d 
0xffffff8204d9b9b0 : 0xffffff801dee8653 
0xffffff8204d9b9f0 : 0xffffff801deda07a 
0xffffff8204d9ba60 : 0xffffff801dd5bca0 
0xffffff8204d9ba80 : 0xffffff801ddae527 
0xffffff8204d9bba0 : 0xffffff801ddae373 
0xffffff8204d9bc10 : 0xffffff801de01e33 
0xffffff8204d9bd60 : 0xffffff801ddbb0c4 
0xffffff8204d9bdd0 : 0xffffff801e3c6b07 
0xffffff8204d9be00 : 0xffffff801e3ca334 
0xffffff8204d9be20 : 0xffffff801e41e475 
0xffffff8204d9be40 : 0xffffff801e4234da 
0xffffff8204d9be80 : 0xffffff801e42c00d 
0xffffff8204d9bf00 : 0xffffff801e42bcb7 
0xffffff8204d9bf50 : 0xffffff801e42d786 
0xffffff8204d9bfa0 : 0xffffff801dd5b0ce 

BSD process name corresponding to current thread: kernel_task
Boot args: dart=0 debug=0x100 shikigva=60 

Mac OS version:
18D109

Kernel version:
Darwin Kernel Version 18.2.0: Thu Dec 20 20:46:53 PST 2018; root:xnu-4903.241.1~1/RELEASE_X86_64
Kernel UUID: 1970B070-E53F-3178-83F3-1B95FA340695
Kernel slide:     0x000000001da00000
Kernel text base: 0xffffff801dc00000
__HIB  text base: 0xffffff801db00000
System model name: iMac14,2 (Mac-27ADBB7B4CEE8E61)

System uptime in nanoseconds: 5248223819221
last loaded kext at 245582763616: com.apple.filesystems.msdosfs	1.10 (addr 0xffffff7fa2bd2000, size 69632)
last unloaded kext at 305787159340: com.apple.filesystems.msdosfs	1.10 (addr 0xffffff7fa2bd2000, size 61440)
loaded kexts:
at.obdev.nke.LittleSnitch	5267
com.insanelymac.IntelMausiEthernet	2.4.1d1
org.vulgo.NoVPAJpeg	1.0.0
as.vit9696.AppleALC	1.3.6
as.vit9696.WhateverGreen	1.2.7
as.vit9696.Lilu	1.3.5
com.rehabman.driver.USBInjectAll	0.7.1
org.netkas.driver.FakeSMC	1800
com.apple.fileutil	18.306.12
com.apple.filesystems.autofs	3.0
com.apple.driver.AppleTopCaseHIDEventDriver	138.2
com.apple.driver.AGPM	110.23.46
com.apple.driver.ApplePlatformEnabler	2.7.0d0
com.apple.driver.AppleMikeyHIDDriver	131
com.apple.driver.X86PlatformShim	1.0.0
com.apple.driver.AppleUpstreamUserClient	3.6.5
com.apple.driver.AppleMCCSControl	1.5.6
com.apple.kext.AMDFramebuffer	2.0.4
com.apple.driver.AppleGFXHDA	100.1.40
com.apple.driver.AppleOSXWatchdog	1
com.apple.kext.AMDRadeonX4000	2.0.4
com.apple.AGDCPluginDisplayMetrics	3.28.4
com.apple.driver.AppleHV	1
com.apple.iokit.IOUserEthernet	1.0.1
com.apple.driver.AppleMikeyDriver	282.10
com.apple.iokit.IOBluetoothSerialManager	6.0.10f1
com.apple.driver.pmtelemetry	1
com.apple.Dont_Steal_Mac_OS_X	7.0.0
com.apple.kext.AMD9500Controller	2.0.4
com.apple.driver.AppleLPC	3.1
com.apple.driver.AppleSMCLMU	212
com.apple.driver.AppleIntelSlowAdaptiveClocking	4.0.0
com.apple.filesystems.apfs	945.241.4
com.apple.driver.AppleVirtIO	2.1.3
com.apple.filesystems.hfs.kext	407.200.4
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless	1.0.0d1
com.apple.BootCache	40
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib	1.0.0
com.apple.AppleSystemPolicy	1.0
com.apple.driver.AirPort.BrcmNIC	1400.1.1
com.apple.driver.AppleAHCIPort	329.200.2
com.apple.private.KextAudit	1.0
com.apple.driver.AppleHPET	1.8
com.apple.driver.AppleACPIButtons	6.1
com.apple.driver.AppleBacklight	170.12.11
com.apple.driver.AppleRTC	2.0
com.apple.driver.AppleSMBIOS	2.1
com.apple.driver.AppleAPIC	1.7
com.apple.nke.applicationfirewall	190
com.apple.security.TMSafetyNet	8
com.apple.driver.AppleHIDKeyboard	208
com.apple.kext.triggers	1.0
com.apple.driver.AppleMultitouchDriver	2410.5
com.apple.driver.AppleInputDeviceSupport	2410.2
com.apple.driver.AppleHSBluetoothDriver	138.2
com.apple.driver.IOBluetoothHIDDriver	6.0.10f1
com.apple.kext.AMDRadeonX4000HWLibs	1.0
com.apple.iokit.IOAcceleratorFamily2	404.2.2
com.apple.kext.AMDRadeonX4000HWServices	2.0.4
com.apple.iokit.IOAVBFamily	710.1
com.apple.plugin.IOgPTPPlugin	700.7
com.apple.iokit.IOEthernetAVBController	1.1.0
com.apple.driver.AppleSSE	1.0
com.apple.iokit.IOSurface	255.1
com.apple.driver.AppleSMBusController	1.0.18d1
com.apple.iokit.IOSMBusFamily	1.1
com.apple.AppleGPUWrangler	3.28.4
com.apple.driver.AppleSMBusPCI	1.0.14d1
com.apple.driver.X86PlatformPlugin	1.0.0
com.apple.driver.IOPlatformPluginFamily	6.0.0d8
com.apple.kext.AMDSupport	2.0.4
com.apple.AppleGraphicsDeviceControl	3.28.4
com.apple.iokit.IOSlowAdaptiveClockingFamily	1.0.0
com.apple.iokit.IOUSBHIDDriver	900.4.2
com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport	6.0.10f1
com.apple.iokit.IOBluetoothHostControllerUSBTransport	6.0.10f1
com.apple.iokit.IOBluetoothHostControllerTransport	6.0.10f1
com.apple.iokit.IOBluetoothFamily	6.0.10f1
com.apple.driver.AppleUSBAudio	315.6
com.apple.driver.usb.IOUSBHostHIDDevice	1.2
com.apple.iokit.IOAudioFamily	206.5
com.apple.vecLib.kext	1.2.0
com.apple.driver.usb.networking	5.0.0
com.apple.driver.usb.AppleUSBHostCompositeDevice	1.2
com.apple.driver.usb.AppleUSBHub	1.2
com.apple.iokit.IOAHCIBlockStorage	301.200.2
com.apple.iokit.IOSerialFamily	11
com.apple.filesystems.hfs.encodings.kext	1
com.apple.iokit.IO80211Family	1200.12.2
com.apple.driver.mDNSOffloadUserClient	1.0.1b8
com.apple.driver.corecapture	1.0.4
com.apple.iokit.IOAHCIFamily	288
com.apple.driver.usb.AppleUSBXHCIPCI	1.2
com.apple.driver.usb.AppleUSBXHCI	1.2
com.apple.driver.usb.AppleUSBHostPacketFilter	1.0
com.apple.iokit.IOUSBFamily	900.4.2
com.apple.driver.AppleUSBHostMergeProperties	1.2
com.apple.driver.AppleEFINVRAM	2.1
com.apple.driver.AppleEFIRuntime	2.1
com.apple.iokit.IOHIDFamily	2.0.0
com.apple.driver.AppleBacklightExpert	1.1.0
com.apple.iokit.IONDRVSupport	530
com.apple.iokit.IOGraphicsFamily	530.14
com.apple.security.quarantine	3
com.apple.security.sandbox	300.0
com.apple.kext.AppleMatch	1.0.0d1
com.apple.driver.DiskImages	493.0.0
com.apple.driver.AppleFDEKeyStore	28.30
com.apple.driver.AppleEffaceableStorage	1.0
com.apple.driver.AppleKeyStore	2
com.apple.driver.AppleUSBTDM	456.230.1
com.apple.driver.AppleMobileFileIntegrity	1.0.5
com.apple.kext.CoreTrust	1
com.apple.iokit.IOUSBMassStorageDriver	145.200.2
com.apple.iokit.IOSCSIBlockCommandsDevice	408.200.1
com.apple.iokit.IOSCSIArchitectureModelFamily	408.200.1
com.apple.iokit.IOStorageFamily	2.1
com.apple.driver.AppleCredentialManager	1.0
com.apple.driver.KernelRelayHost	1
com.apple.iokit.IOUSBHostFamily	1.2
com.apple.driver.usb.AppleUSBCommon	1.0
com.apple.driver.AppleBusPowerController	1.0
com.apple.driver.AppleSEPManager	1.0.1
com.apple.driver.IOSlaveProcessor	1
com.apple.iokit.IOReportFamily	47
com.apple.iokit.IOTimeSyncFamily	700.7
com.apple.iokit.IONetworkingFamily	3.4
com.apple.driver.AppleACPIPlatform	6.1
com.apple.driver.AppleSMC	3.1.9
com.apple.iokit.IOPCIFamily	2.9
com.apple.iokit.IOACPIFamily	1.4
com.apple.kec.pthread	1
com.apple.kec.Libm	1
com.apple.kec.corecrypto	1.0

EOF
Model: iMac14,2, BootROM 133.0.0.0.0, 4 processors, Intel Core i7, 3.49 GHz, 16 GB, SMC 2.15f7
Graphics: Radeon Pro 580, AMD Radeon Pro 580, PCIe
Memory Module: BANK 0/DIMM1, 8 GB, DDR3, 1866 MHz, Crucial Technology, BLT8G3D1869DT1TX0.
Memory Module: BANK 1/DIMM1, 8 GB, DDR3, 1866 MHz, Crucial Technology, BLT8G3D1869DT1TX0.
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x111), Broadcom BCM43xx 1.0 (7.77.61.1 AirPortDriverBrcmNIC-1305.2)
Bluetooth: Version 6.0.10f1, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
PCI Card: Intel Corporation, Series Chipset USB xHCI Host Controller, USB Controller, Built In
PCI Card: Intel Corporation, Series Chipset MEI Controller, IMEI Controller, Built In
PCI Card: Intel PCI Express Gigabit Ethernet, Ethernet Controller, Built In
PCI Card: AMD Radeon Pro 580, Display Controller, PCIe
PCI Card: Intel Corporation, Series Chipset SATA Controller, AHCI Controller, Built In
PCI Card: Apple SATA Controller, SATA Controller, Built In
PCI Card: Broadcom BCM43xx Wireless Network Adapter, AirPort Extreme, Built In
Serial ATA Device: Samsung SSD 840 EVO 250GB, 250.06 GB
USB Device: USB 3.0 Bus
USB Device: Hub
USB Device: Hub
USB Device: Mobius
USB Device: Hub
USB Device: Hub
USB Device: Scarlett 2i2 USB
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: USB Receiver
Thunderbolt Bus: 

 

Share this post


Link to post
Share on other sites

Hey @MaLd0n, just checking in to see if you had any more pointers. I'd be happy to donate more if you have time, or maybe there's a better forum to direct this to? Thank you for your time!

Share this post


Link to post
Share on other sites
1 hour ago, licorice_whip said:

Hey @MaLd0n, just checking in to see if you had any more pointers. I'd be happy to donate more if you have time, or maybe there's a better forum to direct this to? Thank you for your time!

try a fresh install with 10.14.4

check 

https://olarila.com/forum/viewtopic.php?f=50&t=8685

Share this post


Link to post
Share on other sites
18 minutes ago, licorice_whip said:

Thank you @MaLd0n. Just to be certain, should I use the custom DSDT you made me during this fresh install using the link you provided?

U can ;) 

Share this post


Link to post
Share on other sites

Thanks @MaLd0n. I used the guide that you linked, installed the Olarila Mojave 10.14.4, and used the Clover setup for Haswell on your walkthrough. Boots fine through USB, but when I remove USB, it goes from the Apple logo to a black screen. I rebooted with the USB stick again, and this time used the custom Clover folder you gave me above, and same problem... goes from Clover bootloader to Apple logo to black screen. 

 

Any thoughts?

Share this post


Link to post
Share on other sites

Hey @MaLd0n. So I tried to update to 10.14.4 using your guide but I would get no graphics with boot. So I went back to the vanilla guide on Reddit, using 10.14.4, and boot up fine, everything works including all USB ports. The only thing is I'm still having the problem I have had all along... The hackintosh crashes about 1/5 of the time when trying to wake up. I have tried messing with darkwake settings, and have disabled powernap. I am now using the DSDT you made for me. Can you verify that everything looks ok on the RunMe?

 

 

Send me Seans-iMac.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×