Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By cixque
      CLOVER.zipCLOVER.zipDell Venue 11 Pro 7140
      ------------
      Specification
       
       
      Intel Core M 5Y71
       
      Intel HD Graphics 5300
       
      Intel Broadwell-U motherboard
       
      8GB Ram
       
      256GB SSD
       
      Dell DW1850e WWAN + GNSS GPS
       
      Intel Wireless 7265 + Intel Bluetooth
       
      NFC
       
       
      …..
       
       
       
       
       
      Mojave 10.14.6
       
      What works
      Native Power Manager (Generate Plugin type) Full Graphics with QE/CL Brightness (Add PNLF in Config.plist or DSDT Patch) — (Brightness slide bar) Touch Screen, and Pen (DSDT Patch + Voodoo I2C, I2CHID satellite KEXT) HDMI output with hot plug (Lilu + WhateverGreen) HDMI Audio with hot plug (Lilu + AppleALC) no Layout-id needed Front and Rear Cameras MicroSD slot - O2 Micro (I use Adding Arbitrary under Devices in Config file Method) Ref, Post #6 by Jake Jo https://osxlatitude.com/forums/topic/7346-applesdxc-driverdsdt-patch-for-o2-micro-sd-card-readers/ Battery Indicator (ACPIbattery by Rehabman) ——>To utilise both battery, SSDT (by Rehabman) is needed in order to combine 2 batteries as one.
      Travel Keyboard Dell K12a001 (USBinjectall KEXT) Native Keyboard keys (Brightness, volume keys) WWAN card Dell DW1850e (OOB) Bluetooth -------------------
       
      What doesn’t work
       
       
      Sleep Wake — I have no idea how to fix it as it is required DSDT patch I guess. GPS NFC Audio ---> Realtek I2S Audio (PG0.35 for DELL)
       
      In DSDT entries is HDAUDIO\\FUNC_01&VEN_10EC&DEV_0282&SUBSYS_00000000&REV_1000\ Which indicates ALC282
       
      Audio ALC3263 (As it shown in BIOS) - Broadwell rt286 - Card1/Codec#0 (Utilised in I2S Mode) there is nowhere in BIOS to change to HDA mode). Drop OEM HDA and Fix HDA don’t do anything, still show 3 HDMI Audio outputs. If there is a DSDT patch to force HDA Audio mode, Please do enlighten me.
      As a result Internal Speaker, Internal Mic, and Headphone Jack doesn’t work.
       
      Touchpad on Travel Keyboard Dell K12a001 (Should work with DSDT Patch with pin configuration) I have no idea how. Obviously, Intel Wireless 7265 AC. For experimental purpose. https://github.com/daliansky/XiaoMi-Pro-Hackintosh/issues/330 — Knock yourself out. I managed to get it work for awhile but the real problem is kernel panic so I gave up. Ordering compatible card instead. ------------------
       
      Config.plist got it from Rehabman laptop config.
       
       
      BIOS version A20
       
      Enable:
       
      - Legacy Boot Rom
       
      Disable:
       
      - Secure Boot
       
      - TPM 2.0
       
      - Vt-d
       
      ------------
       
      SMBIOS - I use MacBook8,1. —- MacBookAir7,1-7,2 (Min Freq is at 1.2 GHz) MacBookPro12,1 Min Freq is at 800 Mhz and it is the default this cpu should be. Again, there is a way to set it right somewhere in this forum.
       
      ------------
       
      -->> DSDT Windows 8 patch
       
      System sees only one I2C Controller which control Touch Screen.
      Touch Screen registers as Magic Trackpad 2.
      Pen as Mouse
       
      -->> DSDT Windows 8.1 Patch
       
      System sees two I2C Controllers which control Touch Screen and Accelerometer.
      Touch Screen registers as Magic Trackpad 2.
      Pen as Mouse
       
      OOO>>> With Windows 8.1 patch which it should run with this one because it can see more of HID devices and controllers.
       
      Problem is Accelerometer (SHUB).
      Device can automatically rotate screen as it should be BUT it flips the screen wildly even with slightly movement. It stops only when device stays completely still. Eventually it breaks internal screen graphic. It becomes grabble. I restored internal screen graphic by connecting it to external monitor and set rotation of external screen to 0 degree. Then it is back to normal. (I guess it conflict with rotation setting) I disable SHUB in DSDT.
       
      ---------------------
       
      During Installation process Full Graphic acceleration can be activated straight away by Lilu and Whatevergreen. AppStore, iMessage and, FaceTime activate by NullEthernet and SSDT by Rehabman USBInjectAll needed for keyboard and other usb peripherals. Use other tool to keep certain ports active as Rehabman mention this KEXT is not good for a long run. Please do Correct me if I did something worng. Or any suggestions to make this thing runs better.
      CLOVER.zip
      IOReg_SysReport.zip
    • By kushwavez
      A really good motherboard with macOS compatible bult-in Wifi & Bluetooth

      ASUS Z170-Deluxe (with Wifi)
      BIOS: v3801
      CPU: i7-6700K 4.0 to 4.2 GHz (w/o OC)
      RAM: 1x 16 GB Corsair DDR4 2400 MHz
      GPU: Intel HD 530 (Headless) & ASUS Radeon RX 5700 OC 8 GB
      Audio: ALC 1150
      Ethernet: I219V2, I211-AT
      WiFi & Bluetooth: Broadcom BCM94360HMB Half-Mini-PCI-E
      More Specs: https://www.asus.com/Motherboards/Z170-DELUXE/specifications/
       
      Catalina 10.15.4 - Windows 10
      What is working:
      BCM94360HMB Wifi and Bluetooth AirDrop, Handoff, FaceTime, Messages, App Store, iCloud, etc. Intel HD 530 (QE/CI tested, but now I'm using it in headless) Sleep RX 5700 (QE/CI with 2 1080p monitors connected) Sound USB Ports Two Ethernet ports macOS with a light OC (4.12 GHz - 4.5 Ghz, XMP, ASUS optimal) No problem so far ASUS HyperKit with a KINGSTON NVMe SSD - 250 GB  
      What is not working:
      -  
       
      Not tested:
      VideoProc says that Hardware Decoding\Encoding is fully supported and enabled on both HD 530 and RX 5700 but I didn't test it Thunderbolt (no equipment)  
      Issues:
      None  
      BIOS Settings:
      Boot\CSM (Compatibility Support Module): Launch CSM: Disabled Boot\Secure Boot: OS type: Other OS Secure Boot State: Disabled Advanced\System agent (sa) Configuration: VT-d: Enabled Graphics Configuration: Primary Display: Auto iGPU Multi-monitor: Enabled RC6(Render Standby): Enabled DVMT Pre-Allocated: 128M Advanced\PCH Storage Configuration: SATA Mode Selection: AHCI HyperKit: Enable (if you have NVMe SSD with ASUS HyperKit) Advanced\CPU Configuration: Intel Virtualization Technology: Enabled CPU- Power Management Control: Intel SpeedStep: Enabled CPU- C-States: Enabled Intel SpeedShift: Enabled  
      Getting ready for installation:
      Download the bootpack (Clover v5107): Click here -> asus-z170_clover_5107.zip  
      Installation:
      Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager) Copy my Clover folder to the USB's EFI folder Boot with the Installer USB If you have any problem (kp or freeze) boot with config_debug.plist to see what causes the issue  
      Post Installation:
      Download Clover Configurator and generate a new Serial Number for yourself  
      Some pictures:
       

       




       
       
       
      Catalina & Windows 10 Dual-Boot (clean install, on one drive):
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac)
       Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart
      Boot into your Win installer, Format the partition you created for Win, install. 
      Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type: 
      bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi  
      You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)  
      Mounting EFI from Windows:
      Open cmd in administrator mode and type: mountvol b: /s (This will mount your EFI) Open Total Commander or Explorer++ in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI)  
      Notes:
       
      2020.03.26: Updated to 10.15.4 -> Updated WhateverGreen, Lilu -> Updated Clover to v5107
      2020.03.23: Removed "EmuVariableUefi.efi" -> deleted, caused false nvram map, now it's native, updated Clover to v5106
      2020.02.11: Updated to 10.15.3 -> No problem when/after installing
      2020.01.19: Added ASUS HyperKit NVMe SSD to the "What is working" list
      2020.01.12: Tested system with OC, added more informations to BIOS settings
      2020.01.11: Added SmallTreeIntel82576.kext for 2nd Ethernet, Tested Ethernet ports
      2020.01.11: First upload
       
    • By innerd
      Salve, ho da poco aggiornato il bios del notebook in firma alla versione 304, ma dopo averlo fatto non sono piu riuscito a farlo avviare.
      Ho cancellato il dsdt e gli ssdt (eccetto quello delle porte usb e pnlf, il resto ho utilizzato ssdttime con il nuovo dump).
      Credo che si blocchi nel momento in cui dovrebbe apparire la mela (con verbose) e quindi all'inizializzazione della igpu. Avendo il dubbio fosse un problema di framebuffer diverso (volevo anche creare una fake imei ma non ho trovato nessuna guida al riguardo) ho cancellato le vecchie proprietà nel config e provato manualmente tutti i valori mobile con igfxframe come flag, 2 volte sono stato fortunato con 0x1612002 ma senza riuscire a farlo partire piu di quelle poche volte. Con un framebuffer mobile e in safe mode riesco ad entrare ma in nessun altro modo, avete consigli?
      CLOVER.rar
    • By midi-sama
      After a long time of cooking this computer up with a lot of stuff, I'm finally releasing my guide for this P50 with OpenCore.
       
      Lenovo ThinkPad P50 macOS Install with OpenCore
       
      This thread may be used for questions/corrections/additions. Good Luck.
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Pro and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Pro, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware using Catalina 10.15.3
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install.
       
       
      HARDWARE USED
      • Intel I9 9900k 
      • Gigabyte AORUS Z390 PRO
      • Sapphire Nitro+ SE Vega56 (connected to monitor with DisplayPort)
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit. 
      • CoolerMaster MASTERLIQUID ML360R RGB CPU Cooler
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       

       
       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar
       
       
      CLOVER  FOLDER
      Use this folder with fully patched DSDT
      Current EFI 
      Updated 26/03/2020
      PLEASE NOTE - You MUST update to the latest EFI before updating to 10.15.4 or you may find your unable to update.
       
      Clover EFI Update - 26/03/2020 - Use with Bios revision F12d Only or Replace with the older F11 DSDT if you don't want to update the bios
      Clover Z390 Pro Vega Navi EFI 260320.zip - Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI
      Clover Z390 Pro Polaris EFI 260320.zip - R5XX Polaris DSDT EFI
       
       
      PLEASE NOTE - Please flash your motherboard bios to revision F12d to use my current EFI. It’s a major rework of the bios and vital changes have been made to the layout and power tables. New DSDTs have been created and installed into the new EFI’s but will not work correctly with any other bios revision.
       
       
      Latest Gigabyte Z390 PRO BIOS (F12d)
      mb_bios_z390-aorus-pro_f12d.zip
       
       
      CFG Unlock (MSR) F12d BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - N-D-K Fork of OpenCore (05/03/2019)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Clover
      Clover Configurator
      Kext Updater
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      FakeSMC    (Can be used instead of VirtualSMC)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F12d)
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Disabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup 
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

       

       

       

       
       
       
×