Jump to content
Sign in to follow this  
Followers 0
Fede1132

[AMD R7 2700X] Error loading kernel (0x9)

2 posts in this topic

Recommended Posts

Hi guys i have a problem install macOs Mojave on my PC, I have this configuration:

CPU: Ryzen 7 2700X;
GPU1: GTX 970 Strix(For game rendering and 144Hz Monitor);
GPU2: GTX 750ti Strix(For 2nd monitor rendering to get 100% performances from 1st 144Hz Monitor);
MotherBoard: MSI x470 GAMING PLUS
Hard Disk 1 (Windows 10): Samsung EVO M.2;
Hard Disk 2 (For Storage): RAID (1) between two hard disks;
Hard Disk 3 (For Mojave): Kingston SSD 120GB;

I have created my USB with this:
 

  • Create Bootable USB
    • Code:
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB -- /Applications/Install\ macOS\ Mojave.app -- nointeract && say Done.
  • Clover Settings:
    • Boot:
      • Verbose;
      • dart=0;
      • nv_disable=0;
      • kext-dev-mode=1;
      • GraphicsEnabler=No;
      • XMPDetection = No.
    • Cpu:
      • C6.
    • Devices: (Not Enabled = [ ] - Enabled = [-] - Full Enabled [✓])
      • Inject (Full Enabled);
      • Add ClockID (Full Enabled);
      • FixOwnership (Full Enabled);
    • Gui: (Not Enabled = [ ] - Enabled = [-] - Full Enabled [✓])
      • Enabled (Full Enabled);
      • Screen Resolution: 1920x1080;
    • Kernel and Kext Patches: (Not Enabled = [ ] - Enabled = [-] - Full Enabled [✓])
      • Apple RTC (Full Enabled);
      • KernelPm (Full Enabled);
    • SMBIOS:
      • iMac(18,3);
    • System Parameters:
      • Inject Kexts = Yes;
      • Inject System ID;
  • Used Kexts:
  • BIOS:
    • VT-d = Disabled;
    • XHCI Hand-Off = Enabled;
    • Legacy USB Support: Enabled;
    • Hard Disk: AHCI Mode;
    • Selection Mode: Legacy + EUFI;

Clover Install Log:

Spoiler


Clover EFI installer log - Fri Feb  1 15:50:05 CET 2019
Installer version: v2.4k r4862 EFI bootloader
======================================================
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk2         121.1 GB   disk0s2

/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:                 Apple_APFS Container disk2         1000.0 GB  disk1s2

/dev/disk2 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +1.1 TB     disk2
                                 Physical Stores disk0s2, disk1s2
   1:                APFS Volume Macintosh HD            75.8 GB    disk2s1
   2:                APFS Volume Preboot                 24.3 MB    disk2s2
   3:                APFS Volume Recovery                514.5 MB   disk2s3
   4:                APFS Volume VM                      2.1 GB     disk2s4

/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *320.1 GB   disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:                  Apple_HFS Install macOS Mojave    319.7 GB   disk3s2

======================================================
Backing up EFI files

======================================================
Installing BootSectors/BootLoader

Stage 0 - Don't write any of boot0af, boot0md, boot0ss to /Volumes/Install macOS Mojave
Stage 1 - Don't write any of boot1h2, boot1f32alt, boot1xalt to /Volumes/Install macOS Mojave
======================================================
Installing RC Scripts

Installing RC scripts on target volume '/Volumes/Install macOS Mojave'


Theme 'Clovy' (defined in config.plist) not found !
Using default theme 'embedded'
======================================================
=========== Clover EFI Installation Finish ===========
======================================================
 

Full Error Log:

Spoiler

sxApt ioFlx3Drv: Starting overrides for \Systen\Library\CoreServices\boot.efi

Using reloc block: no, hibernate wake: no

Start 

Start OSName

End OSName

Start InitDeviceTree

Start InitDeviceTree

End InitDeviceTree

Start CheckHibernate

End CheckHibernate

efiboot loaded from device: Apci(PNP0A03,0)/Pci(1|3)/Pci(0,0)/Usb(12, 0)/HD(Part2,Sig.......)

efiboot file path \System\Library\CoreServices\boot.efi

Start OpenVolume

End OpenVolume

Start ProcessOptions

End ProcessOptions

RegisterRestartDataProtocol: called 0xb82c6f98

RegisterData protocol installed successfully.

Start SetConsoleMode

End SetConsoleMode

Start ReadKernelCache

End ReadKernelCache

Start UncompressKernelCache

End UncompressKernelCache

Start CalculateAdler32

End CalculateAdler32

Start LoadKernelFromStream

Error allocating 0x3391 pages at 0x000000000f800000 alloc type 2

End LoadKernelFromStream

ERROR||| Load prelinked kernel with status 0x8000000000009

Error loading kernel cache (0x9)

 

Edited by Fede1132

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Reel
      All work 10.10, 10.11, 10,12
      camera not work in 10.13, 10.14
      You need SwitchResX that the screen does not freeze
      Custom resolutions: Back porch - lines change to 2
      UEFI boot moded bios https://github.com/Thiblizz/l502x-modded-bios
       
      For 10.14 you need: HD3000 Fix for Mojave.zip
      Installed in S/L/E 
       
      SMBIOS: MacbookPro 8.3 or MacbookPro 9.1
       
       

       

       
       
    • By glasgood
      CLOVER DUAL BOOT MOJAVE & WINDOWS 10 GUIDE 
       

       
       
      INCLUDES  MBR / LEGACY BIOS  TO  GPT / EFI CONVERSION
      USING MBR2GPT TOOL
       
       
      PREREQUISITE: Two physical discs ( SSD’s or HDD’s )
       
       
       
       
       
      STEP 1 - Clover dual boot configuration 
       
      Open config.plist with Clover Configurator
       
      Boot
       Legacy = PBR Timeout = True ( will remove the Timeout countdown, from Clover boot menu)  

       
      GUI 
      Scan / Custom
       Entries = True  Tool = True  Legacy = False ( removes extra Windows 10 entries )  
      Hide Volume
      - Preboot ( macOS Preboot )
      - Recovery ( macOS Recovery )
       

       
      So at boot you will have two options: boot macOS Mojave or Windows 10 
       
       
       
       
       
       
       
      ————————————————————
       
       
      STEP 2 - Using a drive without Windows 10 installed
       
      Disconnect system drive that contains your macOS Mojave install from computer ( This is so that Windows does not overwrite existing macOS Mojave boot loader )
       
      Proceed with a Windows 10 UEFI install.  
      After installation reconnect macOS Mojave Drive, the Windows installation should now be detected and usable in Clover. 
      If Windows 10 is not detected or able to boot,  then verify you installed Windows 10 as UEFI and not MBR ---->  ( Read step 2 - For a drive with Windows 10 installed )
       
       
      OR
       
       
       
      STEP 2 - Using a drive with Windows 10 already installed
       
      Verify your Windows install is  GPT / UEFI or MBR / Legacy BIOS.   
      If Windows install is GPT UEFI then Windows 10 install is ready to use at Clover boot menu, you should be able to boot into Windows directly from Clover boot screen. 
       

       
       
      But if  Windows drive is detected at Clover boot screen, but when booting Windows you get a black screen with a cursor on the top left,
      then this is most likely because Windows drive is MBR ( Legacy BIOS ).  You can easily convert MBR to GPT using  Windows MBR2GPT tool ( this saves hours work having to reinstall Windows 10 and setting up all your applications again  ) 
       
      If Windows 10 install is MBR / Legacy BIOS  then simply convert to GPT / UEFI  following instructions below ( read video summary and view video )
       
       
      ** To use Windows 10  MBR2GPT tool  you must have Windows 10 version 1703 ( creators update  ) or later and less than 3 partitions on 
      the Windows 10 drive **
       
      Video summary:
       
      Confirm Windows 10 drive is MBR Legacy BIOS ( in Windows Disk Management ) Reboot into Windows PE ( Advanced Startup ) Convert from MBR Legacy BIOS to GPT UEFI ( using commands below ) mbr2gpt /validate mbr2gpt /convert Restart Verify Windows 10 drive has changed to GPT UEFI ( in Windows Disk Management )  
       
       
       
      After conversion Windows 10 is ready to use at the Clover boot menu 
       
       
    • By gk12345
      hello to everyone, i managed to install mojave on my asus ux303ub with i5 cpu and now sleep does not work when i press sleep display turns black and pc stays on and then i have to force shut down by holding power button in order to restart pc ,by the way i used the clover folder from a guide on the internet, any help would be appreciated, thanks
    • By Bahaa
      Need help here
      My graphic card is detached 7mb
      and I try a lot of solution and no one work 
      can any one help
       

    • By Gracie
      Hello, insanely kind people! 
      I had full working Speedstep on my system with El Capitan, but after installing Mojave i cant make it working again!
      Help me please. Actually system is working only with NullCPUPowerManagement.kext. As soon as i remove it from Extensions directory i've got kernel panic at the boot.
      I tried to put SSDT.aml from my previous ElCapitan clover, tried to make new by different utilities, but still no luck.

      My system is:
      Pentium G3258
      Asus Z97-K USB 3.1
      Nvidia GTX 670


      i''m attaching my new clover.plist of Mojave and old El Capitan one, which makes Speedstep fully working and overclocking my little Pentium from 3.2 to 4.5GHz. Now i see huge speed loss without SpeedStep on Mojave  Please help, anybody! Also im attaching my working SSDT.aml from El Capitan.
      El Capitan SSDT.aml
      El Capitan config.plist
      Mojave config.plist
×