Jump to content
mariosk9gr

i9-9900k, Asus Maximus XI Hero, Rx580 8Gb Pulse, Random Freezes

8 posts in this topic

Recommended Posts

Hi everyone I built a new system 2 months ago mainly for video editing/photography work. This is my 4th hackintosh since 2013.

First of all system specs and bios settings:

 

Intel i9-9900k

Asus Maximus XI Hero Z390

G.Skill 16GB 3200mhz 16-18-18-38 RGB

Sapphire Rx580 8Gb Pulse 

Samsung 970 EVO 500Gb 

Samsung 850 EVO 250Gb

Dell U2413 1920x1200

Dell U2417h 1920x1080

Nzxt Kraken X62 AIO

 

BIOS Settings

 

VT-d - Disable

CFG-Lock - Disable

Secure Boot Mode - Disable

OS Type - Other OS

XHCI Handoff - Enabled

Above 4G Decoding - Enabled

 

 

2 Months ago...

At beginning of building this system my motherboard was Asus Prime Z-390-A and gpu was Sapphire Rx580 8Gb Nitro+

After many successful installations using different methods, my main problem which is random freezes, remains until today.

Its not the 1st forum Im talking about my issue... I have write in many different places, trying many different methods, kexts, drivers, settings inside macOS/bios.

Important to know is that under Windows 10 everything is working great, including stress tests for cpu/gpu/ram/disks etc.

Also Random Freezes are present in both High Sierra 10.13.6 and Mojave (10.14 - 10.14.3)

 

The Nightmare!

Random freezes..! You don't know when it will happen...

In most cases I have found that happens in idle mode, especially when Im not doing anything. Everything except the mouse cursor freezes. If music or audio is playing when it happens, it continues play.

Around mouse cursor a green square glitch box is showing up. Only Reset works. 

This issue drove me mad and almost got me crazy. Depression... where the issue lies? motherboard? gpu? ram? psu? where?!?!?!

So after many many attempts I took the decision to sell my Asus Prime Z390-A and buy Maximus XI Hero... and so I did! The result was 2 days later to have the 1st freeze again. Exactly the same as before! Its not motherboard related ofc... there are a few people that I already found to have success stories with the same motherboards! Nevermind I don't regret for my choice.

So, the procedure again... posts, settings, lots of reading, drivers, kexts, different clover builds etc. No Happiness!

Second conclusion was that most people use Pulse editions of Amd gpus cause they are the most stable. Very little info I had discovered about Nitro editions so far... that led me to pull the plug again, sell the Nitro and buy the Pulse Edition. OMG!

In reality and inside of my mind I knew that I would experience freezes again! They are here to stay.... Nightmare! So Pulse didn't work out for me either.

 

Temporary solution

A friend of mine lend me his Asus gtx1050 2Gb to test it for a couple of weeks. Nevertheless all my previews builds were based with Nvidia GPUs and never had any issues.

I installed High Sierra 10.13.6, enabled CSM in Bios cause otherwise only 1/2 monitors was working under HS. For 10 Days I didn't have any freezes at all!!!

Why? so many people are using these days rx580s to have native support under new MacOS... why it's not working for me!

For a second something crossed my mind... it may be that with gtx1050 I had CSM enabled... but I have it disabled with Rx580 otherwise I cannot boot at all. Cannot pass Apple logo loading screen!

 

HEVC, Hardware accelaration is working.

Fcpx BruceX test is giving me 14secs.

Geekbench also provides good results for cpu/ram 36900/6658.

OpenCL 143000, Metal 141000.

Heaven lastly is giving good score compared to other systems with same gpus.

Custom SSDT with all usbs working great.

Sleep/Wake works w/o issues.

 

If I can get rid these random freezes and rest my mind finally! Damn it... depression!

Many times crossed my mind to go back to win... but I can't! I love macOS... its the only way for a photographer/videographer! It's the design, the aesthetics! I've been using windows machines since 11 years old and now Im 36. After 2013 windows died for me. Don't get me wrong, on my 3ssd I have them installed but very rarely I will use them. They work mostly as a backup machine in case I have to deliver a work to a client and something goes wrong with macos.

 

 

 

 

 

 

 

 

 

Screenshot 2019-01-27 at 13.40.34.png

Screenshot 2019-01-27 at 13.41.11.png

Screenshot 2019-01-27 at 13.42.02.png

Screenshot 2019-01-27 at 13.42.49.png

Screenshot 2019-01-27 at 14.05.59.png

config.plist

Share this post


Link to post
Share on other sites
Advertisement

Propably it's against the rules of this forum BUT if someone can help me to identify the problem to my issue and help me solve it, Im willing to donate! Im tired with all of this last couple of months and I really need to get my system stable and finally rest!

Edited by mariosk9gr

Share this post


Link to post
Share on other sites

The only update I can provide is that I changed also my psu to a Corsair RM850x (2018 v2) but freezes are still here Ryo unfortunately.

I will find a way that's for sure...!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×