Jump to content
Wayang-NT

[pre-release] macOS Mojave 10.14.4

205 posts in this topic

Recommended Posts

7 hours ago, PMheart said:

Well, the "long patch" varies from time to time, are you sure that you are using the correct one?

I update 10.14.4 

I test long patched same result.

F

C1E30848 63D389D0 48C1EA20 B9990100 000F3048 FF05926E 76004883 C4085B5D C30F1F00 

R

 

BB00FF00 004863D3 89D048C1 EA20B999 0100000F 3048FF05 93AE7600 4883C408 5B5DC390 

Screen Shot 2019-02-01 at 8.41.57 AM.png

Share this post


Link to post
Share on other sites
Advertisement
10 hours ago, nmano said:

I update 10.14.4 

I test long patched same result.

F

C1E30848 63D389D0 48C1EA20 B9990100 000F3048 FF05926E 76004883 C4085B5D C30F1F00 

R

 

BB00FF00 004863D3 89D048C1 EA20B999 0100000F 3048FF05 93AE7600 4883C408 5B5DC390 

Screen Shot 2019-02-01 at 8.41.57 AM.png

Hi,

 

Good to hear. Could you please try this patch? You need to REMOVE ALL POSSIBLE PERFORMANCE FIX before testing. Thanks a lot!

 

find
48 63 D3 89 D0 48 C1 EA 20 B9 99 01 00 00 0F 30

repl
90 90 B8 00 FF 00 00 31 D2 B9 99 01 00 00 0F 30

 

Once again, be sure to remove all previous performance fix patch in advance!

And thanks again. :)

Share this post


Link to post
Share on other sites
2 hours ago, PMheart said:

Hi,

 

Good to hear. Could you please try this patch? You need to REMOVE ALL POSSIBLE PERFORMANCE FIX before testing. Thanks a lot!

 


find
48 63 D3 89 D0 48 C1 EA 20 B9 99 01 00 00 0F 30

repl
90 90 B8 00 FF 00 00 31 D2 B9 99 01 00 00 0F 30

 

Once again, be sure to remove all previous performance fix patch in advance!

And thanks again. :)

Thanks @PMheart

 

I apply your patched please check my config

Thanks.

 

config.plist.zip

Screen Shot 2019-02-01 at 10.09.28 PM.png

Share this post


Link to post
Share on other sites
8 minutes ago, nmano said:

Thanks @PMheart

  

I apply your patched please check my config 

Thanks. 

 

config.plist.zip

Screen Shot 2019-02-01 at 10.09.28 PM.png

Yes, I checked your config and it turns out that you are applying the patch correctly.

 

The score looks pretty much the same as applying the old, long patch. Is it satisfying? If so, congratulations and thanks @vit9696 over and over again!

 

EDIT: No, one thing is not correct. ;) The credit does not goes to me but @vit9696 !

Edited by PMheart

Share this post


Link to post
Share on other sites
Yes, I checked your config and it turns out that you are applying the patch correctly.

 

The score looks pretty much the same as applying the old, long patch. Is it satisfying? If so, congratulations and thanks [mention=1135927]vit9696[/mention] over and over again!

 

EDIT: No, one thing is not correct. The credit does not goes to me but [mention=1135927]vit9696[/mention] !

good, as result, could only short patch covered 10.13.4~10.14.4 beta1? i have all performance patch you wrote since 10.13.4 beta1

 

나의 LG-F800S 의 Tapatalk에서 보냄

 

 

 

Share this post


Link to post
Share on other sites
25 minutes ago, Sherlocks said:

good, as result, could only short patch covered 10.13.4~10.14.4 beta1? i have all performance patch you wrote since 10.13.4 beta1

 

나의 LG-F800S 의 Tapatalk에서 보냄

 

 

 

Wow, you must be a big fan of me then. :P Just joking.

 

Well, if possible, do not hesitate to check if the patch works for previous versions. :)

 

EDIT: I think this patch can be better (I eliminated some redundant bytes)

find
C1 E3 08 48 63 D3 89 D0 48 C1 EA 20 B9 99 01

repl
C1 E3 08 B8 00 FF 00 00 31 D2 90 90 B9 99 01

 

Edited by PMheart

Share this post


Link to post
Share on other sites
Wow, you must be a big fan of me then. Just joking.
 
Well, if possible, do not hesitate to check if the patch works for previous versions.
 
EDIT: I think this patch can be better (I eliminated some redundant bytes)
findC1 E3 08 48 63 D3 89 D0 48 C1 EA 20 B9 99 01replC1 E3 08 B8 00 FF 00 00 31 D2 90 90 B9 99 01

 

right. since 10.13.4, pattern is same. if short patch was checked, we can clean patch as only one.

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites
1 minute ago, Sherlocks said:

right. since 10.13.4, pattern is same. if short patch was checked, we can clean patch as only one.

나의 LG-F800S 의 Tapatalk에서 보냄
 

Oh, good, thanks for the verification.

 

As for 10.13.3-, I think the pattern has already been short enough, no need to cleanup then. Well, now that there is already 10.13.6, no one would care for the old version I guess. :)

Share this post


Link to post
Share on other sites
28 minutes ago, PMheart said:

Oh, good, thanks for the verification.

 

As for 10.13.3-, I think the pattern has already been short enough, no need to cleanup then. Well, now that there is already 10.13.6, no one would care for the old version I guess. :)

 

actually like you said, we don't need old patch for 10.13.5-. i just always recorded history of patch. also i have been saved installer of first release(10.1x) of macos version and last version(10.1x.6 or 10.1x.5) to check each version.

 

so, what is correct patch?

nmano used 

4863D389 D048C1EA 20B99901 00000F30

9090B800 FF000031 D2B99901 00000F30

 

but

you wrote patch again.

find
C1 E3 08 48 63 D3 89 D0 48 C1 EA 20 B9 99 01

repl
C1 E3 08 B8 00 FF 00 00 31 D2 90 90 B9 99 01

 

what is correct patch? now seems to not clear

 

Share this post


Link to post
Share on other sites
1 hour ago, Sherlocks said:

 

actually like you said, we don't need old patch for 10.13.5-. i just always recorded history of patch. also i have been saved installer of first release(10.1x) of macos version and last version(10.1x.6 or 10.1x.5) to check each version. 

 

so, what is correct patch?

nmano used 

4863D389 D048C1EA 20B99901 00000F30 

9090B800 FF000031 D2B99901 00000F30 

 

but

you wrote patch again.


find
C1 E3 08 48 63 D3 89 D0 48 C1 EA 20 B9 99 01

repl
C1 E3 08 B8 00 FF 00 00 31 D2 90 90 B9 99 01

 

what is correct patch? now seems to not clear

 

It's obviously clear and cannot be more. ;P

 

NOP (0x90) is just a padding and simply does nothing, thus they can be put anywhere. (i.e before or after any instruction)

Share this post


Link to post
Share on other sites
It's obviously clear and cannot be more. ;P
 
NOP (0x90) is just a padding and simply does nothing, thus they can be put anywhere. (i.e before or after any instruction)
okay first patch nmano used was made by vit9696 right?

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

Today's beta version of 10.14.4 installed quickly and easily.  However, it seems that, since I installed it, some of my older apps are no longer working, such as UnRarX.  Even the newest version of VidProc would not open.  I got an error message that the app was damaged and should be moved to Trash.  Anyone else experience this or something similar?

Share this post


Link to post
Share on other sites
21 minutes ago, mnfesq said:

Today's beta version of 10.14.4 installed quickly and easily.  However, it seems that, since I installed it, some of my older apps are no longer working, such as UnRarX.  Even the newest version of VidProc would not open.  I got an error message that the app was damaged and should be moved to Trash.  Anyone else experience this or something similar?

You probably need to re-run this, even Security & Privacy on Prefs already said "Anywhere".. then reboot:

sudo spctl --master-disable
Edited by Badruzeus

Share this post


Link to post
Share on other sites
4 hours ago, Badruzeus said:

You probably need to re-run this, even Security & Privacy on Prefs already said "Anywhere".. then reboot:


sudo spctl --master-disable

 

Good one!  It worked.

Share this post


Link to post
Share on other sites
On 2/1/2019 at 7:54 PM, PMheart said:

Hi,

 

Good to hear. Could you please try this patch? You need to REMOVE ALL POSSIBLE PERFORMANCE FIX before testing. Thanks a lot!

 


find
48 63 D3 89 D0 48 C1 EA 20 B9 99 01 00 00 0F 30

repl
90 90 B8 00 FF 00 00 31 D2 B9 99 01 00 00 0F 30

 

Once again, be sure to remove all previous performance fix patch in advance!

And thanks again. :)

Thanks @PMheart

 

I apply your patched please check my config

Thanks.

Thank you @vit9696

Share this post


Link to post
Share on other sites

can anyone help? what is the difference between the developer builds and the beta builds?

I have developer build 18e174f  and noticed that some have build number 18e184e

Thanks

osxone

Share this post


Link to post
Share on other sites
On 2/7/2019 at 4:49 AM, osxone said:

can anyone help? what is the difference between the developer builds and the beta builds?

I have developer build 18e174f  and noticed that some have build number 18e184e

Thanks

osxone

beta build is a relatively stable dev build

Share this post


Link to post
Share on other sites
On 1/29/2019 at 7:09 AM, fusion71au said:

On my legacy Dell laptop (Geforce 8600M GT/tesla) using MBP7,1 SMBIOS and -no_compat_check boot flag, had same error as @macq - hang on message ioconsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0 after DSMOS arrives.

 

Maybe with this latest beta, more stringent checking of systems with deprecated SMBIOS + non metal graphics?  
MacPro5,1 SMBIOS also works booting 10.14.4 beta/18E174f macOS Base System on my legacy desktop (Desktop 2 in signature with ATI HD5770) with VESA graphics.

 

Did Apple new security rules (CSR/SIP related) prevent unsigned binaries to be loaded on this new 10.14.4 kernel?

Any of you can check for it, probably.. need an update? I realized that also need to re-run: $ sudo spctl --master-disable ..once updated to this build, though previously (on 10.14.3) is disabled. Thanks.

Edited by Badruzeus

Share this post


Link to post
Share on other sites
1 hour ago, Badruzeus said:

 

Did Apple new security rules (CSR/SIP related) prevent unsigned binaries to be loaded on this new 10.14.4 kernel?

Any of you can check for it, probably.. need an update? I realized that also need to re-run: $ sudo spctl --master-disable ..once updated to this build, though previously (on 10.14.3) is disabled. Thanks.

csrutil status returns disabled. I'm not able check second command because lack of command line in Mojave:(. As wern apfel  discovered in this topic https://www.insanelymac.com/forum/topic/303186-how-to-modification-of-amd-fb-clover-injection/?page=16 ,  in case of non metal Radeons, way of 10.14.4 reads connectors might be the culprit.

 

Share this post


Link to post
Share on other sites
14 minutes ago, hardcorehenry said:

csrutil status returns disabled. I'm not able check second command because lack of command line in Mojave:(. As wern apfel  discovered in this topic https://www.insanelymac.com/forum/topic/303186-how-to-modification-of-amd-fb-clover-injection/?page=16 ,  in case of non metal Radeons, way of 10.14.4 reads connectors might be the culprit.

 

I was asking bcoz I see this log since 10.14.4 Beta 1-2 (which didn't appear on 10.14.3).

Though I'm not really sure it' s related to CSR or SIP..

"Forcing CS_RUNTIME for entitlement..."

..and my CSR configs are still same: CsrActiveConfig=0x67 | BooterConfig=0x28.

Edited by Badruzeus

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×