Jump to content
ludufre

[GUIDE] Lenovo ThinkPad L440 (20AS) - Mojave 10.14.3

13 posts in this topic

Recommended Posts

Installing macOS Mojave on Lenovo ThinkPad L440

image.thumb.png.642df899eb5ecbca6796dab2042f230d.png

 

There are two version of this laptop:

- 20AS = Chipset QM87, without Express Card (mine).

- 20AT = Chipset HM86, with Express Card.

I strong believe is the same thing...

 


Changelog:

 

03/13/2019 13:15h GMT-0

- Updated info about touchpad replacement and CPU and 4G LTE modem.

 

02/05/2019 18:47h GMT-0

- Updated info about CPU replacement and 4G LTE modem.

 

02/04/2019 15:24h GMT-0

- Sometimes the VoodooHDA.kext doesn't work.

- Added AppleHDADisabler.kext to fix that (attached bellow).

 

01/24/2019 14:42h GMT-0

- Added more adjustments to use of VoodooHDA.

- Updated VoodooHDA links to 2.9.1 official (without installer).

- Changed PCM volume from 90 to 180 in Info.plist (attached modified VoodooHDA.kext bellow)

- Updated SSDT-L440.aml (Removed HDEF and HDAU, not needed).

- Updated config.plist (Changed to user Audio layout to 1).

 

01/22/2019 20:47h GMT-0

- I gave up on the AppleALC.

- Headset does not work.

- Now with VoodooHDA is perfect and the sound even louder.

 

01/22/2019 14:37h GMT-0

- Add info about update 10.14.3. 

 

01/22/2019 13:46h GMT-0

- Add link to BIOS reassing guide.

 

01/20/2019 11:49h GMT-0

- First version.

 

What works and what does not
 
- Processor: Intel Core i5-4300M -> Tick.png Work. All SpeedStep stages.
- Video Card: Intel HD4600 -> Tick.png Work. QE/CI and Metal.
- Chipset: Intel QM87 -> Tick.png Work.
- Mini DisplayPort -> Tick.png Work. But no audio, yet.

- VGA -> Cross.png Not work. Normal.

- Audio: ALC292 -> Tick.png Work.

- WiFi/Bluetooth: Intel AC 7260 -> Cross.png Not work. Replaced with DW1560 (need whitelist removal).

- Ethernet: Intel I217-LM -> Tick.png Work.

- Card Reader: Realtek RTS5227 -> Cross.png Not work.

- Keyboard and Touchpad -> Tick.png Work.
- Webcam -> Tick.png Work.

- Fingerprint Reader -> Cross.png Not work. Normal.

- USB3.0 -> Tick.png Work.
- Sleep -> Tick.png Work.

- Airdrop, Handoff, Instant Hotspot and Continuity -> Tick.png Work after replaced wireless.

 

 

Extras
 
- FullHD 1920x1080 display upgrade: 

Replaced with AU Optronics B140HAN01.1 30pin eDP (B140HAN01.2 and B140HAN01.3 also compatible).

Apparently same screen as Dell Latitude E6440, E7440, Lenovo Ideapad U430 and E129.

 

- CPU upgrade:

Replaced the stock Intel Core i5 4300M 2.6Ghz (3.3Ghz turbo) 6M cache with Intel Core i7 4700MQ 2.4Ghz (3.4Ghz turbo) 6MB.

I initially had problems with overheating. The processor ran at full load above 90 degrees.

After using a quality thermal paste I can work between 70 and 80 degrees.

Acceptable taking into consideration that the new processor has 47TDP versus 37TDP which is recommended.

I also had no problem consuming the battery while charging. The original 65W source seems to have figured out.

 

- Touchpad upgrade:

Replaced the stock with T460 touchpad.

This is serious: you have to do it! It should be stock. Touchpad with precision and absurd quality!

Just do it!

 

- RAM upgrade:

No mistery here. Just upgade.

 

 

Todo

 

- Make DP audio work.

- Make Card Reader work.

- Upgrade CPU to i7-4712MQ (Ordered. It's on the way) Done, but received i7-4700MQ (47w TDP, with good paste I have no overheating)

- Replace touchpad with T460 model (Ordered. It's on the way) Done. Sensitivity and perception of quality much better. I recommend 100%!

- Sierra Gobi5000 4G LTE modem EM7355 (Ordered. It's on the way. I hope works. ^_^) Done, but not work. Recognize but not connect. I already gave up...

- Upgrade to 16GB RAM Done

 

 

What you need to install

- Running install of macOS
- One USB flash drive of 8GB or bigger
- macOS Mojave install app
- Clover EFI

- Clover Configurator

- Some KEXTs and SSDT patches


How create create the install flash drive
 
Prepare install flash drive


Format the flash drive with GUID partition mapping and name it "Install".

- Open Disk Utility.
- Click in View, then "Show All Devices".
- Select the destination flash drive, then Erase.
- Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map

 

Create install flash drive

Open terminal and run this command:

sudo /Applications/Install\ macOS\ .app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction

This will take about 30 minutes.

 

image.png.dbfbb044438583c128d2b973252bc02e.png


Install bootloader

Download the RehabMan's CloverEFI fork (used 4701) and install with this options on "Install macOS Mojave":

 
- Install for UEFI booting only
- Install Clover in the ESP
- UEFI Drivers - ApfsDriverLoader-64
- UEFI Drivers - AptioMemoryFix64


image.png.41c5e42019a1984eb6ebee88be38e892.pngimage.png.544e088b0b3db5021e4f69cc1802e7b0.png

 

 

Make things works

Will be created a partition named EFI and mounted in Desktop.

- Replace the /Volumes/EFI/CLOVER/config.plist with mine attached below

              If you have modded BIOS with Advanced Menu and enabled 128MB DRAM-prealloc use 128MB_DRAM-prealloc_config.plist.zip

              If no, then use 32MB_DRAM-prealloc_config.plist.zip

- Put SSDT-L440.aml attached below in /Volumes/EFI/CLOVER/ACPI/patched/

 

Generate your Serial, MLB and SmUUID

 

- Open the replaced config.plist with Clover Configurator (used 5.3.2.0)

- Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.

 

Download those Kexts and put in /EFI/CLOVER/kexts/Other/

 

Download the FakeSMC.kext from here. I used the version 2018-0915.

- Download the VoodooPS2Controller.kext from here. I used version 2018-1008.

Download the IntelMausiEthernet.kext from here. I used the version 2018-1031.

Download the Lilu.kext from here. I used the version 1.3.1.

Download the AppleALC.kext from here. I used the version 1.3.4.

Download the VoodooHDA from here. I used the version 2.9.1.

Download the WhateverGreen.kext from here. I used the version 1.2.6.

Download the AppleBacklightFixup.kext from here. I used the version 2018-1013.

Download the USBInjectAll.kext from here. I used the version 2018-1108.

Download the ACPIBatteryManager.kext from here. I used the version 2018-1005.

 

 

Wifi and Bluetooth (DW1560 / BCM94352Z)

 

Unfortunately, some notebook manufacturers are currently blocking the replacement of wireless cards. They want you to only use the models sold by them. And of course, none of them from Lenovo for this notebook model is compatible with MacOS.

 

If you try to start with an unauthorized wifi card for them, you will receive a screen error:

1802: Unauthorized network card is plugged in - Power off and remove the network card.

Since this check is done directly in the BIOS, the only solution is to modify it.

But since nothing is easy in this life, there is one small big problem:

- The BIOS update procedure does not allow you to use modded files as it used to be.

- You will need to physically reach your BIOS on the motherboard and make use of a USB BIOS reader/writer.

 

So what you need to do:

1. Disassembly your laptop;
2. Dump your BIOS with an USB BIOS reader with SOIC8 clip (to not desolder from the motherboard);
3. Patch it (In addition to removing the whitelist, add the advanced menu);
4. Fix RSA signature;
5. Reflash BIOS;

6. Replace wireless card;

7. Remount your laptop;
8. Done.

 

Soon, I'll provide step by step in this process. Probably until end of this week.

In the meantime, if you need to, send me your dump that I do steps 3 and 4 for you.

I also add the Advanced Menu so you can increase to 128MB the DRAM-prealloc.

 

To fix a Modded BIOS to remove the 5 beeps on boot, you need this guide: https://www.insanelymac.com/forum/topic/337333-guide-fix-insyde-h2o-bios-signature-5-beeps-on-lenovo (traduzido: pt-BR)

 

 

After replaced the wireless card. Download those Kexts and put in /EFI/CLOVER/kexts/Other/

 

Download the AirportBrcmFixup.kext from here. I used the version 1.1.9.

Download the BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext from here. I used the version 2018-0505.

Download the BT4LEContinuityFixup.kext from here. I used the version 1.1.2.

 

 

Now you can start the instalation without problem (I guess).

 

 

How install

 

UEFI Setup Configuration and Installation

UEFI configuration
 

My BIOS is the latest: 1.93 (J4ET93WW) 


- Shutdown and insert the flash drive.
- Power on with F1 pressed to enter BIOS setup.
- Change value: Config - Intel(R) AMT - Intel(R) AMT Control to DISABLED

- Change value: Security - Security Chip to DISABLED

- Change value: Security - Anti-Theft - Intel(R) AT Module Activation to DISABLED

- Change value: Security - Anti-Theft - Computrace to DISABLED

- Change value: Security - Secure Boot to DISABLED

- Change value: Startup - UEFI/Legacy Boot to BOTH, Legacy First and CSM Support = Yes

- Save & Exit Setup (F10)

 

- Now, hold the F12

- In the list, select your flash drive.

 

The installer will start. 


Format destination disk

Format the disk with GUID partition mapping and name it "Macintosh".

- Select Disk Utility in the list, then press Continue.
- Click in View, then "Show All Devices".
- Select the destination Disk, then Erase.
- Name: HD, Format: APFS and Scheme: GUID Partition Map

Close Disk Utility.

Select "Install macOS", then Continue.
Follow instructions in screen.

After install

After first part install the system will reboot. Maybe you have to press F12 again and select the flash drive.

The second part of the installation will begin. This will take 16 minutes.
 

Post installation

Install bootloader
 
When the second part of install finish, the system will reboot again.

After performing the user initial setup and go to the desktop, you need to install Clover on internal disk.

Open the Clover installer inside flash drive that you copied before.

Use same options above but choose the system partition this time.

Now you need to replace the config.plist inside your destination disk EFI parittion with config.plist inside flash card EFI partition.

The flash drive EFI partition is unmounted. Mount with terminal "sudo diskutil mount /dev/rdiskXs1". To know what X is, use "diskutil list", most likely is 1.

 

Last step

 

Copy all Kexts from flash drive to /Library/Extensions, with those commands in Terminal:

sudo cp -R /Volumes/EFI/EFI/CLOVER/kexts/Other/* /Library/Extensions/
sudo chmod -R 755 /Library/Extensions
sudo chown -R root:wheel /Library/Extensions
sudo kextcache -i /

Restart the system.

 

 

It's done!

 

 

Updates

 

System update 10.14.3

 

- Updated with success;

- Everything works perfectly after reboot;

 

image.png.c531b357abf70e4ee78a2a43ea4aa96c.png

 

 


 
And last but not least
 
I would like to thank the following community members, by making these dream possible:
@crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @Shiki and all others members involved directly or indirectly.

 

 

 

 

 

 

32MB_DRAM-prealloc_config.plist.zip

128MB_DRAM-prealloc_config.plist.zip

SSDT-L440.aml

VoodooHDA.kext.zip

AppleHDADisabler.kext.zip

Edited by ludufre

Share this post


Link to post
Share on other sites
Advertisement
2 minutes ago, RandomTech said:

Excellent guide, I'm planning to get Lenovo X1 Carbon and sure this guide will make things easier.

 

Cool. 

 

As incredible as it seems the most difficult for me was not even to make the mod in the BIOS, was to configure the Frame Buffer for the miniDP port to work. It cost me a week! I even gave up and returned to the High Sierra,

but finally decided to try one last time and I did it.

 

If you need help on the mod to release whitelist in the BIOS give me a hello.

Share this post


Link to post
Share on other sites
21 hours ago, ludufre said:

 

Cool. 

 

As incredible as it seems the most difficult for me was not even to make the mod in the BIOS, was to configure the Frame Buffer for the miniDP port to work. It cost me a week! I even gave up and returned to the High Sierra,

but finally decided to try one last time and I did it.

 

If you need help on the mod to release whitelist in the BIOS give me a hello.

I will, thank you for the offer.

Share this post


Link to post
Share on other sites

Hey Thanks man for this awesome guide/config. installed it on my Lenovo L540 and it works pretty finde. ^_^

 

 

 

Share this post


Link to post
Share on other sites
Just now, tonton91 said:

Hey Thanks man for this awesome guide/config. installed it on my Lenovo L540 and it works pretty finde. ^_^

 

 

 

 

Nice! The L540 and L440 use the same motherboard I think (the BIOS I'm sure are the same).

Share this post


Link to post
Share on other sites
Just now, ludufre said:

 

Nice! The L540 and L440 use the same motherboard I think (the BIOS I'm sure are the same).

 

@Lenovo Bios Update Website there is the same exe for l440 and l540, you are right i think. Only problems i got:

- Laggy touchpad (got the oem pad but swapped the 460 touchpad kext and it worked fine)

- when accessing webpages with video or streamingcontent the system is slowing down (i think it is the crappy mediathek driver with ralink usb dongle)

- sometimes it boots only at 3rd attempt (next time ill read the bootlog)

 

Share this post


Link to post
Share on other sites
28 minutes ago, tonton91 said:

 

@Lenovo Bios Update Website there is the same exe for l440 and l540, you are right i think. Only problems i got:

- Laggy touchpad (got the oem pad but swapped the 460 touchpad kext and it worked fine)

- when accessing webpages with video or streamingcontent the system is slowing down (i think it is the crappy mediathek driver with ralink usb dongle)

- sometimes it boots only at 3rd attempt (next time ill read the bootlog)

 

 

- Laggy touchpad: You're right, I still have original (my T460 has not arrived yet) and I can confirm. Had not realized yet why use with keyboard and mouse connected on a second monitor at work.

- System slowing down: You sure the Speed Step is working? Why usb dongle? Why do not you replace a wireless card?

- Sometimes it boots at 3rd attempt: Do this, see at boot what's happening next. But if it's kernel panic it will not appear in the log, right?

Share this post


Link to post
Share on other sites
22 minutes ago, ludufre said:

 

- Laggy touchpad: You're right, I still have original (my T460 has not arrived yet) and I can confirm. Had not realized yet why use with keyboard and mouse connected on a second monitor at work.

- System slowing down: You sure the Speed Step is working? Why usb dongle? Why do not you replace a wireless card?

- Sometimes it boots at 3rd attempt: Do this, see at boot what's happening next. But if it's kernel panic it will not appear in the log, right?

 

To the slowdown:

- Speedstep is working, Intel Power gadget shows the CPU clocking from 0.8 up to 3.1 Ghz (i5 4300m)

- when playing youtube videos the cpu clocks to 3.1ghz and 100% load for ~ 30sec-1min then it normalizes, when changing the video, windowsize or go to fullscreen its the same issue.

- plugged in an ethernetconnection and got the same problem, maybe its a faulty codec?

Wifi dongle:

- ordered a clip and a programmer, gonna flash the bios soon. (any recommends for a wificard-model?)

Boot at 3rd attempt:

- with enabling verbose it crashed not everytime and doesnt need 3 attempts (only one up to now)

- yes this are panics, i can send you 2 logs,efi and a bootlog

Share this post


Link to post
Share on other sites

Abou the slowdown, I'm pretty sure you are not using WhateverGreen.kext, right? Try installing it. If you already have, run kextstat to see if is loaded.

You can order a DW1560, It's works very nice and have Continuity, AirDrop and Handoff. Only Instant Hotpot that sometimes don't work.

Send me the logs about the panics

Share this post


Link to post
Share on other sites
1 minute ago, ludufre said:

Abou the slowdown, I'm pretty sure you are not using WhateverGreen.kext, right? Try installing it. If you already have, run kextstat to see if is loaded.

You can order a DW1560, It's works very nice and have Continuity, AirDrop and Handoff. Only Instant Hotpot that sometimes don't work.

Send me the logs about the panics

Thanks for the advice for the Card, ill order one once I successfully flashed my bios.

Whatevergreen is loaded with v1.2.6 (newest from repo)

 

ill prepare the pm sec

Share this post


Link to post
Share on other sites
12 hours ago, eldiego said:

Hi friend, thanks for this guide, all work flawless except de laggy touchpad

 

True, I was able to confirm this on Feb. 6 (post)

It turned out that I did not even try to fix it because I ordered a new touchpad of the model T460.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Gracie
      Hello, insanely kind people! 
      I had full working Speedstep on my system with El Capitan, but after installing Mojave i cant make it working again!
      Help me please. Actually system is working only with NullCPUPowerManagement.kext. As soon as i remove it from Extensions directory i've got kernel panic at the boot.
      I tried to put SSDT.aml from my previous ElCapitan clover, tried to make new by different utilities, but still no luck.

      My system is:
      Pentium G3258
      Asus Z97-K USB 3.1
      Nvidia GTX 670


      i''m attaching my new clover.plist of Mojave and old El Capitan one, which makes Speedstep fully working and overclocking my little Pentium from 3.2 to 4.5GHz. Now i see huge speed loss without SpeedStep on Mojave  Please help, anybody! Also im attaching my working SSDT.aml from El Capitan.
      El Capitan SSDT.aml
      El Capitan config.plist
      Mojave config.plist
    • By guitar201
      I’m currently getting around 30seconds on the brucex test and think I can do better.   Ive tried disabling dgpu in the bios and enabled to no availe.  Currently running 10.14.3 with corps dsdt script.  
       
      System is a:
       
      ​
       
      Core i5-8400 / Gigabyte Z370 SLI XP mobo
       
       
      Vega 64
       
       
      GC-Alpine Ridge Thunderbolt 3 card
       
       
      [https://pastebin.com/W3PVZCxh](https://pastebin.com/W3PVZCxh) My Config.plist
       
       
       
      [https://imgur.com/a/KZ9qgop](https://imgur.com/a/KZ9qgop) Contents of my EFI folder
       
      Any suggestions is appreciated.  Thanks. 
    • By End3rPower50
      Hi, is Qualcomm Atheros AR956x compatible with MacOS Mojave 10.14.3?
    • By SIGNALSOUT
      Hello,
      I don't have access to another Mac, so I downloaded the following files:
       
      InstallESDDmg.pkg
      InstallAssistantAuto.dmg
      RecoveryHDMetaDmg.pkg
       
      Build is 10.14.3
       
      These were direct downloads from Apple Servers. If I extract them all I can build a Install macOS Mojave.app from them. I have tried various things in order to get the Mojave Patcher to accept the .app but I cannot get it to boot. The USB key it creates doesn't look proper as some of the files end up on the root of the disk, such as Base. and when it's finished flashing it changes the usb key's name to OS X Base.
       
      Could someone be of assistance and provide me with a tree print out of the file structure for Install macOS Mojave.app please?
      Thank you,
      Nate
×