Jump to content
Tobiko

[REQUEST] DSDT SSDT for sleep and shutdown HP 17u 2EW64UA

36 posts in this topic

Recommended Posts

Ok, I have since added HDAS>HDEF in the config.plist should I remove that too when using this DSDT?

Share this post


Link to post
Share on other sites
Advertisement

Ok I put in the latest DSDT and removed Fix Shutdown and Add PNFL from the config.plist. I tried with and without the HDAS>HDEF patch same issue with shut down. 

Share this post


Link to post
Share on other sites
1 hour ago, Tobiko said:

Ok I put in the latest DSDT and removed Fix Shutdown and Add PNFL from the config.plist. I tried with and without the HDAS>HDEF patch same issue with shut down. 

 

OK, I have tried all of the shutdown patches that I am aware of.  You are the second person with an HP laptop that I was unable to help with this issue despite the fact that the Intel shutdown patch worked for me.  Perhaps @MaLd0n has some suggestions but, with your current set up, you seem to have several extraneous settings that make it difficult to isolate the exact problem.  I would consider removing as many settings from config.plist as possible and as many custom kexts as possible and then start adding them one-by-one until you can boot up.  Once you can boot up, don't add any more settings until the shutdown issue is resolved.  Another suggestion is to make a post in the Lilu plug-ins section and see if anyone might be able to create a shutdownfixup kext for Lilu that you can help test.  The more widespread the problem with HP laptops, the more someone might be willing to help you look into that.  I've pretty much exhausted my know-how in this area but will follow your progress.

 

EDIT:  I see that some HP laptops have had this same shutdown problem with Windows 10.  One suggestion was to enable virtualization technology.  Since I bought my new HP expressly for the purpose of improving my Parallels Windows 10 VM performance, I have always had virtualization enabled.  Do you?  What happens if you enable virtualization and use the DSDT I made with the Intel shutdown patch?

Edited by mnfesq

Share this post


Link to post
Share on other sites

 

 

30 minutes ago, mnfesq said:

 Another suggestion is to make a post in the Lilu plug-ins section and see if anyone might be able to create a shutdownfixup kext for Lilu that you can help test.

 

I will make one as soon as I get back. 

 

With your latest DSDT should I keep HDAS>HDEF enabled in the config.plist?

 

32 minutes ago, mnfesq said:

you seem to have several extraneous settings that make it difficult to isolate the exact problem.

 

Oh man. Can you give me a hint as to which ones? 

 

I have virtualization enabled. I've also tried with it disabled. 

 

Thanks for all the help. This was a complete win. My wakereason is now clean thanks to you and I was able to get rid of the backlight fixup kext, get rid of a BCM kext and have everything injecting through Clover. I'll try to clean up the config.plist but I thought all of the settings I had in there I needed. 

Share this post


Link to post
Share on other sites
2 hours ago, Tobiko said:

I will make one as soon as I get back. 

 

With your latest DSDT should I keep HDAS>HDEF enabled in the config.plist?

 

Oh man. Can you give me a hint as to which ones? 

 

I have virtualization enabled. I've also tried with it disabled. 

 

Thanks for all the help. This was a complete win. My wakereason is now clean thanks to you and I was able to get rid of the backlight fixup kext, get rid of a BCM kext and have everything injecting through Clover. I'll try to clean up the config.plist but I thought all of the settings I had in there I needed. 

 

OK, I found that the DSDT patch I used did not patch your _PTS method properly.  All it did was add the SLPE definition but it never used that definition in _PTS.  I manually edited your DSDT to include SLPE for argument 0x05 in _PTS.  I'm hoping that's the error that prevented shutdown.  Now, your DSDT has the same shutdown patch as mine.

 

DSDT.aml.zip

Share this post


Link to post
Share on other sites
1 hour ago, Tobiko said:

Thanks again. Unfortunately this thing is stubborn. Shutdown is still the same. 

 

I will post asking about the shutdown kext. Is this the section you were thinking I should post in https://www.insanelymac.com/forum/647-lilu-and-plugins/ ? Or is there a different one. 

 

I really thought that the error I found was the problem.  Do you mind sending me your Runme one more time.  I just want to be positive that the DSDT I fixed is the one you have loaded.  Thanks.

Share this post


Link to post
Share on other sites
56 minutes ago, Tobiko said:

Okay. 

 

Sorry for the delay.

Send me Craptop.zip

 

I tried adding Shutdown patch v.2 from RehabMan to the Intel patch.  Just a shot in the dark but give it a try.  Be sure to load DSDT1.aml manually in Clover options.

 

DSDT1.aml.zip

Share this post


Link to post
Share on other sites

I renamed it DSDT.aml and booted it with that. I have DSDT.aml specified in the config.plist/Clover. 

 

Shut down is still the same. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×